Page Cover.html

[Cover] [Contents] [Index] Next Section

[Cover] [Contents] [Index] Next Section


Page 1
PART I
FUNDAMENTALS OF LEARNING THEORY


Page 3
1
Introduction
The present chapter introduces the subject matter of this book, namely, formal models of empirical inquiry. We begin by indicating the issues that motivate our study. Next come illustrations of models, followed by discussion of their principal features.
§1.1 Empirical Inquiry
Many people who have reflected about human understanding and its origins have noticed an apparent disparity. Bertrand Russell [164] (cited in Chomsky [40]) put the matter this way:
How comes it that human beings, whose contacts with the world are brief and personal and limited, are nevertheless able to know as much as they do know?
Focusing attention on intellectual development, the disparity is between the information available to children about their environment, and the understanding they ultimately achieve about that environment. The former has a sparse and fleeting character whereas the latter is rich and systematic.
To better understand the issue, consider the acquisition of a first language.1 A few years of casual contact with the ambient language suffices for the infant to master a grammatical system so complex that it still defies description by linguists. Within broad limits, the particular sample of language to which the infant is exposed does not seem to affect the grammatical principles induced, since children raised in different households within the same linguistic community are able to communicate effectively. Moreover, the child's learning mechanism is apparently built to acquire any human language, for children of different racial or ethnic backgrounds are able to acquire the same languages with the same facility. Evidently, some mental process (perhaps largely unconscious) allows children to convert the fragmentary information available about the ambient language into systematic principles that describe it generally.
The same kind of process underlies other tasks of childhood. By an early age the child is expected to master the moral code of his household and community, to assimilate its artistic conventions and its humor, and at the same time to begin to understand the physical principles that shape the material environment. In each case the child is
1 For an overview and guide to the literature, see Pinker [148].


Page 4
required to convert data of a happenstance character into the understanding (implicit; or explicit) that renders his world predictable and intelligible.
It is not surprising that so little is known about the mental processes responsible for children's remarkable intellectual achievements. Even elementary questions remain the subject of controversy and inconclusive findings. For example, there is little agreement about whether children use a general-purpose system to induce the varied principles bearing on language, social structure, etc., or whether different domains engage special-purpose mechanisms in the mind.2
The disparity just noted for intellectual development has also been observed in the acquisition of scientific knowledge by adults. Like the child, scientists typically have limited access to data about the environment, yet are sometimes able to convert this data into theories of astonishing generality and veracity. At an abstract level, the inquiries undertaken by child and adult may be conceived as a process of theory elaboration and test. From this perspective, both agents react to available data by formulating hypotheses, evaluating and revising old hypotheses as new data arrive. In the favorable case, the succession of hypotheses stabilizes to an accurate theory that reveals the nature of the surrounding environment. We shall use the term ''empirical inquiry" to denote any enterprise that possesses roughly these features.
It is evident that both forms of empirical inquiry — achieved spontaneously in the early years of life, or more methodically later on — are central to human existence and cultural evolution. It is thus no accident that they have been the subject of speculation and inquiry for millenia.3 The present book describes a set of conceptual and mathematical tools for analyzing empirical inquiry. Their purpose is to shed light on both intellectual development and scientific discovery. They may also be of use in guiding the development and evaluation of artificial systems of empirical inquiry (such as those described in Langley, Simon, Bradshaw, and Zytkow [123]).
Since the pioneering studies of Putnam [155], Solomonoff [184, 185], Gold [80], and the Blums [18] a large technical literature has been devoted to the development and use of the tools at issue here. Papers within this tradition are spread over journals and books in mathematics, computer science, linguistics, psychology, and philosophy. Our topic has variously been called "The Theory of Scientific Discovery," "Formal Learning Theory," "The Theory of Machine Inductive Inference," "Computational Learning Theory," and "The Theory of Empirical Inquiry." We shall use all these terms to describe the collection of definitions, examples, and theorems that emerge from the literature. Our goal is to
2 For discussion, see Chomsky [40], Pinker [148], and Osherson and Wasow [142].
3 See Russell [163] for an historical overview.


Page 5
organize part of this material, and to render it accessible to students and researchers interested in empirical inquiry. Along the way we shall provide pointers to areas given little coverage in these pages.
§1.2 Paradigms
The material to be presented facilitates the definition and investigation of precise models of empirical inquiry. Such models are often referred to as "paradigms." A paradigm offers formal reconstruction of the following concepts, each central to empirical inquiry.
1.1 (a) a theoretically possible reality
(b) intelligible hypotheses
(c) the data available about any given reality, were it actual
(d) a scientist
(e) successful behavior by a scientist working in a given, possible reality
The concepts figure in the following picture of scientific inquiry, conceived as a game between Nature and a scientist. First, a class of "possible worlds," or possible realities, is specified in advance; the class is known to both players of the game. Nature is conceived as choosing one member from the class, to be the actual world; her choice is initially unknown to the scientist. Nature then provides a series of clues about the actual reality. These clues constitute the data upon which the scientist will base his hypotheses. Each time Nature provides a new clue, the scientist may produce a new hypothesis. The scientist wins the game if his hypotheses ultimately become stable and accurate. Whether the scientist can win the game depends on the breadth of the set of possible worlds. The more constrained Nature's choice of actual world, the more likely the scientist is to discover it.
Different paradigms formalize this picture in different ways, resulting in different games. To fix our ideas, let us now examine some simple paradigms, without concern for rigor at this point.
§1.3 Some Simple Paradigms
Call a set of positive integers "describable" just in case it can be uniquely described using an English expression. For example, the set {2, 4, 6, 8, . . .} is one such set since it is


Page 6
uniquely described by the expression "all positive, even integers." The describable sets are the theoretically possible realities of the current paradigm (in the sense of 1.1a).
To play the game, it will help to focus on a proper subset of all these realities, namely, the subcollection C defined as follows. C contains all sets that consist of every positive integer with a sole exception. Plainly, every set in C is describable; the set {1, 3, 4, 5, 6, . . .}, for example, is uniquely described by "all positive integers except for 2."
In what follows, we shall play the role of Nature; you play the role of scientist. In our role as Nature, we select one member of C, and you (in your role as scientist) must discover the set that we have in mind. Clues about our choice will be provided in the following way. First, we shall order all the elements of the set in the form of a list; then the list will be presented one element at a time. There is no constraint on the list made from the chosen set, except that it must contain all the elements of the set, and only these. For example, one list of the set {2, 3, 4, 5, 6, 7, 8, 9, . . .} is: 3, 2, 5, 4, 7, 6, 9, 8, . . .. Aside from seeing the list's members presented one by one, you are provided no further information about it. A list of our set corresponds to 1.1c, the data made available about the possible reality chosen to be actual.
Each time a number is presented, you may announce a conjecture about the set chosen from C at the beginning of the game (guesses about how we listed the chosen set are not required). Your guesses must take the form of English expressions that uniquely describe a set of positive integers. It is these expressions that constitute the intelligible hypotheses of our paradigm (see 1.1b). Your conjectures at any given moment will be based exclusively on the data available to you, so for purposes of this game you may be construed as a system that translates data into hypotheses. Indeed, any such system is considered to be a "scientist" within the current paradigm, in the sense of 1.1d.
All of items 1.1a-d have now been specified. As for 1.1e, we stipulate that you win the game just in case you make only a finite number of conjectures, and the last one is correct.
Let's play. We have selected a set and ordered it. Here is the first member of the list: 1. Guess, if you like. Next member: 3. Guess again, if you like. To abbreviate, here are the next ten members of the list: 4, 5, 6, 7, 8, 9, 10, 11, 12, 13. Perhaps your latest conjecture is "all positive integers except for 2." That is a reasonable conjecture. However, it is wrong since according to our list the next number is 2. So go ahead and guess again. Here are the subsequent ten members: 15, 16, 17, 18, 19, 20, 21, 22, 23, 24. Perhaps now your latest conjecture is "all positive integers except for 14."
The game goes on forever, so we interrupt it at this point to consider the paradigm


Page 7
in more general terms. Let us say that a "guessing rule" is a set of instructions for converting the clues received up to a given point into a conjecture about the chosen set. Your own guesses may well have been chosen according to some guessing rule, and you might take a moment to attempt to articulate it.
Now consider the following guessing rule:
1.2 Guessing rule: Suppose that S is the set of numbers that have been presented so far. Let m be the least positive integer that is not a member of S. (S must be finite, so such a number certainly exists.) Emit the conjecture "all positive integers except for m" unless this was your last conjecture (in which case make no conjecture at all).
To illustrate, if the numbers presented so far were {4, 5, 8, 1}, then rule 1.2 would direct you to conjecture "all positive integers except for 2" (unless you had just made this conjecture, in which case you would not do it again). You should be able to convince yourself of the following fact:
1.3 Fact: No matter which set was chosen from C at the start of the game, and no matter what list was made from that set, consistent application of guessing rule 1.2 is a winning strategy; that is, if you use rule 1.2, then you win in all cases.
Now let us modify the game by adding the set of all positive integers (without exception) to the initial collection C. So our choice of set as "actual reality" is expanded to include one new possibility, namely, {1, 2, 3, 4, 5, . . .}. This changes matters quite a bit. For example, guessing rule 1.2 is no longer guaranteed to succeed at the game. Indeed, it is clear that, faced with any listing for the new set {1, 2, 3, 4, 5, . . .}, the rule changes its guess infinitely often, and hence never produces a last, accurate conjecture. A more significant fact is the following.
1.4 Fact: No guessing rule is guaranteed to win the new game. That is, for every guessing rule R there is a set in the (expanded) collection C and some way to list the set such that R fails to produce a last, correct conjecture on the list.
The techniques needed to prove Fact 1.4 will be presented in Chapter 3. You can grasp the matter intuitively, however, by playing the new game with a friend. This time you play the role of Nature, and try to defeat your opponent with the following tactic. Begin with the list 2, 3, 4, 5, 6, 7, . . ., extending it until your friend announces the hypothesis "all positive integers except 1." Suppose that your list must be extended to 33 for this to happen. Then continue your list with 1, 35, 36, 37, 38, 39, 40, . . . until you have extracted


Page 8
the hypothesis "all positive integers except 34." Suppose that the list has reached 61 at this point. Then continue with 34, 63, 64, 65, 66, 67, . . . until you hear "all positive integers except 62." If you continue in this devious way, one of two things will happen. Either:
(a) your friend will go for the bait each time, and thereby change her hypothesis infinitely often, or
(b) she will at some point refuse to adopt the conjecture that you intended for her.
In both cases your friend will fail to make a last, correct conjecture about the list you have made. Moreover, in both cases the list you make belongs to the game. To see this, consider the two cases. In case (a), you will end up listing every positive integer. Since this set is a member of the initial collection C, your list represents a legitimate choice for Nature at the start of the game. In case (b), you will end up listing some set consisting of every positive integer with a sole exception. This set is also in C. Thus, in both cases your friend's guessing rule fails on some list for a set that might have been Nature's initial choice. Hence her guessing rule is not guaranteed to win the new game, which proves 1.4. (A more rigorous version of the proof is given in Chapter 3.)
Let's play the last game again (with the extended collection C), but this time within a slightly different paradigm. Instead of being able to arbitrarily order the chosen set, Nature is now required to present the set in increasing order. So there is just one possible listing of any given set in C. For this paradigm, it is easy to formulate a guessing rule that wins in all cases (try stating such a rule).
The foregoing variations point to a basic question about any, well-defined paradigm. The question is: For what collections of realities can winning guessing rules be formulated? This question is a dominant theme of our book.
§1.4 Discussion of the Paradigms
We now comment on various aspects of the paradigms just introduced. In fact, our remarks are relevant to almost all of the paradigms discussed in this book.
§1.4.1 Possible Realities as Sets of Numbers
Limiting the possible realities to sets of positive integers is not as austere as it might seem at first. This is because integers may be conceived as codes for objects and events found in scientific or developmental contexts. For example, the sentences to which children


Page 9
are exposed in the course of language acquisition (like all sentences of human language) are complex structures involving phonetic, syntactic, and semantic levels of representation. Their complexity notwithstanding, it may nonetheless be possible to enumerate all possible sentences in a kind of alphabetical order in something like the way pairs, triples, or quadruples of integers can be enumerated.4 If the enumeration can be carried out by a computable process, then it yields a useful correspondence between sentences and integers, and the latter can be used as codes for the former. In this case, a set of integers corresponds to a language, namely, the language whose sentences are coded by the integers in the set.5
Notice that a correspondence of this kind requires that the set of coded entities be denumerable, i.e., have the same cardinality as the integers serving as codes. It might be thought that the restriction to denumerable domains excludes scientific contexts bearing on physical quantities whose values are arbitrary real numbers. However, the rational numbers provide sufficient precision in scientific practice, and the rationals are a denumerable set. So integers can also be used to code many situations involving physical quantities.
For mathematical simplicity, the possible realities figuring in this book are taken to be sets of numbers, or else functions from numbers to numbers. We limit ourselves thereby to studying scientific or developmental contexts in which the relevant objects of inquiry (like sentences) can be coded as integers. It is our belief that much insight into empirical investigation can be achieved within this limitation, a claim that the reader will ultimately have to evaluate for him- or herself.6
There is an additional, noteworthy property of the sets and functions that play the role of possible realities in most of what follows. They are "computable" in the sense of being manipulable and recognizable by computer programs (this will be made precise in the next chapter). It is important to recognize that most sets of numbers and most numerical functions are not computable. In fact, from the point of view of their respective cardinalities, the computable functions stand in the same relation to the class of all numerical functions as do the integers to the real line. It follows that by limiting attention to possible realities of a computable nature our theory does not embrace every conceivable scientific situation (we return to this point in Chapter 3). Once again, we believe that this restriction leaves a large and important class of scientific contexts within the purview
4 For exposition of this kind of enumeration, see Boolos and Jeffery [21, Chapter 1].
5 For more extended discussion see Weihrauch [192, Chapter 3.3].
6 Paradigms involving more expressive scientific languages are discussed in Martin and Osherson [127, 128].


Page 10
of the theory, although we admit to having no proof of this claim.
Another concession to mathematical simplicity can be noted here. Starting in the next chapter, the natural numbers {0, 1, 2, 3, . . .} will be used to construct possible realities, rather than the positive integers {1, 2, 3, 4, . . .}. This choice facilitates the use of techniques and results from the theory of recursive functions.
§1.4.2 Intelligible Hypotheses
We take hypotheses to be symbolic representations of a real or fictitious world. For example, most hypotheses announced in scientific journals are written in the symbols of the Roman alphabet, supplemented with mathematical notation. Alternatively, the alphabet might be drawn from some system of neural notation used by the brain to represent the structure of the ambient language.
To be intelligible, a symbolic system must provide finite representations of the reality it is designed to depict, even if that reality is infinite in size. For example, the English expressions like "all positive integers except 5" is a finite string of letters that uniquely describes an infinite set. Computer programs can also be conceived as finite descriptions of sets of numbers. Specifically, program P can be taken as specifying the set of all numbers n such that P given input n eventually stops running. This is the approach described in the next chapter and used throughout the sequel. The emphasis on computer programs as hypotheses stems in part from the desire for technological applications. Moreover, it is felt that programs stand in a particularly intimate relation to the sets they describe, inasmuch as they provide a means for recognizing the members of the set. In contrast, the English description "all positive integers that Gauss ever wrote down" uniquely describes a set of numbers, but gives little access to its members.
§1.4.3 Scientists
In our sample paradigm above, scientists were conceived as systems that convert finite sequences of numbers into hypotheses. The scientist may thus be pictured as traveling down an infinite list of numbers, examining the finite amount of data available at any point in the voyage, and emitting hypotheses from time to time about the contents of the entire list, including the infinite, unseen portion. For most of the book, it will be assumed that scientists are mechanical, that is, simulable by a computer. Indeed, we shall usually equate scientists with computer programs. It will sometimes prove helpful, however, to remove the assumption of computability from our conception of scientists, in which case


Page 11
they will be conceived as arbitrary functions mapping finite data-sets into conjectures. This liberal attitude will allow us to separate information-theoretic from computability-theoretic aspects of scientific discovery, as will become clearer in Chapter 3.
On the other hand, much of our attention will also be devoted to scientists drawn from narrow subsets of the class of computable processes. That is, we shall consider scientists who operate under various constraints concerning the time devoted to processing data, available memory, selection of hypotheses, ability to change hypotheses, etc. Study of such restrictions will shed light on several issues, including:
(a) the impact of various design features on the performance of computers as scientists, for example, the feature that prevents a computer from abandoning an hypothesis that is consistent with all available data;
(b) the prospects for success by scientists who possess human characteristics, such as time and memory limitations; and
(c) the wisdom of conforming to "rational policies" such as never producing an hypothesis falsified by current data, or never producing an hypothesis that describes a theoretical possibility ruled out in advance.
It will be seen that exploration of such issues sometimes leads to unexpected conclusions.
§1.4.4 Success versus Confidence about Success
To be successful on a list of numbers, the scientist must produce a final, correct conjecture about the contents of the entire list. She is not required, however, to "know" that any specific conjecture is final. To see what is at issue, consider the first paradigm introduced above in which C contains just the sets of positive integers with a sole exception. Upon seeing 2, 3, 4, . . ., 1000, a scientist might be confident that the list contains the set of positive integers except for 1. But her confidence does not prevent the list from continuing this way: 1, 1002, 1003, 1004 . . ., 2000. Confidence at 2000 that the list holds all positive integers except for 1001 is equally unfounded, since the list may continue: 1001, 2002, 2003, 2004, . . .. Thus, the scientist is never justified in feeling certain that her latest conjecture will be her last.
On the other hand, Fact 1.3 does warrant a different kind of confidence, namely, that systematic application of guessing rule 1.2 will eventually lead to an accurate, last conjecture on any list generated from a member of C. The relevant distinction may be put this way: If we know that the actual world is drawn from C, then we can be certain


Page 12
that our inquiry will ultimately succeed (if the right guessing rule is applied). But we cannot be certain at any given stage of our inquiry that success has finally arrived.
This asymmetry is a fundamental characteristic of empirical inquiry. In the usual case, scientists can never feel completely confident that their current theory will remain uncontradicted by tomorrow's data. They can only hope that the mental system by which they select hypotheses is adapted to the reality they face. Distinguishing these two issues allows us to focus on scientific success itself, rather than on the secondary question of warranted belief that success has been obtained. Thus, our question will typically be:
What kind of scientist reliably succeeds on a given class of problems?
rather than:
What kind of scientist "knows" when she is successful on a given class of problems?
Clarity about this distinction was one of the central insights that led to the mathematical study of empirical discovery (see Gold [80, pp. 465-6]).
§1.4.5 Criteria of Success
Compare guessing rule 1.2 to the following, revised version.
1.5 Guessing rule: Suppose that S is the set of numbers that have been presented so far. Let m be the least positive integer that is not a member of S. If 2m is not a member of S, make no conjecture. Otherwise, emit the conjecture "all positive integers except for m" unless this was your last conjecture (in which case make no conjecture at all).
Thus, 1.5 is just like 1.2 except that it imposes a possible delay in producing the conjecture "all positive integers except for m." Although the delay is pointless, it is easy to see that systematic use of 1.5, as with use of 1.2, guarantees success in the first paradigm introduced above.
Rule 1.5 highlights the liberal attitude embodied in our current definition of scientific success. We require that the scientist produce a final conjecture that is correct, but there is no requirement that this final conjecture come as quickly as possible. Let us admit, however, that scientists who examine extravagant amounts of data before making a final, correct conjecture might be considered as useless as scientists who never guess correctly


Page 13
at all. So we might be led to formulate more stringent criteria of scientific success that impose standards of efficiency. Indeed, this is the topic of Chapter 12, below.
Although liberal with respect to efficiency, our present success criterion is stringent about accuracy. To succeed on a given list, the scientist must produce an English description for exactly the numbers in the list, with no omissions or additions. Such accuracy is required in order to make our games interesting, since the sets in play differ by only a few numbers. But what if the initial collection C were such that every pair of members was infinitely different? In this case, a small error in the scientist's final conjecture might be tolerable. Success in this approximate sense is the topic of Chapters 6 and 7.
More generally, we shall investigate success criteria that are liberal and stringent in a wide variety of ways. In addition to efficiency and accuracy, we shall be concerned with tolerance for noisy data, with different senses of "last conjecture on a list," with behavior on lists outside of a given scientist's competence, and so forth. Of two, distinct criteria we often ask: What kinds of scientific problems can be solved under one criterion that cannot be solved under the other? In this way we hope to shed light on the limits of empirical inquiry that emerge from different kinds of scientific ambition.7
Beyond what has been mentioned so far, many additional topics will occupy the chapters of the present book. But enough preliminaries! To get started in a serious way, it is now necessary to review a body of notation and conventions drawn from the theory of computation. This is the topic of the next chapter. Subsequently, in the remaining two chapters of Part I, we formally define and investigate some elementary paradigms.
Summary
The Theory of Machine Inductive Inference (or "Computational Learning Theory," etc.) attempts to clarify the process by which a child or adult discovers systematic generalizations about her environment. The clarification is achieved through the analysis of formal models — called paradigms — of scientific inquiry. Each paradigm specifies five concepts central to empirical inquiry, namely:
(a) a theoretically possible reality
(b) intelligible hypotheses
(c) the data available about any given reality, were it actual
7 As mentioned in the preface, however, the book is far from exhaustive in treating paradigms with claim to illuminating aspects of scientific discovery. In particular, we do not discuss PAC models of learning (see Kearns and Vazirani [105] for an excellent overview).


Page 14
(d) a scientist
(e) successful behavior by a scientist working in a given, possible reality
One important question about a given paradigm is this: For what classes of possible realities do there exist scientists who are guaranteed to succeed within any reality drawn from the class?
In order to apply the resources of computational theory to the problem of inductive inference, possible realities are often conceived as sets of integers. In turn, the integers can be conceived as codes for complex objects such as sentences or experimental data. Hypotheses within our theory are usually taken to be computer programs operating over integer inputs. A scientist is any system that converts the finite data sets generated by an environment into hypotheses about the totality of that environment. We shall mainly be concerned with scientists whose behavior is simulable by computer. Much of our inquiry will be devoted to scientists who possess special properties, such as efficiency, ability to cope with noisy data, etc.
Through a simple game, we illustrated one criterion of successful scientific behavior; subsequent chapters will investigate a variety of alternatives. It was noted that our theory distinguishes scientific success from the confidence that a scientist might feel about such success. Only the former will be at issue here.


Page 15
2
Formalities
We now review the standard notations and definitions to be used in the sequel. This material is designed to be more of a reference than part of our main story. So we advise the reader to skim the present chapter, consulting it later as needed.
What We Assume of the Reader.
We assume that the reader has some background in the theory of computation. In particular, we assume the reader is acquainted with the Church-Turing Thesis, the existence of universal Turing machines, the unsolvability of the halting problem, the partial recursive functions, the (total) recursive functions, and the recursively enumerable sets. Almost any text on the theory of computation covers these topics. See, for example, any of Rogers [158], Hopcroft and Ullman [82], Cutland [45], and Lewis and Papadimitriou [126].
The Natural Numbers.
N denotes the set of natural numbers { 0, 1, 2, . . . } and N+ denotes the set of positive integers; '#' and '*' are special constants that are not elements of N. For two natural numbers m and n,
Ranges of Variables.
If a symbol is said to be a variable that ranges over a particular domain, then by convention decorated versions of the symbol (e.g., superscripted and subscripted versions of the symbol) are also variables over the same domain. Generally, e, i, j, k, l, m, n,, . . ., x, y, z range over N; a, b, c, d range over [image]; f, g, h, p, q, and r range over total functions from N to N; and h , n , q , and x range over (possibly) partial functions from N to N. Uppercase roman letters are generally used as variables over subsets of N and sometimes N k for some k> 1. Upper case script letters, A, B, C, . . ., are generally used as variables ranging over classes of sets or functions.
Sets.
The symbols [image], [image], [image], and [image] denote proper subset, proper superset, subset (possibly proper) and superset (possibly proper), respectively. denotes 'element of.' [image] denotes the empty set. card(A) denotes the cardinality of A. denotes card(N) and [image] denotes the cardinality of the power-set of N. min(A) denotes the minimum element of A, where [image]. max(A) denotes the maximum element of A, where


Page 16
if A is infinite and [image]. By convention, min(x 1, . . ., x k) = min({x 1, . . ., x k}) and max(x 1, . . . ,x k) = max({ x 1, . . ., x k}). For each [image], A[n] denotes [image]. A - B denotes the set [image]. For [image], [image] denotes the complement of A, that is, N - A. A D B denotes the symmetric difference of A and B, that is, [image]. denotes the disjoint union of A and B, that is, [image]. For each [image], A = n B means that [image]; A and B are called n-variants. A =* B means that card(A D B) is finite; A and B are called finite variants.
For each finite set A, we define the canonical index of A to be the natural number [image]. (The canonical index of [image] is thus 0.) The canonical indexing provides a one-to-one correspondence between finite sets and the natural numbers. D x denotes the finite set whose canonical index is x(see Rogers [l58])
For natural numbers x and z, let:
.
.
.
.

Let R denote the set of real numbers. For each a and [image], let:
.
.
.
.

Logical Symbols.
As usual, '' and $ are used for universal and existential quantifiers. , [image], and $ ! denote 'for all but finitely many,' 'there exist infinitely many,' and 'there exists a unique.' That is:
is finite.
is infinite.
is a singleton.
The symbols [image], [image], and [image], respectively, denote logical negation, or and and. Fix an [image], and, for each [image], let [image] be a predicate. Then, [image] denotes [image] and [image] denotes [image].
Functions.
Let A and B be arbitrary sets (that is, not necessarily subsets of N). Then [image] (respectively, [image]) denotes the collection of all partial (respectively, total) functions from A to B. Unless otherwise specified, when we say y is a partial function we will mean that y : and when we say f is a total function, we will mean


Page 17
that [image]. The domain and range of y are denoted by domain( y ) and range( y ), respectively. denotes the class [image]. denotes the class of all total recursive functions. denotes the class of all partial recursive functions. denotes the class of recursive functions with range in N+ [image], [image], and occasionally other script capital letters range over classes of recursive functions.
We often identify a (partial) function, h with its set of ordered pairs (that is [image] . Thus [image] is used to denote the everywhere undefined function. means that h is defined on x, and [image] means that h is defined on x and h (x) = y; [image] and [image] both mean that h is not defined on x. Thus [image] and [image]. h (x) = q (x) means that either [image] or else both [image] and [image]. means that the graph of h is contained in the graph of q or, equivalently, for all [image], h (x) = q (x). denotes the composition of h and q , that is, for each x,
h [n] denotes the partial function such that, for each x,
For each [image] and partial function h , [image]. For each [image], h =n q means that [image]; h and q are called n-variants. Also h =* q means that [image] is finite; h and q are called finite variants. The characteristic function of a set A is denoted by c A, that is, for all x,
Suppose Q is an n-ary predicate. Then,
Suppose that [image] is an expression with xl, . . ., x n as its only free variables. Then [image] denotes the function that maps (x1, . . ., x n) to the value [image]. For example, [image] denotes the function that maps x to x + 1, and [image] denotes the function that maps (x, y) to x + y.


Page 18
Pairing Functions.
A pairing function is a recursive one-one correspondence between N × N (pairs of natural numbers) and N (the natural numbers themselves). We use the following pairing function. For each x and y, define [image] to be the number whose binary representation is an interleaving of the binary representations of x and y where we alternate x's and y's digits and start on the right with the least most significant y digit. For example, [image] since 15 = 1111 (binary), 2 = 10 (binary) = 0010 (binary), and 94 = 10101110 (binary). Define p 1 and p 2 to be the functions such that, for all x and y, [image] and [image]; p 1 and p 2 are, respectively, called the first and second projection functions for [image]. This particular pairing function and its projection functions are computable (on deterministic multi-tape Turing Machines) in simultaneous linear time and constant space. (See Royer and Case [161] for details.) By convention, for all x, [image] and, for all x1, . . ., x n+1, [image], where [image]. The function [image] is a one-one correspondence between N n and N. Following the usual conventions of computability theory we will freely identify a partial function [image] with the partial function [image] such that, for all x 1, . . ., x k,
For each A, [image] we define [image].
Languages.
Henceforth we use the term language as a synonym for "recursively enumerable subset of natural numbers," and we often let L serve as a variable for languages. denotes the class of all recursive languages. e denotes the class of all recursively enumerable languages. Observe that the empty set is recursively enumerable, so [image]. ranges over collections of recursively enumerable languages.
A language L is sometimes said to represent the set [image]. We say L is a single-valued language if and only if, for each x, there is at most one y such that [image] (hence, L represents a partial recursive function). We say that L is a single-valued total language if and only if, for each x, there is exactly one y such that [image] (hence, L represents a total recursive function).
For each [image] and for each [image], it is useful to define the following:


Page 19
Functionals and Operators.
In this book a functional is a (possibly partial) mapping from either [image] or [image] to N, and an operator is a total mapping from either [image] [image] or [image].
Let [image] be a canonical indexing of finite functions.1 [image] is a recursive functional (or, more accurately, an effective continuous functional) if and only if there is an r.e. set A such that, for all [image] and all [image], [image]. (For all [image], recursive functionals of type [image] can be defined similarly.) A recursive functional F has the following two topological properties for all [image] and [image].
Monotonicity: .
Compactness: .
We say that such an F is a total recursive functional if and only if, for all [image] and [image], [image].
We say [image] is a recursive operator if and only if there is a recursive functional [image] such that, for all a 1, . . ., a k, x1, . . ., x l,
In the setting of recursive operators, the analog of both the monotonicity and compactness properties is the following property that holds for all [image].
Continuity: , where s ranges over finite functions.
We say Q is a total recursive operator if and only if Q is a recursive operator such that, whenever a 1, . . ., a k are all total, so is [image].
Programming Systems.
A programming system for a class of partial recursive functions [image] is a partial recursive function n such that [image], By convention, if we do not specify a [image], then [image] is assumed. Intuitively, n , a programming system for [image], corresponds to an interpreter for some programming language capable of expressing all the partial recursive functions; n (p, x) is the result, if any, of running n -program p on datum x. We typically write n p(x) in place of n (p, x). Thus, n p is the partial recursive function computed by n -program p and [image] is an effective
1 The details of this indexing do not matter. All that we care about is that every finite function has an index and that there is a recursive function r such that, for all i, [image], and [image] is the graph of s i


Page 20
indexing of the partial recursive functions. We often refer to p as the n -index of the function Up and typically drop the " n -" prefix when n is understood.
Fix a programming system n . For each i, define [image]. Recall that a set is recursively enumerable if and only if the set is the domain of some partial recursive function. Thus it follows that [image] is an indexing of the recursively enumerable sets. We sometimes say that i is the v-grammar for [image].
An acceptable programming system n is a programming system with the additional property that: for all other programming systems y , there is a recursive function t, such that, for all p,
One can think of t as an effective translator of y -programs into equivalent n -programs (i.e., a compiler). Thus, ' n is acceptable' means that n has the maximality property that, given any other programming system y there is an effective way of re-expressing y -programs as n -programs. Almost any reasonable formalism for the partial recursive functions (e.g., Turing machines, Algol 60, Fortran, ML, etc.) corresponds to an acceptable programming system, although it is not hard to construct nonacceptable programming systems. We fix one particular acceptable programming system as our standard and let j denote it. For ease of notation, we often drop j from [image].
All acceptable programming systems satisfy the following theorem (stated for j ) due to Kleene.
2.1 Theorem (The S-m-n Theorem) For each m, and n> 0, there is a recursive function [image] such that, for all p, x1,. . ., x m, and y1, . . . ,y n in N,
Moreover, one can take each [image] function to be one-one and monotone increasing in each of its arguments.
To help see the import of this theorem, consider the m = n = 1 case and think of p as a program with its only input statement as:
input (a, b)
Then, intuitively, the program s(p, x) is the modification of p produced by replacing the input statement by:


Page 21
; input (b)
Thus, x is treated as a datum which s stores in the "text" of the program p. This may seem a very innocuous property, but is in fact extremely powerful. For example, one can characterize the acceptable programming systems as exactly those programming systems for which the s-m-n theorem holds. The s-m-n theorem will be a key tool in the technical work of this book. Here is a simple application that establishes another property of acceptable programming systems.
2.2 Lemma There is a one-one, strictly increasing, recursive function [image] such that, for all p and x,
Thus, p, pad(p, 0), pad(p, 1), . . . is an infinite, strictly increasing sequence of programs for j p.
Proof: Suppose i is a j -program such that, for all p, x, and y, j (p, x, y) = j (y). (Since [image] is partial recursive, such an i must exist.) Define [image]. By Theorem 2.1 pad is one-one, strictly increasing, and, for all p, x, and y,
Thus, pad(·, ·) is as required.
Recursion Theorems.
Another important property satisfied by acceptable programming systems is Kleene's recursion theorem. This theorem provides us with the means to construct programs that self-referentially refer to their own program text. Here is the theorem's formal statement.
2.3 Theorem (Kleene's Recursion Theorem) For each partial recursive y there is a j -index e such that, for all x,
Moreover, one can uniformly, effectively find such an e. That is, there is a recursive function r such that, for each p, [image].


Page 22
Consider the j -program e in (2.1). Intuitively, this program, on input x, creates a (quiescent) copy of its own "program text" and then uses that "text" together with x as input on which to emulate p. In effect, e creates a self-model which it uses together with its input as input to an emulation of p; e can be thought of as "having" (or more properly, creating) self-knowledge which it employs in a computation of y ; y represents the use to which e puts its self-knowledge.
Proof (of Theorem 2.3): Let d be a j -index be such that, for all x and y, [image]. Hence,
Let [image]. Note that
Therefore, e is as required. See Exercise 2-1 for the proof of the moreover clause.
The recursion theorem is among our most important technical tools. Here is a simple application of Theorem 2.3 that we will have occasion to use later.
2.4 Lemma There exists a j -index e such that, for all y, j e(y)= e, i.e., for all inputs, e outputs its own program.
Proof: Let [image]. Clearly, y is recursive. Hence, by the recursion theorem there is an e such that, for all y, j e(y) = j (e, y) = e.
On occasion we will have recourse to use two strengthenings of the recursion theorem: the k-ary recursion theorem (k > 0) and the operator recursion theorem. The k-ary recursion theorem permits us to construct sets of k distinct programs, each of which may refer to its own and any of its k - 1 many sibling's program text. The operator recursion theorem is, intuitively, an infinitary version of the k-ary theorem. The formal statements of these theorems are given just below. The proof of Theorem 2.5 is left to Exercise 2-7.
2.5 Theorem (The k-ary Recursion Theorem, Smullyan [181]) For each [image], [image] and [image], there are recursive functions r1, . . ., r k such that, for all [image], [image], and [image], we have:


Page 23
2.6 Theorem (The Operator Recursion Theorem, Case [24]) Suppose Q is a re-cursive operator; then there is a recursive, monotone increasing h such that, for all n and x,
Proof: Let f be a recursive function such that, for all i, Q ( j i) = j f(i). By the s-m-n theorem, there is a recursive, monotone increasing s such that, for all p, x, y, and z,
Consider [image]. There is a recursive g such that, for all x, [image]. Thus,
Let d be such that [image]. Then
Taking x = d we have
Let [image] and we are done.
Here is a sample application of Theorem 2.6. See Exercise 2-5 for the proof.
2.7 Lemma There are distinct numbers a0, a1, . . . such that, for all i, W ai = { a i+1}.
Program Size Complexity.
One typically thinks of the "size" of a program as something like the number of characters in the program text, the number of lines in the program (where there is an a priori bound on line lengths), or the number of bytes in the compiled version of the program. In theoretical settings (where programs are identified with elements of N or {0, 1}*), one often uses [image] or just p itself as the size of program p. Blum observed [20] that all the natural examples have in common that, given size m, one can effectively construct a finite table of all of the programs of size m. We state Blum's "axiom" for program size in the following equivalent form for an arbitrary programming system n .


Page 24
2.8 Definition A recursive function s is a program size measure for v if and only if there exists a recursive function bound such that, for all n -programs p and all [image], if [image], then [image].
Clearly, [image] and [image] are examples of program size measures. Blum [20] showed that all program size measures are equivalent in the following sense.
2.9 Theorem Suppose s and s' are both program size measures for v. Then there is a recursive function h such that, for all p,
and [image].
Thus, for recursively invariant results concerning program size (which is all that we will be concerned with in this book), the choice of program size measure does not matter. Therefore, for simplicity we take the size of n -program p to be just p itself. For each partial recursive function a , we define MinProg n ( a ) to be the least number p such that n p = a . Also, for each language L, we define MinGram n (L) to be the least number i such that [image].
Dynamic Program Complexity.
A two-place partial recursive function F is a complexity measure (Blum [19]) for j if and only if F satisfies the two Blum axioms:
(i) For all p, [image].
(ii) The predicate [image] is recursively decidable.
By convention, for all p, F p denotes [image]. Intuitively, F p(x) is the amount of some dynamic resource used by j -program p in computing j p(x). Here is an example. Suppose j is an acceptable programming system based on deterministic multi-tape Turing Machines, and suppose F (p, x) is the number of instructions the Turing Machine coded by p executes on input x, where F (p, x) is undefined if the Turing Machine fails to halt on input x. Then F satisfies the Blum axioms. Blum showed that complexity measures are all equivalent in the following sense.
2.10 Theorem Suppose F and F ' are complexity measures for j Then, there is a recursive function h such that, for all p and all but finitely many x,
and [image].
Thus, for recursively invariant results concerning computational complexity (which is all that we will be concerned with in this book), the choice of complexity measure does not matter. Thus, F will denote a fixed, arbitrary complexity measure.


Page 25
We use F to introduce clipped versions of j and the indexing [image]. For each i and s, define:
Note that there are recursive functions f and g such that, for all i and s, [image] and [image].
Computation Relative to an Oracle.
Informally, we say that a function a is computable relative to a set A if and only if a can be computed by an algorithm that, along with all the usual things algorithms are permitted to do, is allowed to use X A as a "built-in" subroutine. Formally, we say that a is computable relative to A if and only if there is a recursive functional F such that [image] For example, let K denote the diagonal halting problem set, that is, [image] K is a recursively enumerable, nonrecursive set.) Then, [image] computable relative to K. (See Exercise 2-8.)
Limiting Computability.
Suppose [image] an infinite sequence of integers. We write [image] and only if, for all but finitely many i, a i = b. If, for infinitely many i, [image] , we write [image]. We say that a is limiting partial recursive if and only if there is a (total) recursive function g such that, for all x, [image]. So, a (x) is defined if and only if the limit exists. We say that a is limiting recursive if and only if a is total and limiting partial recursive. The following lemma is essentially due to Post.
2.11 Lemma A function a is limiting partial recursive if and only if a is partial recursive in the halting problem.
Thus, the limiting partial recursive functions form a strictly larger class than [image]. A set A is limiting recursive if and only if X A is limiting recursive. A functional F: is limiting recursive if and only if there is a total recursive functional [image] such that, for all f and x, [image].


Page 26
Exercises
2-1 Suppose d is such that, for all p, x, and y, [image]. Show that [image] is as required for the moreover clause of Theorem 2.3.
2-2 Use the recursion theorem to show that, for each partial recursive function y , there is another partial recursive function y ' such that
(i) [image] and
(ii) for all [image].
See page 16 for definition of finite variant of a function.
2-3 (Wiehagen [196]) Use the recursion theorem to show that, for each r.e. set L, there is another r.e. set L' such that
(i) L and L' are finite variants and
(ii) L' = W x where x is the smallest element in L'.
See page 16 for definition of finite variant of a set.
2-4 Use the 2-ary recursion theorem to show the existence of distinct j -programs el and e2 such that, for all x, [image] and [image].
2-5 Use the operator recursion theorem to show that there is a recursive function h such that, for all x, [image]. Taking, a i = h(i) , [image], it follows that the a i's are as required in Lemma 2.7.
2-6 Show that there is a limiting recursive function h such that for all recursive f, for all but finitely many x, f(x) < h(x).
2-7
(a) Prove Theorem 2.5 from Theorem 2.6.
(b) Prove Theorem 2.5 directly from Theorem 2.1.
2-8 Show that [image] is computable relative to K.


Page 27
3
Identification
In Chapter 1 we introduced the idea of a paradigm for scientific discovery and enumerated the concepts that must be specified before a paradigm takes on mathematical meaning. A set of tools for building the needed concepts was described in Chapter 2. In the present chapter we deploy some of this apparatus in the investigation of two fundamental paradigms and some variants thereof. They are called:
• identification of languages; and
• identification of functions.
These paradigms are the barest and simplest to be encountered in this book, yet their underlying structure will show up in all of our ensuing work.
Pursuant to the analysis in Section 1.2, the paradigms are presented by specifying their component concepts, namely:
3.1 (a) a theoretically possible reality
(b) intelligible hypotheses
(c) the data available about any given reality, were it actual
(d) a scientist
(e) successful behavior by a scientist working in a given, possible reality
We shall devote considerable discussion to 3.1a-e in the context of language identification. Our discussion of function identification—and of subsequent paradigms in later chapters—can then be briefer, since many of the same considerations carry over to the new settings. The ideas discussed in this chapter derive from seminal papers by Gold [80] and Blum and Blum [18].
The theoretically possible realities proper to our first paradigm are languages, in the technical sense of Chapter 2, so we begin with their intended interpretation within the paradigm of language identification.
§3.1 Languages as Theoretically Possible Realities
Languages can arise as objects of inquiry within either a scientific or a developmental context. We consider these two contexts in turn.


Page 28
§3.1.1 Languages as Scientific Possibilities
Consider a scientist studying periodicity in the arrangement of atoms packed into the microstructure of a certain class of alloys. She poses the question: For what natural numbers n are there alloys from the class that exhibit periodicity n? Let us call this latter set periods. The results of her observations can be summarized by statements like:
3.2 [image] , [image] , [image] , [image], [image], . . .
or more compactly by:
3.3 3, 41, 17, 53, 75, . . .
The scientist's goal is to transform these data into an accurate and stable conjecture about periods. A language L in this setting corresponds to one possible reality, namely, the reality in which periods = L.
In what follows we shall assume the set periods to be recursively enumerable. It is possible that Nature is not so kind as to guarantee the machine acceptability of sets of integers that correspond to physical processes. However, to keep our topic manageable, we shall limit attention to situations in which the recursive enumerability of the underlying reality is a reasonable assumption; let us take it to be so in the periods example.
In the simplified metaphysics that governs our analysis of science, we always assume that Nature selects exactly one underlying reality to be actual. However, not every logically possible reality need be assumed a genuine alternative. Rather, attention may be focused on some proper subset [image] of the class of all languages. Such a focus amounts to stipulating that the theoretically possible alternatives are limited to [image], other languages being mere logical possibilities ruled out on scientific grounds. Stipulations of this kind allow us to frame questions such as the following: ''Suppose that it is known in advance that periods falls in [image]. What kinds of scientists (if any) are sure to discover which member of [image] is equal to periods?"
A scientist might obtain assurance that periods is limited to a subclass of languages in two ways. On the one hand, prior research carried out by other scientists (e.g., her professors) might allow certain languages to be ruled out of the class of genuine alternatives. On the other hand, it is possible that human genetic endowment imposes certain true beliefs about Nature's choice of language, making languages discrepant with these beliefs seem highly implausible.


Page 29
§3.1.2 Human Languages and Comparative Grammar
Turning to the developmental context, languages in our technical sense may be conceived as representing human languages like Chinese or German that must be mastered by children in the course of their development. Within this perspective, human languages are conceived in a manner familiar from the theory of formal grammar (see Hopcroft and Ullman [82, Chapter 1]) where a sentence is taken to be a finite string of symbols drawn from some fixed, finite alphabet, and a language is construed as a subset of all possible sentences. This definition embraces rich conceptions of sentences, for which derivational histories, meanings, and even bits of context are parts of sentences. Since finite derivations of almost any nature can be collapsed into strings of symbols drawn from a suitably extended vocabulary, it is sufficiently general to construe a language as the set of such strings. By coding strings numerically (see Section 1.4.1), a human language may then be conceived as a subset of the natural numbers N. However, not just any subset of N can play this role. Since human languages are generally considered to have grammars, and since grammars are intertranslatable with Turing Machines, we restrict attention to the recursively enumerable subsets of N—that is, to "languages" in our technical sense.
Now it seems evident to many linguists (notably, Chomsky [40, 43]) that children are not genetically prepared to acquire any arbitrary language on the basis of the kind of casual linguistic exposure typically afforded the young. Instead, a relatively small class [image] of languages may be singled out as "humanly possible" on the basis of their amenability to acquisition by children, and it falls to the science of linguistics to propose a nontrivial description of [image]. Specifically, the branch of linguistics known as "comparative grammar" is the attempt to characterize the class of (biologically possible) natural languages through formal specification of their grammars; and a theory of comparative grammar is such a specification of some definite collection. Contemporary theories of comparative grammar begin with Chomsky (e.g., [38, 39]), but there are several different proposals currently under investigation (see Wasow [190] and Lasnik [124]).
Theories of linguistic development stand in an intimate relation to theories of comparative grammar. For if anything is certain about natural language, it is this: children can master any natural language in a few years' time on the basis of rather casual and unsystematic exposure to it. This fundamental property of natural language can be formulated as a necessary condition on theories of comparative grammar: such a theory is true only if it embraces a collection of languages that is learnable by children. For this necessary condition to be useful, however, it must be possible to determine whether


Page 30
given collections of languages are learnable by children. How can this information be acquired? Direct experimental approaches are ruled out for obvious reasons. Investigation of existing languages is indispensable, since such languages have already been shown to be learnable by children; as revealed by recent studies (e.g., van Riemskijk and Williams [189] and Werker [193]), much knowledge can be gained by examining even a modest number of languages. We might hope for additional information about learnable languages from the study of children acquiring a first language. Indeed, many relevant findings have emerged from child language research. For example a child's linguistic environment appears to be devoid of explicit information about the nonsentences of her language (see Section 3.2, below). As another example, the rules in a child's immature grammar are not simply a subset of the rules of the adult grammar but appear instead to incorporate distinctive rules that will be abandoned later (see Pinker [148]).
However, such findings do not directly condition theories of comparative grammar. They do not by themselves reveal whether some particular class of languages is accessible to children or whether it lies beyond the limits of their learning. The theory of empirical discovery described in this book may be conceived, in part, as an attempt to provide the inferential link between the results of acquisitional studies and theories of comparative grammar. It undertakes to translate empirical findings about language acquisition into information about the kinds of languages accessible to young children. Such information can in turn be used to evaluate theories of comparative grammar.
To fulfill its inferential role, the theory of empirical discovery offers a range of models of language acquisition. This is achieved by providing precise construal of concepts generally left informal in studies of child language, namely, the five concepts listed in Section 1.2. The interesting paradigms from the point of view of comparative grammar are those that best represent the circumstances of actual linguistic development in children. The deductive consequences of such models yield information about the class of possible natural languages. Of course, the paradigm to be presented in this chapter is only a crude representation of language acquisition by children. Many of the models to be discussed later are attempts to improve its fidelity.
More extensive discussion of the role of paradigms in comparative grammar is available in Wexler and Culicover [194], in Osherson, Stob, and Weinstein [138], in Osherson and Weinstein [144], and in Osherson, Weinstein, de Jongh, and Martin [145]. We shall return frequently to both language acquisition and scientific discovery in order to motivate our theory.


Page 31
§3.2 Language Identification: Hypotheses, Data
Let us now complete the definition of the language identification paradigm. It has already been said that the theoretically possible realities—item 3.1a in our list of concepts—are the members of [image], the collection of all languages. It is thus natural to conceive of "intelligible hypotheses" as computer programs or "grammars" for accepting languages. More precisely, it will prove simpler to assimilate hypotheses to the indexes associated with programs, as explained in Chapter 2. To aid intuition, however, we shall often revert to the terminology of grammars and programs. Items 3.1a,b are thereby specified.
Turning to 3.1c, we consider the data that Nature makes available about any given language, L. The totality of all such data is conceived as a listing of L in some arbitrary order. To allow such a list to contain pauses in the presentation of data (corresponding to moments in which there is no linguistic input), we adjoin a nonnumerical element # to N. Our conception of 3.1c may then be rendered as follows.
3.4 Definition (Gold [80])
(a) A text is any mapping of N into [image]. A text may be visualized as an infinite sequence x0, x1, x2, . . . of members of [image]. (The typical variable for texts is T.)
(b) The set of numbers appearing in a text T is denoted by content(T). (Thus, the content of a text never includes #.)
(c) Let [image] and text T be given. T is for S just in case content(T) = S.
For example, consider the following text T:
3.5 0, 0, #, #, 2, 2, #, #, 4, 4, #, #, 6, 6, . . .
content(T) = {0, 2, 4, 6,...}, so T is "for" the set of even numbers. We note that there are uncountably many texts for any nonempty language. On the other hand, there is only one text for [image], namely: #, #, #, . . . .
From the point of view of language acquisition, texts may be understood as follows. We imagine that the sentences of a language are presented to the child in an arbitrary order, repetitions allowed, with no ungrammatical intrusions. Negative information is withheld—that is, ungrammatical strings, so marked, are not presented. Each sentence of the language eventually appears in the available corpus, but no restriction is placed on the order of their arrival. In the event that the language in question is infinite, different sentences continually arise, even though there may also be repetitions of previously presented sentences. If the language is finite, it is possible for the text to finish with an


Page 32
infinite string of #'s; alternatively (if the language is nonempty), it must present at least one sentence infinitely often.
The foregoing picture of the child's linguistic environment is motivated by studies of language acquisition. Several investigations (for example, Brown and Hanlon [22], Hirsh-Pasek, Treiman, and Schneiderman [81], and Demetras, Post, and Snow [55]) give reason to believe that negative information is not systematically available to the learner. Other studies (e.g., Newport, Gleitman, and Gleitman [136] and Schieffelin and Eisenberg [168]) underline the relative insensitivity of the acquisition process to variations in the order in which language is addressed to children. And Lenneberg [125] describes clinical cases revealing that a child's own linguistic productions are not essential to his or her mastery of an incoming language. For further discussion, see Pinker [148].
§3.3 Language Identification: Scientists
We turn to 3.1d, the concept of scientist in the present model. The following notation will be used here and later.
3.6 Definition
(a) Let text T and [image] be given. The n th member oft is denoted by T(n). The initial finite sequence of T of length n is denoted T[n].
(b) The set [image] is denoted by SEQ; s , [image], g are variables over SEQ.
(c) Let [image] be given. The length of s is denoted by [image]. The unique [image] with [image] is denoted [image]. The set of numbers appearing in s is denoted by content( s ). For [image], the n th member of s is denoted by s (n), and the initial sequence of length n in s is denoted by s [n].
For example, if T is the text of 3.5, then T(2) = #, T[5] = 0, 0, #, #, 2, and content(T[5]) = {0, 2}. We note the following facts about this notation.
3.7 Lemma Let text T and [image] be given.
(a) The "first" member oft is T(0); T(1) is the second member.
(b) T[n] does not extend to T(n), so content(T[n]) does not in general include T(n). (For example, if T is 3.5, then 2 [image] content(T[4]).)


Page 33
(c) T begins with s if and only if [image].
(d) [image], but [image], the empty sequence.
(e) SEQ is just the collection of all finite sequences over [image] . This collection is countably infinite.
Consider again our scientist studying periodicity, and suppose that her research gives rise to the text T of 3.3 (representing 3.2). T(n) may be conceived as the data generated at the n th moment of investigation, so T[n] is all the evidence available to the scientist about periods up to the n th moment, the so-called "evidential state" of the scientist at that time. More generally, any [image] constitutes a logically possible evidential state at the [image] moment. Now within the present paradigm, empirical inquiry is conceived as the process of converting evidence into theories. Since the set of all possible evidential states is represented by SEQ and the set of all intelligible hypotheses is represented by N, it is natural to take a scientist to be any system that maps the former into the latter. Officially, then, a scientist within the language identification paradigm is any function—partial or total, computable or noncomputable—from SEQ to N. We use F as a variable for scientists, especially when it is not specified whether the scientist in question is computable.
Let text T and [image] be such that [image]. Then WF(T[n]) denotes the language corresponding to the grammar that F produces upon examining the finite sequence of length n in T. We often say that this language is "conjectured by F on T[n]." If [image], then WF(T[n]) is not defined.
Intuitively, it is helpful to picture a scientist as traveling down a text from left to right, examining the entries in turn. At each step, the scientist is confronted with a new member of SEQ—that is, a new evidential situation s . The scientist may respond to s with either a new or previously-emitted hypothesis (in which case, she is defined on s ); alternatively, she may produce no hypothesis at all (in which case she is undefined on s ).
To illustrate, the scientist in our periods example might implement the function [image] defined as follows. Let P and O be the sets of prime numbers and odd numbers, respectively. Let n, o, and p be indexes for N, O, and P.
3.8 For all [image]:


Page 34
So, if T is 3.3 then for [image], and Fperiods(T[5]) =o.
Two other examples of scientists can be entered here.
3.9 For all [image]:
(a) Ffinite( s ) = the least index for the language content( s );
(b) Ffive ( s = 5.
Scientist Ffinite behaves as if its current evidential state includes all the numbers it will ever see. Consequently, it conjectures a grammar for the finite language made up of just the elements seen to date. Being parsimonious, Ffinite selects the smallest possible grammar. Scientist Ffive has fixed ideas about the incoming language; indeed, its behavior does not even depend on the data presented. We shall have occasion to refer to these two functions later.
Our conception of scientist is broad in some respects. The everywhere undefined function [image] is a scientist, as are functions that seem to make non-optimal use of data. For example, if our scientist keeps poor records of past experiments, her hypotheses might depend only on the last datum examined, i.e., only on T(n) rather than on T[n + 1]. Or she might change her conjecture upon encountering #, even though # provides no information about the underlying language. Such scientists might be termed "subrational," and will be central to paradigms that attempt to model children (for example, in Section 3.8 below). In addition, as Chapter 5 will reveal, our intuitions about scientific rationality are not always trustworthy in the context of precise models of empirical inquiry. So it is wise at this stage not to eliminate any potential scientists from consideration.
Our conception is broad, as well, in allowing both computable and noncomputable functions to be scientists. For those convinced that human intellectual capacities are computer simulable, noncomputable scientists might seem of scant interest. Indeed, most of the paradigms to be discussed in this book restrict attention to the computable case. Nonetheless, our encounter with noncomputable scientists is useful for two reasons. First, despite considerable speculation it is still unclear whether noncomputable processes exist in nature (for discussion see Webb [191] and Suppes [187]). In particular, it is simply not known whether the human brain is suitably modeled as a computational agent. Worse yet, the answers to such questions depend on apparently arbitrary conventions about what to count as inputs and outputs to naturally occurring processes (see Osherson [137]). A second reason to study noncomputable scientists is that many results in the theory of inductive inference do not depend upon computability assumptions; rather, they are information theoretic in character (examples arise in Section 3.6 below). Consideration


Page 35
of noncomputable scientists thereby facilitates the analysis of proofs, making it clearer which assumptions carry the burden. This issue will be revisited in Chapter 11.
On the other hand, Chapters 9 and 10 will discuss senses in which our present conception of scientist is too narrow. Note, for example, that scientists as defined here cannot make decisions on a random basis by including the outcome of a coin-toss as an additional input.
§3.4 Language Identification: Scientific Success
Languages, hypotheses, texts, and scientists are the dramatis personae of the identification paradigm. To develop its story-line we turn now to the criterion of successful inquiry, 3.1e, which is defined in three steps.
§3.4.1 Identifying Texts
3.10 Definition Let scientist F, text T, and [image] be given.
(a) F converges to i on T (written: ) just in case for all but finitely many [image], F(T[n] = i. If there exists an i such that [image], then we say [image]; otherwise we say F(T) diverges (written: ).
(b) F identifies T just in case there is [image] such that F converges to j on T, and W j = content(T).
So, to identify T, F's conjectures must eventually stabilize to a single grammar for content(T). This is impossible, of course, if T is for a non-r.e. set. In the case of interest, however, T is for some language [image], hence there are infinitely many grammars for content(T).
Suppose that F identifies T. Definition 3.10 places no finite bound on the number of times that F "changes its mind" on T. In other words, the set [image] may be any finite size; it may not, however, be infinite. Similarly, the smallest [image] such that W F(T[m]) = content(T) may be any finite number, so F's first correct guess may occur arbitrarily late in T. It is also permitted that for some [image], W F(T[n]) = content(T), but [image]. That is, F may abandon correct conjectures, provided that F eventually sticks with some correct conjecture. Observe that to identify a text, a scientist can be undefined on at most a finite number of its initial sequences.


Page 36
If the text T indicated in 3.3 continues by listing all the odd numbers, then Fperiods, of 3.8 identifies T. In contrast, if T is for any set other than P, O, or N, then Fperiods does not identify T. For other examples, let Ffinite and Ffive, be as specified in 3.9. Ffinite> identifies any text for a finite language and no text for an infinite one. Ffive identifies a given text T if and only if content(T) = W5.
§3.4.2 Identifying Languages
Children are able to learn a language on the basis of many orderings of its sentences. Since Definition 3.10 pertains to individual texts, it does not represent this feature of language acquisition. Similarly, our scientist studying periods might converge to a correct grammar for the set, regardless of the way Nature lists it for her. The next definition incorporates this feature of empirical inquiry.
3.11 Definition (Gold [80])
Let scientist F and [image] be given. F identifies L just in case F identifies every text for L.
It is easy to verify that Fperiods identifies P, O, and N. Ffinite identifies every finite language but no infinite one. Ffive identifies W5 and nothing else.
Suppose that scientist F identifies language L, and let T and T' be different texts for L. It is consistent with Definition 3.11 that F converge on T and T' to different grammars for L. Likewise, F might require more inputs from T than from T' before emitting a grammar for L.
§3.4.3 Identification of a Collection of Languages
Children are able to learn any arbitrarily selected language drawn from a large class; that is, their acquisition mechanism is not prewired for just a single language. Similarly, there might be a wide subcollection [image] of e such that our scientist studying periods would succeed on any text for any member of [image]. Our definition of identification is now extended accordingly.
3.12 Definition (Gold [80]) Let scientist F and [image] be given. F identifies [image] just in case F identifies each [image]. is said to be identifiable just in case some scientist identifies it; it is said to be unidentifiable otherwise.
We use [image] to represent collections of languages. The following reformulation of Definition 3.12 is worth recording.


Page 37
3.13 Lemma Scientist F identifies [image] if and only if F identifies every text for each [image].
Definition 3.12 implies that Fperiods identifies {P, O, N}, and that Ffinite identifies the collection of all finite languages. This latter collection will arise frequently in our discussion, so it is well to have a name for it.
3.14 Definition The collection [image] of all finite languages is denoted by [image].
We thus have:
3.15 Proposition Ffinite identifies [image] (so [image] is identifiable).
Ffive identifies {W5} and no more. Indeed, every singleton collection {L} of languages is identifiable by a suitable, constant scientist. In contrast, questions about the identifiability of collections of more than one language are often nontrivial, since many such questions receive negative answers (as will be seen in Section 3.6). Such is the consequence of requiring a single scientist to determine which of several languages is inscribed in a given text.
Constant scientists serve to highlight the liberal attitude that we have adopted about empirical discovery. The function [image] identifies {W m} but exhibits not the slightest "intelligence" thereby (like the man who announces an imminent earthquake every morning). Within the identification paradigm it may thus be seen that successful inquiry presupposes neither rationality nor warranted belief, but merely stable and true conjectures in the sense provided by the last three definitions. Does this liberality render identification irrelevant to human learning? The answer depends on both the domain in question and the specific criterion of rationality to hand. To take a pertinent example, normal linguistic development seems not to culminate in warranted belief in any interesting sense, since natural languages exhibit a variety of syntactic regularities that are profoundly underdetermined by the linguistic evidence available to the child (see Chomsky [42, 41]). Indeed, one might extend this argument (as does Chomsky [42]) to every nontrivial example of human learning, that is, to every situation involving a rich set of deductively interconnected beliefs to be discovered by (and not simply told to) the learner. In any such case of empirical discovery, hypothesis selection is subject to drastic underdetermination by available data, and thus selected hypotheses, however true, have little warrant. It must be admitted, however, that all of this is controversial (for an


Page 38
opposing point of view, see Putnam [156] and Pullum [154]). In any case we shall later consider paradigms that incorporate rationality requirements in one or another sense (see Chapter 5).
Definition 3.12 is slightly different from the criterion of successful performance that we introduced informally in Section 1.3. Our earlier criterion required the learner to produce a last, correct guess, and to cease guessing thereafter. It thus corresponds to the following version of identification, here labeled ''identification*."
3.16 Definition Scientist F identifies* [image] just in case for every text T for any [image], [image] is finite and nonempty, and content(T) = WF(T[n) for the greatest [image]. In this case [image] is identifiable*.
The reader can easily verify that the two criteria of success are equivalent in the sense of the next proposition.
3.17 Proposition [image] is identifiable if and only if [image] is identifiable*.
Identification* is one of many criteria that are transparently equivalent to identification; another is presented in Exercise 3-4. (Criteria that are not equivalent to identification arise in Chapter 6.)
To close this section we record the identifiability of a collection of languages that. recalls the discussion of Section 1.3.
3.18 Proposition Let [image]. Then [image] is identifiable.
Proof: Given any [image], let x s be the least [image] such that [image]. Let scientist F be defined by the condition that for all [image], F( s ) = the least index for N - { x s }. It is clear that F identifies [image].
§3.5 Identification as a Limiting Process
Let scientist F identify text T, and let [image] be given. We say that F "begins to identify T at moment n" just in case n is the least integer such that:
(a)
(b)


Page 39
Now suppose that scientist Ffinite of 3.9 is working on text T for [image]. By Proposition 3.15 Ffinite identifies T. However, no finite initial segment of T provides sufficient information to determine the moment at which Ffinite begins to identify T. This is because no T[n] in T excludes the possibility that the next element of T (namely, T(n)) lies outside of content(T[n]), thus falsifying Ffinite's present conjecture.
More generally, identification is a limiting process in the sense that it concerns the behavior of a learning function on an infinite subset of its domain.1 Because of the limiting nature of identification, the behavior of a scientist F on a text T cannot in general be predicted from F's behavior on any finite portion of T. The unpredictability is not connected to our external viewpoint, requiring us to observe scientists from the outside. To make this clear, let us briefly consider scientists that announce their own convergence, and may thus be considered to observe their own operation.
3.19 Definition (after Freivalds and Wiehagen [67]) A scientist F is self-monitoring just in case for all texts T, if F identifies T, then
(a) there is a unique [image] with F(T[n]) = 0, and
(b) for this n, F(T[i]) = F(T[n + 1]) for all i > n.
Intuitively, a scientist is self-monitoring just in case she signals her own convergence, where 0 serves as the signal. The following proposition is suggested by our earlier remarks.
3.20 Proposition No self-monitoring scientist identifies [image].
Proof: See Exercise 3-5.
Propositions 3.20 and 3.15 show that identifiability does not entail identifiability by a self-monitoring scientist. Informally, a scientist can identify a text without it being possible for her to ever know that she has done so. (Compare Section 1.4.4, above.)
The limiting nature of identification implies that the behavior of a scientist on short members of SEQ is irrelevant to the class of languages it identifies. To say this more clearly, call a scientist n-mute just in case it is undefined on all [image] with [image]. Then, it is easy to verify that for all [image], [image] is identifiable if and only if some n-mute scientist identifies [image]. This fact invites the thought that some scientists make more efficient use of data than others, and that a more realistic model of empirical discovery would integrate concern for the resources consumed by inquiry. Such concerns will in
1 For this reason Gold [80] refers to identification as "identification in the limit."


Page 40
fact be addressed in Chapter 12. Let. us here consider a related issue, bearing on the infinitary nature of scientific success as we have defined it.
Texts are infinitely long, and convergence takes forever. These features of identification will be preserved in most of the paradigms discussed in this book. However, language acquisition is a finite affair, so our theory might seem from the outset to have little bearing on linguistic development. Similar remarks apply to scientific discovery.
We offer two replies to the foregoing objection. First, although convergence is an infinite process, the onset of convergence occurs only finitely far into an identified text. What is termed "language acquisition" may be taken to be the acquisition of a grammar that is accurate and stable in the face of new inputs from the linguistic environment; such a state is reached at the onset of convergence, not the end.
This first reply notwithstanding, convergence involves grammatical stability over infinitely many inputs, and such ideal behavior may seem removed from the reality of linguistic development. We therefore reply, secondly, that our theory is best interpreted as relevant to the design of a language acquisition system, not to the resources (either spatial or temporal) made available to the system that implements that design. Analogously, a computer implementing a standard multiplication algorithm is limited to a finite class of calculations, whereas the algorithm itself is designed to determine products of arbitrary size. In this light, consider the language acquisition mechanism [image] built into the three-year-old child. However mortal the child, [image] is timeless and eternal, forever three years old in design. Various questions can be raised about [image], for example: What class of languages does [image] identify? If comparative grammar is cast as the study of the design of the human language faculty — as abstracted from various features of its implementation — then such questions are central to linguistic theory, just as analogous questions are central to the study of scientific competence. (For more discussion, see Matthews and Demopoulos [129].)
§3.6 Characterization of Identifiable
The present section provides a necessary and sufficient condition for the identifiability of a collection of languages. Its proof rests on a preliminary result that will appear often in our work.
§3.6.1 Locking Sequences
First, we introduce some important notation.


Page 41
3.21 Definition Let s , [image] be given.
(a) The result of concatenating [image] onto the end of s is denoted by [image]. Sometimes we abuse notation slightly and write [image] (where [image]) to denote the sequence formed by adding x at the end of s .
(b) We write " [image] " if s is an initial segment of [image], and " [image] " if s is a proper initial segment of [image].
(c) Likewise, we write [image] if s is an initial finite sequence of text T.
(d) Let finite sequences s 0, s 1, s 2 . . . be given such that [image] and [image]. Then there is unique text T such that for all [image], [image]. This text is denoted [image].
3.22 Theorem (Blum and Blum[18]) Suppose that scientist F identities [image]. Then there is [image] such that:
(a) [image];
(b) WF( s ) = L; and
(c) for all [image], if [image], then [image].
Proof (following Blum and Blum): Let scientist F and [image] be given. Without loss of generality, we assume that F is defined for all s . Assume that there is no [image] meeting conditions (a)-(c) of the proposition. This implies the following.
3.23 For each [image] such that [image] and WF( s ) = L, there is some [image] such that [image] and [image].
We show that 3.23 implies the existence of a text T for L which F does not identify. This proves the contrapositive of the theorem.
Let U = u(0), u(1), u(2), . . . be an arbitrary text for L. We construct the promised text T in stages. At each stage n we specify a sequence s n such that [image].
Construction of T
Stage [image]. Note that
Stage n+1: Suppose that s n has been defined and that [image]. There are two cases.
Case 1: . Then [image].


Page 42
Case 2: . Then by 3.23 and the fact that [image], choose [image] such that [image] and [image]; let [image].
Observe that [image] for all [image]. Let [image]. T is a text for L, since u(n) is added to T at stage n (so [image]) and no nonmembers of L are ever added to T (so [image]). Finally, F does not converge on T to an index for L, since for each [image] either [image] or, for some [image] with [image], [image]. Thus, there are infinitely many numbers m0, m1, m2, . . . such that either F(T[m i]) is an incorrect index or [image].
Intuitively, if F identifies T, then Theorem 3.22 guarantees the existence of [image] that "locks" F onto a conjecture for L in the following sense: no presentation from L can dislodge F from F( s ). This suggests the following definition.
3.24 Definition (Blum and Blum [18]) Let [image], scientist F and [image] be given. s is a locking sequence for F on L just in case:
(a)
(b)WF( s ) = L;
(c) for all [image], if [image], then [image].
So Theorem 3.22 can be put this way:
3.25 Corollary (Blum and Blum [18]) If scientist F identifies [image], then there is a locking sequence for F on L.
Note that Theorem 3.22 does not characterize F's behavior on elements drawn from [image]. In particular, if [image] is such that [image], then even if s is a locking sequence for F on L, [image] may well differ from F( s ).
§3.6.2 Characterization
We now state and prove a characterization of the collections of identifiable languages.
3.26 Theorem (Based on Angluin [6]) [image] is identifiable if and only if for all [image] there is finite [image] such that for all [image], if [image] then [image].


Page 43
Proof: Let [image] be given. For the left-to-right direction, suppose that scientist F identifies [image]. By Corollary 3.25, for each [image] choose a locking sequence s L for F on L. Since content( s L) is a finite subset of L, it suffices to prove that for all [image], if [image], then [image]. For a contradiction, suppose that for some L, [image], [image] and [image]. Let T be a text for L' such that [image]. Such a text exists because [image]. Because s L is a locking sequence for F on L, and because [image], F converges on T to an index for L. But [image], so F fails to identify T, hence fails to identify L'. This contradicts our choice of F.
For the right-to-left direction, suppose the hypothesis of the theorem, namely:
3.27 For all [image] there is finite [image] such that for all [image], [image] implies [image].
To show that [image] is identifiable, we define a scientist F' as follows. For all [image], F'( s ) = the least i such that for some [image]:
(a) i is an index for L; and
(b)
F'( s ) is undefined if no such i exists.
To see that F' identifies [image], fix [image], and let T be a text for L'. Then for some [image], [image]. Let i0 be the least index for L'. Hence, to prove that F' converges on T to i0 (and thus identifies T), it suffices to show that for all j < i0 and [image], if j is for some [image] and [image], then for all sufficiently large [image], [image]. So let j < i0 and m [image] be given such that j is for some [image] and [image]. Then [image] and [image] Hence by 3.27 there is [image]. Since T is for L', let [image] be large enough so that [image]. Then [image].
Theorem 3.26 allows us to prove that certain collections of languages are not identifiable. We give two examples.
3.28 Corollary (Gold [80]) Let [image] be infinite. Then [image] is not identifiable.
Proof: Let [image]. The condition expressed by 3.26 fails for the infinite language [image]. This is because for each finite [image] there is [image] (namely, D itself!) such that [image] and [image].


Page 44
3.29 Corollary [image] is not identifiable.
Proof: Let [image]. The condition expressed by 3.26 fails for N, because for each finite [image], there is [image] such that [image] ' and [image]. This L' has the form N - {x} for some [image].
To gain insight into the phenomenon of nonidentifiability, consider a scientist F that identifies N, and let us see why F does not identify [image]. By Corollary 3.25 let s be a locking sequence for F on N. Let T be the text: . Then F converges on T to an index for N, whereas T is for [image]. Since no index for N is an index for a finite set, F does not identify T and hence does not identify the finite set content( s ).
Corollary 3.28 yields some lattice-theoretic properties of the class of identifiable subsets of e .
3.30 Corollary
(a) Although [image] is identifiable, none of its proper extensions are identifiable.
(b) Although both [image] and {N} are identifiable, their union is not identifiable.
Corollary 3.30b may be expressed this way: the class of identifiable subsets of e is not closed under finite union. This aspect of identifiability is exploited in Chapter 9.
§3.7 Some Alternative Paradigms
If normal linguistic development is correctly construed as a species of identification, then Corollaries 3.28 and 3.29 yield nonvacuous constraints on theories of comparative grammar. No such theory, for example, could admit as natural some infinite and all finite languages. The force of such constraints is attenuated, however, by the fact that identification is far from adequate as a representation of normal linguistic development. Children's linguistic environments, for example, are probably not arbitrary texts for the target language: on the one hand, texts do not allow for the grammatical omissions and ungrammatical intrusions that likely characterize real environments; on the other hand, many texts constitute bizarre orderings of sentences, orderings that are unlikely to participate in normal language acquisition. In addition, the identification paradigm provides no information about the special character of the child's system for language acquisition. To claim that this system implements some function from SEQ to the set of (indexes for) programs is to say essentially nothing at all. Even the criterion of


Page 45
successful learning is open to question, because linguistic development does not always culminate in the perfectly accurate, perfectly stable grammar envisioned in the definition of identification.
The defects in the identification paradigm can be remedied only in light of detailed information about children's linguistic development. For the most part, the needed information seems not to be currently available. Consequently, we shall not in this book defend the empirical adequacy of any specific model of language acquisition. Rather, the chapters that follow survey a variety of paradigms of varying relevance to intellectual development and to scientific inquiry. The survey, it may be hoped, will suggest questions about linguistic development whose answers can be converted into useful constraints on theories of comparative grammar. It may also suggest new ways of thinking about scientific discovery, both from the normative point of view, and from the point of view of machine implementation.
The present section provides a glimpse of the vast array of paradigms that can be defined (more comprehensive treatment begins in Chapter 5). We shall modify the identification paradigm by narrowing, in turn, its interpretations of "scientist" and "data."
§3.8 Memory-Limited Scientists
It seems evident that children have limited memory for the sentences presented to them. Once processed, sentences are likely to be quickly erased from the child's memory. Here we shall consider scientists that undergo similar information loss. The following notation is used.
3.31 Definition Let [image] be given.
(a) The result of removing the last member of s is denoted by s -; if [image], then [image] [image].
(b) [image] — i.e., the last member of s — is denoted by s last; if [image], then s last = #.
The following definition says that a scientist is memory-limited if her current conjecture depends on no more than her last conjecture and the current datum.
3.32 Definition (Wexler and Culicover [194]) Scientist F is memory limited just in case for all [image], if [image] and [image], then [image].


Page 46
Intuitively, a child is memory-limited if her conjectures arise from the interaction of the current input sentence with the latest grammar that she has formulated and stored. This grammar, of course, may provide information about all the sentences seen to date.
To illustrate, Ffinite — defined in 3.9a — is memory-limited. To see this, suppose that [image] and [image]. These equalities imply that [image] so [image]. In view of Proposition 3.15, this proves:
3.33 Proposition Ffinite is memory-limited, and hence some memory limited scientist identifies [image].
The foregoing example shows that memory limitation is not uniformly fatal, even for nontrivial problems. Nonetheless, memory limitation places genuine restrictions on the identifiable collections of languages, as shown by the next proposition.
3.34 Proposition There is an identifiable collection of languages that is not identified by any memory-limited scientist.
Proof: As a witness to the proposition, let [image] consist of the language [image] along with, for each [image], both the languages:
.
It is easy to verify that [image] is identifiable. On the other hand, suppose that memory-limited scientist F identifies L. We will show that F does not identify [image]. By Corollary 3.25, let s be a locking sequence for F on L. Choose [image] such that [image]. Because [image], we have:
3.35 [image] .
Let:
.
.
Then [image] by 3.35, and [image]. So, since F is memory-limited, [image]. Now let S be a text obtained by omitting all instances of [image] from a given text for L. Define:
.
.


Page 47
Because of memory limitation, it is easy to see that F converges on T and T' to the same F does index. Hence, since these two texts are for different members of [image], F not identify [image] and hence does not identify [image].
Proposition 3.34 shows that, compared to the original paradigm, the memory limited model of linguistic development makes a stronger claim about comparative grammar. This is because the latter model imposes a more stringent condition on the class of human languages: it must not only be identifiable, but identifiable by a memory-limited learner. Of course, this greater stringency represents progress only if children are in fact memory-limited in something like the fashion envisioned by Definition 3.32.
§3.8.1 Fat Text
It may be that in the long run every sentence of a given human language will be uttered indefinitely often. What effect would this have on learning?
3.36 Definition (a) A text T is fat just in case for all [image], [image] is infinite.
(b) Let scientist F and [image] be given. F identifies [image] on fat text just in case for every fat text T for any [image], F identifies T. In this case, [image] is identifiable on fat text.
Thus, every number appearing in a fat text appears infinitely often. Since each fat text for a language L is also a text for L, it is obvious that every identifiable collection of languages is identifiable on fat text. The converse proposition is Exercise 3-15.
Fat text is more interesting in the context of memory limitation. The next proposition shows that the former entirely compensates for the latter. We leave its proof as an advanced exercise.
3.37 Proposition Suppose that [image] is identifiable. Then some memory-limited scientist identifies [image] on fat text.
This concludes our discussion of language identification in the present chapter. Later paradigms bearing on [image] will be variations of this first one, and the reader should interpret terminology and notation in the sense defined here unless there is indication to the contrary. The same may be said of our next paradigm, function identification, to which we now turn.


Page 48
§3.9 Second Paradigm: Identification of Functions
The theoretically possible realities proper to our second paradigm are total recursive functions, introduced in Chapter 2. Many of the paradigms defined later in the book bear likewise on functions, so it is appropriate to begin our discussion by considering their intended interpretation.
§3.9.1 Recursive Functions as Possible Realities
Scientists often investigate physical systems that implement functions on a suitably chosen domain. The volume of a gas, for example, varies functionally with its temperature and pressure, and the electrical response of a photoreceptor depends functionally on the incident light. Such functions can be approximated with arbitrary precision using rational numbers, which may in turn be coded as natural numbers. In this way, scientific inquiry may often be represented as an attempt to discover which numerical function is actually implemented by Nature. To simplify our discussion we assume that the functions in question are total recursive mappings from N to N. Recall that the class of all such functions is denoted by [image]. As with the earlier limitation to recursively enumerable sets (see Section 3.1.1 above), restricting attention to [image] represents the nontrivial assumption that many natural phenomena can be construed as computational processes. Such will be our supposition.
The class [image] may also be considered from the point of view of automatic program synthesis. In this case, the role of Nature is played by a person P who has knowledge of some functional relation [image] but cannot easily write a program to compute f (perhaps for lack of expertise, or simply time). We assume that P's knowledge of f amounts to P being able to respond to any argument [image] with the value f(n). We seek a computerized system that discovers a program for f on the basis of the pairs fed to it. Once again we assume that P. is ''mechanical" in an appropriate sense, so that P's knowledge of f guarantees f's computability. (For more discussion of program synthesis in the context of the theory of empirical discovery, see Shapiro [172] and Jantke [98].)
There is also a linguistic interpretation of [image]. Some theories of language take a sentence to be an ordered pair of representations, one superficial, the other located at a deeper linguistic level. The latter representation stands in close relation to the meaning of the sentence, the former to its phonological realization. It is further assumed that the relation between underlying and superficial representations is a species of functional dependence, different languages implementing different functions of this kind. Competence


Page 49
in a language thus consists in knowing the function that maps one representation onto the other. Under suitable encoding, this competence amounts to knowing which member of [image] effects the mapping embodied by the language. The class of human languages corresponds to only a proper subset of [image], possibly quite narrow. (Variants of this basic framework are possible; see Wexler and Culicover [194] for discussion.)
Within this perspective, language acquisition proceeds as follows. Nature (in the guise of parents) selects some function f from the human subset of [image] and presents the child with the sentences corresponding to f. Contextual clues give the child access to the underlying representation of these sentences, whereas their superficial representations are made available acoustically. She thus receives, in effect, an enumeration of the graph of f. In response she produces a series of conjectures about f, hoping to stabilize on an accurate program for it.
thus corresponds to 3.1a, in our list of concepts to be specified by any paradigm of empirical inquiry. We proceed now to specify the others.
§3.9.2 Function Identification: Hypotheses, Data
Since theoretical possibilities are members of [image], we conceive of "intelligible hypotheses" as programs for computing functions. As usual, it is simpler to assimilate such hypotheses to the indexes associated with programs (see Chapter 2). Item 3.1b thus reduces to N though we shall continue to use "program" as an informal synonym for "index" in the context of function identification. Note the following detail. Whereas only total functions are possible realities, many programs compute properly partial functions. Such programs are legitimate conjectures, but within the present paradigm they are necessarily inaccurate. (Their existence will be crucial to more refined models of empirical inquiry, treated later, e.g., in Chapters 5 and 6.)
We turn now to 3.1c, the data that Nature makes available about any given function, f. The totality of all such data is conceived as a list of the graph of f in Some arbitrary order. For simplicity, we do not allow pauses in the presentation of data, so # does not appear. Officially:2
3.38 Definition
(a) We extend the concept of "text" (see Definition 3.4) to include any single-valued infinite sequence over N × N, i.e., any infinite list of pairs of numbers such that, for each
2 In what follows it will be helpful to recall the modern interpretation of a function, which identifies it with its "graph." See Chapter 2.


Page 50
x, there is at most one y such that (x, y) occurs in the sequence. We use G as a typical variable for texts over N × N.
(b) Similarly to before, the set of pairs appearing in a text G is denoted by content(G).
(c) Let total function [image], and text G be given. G is for f just in case content(G) = f.
Thus, the following sequence represents a text for the squaring function.
3.39 (1, 1) (0, 0) (3, 9) (2, 4) (5, 25) (4, 16) . . .
Notation for texts introduced for languages in 3.6 carries over to functions. Thus, let text G and [image] be given. The n th pair in G is denoted by G(n). The initial finite sequence of G of length n is denoted G[n].
Texts for functions have a property not shared by texts for languages. Let G be a text for a total function, and let T be a text for a language. For any [image] N × N, examination of some initial segment of G suffices to verify the presence or absence of (n, m) in G once and for all. In particular, if (n, m') is found in G, where [image], then [image] content(G). In contrast, no finite examination of T can definitively verify the absence of a number from T. This asymmetry renders function discovery easier than language discovery, as will be seen shortly.
§3.9.3 Function Identification: Scientists
In order to specify the concept of "scientist" in the current paradigm, we remind the reader that a subset X of N × N is a (graph of a) function just in case X contains no two elements of the form (x, y), (x, z) with [image]. Also, we record the fact:
3.40 Lemma Every finite function over N × N is a subset of some member of [image].
3.41 Definition The set { [image] a text for some total function and [image] is denoted by SEG; [image] are variables over SEG. (It will be clear from context whether such variables are supposed to range over SEQ or SEG.)
Notation for members of SEQ carries over to SEG. Thus, let [image] be given. The length of s is denoted [image]. The set of pairs appearing in s is denoted by content( s ). For [image], the n th pair appearing in s is denoted by s [n], and the initial sequence of length n in s is denoted by s [n]. For example, if G is the text of 3.39, then G(3) = (2,4), G[2] = (1, 1) (0,0), and content(G[3]) = {(1, 1), (0,0), (3,9)}. Note that SEG is


Page 51
countably infinite. denotes the concatenation of s and [image]. We also use [image] to denote the addition of the pair (x, y) at the end of s . We introduce one special piece of notation for SEG; we let [image] be the finite function from N to N whose graph is content( s ). Thus [image] provided (x, y) occurs in s .
As in the language context, a scientist examining a text G may be conceived as entering "evidential state" G[n] at moment n. So it is natural to take a scientist to be any system that maps the class of all possible evidential states — namely, SEG — into the set of all hypotheses, namely, N. Officially, a scientist within the function identification paradigm is any mapping — partial or total, computable or noncomputable — from SEG to N. As before, we use F as a variable for scientists, allowing context to determine whether F stands for scientists over SEQ or SEG.
Let text G and [image] be such that [image]. Then [image] denotes the function corresponding to the program that F emits upon examining the finite sequence of length n in G. We often say that this function is "conjectured by F on G[n]." If [image], then [image] is not defined. Note that [image] need not be total.
§3.9.4 Function Identification: Scientific Success
The criterion of success associated with our second paradigm is a straightforward adaptation of the criterion for language identification given in Section 3.4 above.
3.42 Definition (Gold [80]) Let scientist F, text G, [image], and [image] be given.
(a) F converges on G to [image] (written: ) just in case for all but finitely many [image], F(G[n]) = i. If there exists an i such that [image], then we say that [image]; otherwise we say that F(G) diverges (written: ).
(b) F identifies G just in case there is [image] such that F converges to j on G, and [image].
(c) F identifies f just in case F identifies every text for f.
(d) F identifies C just in case F identifies every [image], C is said to be identifiable just in case some scientist identifies it; it is said to be unidentifiable otherwise.
§3.10 Characterization of Identifiable
Identifiability in the current paradigm turns out to be a trivial matter, inasmuch as every subset of [image] is identifiable. This is the content of the next theorem.


Page 52
3.43 Theorem [image] is identifiable.
Proof: The key property of [image] is this. Suppose that f, [image] and [image]. Then there are [image] such that [image], [image] and [image]. It follows that if G is a text for f, there is [image] such that the information in G[n] shows that G is not for g.
Now define scientist F as follows. For all [image], let F( s ) be the least [image] such that:
(a) j i is total; and
(b) [image].
By Lemma 3.40, F is well defined.
Thus, F guesses the first member of [image] that is consistent with s . Our preceding remarks show that, given a text G for [image], F will eventually conjecture and stay with the least index for f, having verified that G is not a text for any function with smaller index.
Although some scientist identifies [image], there is no guarantee that a scientist with various special properties can do so as well. In particular, we shall see in the next chapter that no computable scientist has this ability. Memory limitation also prevents identification of [image], even by scientists representing noncomputable mappings of SEG to N. We examine this matter now; it is the last topic to be discussed in the present chapter.
§3.10.1 Memory Limitation for Function Identification
The following definitions parallel those given in Section 3.8 for the language case.
3.44 Definition Let [image] be given.
(a) The result of removing the last pair in s is denoted by s -; if [image], then [image] [image].
(b) [image] — i.e., the last pair in s — is denoted by s last; if [image], then s last is undefined.
3.45 Definition Scientist F is memory limited just in case for all [image] of positive length, if [image] and [image], then [image].
We shall now define a simple collection of functions that is identified by no memory-limited scientist. For this purpose, the following standard terminology is helpful. Recall


Page 53
from Chapter 2 that [image] is the characteristic function of [image] just in case, for all [image], f(x) = 1 if and only if [image]. Let C0 be the collection of all [image] such that f is the characteristic function of a finite set, or f is the characteristic function of N. Of course, [image].
3.46 Proposition No memory-limited scientist identifies C 0.
Hence, no memory-limited scientist identifies [image].
Our demonstration of Proposition 3.46 rests on the following version of Exercise 3-6. Its proof is a simple adaptation of the argument used to establish Theorem 3.22, and is left for the reader.
3.47 Theorem Suppose that scientist F identifies [image], and let [image] be such that [image]. Then there is nonempty [image] SEG such that:
(a) [image];
(b)
(c) [image].
Proof (of Proposition 3.46): Let f be the characteristic function of N, and suppose that memory-limited F identifies f. It will be shown that F fails to identify the characteristic function of some finite set.
By choosing [image] in Theorem 3.47, we may choose nonempty [image] SEG such that:
3.48 (a) [image];
(b)
(c) [image].
Let [image], and let g be the characteristic function of D. Thus, [image] because D is finite. Suppose that F identifies g (otherwise, F fails to identify the characteristic function of some finite set, and the proof is finished). Letting l in 3.47 be s , choose s ' such that:
3.49 (a) [image];
(b)
(c) [image].


Page 54
Finally, choose an [image] be such that neither (n, 0) nor (n, 1) is in [image], and let [image] be the characteristic function for DU{n}. We will show that F fails to identify some text for g'.
By 3.48(c) and the fact that [image], we have:
3.50 [image] .
From 3.50 and the memory-limitation of F, we have:
3.51 [image] .
By the choice of s ', 3.49 and 3.51 imply:
3.52 [image] .
On the other hand, by 3.51 and memory-limitation, we have:
3.53 [image] .
We deduce from 3.49, 3.52, and 3.53:
3.54 [image] .
Let G' be an enumeration of all the pairs of g' except for (n, 1) (hence [image], for all [image]). Let G be the text that begins with [image] and finishes with G'. Then it is easy to verify that G is a text for g'. However, by 3.54, F converges on G to an index for [image], hence fails to identify g'.
It is easy to verify that every singleton collection of functions is identifiable by a memory-limited scientist, and that the collection of characteristic functions for finite sets is similarly identifiable. So Proposition 3.46 implies that the family of subsets of [image] that are identifiable by a memory-limited scientist is not closed under finite union.
§3.11 Summary
The present chapter defined and investigated two paradigms of scientific discovery that are fundamental to our work. The paradigms introduced in later chapters may be conceived as elaborations or revisions of these two.
The first paradigm takes languages (that is, r.e. sets of numbers) as possible realities, and grammars as scientific hypotheses. The data generated by a language is represented by a text, which is essentially an enumeration of the numbers in the language. Each finite, initial segment of a text is an "evidential position," summarizing all the information


Page 55
available to a scientist up to a given moment of her inquiry. In particular, the initial segment T[n] of text T is the evidential position at moment n of a scientist working on T. A scientist is any function — partial or total, computable or noncomputable — from the set of all such evidential positions to the set N of (indexes for) grammars. For a scientist F to identify a collection [image] of languages, it must be the case that for every text T for any language [image], there is grammar i for L such that F(T[n]) = i for all but finitely many [image].
Identification in the foregoing sense is a nontrivial concept inasmuch as there exist rich, identifiable collections of languages as well as rich unidentifiable ones. A necessary and sufficient condition for identifiability is given in Theorem 3.26.
There are several respects in which the foregoing paradigm is inadequate as a model of language acquisition by children. To take just one example, children are unlikely to remember the entire record of sentences ever addressed to them. We are thus led to define formal scientists who operate under memory restrictions. It was shown in Section 3.7 that such scientists have less scientific competence than their memory-unlimited counterparts. Later chapters will consider other modifications to the language identification paradigm.
The second major paradigm introduced in this chapter takes total recursive functions as the class of possible realities. Hypotheses are construed as (indexes for) programs to compute these functions. The information made available to scientists about a given function f is conceived as an enumeration of the graph of f. The criterion of successful inquiry is a straightforward adaptation of that defined for language identification.
Function identification has a trivial aspect in the sense that there is a single scientist that can identify the entire class of recursive functions. We shall see in the next chapter, however, that this scientist cannot itself be computable.
Similarly to language identification, scientists working under memory limitation suffer from a reduced ability to identify collections of recursive functions.
§3.12 Exercises
3-1 Let [image] be given. Show that [image] is identifiable.
3-2 Let [image] be any collection of nonempty, pairwise disjoint, recursive subsets of N. Show that [image] is identifiable.
3-3 Prove the following facts.


Page 56
(a) Every subset of an identifiable collection of languages is identifiable.
(b) No superset of an unidentifiable collection of languages is identifiable.
3-4 Given [image], scientist F, and [image], F is said to "p percent identify" [image] just in case for each [image] and each text T for L, there is [image] such that:
(a) Wi = L; and
(b) for all but finitely many [image], F(T[j]) = i for p percent of [image].
In this case, [image] is "p percent identifiable." Prove that if p > 50, then [image] is identifiable if and only if [image] is p percent identifiable.
3-5 Call [image] easily distinguishable just in case for all [image] there exists finite [image] such that for all [image], if [image] then [image].
(a) Specify an identifiable collection of languages that is not easily distinguishable.
(b) Let [image] be given. Prove the following. Some self-monitoring scientist identifies [image] if and only if [image] is easily distinguishable.
3-6 Suppose that F identifies [image]. Let [image] be such that [image]. Prove that there is a [image] such that [image] is a locking sequence for F on L.
3-7 Let s be a locking sequence for F on [image]. Let [image] be such that [image]. Show that [image] is a locking sequence for F on L.
3-8 Refute the converse to Corollary 3.25. In other words, exhibit scientist F, [image], and [image] such that s is a locking sequence for F on L, but F does not identify L.
3-9 Suppose that scientist F identifies [image]. Let T be a text for L. T is called a "locking text for F on L" just in case there exists [image] such that T[n] is a locking sequence for F on L. Provide a counterexample to the following conjecture: If F identifies [image], then every text for L is a locking text for F on L.
3-10 Show that some unidentifiable [image] is 49 percent identifiable (see Exercise 3-4).
3-11 Let [image] be any indexed collection of subsets of N. Suppose that the X i are used as languages in place of the indexed collection W i of r.e. sets. How much of the discussion in Section 3.6 carries over to the X i setting?


Page 57
3-12 For each [image] and each [image], define [image]. For each [image] define a collection of languages [image] by:
.
Show that for every [image], [image] is identifiable.
3-13 We define a generalization of the concept of memory limitation.
3.55 Definition Let [image] be given.
(a) The result of removing the last n members of s is denoted by [image]; if [image], then [image].
(b) The finite sequence consisting of the last n members of [image] is denoted by s last n; if [image] then s last n = s .
(c) Scientist F is n-memory limited just in case for all s , [image], if [image] and [image], then [image].
Thus, memory limitation corresponds to 1-memory limitation. Show that for all [image] and [image], some n-memory-limited scientist identifies [image] if and only if some 1-memory-limited scientist identifies [image]. Hint: Use the "padding function" described in Chapter 2.
3-14 The present exercise concerns another generalization of memory-limitation.
3.56 Definition A scientist [image] is called weakly memory limited just in case there is a function [image] with the following properties. For all s , [image],
(a)
(b)
(c)
Intuitively, F can remember any single previous datum of her choice. Clause (b) means that F can change the contents of her memory only by storing the datum currently in view. F is memory-limited in the sense that a given conjecture depends only on (a) the one datum she remembers, (b) the datum currently under examination, and (c) her latest conjecture.


Page 58
(a) Exhibit [image] such that:
(i) [image] is identifiable; but
(ii) no weakly memory-limited scientist identifies [image].
(b) Exhibit [image] such that:
(i) some weakly memory-limited scientist identifies [image]; but
(ii) no memory-limited scientist identifies [image].
3-15 Prove that [image] is identifiable if and only if [image] is identifiable on fat texts.
3-16 A text is called ''lean" just in case it never repeats a number. Prove that [image] is identifiable if and only if [image] is identifiable on lean text.
3-17 (Advanced) Prove Proposition 3.37.
3-18 Text T is called "ascending" just in case for all n, [image], if [image] and [image] and [image], then [image]. is identifiable on ascending text just in case some scientist F identifies every ascending text for every [image]. Prove:
(a) There is [image] such that:
(i) [image] is not identifiable, but
(ii) [image] is identifiable on ascending text.
(b) There is [image] such that [image] is not identifiable on ascending text.
3-19 Text T is called "strictly ascending" just in case # does not occur in T, and for all n, [image], if n < m, then T(n) < T(m). Show that [image] is identifiable on strictly ascending text.
3-20 Let us see what happens if we tighten our success criterion by requiring that scientists never converge to an incorrect. index.
3.57 Definition (Minicozzi [132]) Let scientist F and [image] be given. F identifies [image] reliably just in case:
(a) F identifies [image];
(b) for all texts T, if F converges on T to [image], then content(T) = W i.
In this case, [image] is reliably identifiable.


Page 59
For example, it is easy to see that Ffinite reliably identifies [image].
Reliability is a useful property of scientists, since a reliable scientist never fails to signal the inaccuracy of a previous false conjecture. The signal is given by eventually changing the previous conjecture, or by producing no conjecture at all on a later input. Show, however, that reliability is an excessively strong success criterion by proving the following.
Suppose that [image] is reliably identifiable. Then [image].
3-21 F identifies [image] confidently just in case F identifies [image] and F converges (to some number or other) on every text for a language in the complement of [image]. Show that there is identifiable [image] such that no scientist identifies [image] confidently.
3-22 One strategy for generating conjectures is to choose the first index in some list of indexes that is consistent with the data seen so far. This strategy is known as "induction by enumeration," and is employed by the scientist in Proposition 3.43 concerning function identification. Let us now see how well induction by enumeration works in the paradigm of language identification.
3.58 Definition (Gold [80]) A scientist [image] is an enumerator just in case there is total [image] such that for all [image] F( s ) = f(i), where i is the least number such that [image] (f need not be computable).
(a) Show that
(i) some enumerator identifies [image].
(ii) some enumerator identifies [image].
(b) Given [image], define [image] and [image]. Show that [image] is identifiable, but not by any enumerator.
3-23 Let [image] be the collection of all [image] such that f is the characteristic function of a finite set. Let [image] be the collection of all [image] such that f is the characteristic function of a cofinite set. Show:
(a) Some memory-limited scientist identifies [image].
b) Some memory-limited scientist identifies [image].
(c) No memory-limited scientist identifies [image].


Page 61
4
Identification by Computable Scientists
The focus of our book is the inductive competence of scientists whose behavior can be simulated by computer. The technological interest of this topic is evident, since it lies at the heart of attempts to develop artificial systems of empirical inquiry (see Carbonell [23] and Langley, Simon, Bradshaw, and Zytkow [123]). An additional reason for our focus comes from Cognitive Science. The computer simulability of human ratiocination is one of the most popular hypotheses in that discipline, so it is natural to speculate that children's learning functions are algorithmic processes. By studying the consequences of this hypothesis, it may be possible to provide further constraints on the theory of comparative grammar (see Section 3.1.2).
The present chapter considers the simplest paradigms in which computable scientists appear. Much of the material in later chapters will depend on the results and definitions to be presented here. As before, we discuss language identification prior to function identification. As a preliminary, we introduce a system of notation that will occur throughout the rest of our study.
§4.1 Preliminaries
4.1.1 An Indexing for the Computable Scientists
Computer simulable scientists can be conceived from either an extensional or an intensional point of view. Extensionally, a computable scientist — like any scientist — is a function from SEQ or SEG to N; it is computable in virtue of there being a procedure that recognizes its pairs. Intensionally, a computer scientist is such a procedure, i.e., a computer program that accepts members of SEQ or SEG and returns (if defined) members of N. Our official viewpoint is extensional, so that by "computable scientist" we mean a certain kind of function. As an aid to intuition, however, we sometimes take the intensional point of view, referring to a scientist as a program or Turing Machine.
There are thus three kinds of computable functions now in play within our theory. They may be distinguished by their domains. First, there are the recursive functions (partial and total) with domain N. Next, there are computable scientists within the paradigm of language identification; these functions have domain SEQ. Finally, there are computable scientists within the paradigm of function identification; they have domain


Page 62
SEG. To implement these functions we could conceive of three types of Turing Machine, each with its own domain. The following strategy is simpler, however. We now fix two recursive isomorphisms, one between SEQ and N, the other between SEG and N. The countability of SEQ and SEG (and their simple structure) guarantees the existence of these isomorphisms, whose details will not concern us. The isomorphisms allow the members of SEQ and SEG to be coded as natural numbers, and using these codes the same Turing Machine TM may be conceived alternately as computing any of the three kinds of functions distinguished above. Thus, to implement a scientist for languages the arguments of TM are construed as members of SEQ, thought of as codes for N. Now recall that an acceptable programming system j i was fixed, once and for all, in Chapter 2 (see page 2). The foregoing conventions about SEQ and SEG allow us to interpret the indexes i of this system as also referring to functions with domain SEQ or SEG. In particular, when discussing language identification we often let j i refer to scientists with domain SEQ. And when discussing function identification, we often let j i refer to scientists with domain SEG. The first enumeration can be conceived as listing all the computable scientists in the language domain. The second lists all the computable scientists in the function domain. We use M, with or without decorations, to denote a computable scientist whose domain (either SEQ or SEG) is determined by context.
§4.1.2 Names for Paradigms
In the chapters to follow, many models of empirical inquiry will be defined and analyzed. For the sake of concision, each paradigm will be associated with a symbolic name that
abbreviates its main features. Such names can be illustrated with the paradigms of
Chapter 3.
4.1 Definition
(a) The class of all identifiable collections of languages (in the sense of Section 3.4) is denoted by Lang.
(b) The class of all identifiable collections of functions (in the sense of Section 3.9.4) is denoted by Func.
Thus, [image].1 To illustrate the use of this notation, Exercise 3-3 and Corollary 3.28 imply that [image]. For another illustration, Proposition 3.43 implies that Func is the power set of [image]. It will be convenient to use this kind
1 So Lang is a set of sets of sets of numbers.


Page 63
of notation in slightly ambiguous fashion. Officially, a symbol like Lang denotes a class of collections of languages. However, we also use it unofficially to denote the associated paradigm, that is, an ensemble of definitions concerning possible realities, scientists, and so forth. This allows us to make reference to "the paradigm" Lang. We take the same liberty with Func and the other names to be introduced.
§4.2 Language Identification by Computable Scientist
§4.2.1 The Paradigm TxtEx
We now introduce the paradigm TxtEx. The symbol Txt signifies that the paradigm concerns the identification of languages on texts. Ex signifies that the success criterion is the one specified in Section 3.4, namely, convergence to a single index for the language of the incoming text (Ex stands for Explains). Notice that no part of the name TxtEx refers explicitly to the computable nature of scientists. This is because the restriction to the computable case will henceforth be a feature of all the paradigms to be introduced.2 The only difference between TxtEx and Lang is this: "scientist" now means a computable function — either partial or total — from SEQ to N. All other aspects of the paradigm are the same as before, including the criterion of success given in Definitions 3.10-3.12. Here is the official definition:
4.2 Definition (Gold [80])
(a) Let M be a computable scientist and let [image]. M TxtEx-identifies L (written: ) just in case M identifies L.
(b) [image].
So, TxtEx(M) in the above definition denotes the collection of all languages identified by M. Considered as classes of collections of languages, what is the relation between Lang and TxtEx? Since the computable scientists are a subset of the class of all scientists, it follows that [image]. Now we consider whether the inclusion is strict.
2 TxtEx has other names in the literature, e.g., INT and Lim. The terminology TxtEx is due to Case and Lynes [33].


Page 64
§4.2.2 Lang Compared to TxtEx
We cannot conclude from the mere fact that there are uncomputable scientists that TxtEx is a proper subset of Lang, for there are proper subsets of the class of all scientists such that every identifiable collection of languages is identified by some member of the subset (see Exercise 4-3, below). However, [image] does follow from the fact that the computable scientists form a countable subset of the uncountable class of all scientists.3 This is explained by the following proposition.
4.3 Proposition Let [image] be any countable collection of functions from SEQ to N, and let [image]. Then
Proof: For each [image] and each [image], define [image]. For each [image] define a collection of languages [image] by:
.
Exercise 3-12 shows that for every [image], [image]. We now demonstrate:
4.4 No scientist identifies both [image] and [image] for [image].
To prove 4.4, let [image] and [image] be given, with [image]. Suppose that scientist F identifies [image]. Then, F identifies [image]. By Corollary 3.25, let s be a locking sequence for F on L i, N. Choose finite [image] such that [image]. Observe that [image]. Extend s to a text T for L i,D. Then, since [image] F converges on T to an index for L i,N. Thus, F does not identify L i,D and hence does not identify [image]. This proves 4.4.
It is easy to see that 4.4 implies 4.3 since there are uncountably many [image] and each [image] identifies at most one of the classes [image].
4.5 Corollary [image]. It will facilitate later developments to exhibit a specific collection of languages that falls in Lang — TxtEx.
4.6 Definition Let K be the r.e., nonrecursive set defined on page 25. The collection of languages [image] is denoted [image].
3 The computable scientists are countable because the collection of machines that compute them is countable. In contrast, it is easy to see that the collection of all scientists — i.e., functions from SEQ to N — has the power of the continuum.


Page 65
4.7 Proposition [image].
Proof: By Exercise 3-1, [image]. To show [image], suppose by way of contradiction that a computable scientist M identifies [image]. Note that [image] since [image] for any [image]. Therefore, by Corollary 3.25, there is a locking sequence s 0 for M on K. Suppose that M( s 0) = i0, an index for K. Using M and s 0 we will exhibit [image] as recursively enumerable, contradicting the nonrecursivity of K.
Let k0, k1, k2, . . . be some fixed, recursive enumeration of K. For every [image], let T x be the text [image]. Note that:
4.8 (a) For all [image], T x is a text for K.
(b) For all [image], T x is a text for [image], and [image].
By 4.8a and the choice of s 0, we have:
4.9 Suppose that [image]. Then F(T x[n]) = i0 for all [image].
On the other hand, from 4.8b, the fact that i0 is an index for no set of the form [image] with [image], and the choice of M, we may infer:
4.10 Suppose that [image]. Then [image] for some [image].
Thus, 4.9 and 4.10 imply:
4.11 For all [image], [image] if and only if there is an [image] such that [image].
Now define the function [image] by the condition that for all [image],
.
Since k0, k 1, k 2, . . . is a recursive enumeration, it is easy to see that X is partial recursive. However, the domain of X is [image], which implies that [image] is recursively enumerable.
We mentioned in Section 3.3 that consideration of noncomputable scientists can clarify the respective roles of computational and information-theoretic factors in our theory. This is illustrated by comparing the collections [image] and [image]. By Propositions 4.7 and 3.28, no computable scientist identifies either collection. However, the reasons for the nonidentifiability differ in the two cases. presents a computable scientist with an insurmountable computational problem, whereas the computational structure of [image] is trivial. In contrast, [image] presents the scientist with an insurmountable informational problem, namely, that no [image] allows the finite and infinite cases to be distinguished. No such informational problem exists for [image]. The available information simply cannot be put to use by a recursive learning function.


Page 66
§4.2.3 A Comprehensive, Identifiable Collection of Languages
The languages comprising [image] and [image] are computationally transparent, yet Corollaries 3.28 and 3.29 show that neither is identifiable. In conjunction with Proposition 4.7, these facts might encourage the belief that TxtEx contains only computationally impoverished subsets of e . The purpose of the present section is to show that this belief is mistaken. In particular, it will be seen that there is a computable scientist of simple design that identifies "nearly all" of e . This idea is made precise by the following definition. First, recall from Chapter 2 that two languages L and L' are finite variants just in case both L - L' and L' - L are finite.
4.12 Definition Let [image] be given. covers e just in case for every [image] there is [image] such that L and L' are finite variants.
Languages that are finite variants have similar computational properties. For example, if one is recursive, then so is the other, and similarly for being decidable in polynomial time, etc. Hence, if [image] covers e , then even the most computationally complex sets in e have equally complex counterparts in [image]. Nonetheless:
4.13 Proposition (Wiehagen [196]) There is [image] such that [image] covers e .
Proof: By Exercise 2-3, one can construct, for each [image], an [image] such that:
(a) L and L' are finite variants; and
(b) L' = W x where x is the smallest member of L'.
It follows that [image] covers e . Now define scientist M by the condition that for all [image], M( s ) = the least [image] It is evident that M is computable and identifies [image].
§4.2.4 Computability in the Context of Other Constraints
In Section 3.7 we noted that a model of language acquisition places greater constraint on theories of comparative grammar to the extent that it succeeds in locating the language acquisition mechanism of children in a narrow subset of the class of all scientists. One such subset was discussed, namely, memory-limited scientists, and it was shown that there are identifiable collections of languages that are not identified by any memory-limited scientist. The computable scientists constitute another subset of the same nature, as shown by Corollary 4.5.


Page 67
Let us now consider how such hypotheses interact with each other. Consider two subsets A and B of scientists. Exercise 4-3 shows that it is possible for a collection [image] of languages to be identified by some member of A and by some member of B without being identified by any member of [image]. Thus, the constraint on comparative grammar offered by two hypotheses about children's learning mechanisms cannot be conceived as the intersection of the classes of collections of languages that each permits. This point is illustrated by memory limitation and computability.
4.14 Proposition There is [image] such that:
(a) [image];
(b) some memory limited scientist identifies [image]; and
(c) no computable, memory limited scientist identifies [image].
Proof: Let [image] be a fixed, nonrecursive r.e. set, let [image], and define for all [image], [image], [image]. The collection [image] will witness the proposition.
We give informal proofs of parts (a) and (b) of the proposition. A computable scientist M that identifies [image] works as follows. On incoming text T, M conjectures L until some pair [image] appears in T; then M conjectures L n forever unless [image] appears or has already appeared in T, in which case M conjectures [image] forever. Note that M is computable but not memory limited. A memory limited scientist F' that identifies [image] does the following on T. F' conjectures L until either [image] appears in T for any [image], or [image] appears in T for [image]. In the former case, F' conjectures L n forever unless [image] appears in T, in which case F' conjectures [image] forever. In the latter case, F' conjectures [image] forever. It can be seen that F' is memory limited but not computable (since F' determines whether [image] for nonrecursive A).
To prove part (c) of the proposition, suppose for a contradiction that some computable, memory limited scientist M identifies [image]. Let s be a locking sequence for M on L. This implies that for every [image], [image]. It follows that for some [image], [image], for if this were not the case it would be easy to show (since M is computable) that [image] is r.e., and this would contradict the choice of A. Fix such an m, and let S be any enumeration of L. We define two texts, T and T' thus.


Page 68
By M's memory limitation and the choice of m, [image]. So, again by M's memory limitation, [image] for all [image], that is, M converges on T' and T to the same index. But T' is a text for [image], T is a text for L n, and [image]. Therefore M does not identify at least one of [image] and L n, contradicting our choice of M.
We shall see similar interactions with computability in later chapters.
§4.2.5 Identifiability by Total Scientists
The definitions of Section 3.4 do not require a scientist that identifies text T to be defined on every initial segment T[n] of T. However, there is little effect limiting attention to such scientists. Indeed, we can go further, and limit attention to scientists representing total functions from SEQ to N (hence defined on every initial segment of any environment). Scientists with this property are called "total," and suffice to identify any identifiable collection." This is shown by the following.
4.15 Proposition Let M0, M1, . . . be an enumeration of all (possibly partial) computable scientists. There is total recursive [image] such that for all [image]:
(a) Mf(i) is total; and
(b) For all [image], if Mi identifies L then Mf(i) identifies L.
Proof: Given [image], we want Mf(i) to simulate Mi on [image] but not wait forever if [image]. Therefore, we will allow Mf(i) to wait only [image] steps for [image]. Define: where [image] is the longest initial segment of s such that [image] in [image] steps, if such exists; = 0 otherwise.
Mf(i) is computable because the condition defining [image] can be checked recursively (since the waiting time is bounded by [image]). To see that Mf(i) identifies every language L that Mi does, let T be a text for such an L. Then there is [image] and index j for L such that for all [image], Mi(T[m) = j. Let [image] be the running time of Mi(T[n]). By the definition of Mf(i), if m exceeds both s and n, then Mf(i)(T[m]) = Mi(T[k]) for some [image]. Thus Mf(i) converges on T to j.
The foregoing proof uses two techniques that appear frequently within our theory. First, the scientist Mf(i) whose existence must be proved relies upon an internal simulation of the given scientist Mi. Mf(i) feeds Mi some version of the incoming data and then uses Mi's output for its own conjectures. Such proofs may be called "internal


Page 69
simulation'' arguments. Second, at moment n, Mf(i) does not use Mi's response to the entire sequence T[n] of incoming text T. Rather, Mf(i) uses Mi's response to some possibly proper initial segment T[j] of T[n]. Although the gap between the available and used segments of T may increase with time, Mf(i) eventually produces Mi's response to larger and larger initial segments of T on which Mi is defined. This feature of the proof may be called "falling back on the text."
Proposition 4.15 gives us something more.
4.16 Corollary There exists a recursively enumerable sequence of total computable scientists M0, M1,. . ., such that [image].
We can take Mf(0),Mf(1),. . . to be one such enumeration. A counterpart of the above corollary holds for many of the paradigms considered in this book (with identical proofs). This fact can often be exploited to make diagonalization arguments simpler.
§4.3 Function Identification by Computable Scientist
§4.3.1 The Paradigm Ex
We now introduce the paradigm Ex. As in the language case, the letters "Ex" are short for "explains" and signify that the success criterion is convergence to a single index for the target function. Scientists in the Ex model are computable functions — either partial or total — from SEG to N. All other aspects of the Ex paradigm are the same as for Func. We define:
4.17 Definition (Gold [80]) (a) Let M be a computable scientist and let [image]. M Ex-identifies f (written: just in case M identifies f.
(b) [image].
Analysis of Ex is facilitated by limiting attention to texts of a special kind.
4.18 Definition Let G be a text for total function f. G is canonical just in case for all [image], G(n) =(n, f(n)) (that is, the pair (n, f(n)) occurs in the (n + 1)st position of G). Similarly, [image] is in canonical order just in case s = (0, x0), (1, x1),. . . , (n, x n) for [image] and x0, . . ., [image] Let INIT be the collection of all [image] that are in canonical order.


Page 70
Although the canonical text for [image] constitutes only one among uncountably many orderings of f, there is an algorithm A. that progressively converts any incoming text G into a canonical text G' for the same function. Informally, A works on G by reading and storing the members of G until some pair of the form (0, x) appears. (If G is for some [image], then exactly one such pair must eventually occur.) A writes this pair as the first member of G'. Next, A searches its memory for some pair of the form (1, x); if no such pair is found in memory, A reads and stores more of G until such a pair is found. This pair is written onto G', and A then searches for a pair of the form (2, x) . . . . This process continues indefinitely. Although A may be required to store ever larger initial segments of G, its storage requirements are finite at any given time. It is clear that A gradually produces a canonical text for content(G). Formally, we let [image] be defined as follows.
4.19 Definition For all [image], F A( s ) is the longest [image] such that [image].
F A is computable, and applying it to ever longer initial segments of a text produces ever longer initial segments of the corresponding, canonical text. That is:
4.20 Lemma If G is an arbitrary text for [image], then [image] is the canonical text for f.
The ability to algorithmically transform any text into canonical order simplifies the Ex paradigm. This is shown by the following proposition.
4.21 Proposition Let [image] be given. if and only if there is a computable scientist that identifies the canonical text for any member of C.
Proof: The left-to-right direction is immediate. For the other direction, we use an internal simulation argument. Suppose that computable scientist F identifies the canonical text for any member of [image]. Define scientist F* as follows. For all [image], F*( s ) = F(F A(s)). F* is computable because it is the composition of computable functions. Moreover, F* converges to [image] on text G for [image] if F converges to i on the corresponding canonical text. Since F identifies the latter, F* identifies the former and thus identifies C.
To prove claims of the form [image] or [image] we shall henceforth rely implicitly on Proposition 4.21, and consider only canonical texts. The following slight abuse of


Page 71
terminology will also be employed. We often identify a function f with its canonical text (and vice versa). Thus [image] will denote both the function f as well as the canonical text for f. Moreover, f[n] will denote both the partial function [image] and the initial segment of length n of the canonical text for f. Context will determine which one is intended. The obvious analogue to Proposition 4.15 may also be recorded here (in which the Mi's represent machines with domain SEG).
4.22 Proposition Let M0, M1, . . . be an enumeration of all (possibly partial) computable scientists. There is a total recursive [image] such that for all [image]:
(a) Mf(i) is total;
(b) For all [image], if Mi identifies g then Mf(i) identities g.
4.23 Corollary There exists a recursively enumerable sequence of total computable scientists M0, M1, . . ., such that [image].
§4.3.2 Identifiability in Ex
Proposition 3.43 shows that the identifiability problem has a trivial solution in the Func paradigm: every set of total recursive functions is identifiable. In contrast, identifiability within Ex is not such a simple affair, as we shall now see. Define two subsets of R as follows.
4.24 Definition (a) SD is the set of all [image] such that j f(0) = f.
(b) A e Z is the set of all [image] such that for all but finitely many [image], f(x) = 0.
The symbol SD may be read as "self-describing." The symbol A e Z may be read as "almost everywhere zero." Lemma 2.4 shows that [image].
4.25 Theorem (The Nonunion Theorem, Blum and Blum [18]) [image] and [image], but [image].
Proof: Exercise 4-10 shows that both SD and A e Z are in Ex. It remains to prove that [image]. So, suppose that computable scientist M identifies A e Z. By Proposition 4.22 we may assume without loss of generality that M is total. It suffices to


Page 72
exhibit an element of SD that M fails to identify. By use of the recursion theorem., we shall exhibit an index e such that:
4.26 (a) [image]. (b) M fails to identify j e. (c) j e(0) = e.
Given such an e, j e is the required element of SD.
We construct j e in stages. For each s, s s will denote the finite initial segment of the graph of j e defined as of the end of stage s. We will have [image], and we let [image].
By the recursion theorem we can choose e such that j e(0) = e, and we set s 0 = j e[1] (that is s 0 = (0, e)). For remaining stages of the construction we rely on the following claim.
4.27 Claim Given a [image], one can effectively find a [image] such that [image] and [image].
Proof: (of Claim 4.27) Note that if there exists a [image] such that [image] one can effectively find such a [image] by exhaustive search. Therefore it suffices to show that for each s there is such a [image]. Suppose for a contradiction that for all canonical [image], [image]. But then M can Ex-identify at most one function whose canonical text begins with s . Since there are infinitely many functions in A e Z whose canonical text begins with s , we have a contradiction to M Ex-identifying each function in A e Z.
Here then is the construction.
The Construction of j e:
Stage 0: s 0 = (0, e).
Stage s+1: Suppose that s s has been defined. Find a canonical [image] such that [image]. (By Claim 4.27 such a [image] can be found effectively from s s.) Set [image].
It is easy to verify that j e satisfies 4.26 as promised.
Theorem 4.25 shows that Ex is not closed under union. As another corollary we have:
4.28 Theorem (Gold [80])


Page 73
§4.3.3 Finding Unidentified Functions
For this subsection, let M0, M1, . . . be an indexing of total computable scientists as in Corollary 4.23. Now, Theorem 4.28 states that for every computable scientist M, there is [image] such that M does not identify f. But can an index for such an f be found effectively from an index for M? An affirmative answer to this question would imply the existence of a total recursive [image] such that:
4.29 (a) for all [image], [image], and
(b) Mi does not identify j h(i).
However, we now show:
4.30 Proposition There is no total recursive [image] that satisfies the conditions in 4.29.
Proof: Suppose by way of contradiction that there is such an h. Then by the recursion theorem there is an e such that for all s , Me( s ) = h(e), Clearly, Me identifies s h(e), a contradiction.
Proposition 4.30 shows that no evil demon of a mechanical nature can examine the internal program of a given scientist and then select a function that the scientist fails to identify. On the other hand, the demon can map an arbitrary scientist's program into a different conundrum, described by the following proposition.
4.31 Proposition There is a total recursive function [image] such that for all [image]:
(a) W h(i) contains exactly one index for a total function, say, j (W>h(i) may or may not contain indexes for partial functions);
(b) Mi does not identify j j; and
(c) j j(0) = i.
Clause (c) means that j j "names" the scientist Mi for which W h(i) has been constructed (this property of h will be used later).
Proof: Let [image] be given. We describe, in stages, a procedure that uses Mi to enumerate the graphs of functions (in canonical order). Although many graphs will be initiated, only one will be extended indefinitely; the others will terminate after some finite initial segment. Mi will fail to identify the unique total function to be enumerated. Our construction will be uniformly effective in i and thus constitutes the witness h to


Page 74
the proposition. The following terminology is needed. First, we fix a standard method (uniform in i) for enumerating the set:
.
Next, given x, [image] and [image], we say that Mi "predicts (x, y) on s " just in case:
(a) [image] and
(b) no pair of the form (x, z) occurs in content ( s ) for any [image].
Finally, given text G and x, y, j, [image], we say that Mi "is seen within m steps to predict (x, y) in G at point j" just in case Mi predicts (x, y) on G[j + 1], and (G[j + 1], x, y) emerges from our standard enumeration of G within m steps of computation.
We now give a procedure for enumerating the graph of a (possibly partial) function f as well as (possibly partial) functions g0, g1, . . . . (There may be finitely or infinitely many gi.) Exactly one of these functions will be total and each of the other functions, will be defined on some finite initial segment of N. (Which of these functions will be total depends on the behavior of Mi.) The enumeration of a function's graph proceeds by specifying its canonical text. In particular, G f will denote the canonical text that enumerates f. Initially, Gf =(0, i).
Procedure for enumerating the graphs of f and the g i's
Stage n: Suppose that p is the current length of G f. Let [image] . . . . Search for the least number [image] such that [image], m and Mi is seen in m steps to predict (x, 0) in G at point j. If such a [image] exists, then set [image] and also set
.
If no such [image] exists, then let g n be the function whose graph is enumerated by G and extend G f no further. Proceed to the next stage only if [image] exists; in this case, no more pairs will be enumerated into g n, which is thus finite. (Observe that if [image] exists then no matter how f is extended subsequently, Mi has made a new, incorrect guess about f on G f[j + 1]. On the other hand, if no such [image] exists, then f is finite, g n is total, Mi fails to identify g n's canonical text, and no other functions are created.)
It is easy to verify that if the construction proceeds through only n many stages, then:
(a) only n + 2 functions f, g0, g1, . . ., g n are specified;


Page 75
(b) only gn is total; and
(c) Mi fails to identify gn's canonical text.
On the other hand, if the construction proceeds through infinitely many stages, then:
(a) infinitely many functions f, g0, g1, . . . are specified;
(b) only f is total; and
(c) Mi fails to identify f's canonical text.
So in either case, Mi fails to identify the one, total function specified. Finally, observe that for all of the functions h specified in the construction (whether partial or total), h(0) = i.
§4.4 Parameterized Scientists
Real scientists are sensitive not only to evidence from their laboratories but also to general information about the character of the scientific problem they confront. In particular, the hypothesis produced by scientists in response to given data depends in part on the background knowledge they obtain from teachers and colleagues. Such knowledge rules out certain logically possible realities and embraces others. In the paradigms discussed so far, it is not possible to communicate with scientists in this sense. They thus have "one-track minds," being adapted to a single class of possibilities but no others. This feature of scientists is appropriate for modeling language acquisition — since parents have no means of informing infants about the class of human languages — but limits the fidelity of our results to adult, scientific discovery. The present section introduces a model in which scientists are given a description of a class of theoretical possibilities and must then adapt their conjectures accordingly. The ideas in this section are due to Jantke [98], and explored further by Osherson, Stob, and Weinstein [141].
§4.4.1 Communicating with Scientists
Numbers will be used to inform scientists of the class of theoretical possibilities they face. The following definition shows how numbers are used for this purpose.
4.32 Definition
(a) Any mapping of N into the power set of e is a descriptor for languages.
(b) Any mapping of N into the power set of R is a descriptor for functions.


Page 76
Thus, a descriptor for languages maps each natural number into a collection of languages, and similarly for descriptors for functions. In the context of descriptor DL, we call [image] a "description" of DL(i). Description i may be conceived as an inductive inference problem posed to a scientist, namely, the problem of identifying DL(i). A well-rounded, generally intelligent scientist should respond to i by adapting her scientific strategy in such a way that she identifies the described collection DL(i). Here are two examples of descriptors that will occupy us in the sequel.
4.33 Definition
(a) [·] denotes the descriptor for languages defined as follows. For all [image], [image] .
(b) [·]f denotes the descriptor for functions defined as follows. For all i [image], [image].
Thus, [·] interprets i as the collection of all languages with indexes in Wi. [·]f interprets i as the collection of all total recursive functions with indexes in W i. Note that W i may well contain indexes j such that j j is only partial, hence not a member of [image]. Such partial functions j j are not described by [i]f and hence do not figure in the scientific problem posed by i. Indexes in [i]f for nontotal functions should thus be considered as "noise" in the description. No such noise occurs for [·]. In this sense, [·] is more transparent than [·]f.
Given [image], W i may contain equivalent indexes, that is, multiple indexes for the same language. It is thus possible for W i to have more members than [i]. The same is true of [·]f. This is a sense in which neither descriptor is perfectly transparent.
Scientists that accept descriptions of problems have an additional, numerical argument. They are thus called "parameterized."
4.34 Definition
(a) A parameterized scientist for languages is any computable mapping (partial or total) from N × SEQ into N.
(b) A parameterized scientist for functions is any computable mapping (partial or total) from N × SEQ into N.
By "parameterized scientist" is meant either parameterized scientist for languages or for functions; context determines which kind is at issue. As a variable for parameterized scientists, we use G .


Page 77
If the first argument, i, of a parameterized scientist G is fixed, the resulting function is just a scientist in the usual sense. This scientist can be denoted by [image]. The [image] signifies that G is to be considered as a function only of its second argument, the first argument having been fixed at i. Thus, if G , is a parameterized scientist for languages, then for every [image], [image] is a computable function from SEQ to N.
In general, a parameterized scientist can identify some of the collections described to it but not others; and it may succeed if the description is described in one way but not another. To characterize the competence of a parameterized scientist we rely on the following definition.
4.35 Definition Let [image], parameterized scientist G , and descriptor DL (either for languages or functions) be given. G performs X on DL just in case for all [image], [image] identifies DL(i). X is performable on DL just in case some parameterized scientist performs X on DL.
Thus, to perform [image] on DL, G must convert any description [image] into a scientist [image] that identifies DL(i). In this sense a parameterized scientist may be conceived as a device that synthesizes ordinary scientists on the basis of input problem descriptions. The synthesizer provides trustworthy responses only to the set of descriptions that it performs.
§4.4.2 Performability on [·]
Suppose that [image] is such that [image] contains an index for N and also an index for each finite set. Then by Corollary 3.28, no [image] for which [image] is performable on [·]. Is unidentifiability the only reason for nonperformability? That is, if [image] for all [image], does it follow that X is performable on [·]? We shall now see that the answer is negative inasmuch as every finite collection of languages is identifiable (Exercise 4-1), yet [image] is not performable on [·]. Indeed, the next proposition makes an even stronger claim.
4.36 Proposition [image] is not performable on [·].
Proof: Fix a parameterized scientist G . Let p be an index for N and let h be a recursive function such that for all j, Wh(j) = {p, j }. By an application of the recursion theorem we shall construct an e such that [image] fails to identify [image]. The existence of such an e implies the proposition.


Page 78
We will construct W e in stages s = -1, 0, 1, 2, . . .. By the recursion theorem we allow the construction to have access to the desired index e. The construction of W e may complete all the stages, or else reach only finitely many of them. In each stage s that is entered we define a number [image], and a text T s, and also indicate what new elements are enumerated into W e. It will be the case that at the end of every completed, odd-numbered stage s, T s is a text for N, and for every completed, even-numbered stage s, T s is a text for the finite part of W e enumerated by the end of stage s.
Stage -1: Set m-1 = 0 and T-1 = 0,1,2, . . .. Leave W e empty.
Stage 2n, for [image]: Suppose that m2n-1 and text T2n-1 for N have been defined. Search for m2n > m2n-1 such that
If the search for m2n fails to terminate, then the enumeration of W e ceases at this stage. In this case, W e is finite, and [image] fails to identify the text T2n-1 for N, because for each m > m2n-1, G (h(e), T2n-1[m]) is an index for a language that does not properly include content(T2n-1[m]). If the search for m2n is successful, then enumerate the contents of T2n-1[m2n] into W e and set text
Note that T2n is a text for the finite set of numbers enumerated into W e up to this stage.
Stage 2n+1, for [image]: Suppose that text T2n and m2n have been defined. Search for m2n+1 > m2n such that
.
If the search for m2n+1 fails to terminate, then the enumeration of W e ceases at this stage. In this case, T2n is a text for the finite language W e, and [image] fails to identify T2n because it converges on T2n to all index for a superset of content(T2n) = W e. If the search for m2n+1 is successful, then enumerate [image] into W e and set text
Note that T2n+1 is a text for N.
If the enumeration of W e fails to progress past some even stage of the foregoing construction, then W e is finite and [image] fails to identify some text for N.


Page 79
If the enumeration of W e fails to progress past some odd stage, then W e is finite and [image] fails to identify some text for W e.
If the construction progresses past all stages, then W e = N and [image] fails to converge on some text for W e and so fails to identify W e (in this case e and p are equivalent indexes, both for N).
Thus, in all cases [image] fails to identify {W p, We} = [h(e)].
In conjunction with Exercise 4-1, Proposition 4.36 implies:
4.37 Corollary [image] is not performable on [·].
Thus, no parameterized scientist can adapt herself to the identification of an arbitrary, identifiable [image] on the basis of an [·] description of [image]. In this sense there is no universal learning machine for [·] and TxtEx.
The proof of Proposition 4.36 rests on the possible presence of equivalent indexes in the description of a class of languages. Disallowing such equivalences in fact makes performability easier. The next definition helps to make this claim precise.
4.38 Definition [image] .
So, if [image] then W i contains no two equivalent indices. (The symbol '' [image] " may be read as "no equivalences.")
4.39 Proposition [image] is performable on [·].
Proof: Exercise 4-15.
Is the finiteness qualification in Proposition 4.39 essential? The next proposition shows that it is.
4.40 Proposition [image] is not perform able on [·].
Thus, no parameterized scientist can adapt itself to the identification of an arbitrary, identifiable [image] even on the basis of an [·] description of [image] that is purged of equivalent indices. A proof of 4.40 is given in Osherson, Stob, and Weinstein [141, Proposition 3C] and omitted here.


Page 80
§4.4.3 Performability on [·]f
If n is an index for N, then Theorem 4.28 shows that no superset of {n} is performable on [·]f. However, nonperformability also infects much simpler sets of indexes, as the following proposition reveals.
4.41 Proposition (Jantke [98]) Let [image] be the set of all indexes x with the following property: there is exactly one [image] such that j j is total. Then I is not perform able on [·]f.
So, no parameterized scientist can take an arbitrary [image] and adapt itself to identify the sole [image] with an index in Wi.
Proof:4 Let total recursive h be the function guaranteed by Proposition 4.31. Then:
4.42 For all [image], [image].
Given [image], let g i be the sole member of [image] with an index in W h(i). It follows immediately from 4.31 that:
4.43 [image] is not identifiable.
Now for a contradiction, suppose that parameterized scientist G performs I on [·]f. Then:
4.44 For all [image], [image] identifies gi.
Define (unparameterized) scientist M as follows. For all [image], if content( s ) does not contain exactly one occurrence of a pair of the form (0, i), then M is undefined. Otherwise, if [image] then M( s ) = G (h(i), s ). It follows from 4.44 that M identifies [image], contradicting 4.43.
4.45 Corollary [image] is not performable on [·]f.
It is the presence of indexes for nontotal functions in the descriptions delivered by [·]f that causes nonperformability. To see this, we first define the set of descriptions free of this problem.
4.46 Definition [image] .
The symbol " [image] " may be read as "all total." We leave the following proposition as an exercise.
4 A different proof is given in [98].


Page 81
4.47 Proposition [image] is performable on [·]f.
Further discussion of parameterized scientists may be found in Jantke [98].
§4.5 Exact Identification
In this final section of the chapter, we advance a paradigm designed to refine the constraints on comparative grammar provided by considerations of learnability (see Section 3.1.2, above). Only the identification of languages is at issue.
§4.5.1 Exact Learning and Comparative Grammar
The converse of the dictum that natural languages are learnable by children (via casual exposure) is that nonnatural languages are not learnable. Put differently, the natural languages are generally taken to be the largest collection of child-learnable languages. We are thus led to consider paradigms in which learners are required to respond successfully to all languages in a given collection and to respond unsuccessfully to all other languages. One such paradigm relies on a modification of the identification concept that is defined as follows.
4.48 Definition
(a) Let scientist [image] and [image] be given. F identifies [image] exactly just in case for all texts T, F identifies T if and only if T is for some [image]. In this case [image] is exactly identifiable.
(b) The class of all [image] such that some computable [image] identifies [image] exactly is denoted by TxtExExact.
For example, the scientist defined in the proof of Proposition 3.18 identifies [image] exactly. Similarly, let g be some recursive function such that W g( s ) = content( s ) for each [image] and consider a scientist F that on [image] emits g( s ). Clearly, this F identifies [image] exactly. Hence [image].
Two points should be borne in mind about Definition 4.48. First, if F identifies [image], then F identifies every subset of [image] and may identify some proper supersets of [image] as well (see Exercise 3-3). In contrast, if F identifies [image] exactly, then F exactly identifies no collection [image]. Second, if F identifies [image] exactly, then there is a strong sense in which F fails to identify [image]; namely, F fails to identify any text for such an L,


Page 82
not simply one text. A weaker version of the exact identification paradigm is discussed in Exercise 4-21.
Since each scientist exactly identifies only one collection of languages, TxtExExact can contain no more collections than there are computable scientists to exactly identify them. Hence, the cardinality of TxtExExact is at most countably infinite. On the other hand, every singleton collection {W i} of languages is exactly identifiable. So TxtExExact is countably infinite. In contrast, TxtEx is uncountable. This is because TxtEx contains collections with infinitely many members ( [image], for example) and each of the uncountably many subsets of such a collection is also in TxtEx. We conclude:
4.49 Proposition (TxtEx - TxtExExact) is uncountable.
Proposition 4.49 shows that the criterion of exact identification places more constraint on theories of human language than does identification tout court. Should we require of such a theory that it embrace an exactly identifiable collection? Although the remarks at the beginning of this section suggest an affirmative response, the matter is clouded by the following consideration.
Human languages are not only learnable, they are also highly expressive in the sense that many thoughts can be communicated within any one of them. Let us therefore stipulate that a language be counted as human just in case it is both learnable and highly expressive. Now consider the impoverished language consisting of the single expression "Go!" with its usual meaning. The Go-language may well be learnable by children through casual exposure. If so, then not every learnable language is human, and hence the human languages are a proper subset of the class of learnable languages. This entails that a theory of human language can be legitimately evaluated against the standard of identifiability, but not against the standard of exact identifiability.
It may be possible to disarm the foregoing objection to exact learning. There is evidence that children exposed to inexpressive languages (e.g., pidgins) as well as children denied access to any ambient language (e.g., deaf children in certain circumstances) invent linguistic devices of considerable complexity and communicative potential (see Feldman, Goldin-Meadow, and Gleitman [57], Sankoff and Brown [166], Bickerton [17], and Gleitman and Newport [79]). These findings suggest that children may not be capable of learning profoundly inexpressive languages. If this is true, then the human languages coincide exactly with the learnable languages, and exact identifiability is the appropriate standard for the evaluation of theories of comparative grammar.
Finally, suppose that certain inexpressive languages turn out to be learnable after all. In this case it is possible that comparative grammar can be investigated more successfully


Page 83
if such languages are admitted as human, perhaps as special cases. Exact identification would then, once again, be the appropriate standard of learnability.
§4.6 Summary
Computable scientists occupy center stage in our theory of scientific inquiry. To study them we extend our conception of Turing Machines so that they also represent functions from SEQ to N and from SEG to N. The choice of domain depends on whether we consider natural numbers as codes for SEQ or for SEG. In either case, the class of computable scientists is indexed as Mi.
A wide variety of paradigms are defined and analyzed in the chapters to follow. For concision, each is associated with a symbolic name that refers to the family of collections of languages or functions that can be identified within them. For example, Lang is the family of all collections of languages that can be identified in the sense of Section 3.4, and Func is the family of all identifiable collections of functions in the sense of Section 3.9.4. Restricting attention to computable scientists, these paradigms become TxtEx and Ex, respectively.
Introducing the computability constraint on scientists limits the collections that can be identified. In particular, it was shown that both Lang - TxtEx and Func - Ex are nonempty. When computability is considered in conjunction with other characteristics of scientists, the impact on identifiability is not straightforwardly deducible from the impact of each characteristic considered separately. This was illustrated by considering the kinds of collections of languages that can be identified by scientists who are either computable, memory-limited, or both.
Real scientists have flexibility that is not represented by functions from SEQ or SEG to N. In particular, scientists can often take account of background knowledge communicated to them from an external source such as colleagues or professors. To incorporate this feature of empirical inquiry into our theory we consider "parameterized scientists" who receive an additional, numerical input. The input is conceived as a code for a class of languages or functions that delimit the possible realities that the scientist must envision. Given a set of such codes, we ask whether there exists a computable, parameterized scientist that can identify the class associated with any code in the set. Two kinds of codes were considered, one for communicating classes of languages to scientists, the other for communicating classes of functions.
Finally, we returned to the study of comparative grammar and observed that the class of human languages is generally defined as including all and only the languages


Page 84
that children can acquire in normal fashion. This reflection leads to a new criterion of successful performance called "exact identification." To identify exactly a collection [image] of languages the learner must identify [image] and fail to identify any text for any language outside of [image].
§4.7 Exercises
4-1 Suppose that [image] contain only finitely many languages. Show that [image].
4-2 Let K be the r.e., nonrecursive set defined on page 25. Define
.
Show that
4-3 Given a class [image] of scientists, denote by [image] the class of [image] such that some [image] identifies [image].
(a) Show that if [image], then [image] but [image] is possible.
(b) Evaluate the validity of the following claims.
(i) [image].
(ii) [image].
(iii) [image].
(iv) [image].
4-4 Given [image]. Let L i = {0,1, . . ., i}. Let [image] Suppose that [image]. Show that [image] if and only if [image].
4-5 Show that TxtEx is not closed under finite union.
4-6 Show that there is [image] with the following properties.
(a)
(b) Some scientist (not necessarily computable) identifies [image] confidently (see Exercise 3-21).
(c) No computable scientist identifies [image] confidently.


Page 85
4-7 (Angluin [6]) Most practical classes of languages are uniformly decidable. A sequence of nonempty languages L0, L1, . . . is an indexed family just in case there exists a computable function f such that for each [image] and for each [image],
In other words, there is a uniform decision procedure for languages in the class. The purpose of this and the next two exercises is to explore the identifiability of indexed families of computable languages. In this exercise we establish Angluin's characterization (described in Theorem 3.26) for an indexed family of computable languages. To this end, we define a finite tell-tale set.
Let [image] be an indexed family of computable languages. A is a finite tell-tale of L i just in case A is a finite subset of L i and there is no j such that [image].
Show that an indexed family of computable languages [image] belongs to TxtEx just in case there is a procedure, effective in i, that enumerates all elements in a finite tell-tale of L i.
There has been considerable work on identification of several natural indexed families of computable languages, e.g., subclasses of elementary formal systems, of logic programming languages, and of formal languages in the Chomsky hierarchy. For results on elementary formal systems, we refer the reader to the papers of Arikawa, Miyano, Ayumi Shinohara, Takeshi Shinohara, and Yamamoto [9, 8, 175]. Sample results about identification of logic programming languages can be found in Arimura and Shinohara [10] and Krishna Rao [112]. Yokomori [205] contains results about identification of languages accepted by a class of deterministic automata. See Sakakibara [165] for a survey of related results about grammatical inference.
4-8 (Angluin [5]) A collection of languages [image] has finite thickness just in case for each [image], [image] is finite.
Show that if an indexed family of computable languages [image] has finite thickness, then [image].
4-9 (Wright [204], see also Motoki, Shinohara, and Wright [133]) A collection of languages [image] has infinite elasticity just in case there exists an infinite sequence of pairwise distinct numbers, [image], and an infinite sequence of pairwise


Page 86
distinct languages, [image], such that for each [image], [image], but [image]. is said to have finite elasticity just in case [image] does not have infinite elasticity.
1. If a class of languages has finite thickness, then show that it has finite elasticity.
2. Show that if an indexed family of computable languages [image] has finite elasticity, then [image].
4-10 Show that both [image] and [image] are members of Ex.
4-11 Does the analogue to Proposition 4.30 hold for language identification?
4-12 Let [image] be given. Show that there is [image] such that [image].
4-13 Consider the scientist F defined in the proof of Theorem 3.43. It follows from Theorem 4.28 that F is not computable. Describe the aspect of F that renders it un-computable.
4-14 Show that Proposition 3.46 can be strengthened to the following: There is [image] such that no memory limited scientist (computable or not) identifies [image].
4-15 Prove Proposition 4.39.
4-16 Prove Proposition 4.47.
4-17 Let [image] be the set of all indexes x such that card(W x) is finite. Show that J is performable on [·]f.
4-18 Let [image] be as defined in Exercise 4-2. Show that [image].
4-19 Suppose that (not necessarily computable) [image] identifies [image] exactly. Show that for all [image], [image] if and only if there is a locking sequence for F on L.
4-20 (Advanced) Show that [image] if and only if [image] and [image] is arithmetically indexable.
Hint: Use Exercise 4-19.


Page 87
4-21 (Advanced) We define a success criterion in the spirit of exact identification but somewhat weaker.5 Given scientist F and [image], F exactly identifies [image] in the weak sense just in case F identifies [image] and F identifies no language in the complement of [image]. The class of all [image] such that some computable M: identifies [image] exactly in the weak sense is denoted by TxtExWeakExact. Prove:
(a) [image] if and only if [image] and [image] is [image] indexable.
(b) There is [image] such that [image] is not [image] indexable.
Conclude that [image].
5 For the background to this exercise, see Rogers [158, Chapters 14,16] or Shoenfield [176, Chapters 6,7].


Page 89
PART II
FUNDMENTAL PARADIGMS GENERALIZED


Page 91
5
Strategies for Learning
The paradigms TxtEx and Ex allow scientists to be any computable device whatsoever. This conception seems excessively general if only because human scientists (and the computers they build) operate under resource constraints involving time and memory. In addition, real scientists are apt to impose various methodological constraints upon their theorizing, for example, requiring that present hypotheses account for all available data. In the present chapter we formalize and investigate such constraints by considering the inductive competence of alternative subsets of the class of computable scientists. Any such subset is called a strategy, and the principal question it invites is whether every identifiable collection of languages or functions is identified by a member of the strategy. We shall see that the answer is often negative, even for strategies that appear to embody a rational canon of hypothesis selection. In this sense, many of the strategies to be defined below are restrictive constraints on scientists.
In terms of paradigms, the present chapter may be conceived as exploring alternative conceptions of scientist, while leaving untouched the interpretations of theoretically possible reality, data etc. that we introduced in Chapters 3 and 4. Let us also note the connection of strategies to language development in children. To the extent that human children are essentially identically endowed for language acquisition (which seems manifestly to be the case), their learning methods are drawn from an extremely narrow strategy in the sense defined above. So it is suggestive to examine the inductive capacity of diverse constraints on scientists in hopes of finding one that allows identification of just the languages children can assimilate. (See Section 3.1.2 for more discussion.)
In what follows, we first consider strategies for the identification of languages, and then of functions.
§5.1 Strategies for Language Identification:
Introduction
We divide strategies for language learning into four groups:
1. constraints on potential conjectures,
2. constraints on the information available to a scientist,
3. constraints on convergence, and


Page 92
4. constraints on the relation between conjectures.
The next four sections treat each of these in turn.
Relative to any given constraint a further distinction often arises. As an example, consider the requirement that conjectures must be consistent with the data that give rise to them. Formally, scientists satisfying this requirement have the property that on evidential state s they output the index of a language that contains content( s ). Observe, however, that this requirement can be interpreted in the following two different ways.
1. Global consistency: A collection of languages, [image], is identifiable by a globally consistent scientist just in case there exists an M that is consistent on all [image] and M identifies [image]. Such collections of languages are denoted [TxtEx]consistent.
2. Class consistency: A collection of languages [image] is identifiable by a class-consistent scientist just in case there exists an M that is consistent on all evidential states drawn from languages in [image] and M identifies [image]. Such collections of languages are denoted [TxtEx]class-consistent.
Of course, the question immediately arises whether [TxtEx]consistent is a proper subset of [TxtEx]class-consistent. (See Proposition 5.13 below.) For many strategies, considering both the global and class versions is meaningful, whereas for other strategies only one version makes sense.
§5.2 Constraints on Potential Conjectures
From the premise that M identifies [image], one can deduce no information about the nature of M( s ) for any particular [image]. For example, is M( s ) consistent with s ? This section considers the effects on identification of various constraints on ways in which learners respond to evidential states.
§5.2.1 Totality
The most elementary constraint on a conjecture is that it exist. This requirement may be formulated as follows.
5.1 Definition
(a) M is always defined on L just in case, for every s with [image], we have [image].


Page 93
(b) M is always defined on [image] just in case M is always defined on each [image].
(c) M is always defined just in case M is always defined on each [image].
Clearly ''M is always defined" is the same as "M is total." As discussed in the introduction, we may distinguish the global and the class versions of this strategy. The collections of languages identifiable by the two versions are recorded in the next definition.
5.2 Definition(
a) [image].
(b) [image].
As might be expected from Proposition 4.15, requiring that scientists always be defined is not restrictive. The following proposition is simply a restatement of Proposition 4.15.
5.3 Proposition [TxtEx]all-def = [TxtEx]class-all-def = TxtEx.
It will simplify the formulation of definitions and results in this chapter to limit attention to scientists that are defined on all inputs. We thus enter the following convention.
Convention: Just for Chapter 5, the term "scientist" applies only to total functions from SEQ to N (in the language identification paradigm), or to total functions from SEG to N (in the function identification paradigm).
§5.2.2 Consistency
Our next strategy captures a natural constraint on hypothesis selection, namely, that each conjecture made by a learner be consistent with the the data seen thus far.
5.4 Definition (Angluin [6])
(a) M is said to be consistent on L just in case, for every s with [image], we have [image].
(b) M is consistent on [image] just in case M is consistent on each [image].
(c) M is consistent just in case M is consistent on each [image].
We first consider the global version of consistency.
5.5 Definition [image] .


Page 94
It is easy to verify that the collection of all finite languages can be identified by a consistent scientist. Consistency appears to be a rational strategy. However, the following proposition demonstrates that consistency restricts TxtEx.
5.6 Proposition Suppose [image] is consistently identifiable. Then [image] is a collection of recursive languages.
Proof: Suppose [image]. By the locking sequence lemma (Theorem 3.22), there is a sequence s such that [image], WM( s ) = L, and for each [image] with [image], we have that [image].
Suppose [image]. Then [image], since s is a locking sequence for L. Now suppose [image]. Then, since M is consistent, [image] is not an index for L, and hence [image]. Thus [image] if and only if [image]. Since M is total, this constitutes an effective test for membership in L.
There are certainly [image] that include nonrecursive languages. One such collection is { K }! Hence Proposition 5.6 yields the following corollary.
5.7 Corollary [image] .
Proposition 5.6 suggests the following question: If attention is limited to the recursive languages, does consistency still restrict TxtEx? The next proposition provides an affirmative answer.
5.8 Proposition There is an [image] such that [image].
Our proof of the proposition uses the following lemma and definition. The lemma is a standard exercise.
5.9 Lemma For each 0-1 valued recursive function h(·, ·), there is a recursive set S which differs from each of the recursive sets [image] where i = 0, 1, · · ·.
5.10 Definition [image] is said to be r.e. indexable just in case there is [image] such that [image]; in this case S is said to be an r.e. index set for [image]. Similarly, [image] is said to be r.e. indexable just in case there is [image] such that [image] and S is said to be an r.e. index set for C.
Although the recursive sets are r.e. indexable (see Rogers [158, Page 73]), Lemma 5.9 says that the collection of characteristic functions of recursive sets is not r.e. indexable.


Page 95
Proof (of Proposition 5.8): For each [image], define [image]. Let [image] is recursive }. Clearly, [image].
Suppose, however, that a consistent scientist M identifies [image]. Let h be the function defined by the following equation:
Since M must be total, h is clearly total recursive. Thus h satisfies the hypothesis of Lemma 5.9, so there is a recursive set S such that no [image] is a characteristic function of S. But let i' be an index for S, and let s ' be a locking sequence for M on L i'. Suppose [image]. Then [image], which implies that [image]. Now suppose [image]. Then [image], since M is consistent so that [image]. Thus [image] is the characteristic function of S, contradicting the choice of S.
We now consider the class version of consistency in which a scientist is required to be consistent only on the evidential states drawn from the languages under consideration.
5.11 Definition (Barzdins * [13])
We leave it to the reader to show the following proposition which establishes that the class version of consistency also restricts TxtEx.
5.12 Proposition (Barzdins* [13]) [image] .
A natural question is how the global and class versions of consistency compare. As the [image] of the proof of 5.8 is readily seen to be in [TxtEx]class-consistent, that proof also yields the following.
5.13 Proposition [image] .
§5.2.3 Accountability
We next consider scientists whose hypotheses always include some prediction about the state of affairs outside the data thus far seen.


Page 96
5.14 Definition
(a) M is said to be accountable on L just in case, for every s with [image], we have that WM( s ) - content( s ) is nonempty.
(b) M is said to be accountable on [image] just in case M is accountable on each [image].
(c) M is accountable just in case M is accountable on each [image].
Thus the hypotheses of accountable learners are always subject to further confirmation. The next definition considers the global and the class versions of accountability.
5.15 Definition
(a) [image].
(b) [image].
It is easy to see that [image] and that no accountable scientists can identify any finite language. This suggests the following question. If attention is restricted to infinite languages, are there identifiable collections of languages that cannot be identified by class-accountable scientists? The next proposition provides an affirmative answer.
5.16 Proposition There is an [image] such that every [image] is infinite.
Proof: Recall from Chapter 2 that for each L and x, [image]. Let [image].
Clearly, [image].
Suppose by way of contradiction that a class-accountable scientist M identifies [image]. By Kleene's recursion theorem (Theorem 2.3) there exists an index e such that W e may be defined in stages s = 0, 1, 2, . . ., as below. For each s, [image] denotes the finite portion of W e enumerated as of the beginning of stage s. In each stage s, we determine a number y s+1, finite sets S s+1 and X s+1, and sequence s s+1. We begin with [image], [image], [image], s 0 chosen so that content( s 0) = S0, and [image]. Go to stage 0.
Begin ( Stage s )
Search for the least [image], if any, such that [image].


Page 97
If [image] is ever found, then:
set [image],
set y s+1 to the least number of the form [image] that is not in the finite set [image],
set [image],
set s s+1 be the least extension of s s such that content( s s+1) = S s + 1,
set [image], and
go to stage s + 1.
End ( Stage s )
To show that M fails to accountably identify [image], we consider two cases.
Case 1: All stages of the construction halt. Let L = W e. It is easy to see that [image] and [image]. Let [image]. Observe that T is a text for L. But for each i we have [image]. Thus M fails to identify L.
Case 2: Some stage s starts but does not halt. By Kleene's recursion theorem there exists an e' > e such that [image]. Clearly, [image]. However, [image]. Thus, M fails to be accountable on W e'.
The global version of accountability turns out to be more restrictive than the class version. To show this, let us first recall from Chapter 4 that [image] and introduce the following.
5.17 Definition [image] .
5.18 Proposition [image] .
Proof: We first show that [image]. By the S-m-n Theorem (Theorem 2.1), there is a recursive g such that, for all i, [image]. Let G N be an index for N. Consider the scientist M that behaves as follows on each s :
It is easy to verify that M is accountable on [image] and that is identifies [image].
Now suppose by way of contradiction that an accountable scientist M identifies [image]. Through an implicit use of Kleene's recursion theorem (Theorem 2.3), we exhibit a [image] which M fails to identify. We construct a text for this W e in stages.
Stage 0: s 0 = [image].


Page 98
Stage n + 1: Let [image] be the least number such that [image] is found in [image] steps. (Such a number must exist, since M is accountable.) If (i) [image], then let [image]. Else if (ii) [image], then let [image].
Let [image] and W e = content(T). It is clear that [image]. It is also clear that M fails to identify T, since for each n, either (i) [image] (by not being single valued), or else (ii) [image].
§5.2.4 Prudence
Suppose scientist M is defined on [image]. We say that M makes a "wild guess" if M does not identify WM( s ). Here we consider scientists that never respond to their data with a wild guess.
5.19 Definition
(a) M is said to be prudent just in case for all [image], if M( s ) is defined, then M identifies WM( s ).
(b) [image].
In other words, prudent learners only conjecture grammars for languages they are prepared to learn. It is easy to verify that the collection of finite languages, and the collection of co-singleton languages, can be identified by prudent scientists.
If "prestorage" models of linguistic development are correct, then children acquiring language may well be prudent learners. A prestorage model posits an internal list of candidate grammars that coincides exactly with the natural languages. Language acquisition amounts to the selection of a grammar from this list in response to linguistic input. Such a prestorage learner is prudent in as much as his or her linguistic hypotheses are limited to grammars from the list, that is, to grammars corresponding to natural (i.e., learnable) languages. The next proposition reveals that prudence has no impact on learnability.
5.20 Proposition(Fulk [71]) [image].
The proposition is an immediate corollary of the following lemmas. We defer the proofs of these lemmas to Section 5.4.1. To help state these lemmas, we introduce the following definition.


Page 99
5.21 Definition [image] is called r.e. extendible just in case there is an r.e. index-able [image] such that [image].
5.22 Lemma TxtEx = [TxtEx]prudent if and only if every [image] is r.e. extendible.
5.23 Lemma [image] is r.e. extendible.
§5.3 Constraints on the Use of Information
Each initial sequence T[n] of a text T provides partial information about the identity of content(T). The information embodied in T[n] may be factored into two components:
(i) content(T[n]), that is, the subset of content(T) available to the scientist by the nth moment, and
(ii) the order in which content(T[n]) occurs in T[n].
Human learners operate under processing constraints that prevent them from fully exploiting either kind of information. The notion of memory limitation studied in Chapters 3 and 4 is an example of a strategy modeling the first kind of restriction. The next two strategies capture the second kind of limitation.
§5.3.1 Set-driven Scientists
A set-driven scientist is insensitive to the order in which data are presented.
5.24 Definition (Wexler and Culicover [194])
(a) M is set driven just in case for all s , [image], if [image], then [image].
(b) [image].
Note that we consider only the global version of set-drivenness. It is easy to verify that [image], the collection of finite languages, is identified by a set-driven scientist.
Identification of a language L requires identification of every text for L, and these texts constitute every possible ordering of L. This consideration encourages the belief that the internal order of a finite sequence plays little role in identifiability. However, the next proposition shows the belief to be unjustified.


Page 100
5.25 Proposition (Scháfer-Richter [167], Fulk [69])
Proof: For each j, define [image] and, for each j and n, define [image]. Let M0, M1, M2, . . . denote an enumeration of all scientists. For each j, let
Let [image]. It is easy to see that [image].
Suppose by way of contradiction that Mj is a set-driven scientist that identifies [image]. Mj thus identifies the text [image]. So there must be an [image] and an index i for L j such that M j( s j,n) = i. In particular, there must be a least [image] such that M j( s j,n) = i and [image]. But then Mj does not identify content( s j,n), since on the text [image] must conjecture i in the limit, since Mj is set driven. Thus Mj fails to identify [image], a contradiction.
§5.3.2 Rearrangement-independent Scientists
Set-driven scientists ignore the order in which data arrive and base their conjectures only on the content of the data seen at any given time. The following definition introduces a less stringent variation on set-drivenness.
5.26 Definition (Schäfer-Richter [167], Fulk [69, 71])
(a) M is rearrangement-independent just in case for every s , [image] with [image] and [image], we have [image].
(b) [image].
Unlike set-drivenness, rearrangement independence turns out not to be restrictive; we delay the proof of this fact to the next section.
§5.4 Constraint on Convergence
Suppose that a scientist M identifies [image]. Then for each [image] and each text T for L, M must converge to some index for L. This M does not necessarily converge to the same


Page 101
index on different texts for the same language in [image], nor need M necessarily converge on texts for languages outside [image]. We next consider two constraints on convergence that limit the freedom of scientists in these ways.
§5.4.1 Order Independence
As the first constraint on convergence we consider scientists that converge to the same index on every text for a language.
5.27 Definition (Blum and Blum [18])
(a) M is order-independent on L just in case for all texts T, T' for L, if [image], then [image].
(b) M is order-independent on [image] ; just in case M is order-independent on each [image].
(c) M is order-independent just in case M is order-independent on each [image].
Thus an order-independent scientist is relatively insensitive to the choice of text for a language on which it is order-independent: any such text eventually leads it to the same index. Note that different texts for the same language may cause an order-independent scientist to examine different amounts of input before convergence begins (just as for order-dependent scientists).
5.28 Definition (Blum and Blum [18])
(a) [image].
(b) [image].
Clearly, [image]. The effect of order independence on scientists may at first appear to be restrictive because of the following consideration. An order-independent learning policy seems to require the ability to determine the equivalence of distinct indexes, but the equivalence question cannot in general be answered by a computational process, indeed, the set [image] is not even r.e. (sec Rogers [158, Section 5.2]). Contrary to expectation, order independence turns out not to be restrictive. This follows from the following extension of a result of Blum and Blum [18] by Fulk [71].


Page 102
5.29 Proposition (Fulk [71]) Given any scientist M, one can effectively construct scientist M' such that all the following conditions hold.
1. .
2. M' is order-independent.
3. M' is rearrangement-independent.
4. If there exists a locking sequence for M' on L, then M' identifies L.
5. If M' identifies L, then all texts for L contain a locking sequence for M' on L.
5.30 Corollary (Blum and Blum [18])]
5.31 Coronary (Fulk [69], Schäfer-Richter [167])
To help prove Proposition 5.29, we introduce the following weakening of the notion of locking sequence.
5.32 Definition (Fulk [69]) Given a scientist M and a language L, we say that s is a stabilizing sequence for M on L just in case
(a) [image], and
(b) [image].
So, a stabilizing sequence on L is like a locking sequence on L, except that M's conjecture on it need not be an index for L. The proof of the following lemma is left to the reader.
5.33 Lemma If M identifies L, then every stabilizing sequence for M on L is also a locking sequence for M on L.
The next two definitions introduce some terminology we use in describing how to search for stabilizing sequences.
5.34 Definition For each [image], visible( s ) denotes the set [image].


Page 103
Note that the usage '' [image] " in the above definition implicitly identifies an initial sequence with its canonical indexing and thereby induces a linear ordering on elements of SEQ. Also note that for each [image], the cardinality of visible( s ) is finite and visible( s ) can be effectively computed from s . Furthermore, visible( s ) depends only on the content and length of s .
5.35 Definition Given a scientist M and a [image], s 0 is called a candidate stabilizing sequence for M at s just in case:
(a) [image], and
(b) [image].
The following two claims summarize the properties of candidate stabilizing sequences. The proof of the first claim is immediate and is left to the reader.
5.36 Claim
(a) Given M, s , and s 0, it is effectively decidable whether s 0 is a candidate stabilizing sequence for M at s .
(b) Given M and s , there is a candidate stabilizing sequence for M at s .
(c) If s 0 is a stabilizing sequence for M on L, then s 0 is a candidate stabilizing sequence for every sequence s such that [image] .
(d) If [image] and s 0 is not a candidate stabilizing sequence for M at s , then for all [image] is not a candidate stabilizing sequence for M at [image].
5.37 Claim Given a scientist M and text T such that s is a candidate stabilizing sequence for M at T[n] for infinitely many n, then a is a stabilizing sequence for M on content(T).
Proof: Suppose by way of contradiction that s is not a stabilizing sequence for M on content(T). Then there exists a s ' such that [image] and [image]. But, for all but finitely many n, [image]. Hence, for all but finitely many n, s fails to be a candidate stabilizing sequence for M at T[n], a contradiction.
As a corollary to the above two claims we have
5.38 Corollary Suppose M and T are given. Then the following are equivalent:


Page 104
(a) s 0 is a stabilizing sequence for M on content(T).
(b) s 0 is a candidate stabilizing sequence for M at all but finitely many initial segments of T.
(c) s 0 is a candidate stabilizing sequence for M at infinitely many initial segments of T.
Proof (Proposition 5.29): Let pad(.,.) be a recursive one-to-one padding function such that for [image] W pad(i,j) = W i (see Chapter 2). Let M' be a scientist such that for each [image], M'( s ) = pad(M( s 0), s 0)), where s 0 is the least candidate stabilizing sequence for M at s . By Claim 5.36, the search for s 0 is effective and always succeeds.
So by Corollary 5.38, we have
5.39 Claim For any text T, [image] if and only if s 0 is the least stabilizing sequence for M on content(T). Moreover, if there exists no stabilizing sequence for M on content(T), then
We now show that M' satisfies all the properties claimed in the proposition.
1. Fix an [image] and let T be an arbitrary text for L. By Theorem 3.22 there exists a locking sequence for M on L. Hence there is also a stabilizing sequence for M on L. Let s 0 be the least stabilizing sequence for M on L. Then by Claim 5.39 we have that [image], but by Lemma 5.33, s 0 is also a locking sequence for M on L. Hence, [image].
2. By Claim 5.39, if M' converges on T, then the value of M'(T) depends only on content (T). Thus M' is order-independent.
3. It is clear from the construction that M' is rearrangement-independent, because the least candidate stabilizing sequence for M at s depends only on content( s ) and [image].
4. Suppose s is a locking sequence for M' on L. Then M' identifies all texts for L that extend s . Since M' is order-independent, it follows that M' identifies L.
5. Suppose M' identifies L. Let s 0 be the least stabilizing sequence for M on L and let T be an arbitrary text for L. Choose an n0 so large that
(a) [image], and
(b) ( "s < s 0) [ s is not a candidate stabilizing sequence for T[n0]].
Such an n0 must exist. (For (b), use Corollary 5.38). By Claim 5.36, we thus have that, for all [image] with [image], s 0 is the least candidate stabilizing sequence for M at [image]. Thus T[n0] is a locking sequence for M' on L.
We now return to the proofs of Lemmas 5.22 and 5.23.


Page 105
Proof (Lemma 5.22): Suppose first that TxtEx = [TxtEx]prudent. Fix an [image]. We argue that [image] is r.e. extendible. Let M be a prudent scientist that identifies [image]. Then [image] is an r.e. set. Since M is prudent, M identifies [image]. Clearly, [image] is r.e. indexable and a superset of [image].
Now suppose that every [image] is r.e extendible. Fix an [image] and let [image] be a superset of [image] that is r.e. indexable, say by the r.e. set S. Without loss of generality we take S to be infinite. By Proposition 5.29, there is a total order-independent scientist, M, that identifies [image]. We show how to construct a prudent scientist M' that identifies [image] (and hence [image]). Let S0, Sl, . . . be a one-one recursive enumeration of S. Let T i be a text for W si that can be obtained recursively from i. Now, for each s , define
.
Since M is order-independent and identifies [image], M' will converge on any text T for [image] to an si such that W s i = L. Also, every index in S is an index for a language in [image], and M' outputs only indexes from S. Thus M' is prudent and identifies [image].
Proof (Lemma 5.23): Our goal is to show that every [image] is r.e extendible. Fix an [image]. By Proposition 5.29, [image] is identifiable by some scientist M such that M identifies L if and only if there is a locking sequence for M on L. Without loss of generality we assume that [image]. We exhibit an r.e. indexable collection [image] such that [image] and [image]. There are two cases:
Case 1: M identifies N. Define a recursive function ƒ by
To see that ƒ defined in this way is recursive, we argue informally. Given s , to enumerate W ƒ ( s ), compute M( s ) and enumerate nothing in W ƒ ( s ) until, if ever, a stage s is reached such that WM( s ),s contains all of content( s ). At this point begin enumerating all of WM( s ) into W ƒ ( s ) until, if ever, there is discovered a sequence g such that [image], [image] and [image]. If such a g exists, then begin enumerating all of N into W ƒ ( s .
Since ƒ is recursive, [image] is r.e. On the other hand, since [image] and N are identified by M and since M identifies every L such that there is a locking sequence for M on L, M identifies every language with an index in S.


Page 106
Case 2: M does not identify N. Define a recursive function ƒ by
We leave it to the reader to argue that ƒ defined in this way is recursive.
Suppose G i is a grammar (effectively obtained from i) for [image]. Let [image]. Clearly, S is an r.e. index set for some collection of languages, [image]. Note that S contains all languages identified by M, together with all initial segments of N. Let r be a total recursive function such that for every [image], [image]. To see that [image], define scientist M' as follows:
Since M does not identify N, M' identifies all that M does, together with all initial segments of N.
§5.4.2 Reliability
A scientist that occasionally converges to an incorrect language may be termed "unreliable."
5.40 Definition (Minicozzi [132])(a) M is reliable on L just in case for any text T for L, if [image], then WM(T) = L.
(b) M is reliable on [image] just in case M is reliable on each [image].
(c) M is reliable just in case M is reliable on each [image].
Thus a scientist that does not converge on any text is reliable. Only the global version of reliability yields a useful strategy.
5.41 Definition
It is easy to see that the collection of finite languages is identifiable by a reliable scientist. On the other hand, the obvious scientist for identifying


Page 107
— namely, the one that responds to [image] with a canonical index for N minus the least number missing from content( s ) — is not reliable as it converges on a text for the even numbers but fails to identify them.
Reliability is a useful property of scientists. A reliable scientist never fails to signal the inaccuracy of a previous conjecture. To explain, let M be a reliable scientist, let T be a text for some language, and suppose that for some i, [image], M(T[n]) = i. If [image] — that is, if i is incorrect—then for some m > n we have [image]. (This is the case, because otherwise M converges on T to the incorrect index i, contradicting M's reliability.) The new index M(T[m]) signals the incorrectness of i. It might thus be hoped that every identifiable collection of languages is identified by a reliable scientist. However, reliability turns out to be quite a debilitating constraint on scientists, as shown by the following proposition.
5.42 Proposition Suppose some reliable scientist M identifies [image]. Then L is finite.
Proof: This is a straightforward locking sequence argument. Let s be a locking sequence for M on L. Then, if [image], M converges on T to an index for L. Thus L = content(T) = content( s ), which is finite.
5.43 Corollary
§5.5 Constraints on the Relation between Conjectures
The successive conjectures emitted by an arbitrary scientist need stand in no particular relation to each other. We now deal with strategies resulting from imposition of such a relation.
§5.5.1 Conservatism
A seemingly rational constraint is captured by the following strategy.
5.44 Definition (Angluin [6])
(a) M is conservative on L just in case for all s and [image] such that [image] and [image], if [image], then [image].
(b) M is conservative on [image] ; just in case M is conservative on each [image].
(c) M is conservative just in case M is conservative on each [image].


Page 108
5.45 Definition
(a) [image].
(b) [image].
A conservative scientist thus never abandons a locally successful conjecture, that is, a conjecture that generates all the data seen to date. It is easy to verify that the collection of all finite languages and the collection. of all co-singleton languages can be identified by conservative scientists.
The following proposition implies that conservatism is restrictive.
5.46 Proposition (Angluin [6]) [image] .
Proof: This argument is essentially the same as that for Proposition 5.25. Consider the class [image] defined in that proof and suppose that Mj is a conservative scientist that identifies [image]. As argued in the proof of Proposition 5.25, Mj must identify the text [image], for L j. Thus there is a least pair [image] such that Mj(T[n]) = i and [image]. So [image] is not identified by Mj, since on the text [image] Mjmust continue to output i by the conservativeness of Mj.
It turns out that both global and class versions of conservatism render the same collections of languages identifiable, as implied by the next proposition. Its proof is discussed in Exercise 5-21.
5.47 Proposition [TxtEx]conservative = [TxtEx]clss-conservative.
§5.5.2 Generalization Strategies
We now consider a collection of strategies that require scientists to "improve" upon their successive conjectures. A scientist can begin by hypothesizing an index for a language smaller than the target language and then build to the target language. Such strategies are referred to as generalization strategies, and they model bottom-up or specific-to-general searches in artificial systems for empirical inquiry. For example, see systems such as Muggleton and Feng's Golem [134].
Three different generalization strategies have been proposed.
5.48 Definition (Jantke [99])


Page 109
(a) M is said to be strong-monotonic on L just in case, for each [image] with [image] and each [image], we have [image].
(b) M is said to be strong monotonic on [image] just in case M is strong-monotonic on each [image].
(c) M is strong monotonic just in case M is strong monotonic on each [image].
So, a strong-monotonic scientist, upon being fed a text for a language, outputs a chain of hypotheses such that if index j is hypothesized after index i, then [image]. A consequence of this requirement is that if a scientist incorrectly hypothesizes that a particular element belongs to the target language, then it cannot revise this assumption by emitting a hypothesis that excludes this element.
5.49 Definition
(a)
(b) [image].
Exercise 5-15 shows:
We thus consider only the global version in the sequel.
Wiehagen [200] suggested that the requirement of strong monotonicity is too stringent. He proposed the weaker notion of monotonic strategy, which simply requires that a scientist's successive hypotheses be more general only with respect to the target language. More precisely:
5.50 Definition (Wiehagen [200])
(a) M is said to be monotonic on L just in case, for each [image] with [image] and each [image], we have [image].
(b) M is said to be monotonic on [image] just in case M is monotonic on each [image].
Thus a monotonic strategy is allowed to correct its mistaken assumption that certain nonelements of L belong to L, but once it has correctly concluded that an element of L belongs to L it is not allowed to output a hypothesis that contradicts such a conclusion. The reader should note that we deliberately omitted the third clause in the above definition because the global version of monotonicity is equivalent to the requirement of strong


Page 110
monotonicity. (See Exercise 5-19.) For this reason, in the next definition we introduce only the class version of monotonicity and, in keeping with the usage in the literature, refer to the class as [TxtEx]monotonic instead of [TxtEx]class-monotonic.
5.51 Definition [image] .
The third generalization strategy, referred to as weak monotonic, allows a scientist to expel elements from its hypothesis only if it encounters elements in its evidential state that cannot be accounted for by its current hypothesis. More precisely:
5.52 Definition (Lange and Zeugmann [119])
(a) M is said to be weak monotonic on L just in case, for each [image] with [image] and each [image] with [image] we have that [image].
(b) M is said to be weak monotonic on [image] just in case M is weak monotonic on each [image].
(c) M is weak monotonic just in case M is weak monotonic on each [image].
So, if a weak-monotonic scientist conjectures index j after index i and the set of elements seen by the scientist when index j is conjectured is a subset of W i, then [image]. The collections of languages identified by the global and the class versions of weak-monotonic scientists are introduced in the next definition.
5.53 Definition
(a)
(b) [image].
It is easy to see that
Equality follows using the following fact. (See Exercise 5-21.)
We note that there is a similarity between weak-monotonicity and conservativeness. A conservative scientist can only change her hypothesis if the current hypothesis does not


Page 111
account for some data; a weak-monotonic scientist must keep generalizing until the current hypothesis fails to account for some data. A nontrivial proof shows that weak-monotonic scientists and conservative scientists identify the same collections of languages. (See Exercise 5-21.)
We now consider the interplay between the three generalization strategies defined above. It is easy to verify the following proposition.
5.54 Proposition
(a)
(b)
(c)
(d)
The next result shows that there are collections of languages that can be identified by monotonic scientists but cannot be identified by any weak-monotonic scientists.
5.55 Proposition
Before proving this proposition, we note the following corollary that follows from the above proposition and Proposition 5.54.
5.56 Corollary
(a)
(b)
Proof (Proposition 5.55): Let M0, M1, . . . be an enumeration of total computable scientists along the lines of Corollary 4.16. For each j and m, let [image] and [image]. For each j, let T j denote the text [image] and let
Note that S j is recursive. Now define the collection of languages:
We show that [image].


Page 112
We first exhibit a monotonic scientist that identifies [image]. Let G N be an index for N. Let [image] be an index for [image]. Let G j be an index for L j that can be effectively obtained from j. Let [image] denote an index for [image] that can be effectively obtained from j and m. Let [image]. Now let M be a scientist that, for each s
.
It is easy to verify that M is monotonic and identifies [image].
Next we show that no weak-monotonic scientist identifies [image] Suppose scientist Mj identifies [image] Consider the language L j. Clearly, [image] because otherwise [image] and Mj does not identify L j. Let [image], hence [image]. Suppose s is an extension of T j[m] such that [image] and [image] Such a s exists as [image] and Mj identifies [image] Thus we have [image], which violates the weak-monotonicity property for identification of [image] by Mj. Thus Mj fails to be weak monotonic.
The next proposition shows that there are collections of languages that can be identified by weak-monotonic scientists but not identified by any monotonic scientists.
5.57 Proposition [image] .
The above proposition (together with Proposition 5.54) implies the following corollary.
5.58 Corollary
(a)
(b) [image].
Proof (Proposition 5.57): This argument is based on a technique due to Lange and Zeugmann [119].
For each m and n, we define:


Page 113
We also define [image].
It is easy to verify that [image].
We next show that [image] Consider any scientist M that identifies [image] Let s be such that [image], for some [image] and WM( s ) = L1. (Note that there exists such a s , since M identifies L1.)
Let [image] be such that [image], for some n > m, and [image]. (Note that there exists such a s ' since M identifies [image].)
Let [image] be such that [image] and [image] (Note that there exists such a s '', since M' identifies [image].)
We finally claim that M fails to be monotonic while identifying [image]. To see this it is sufficient to observe that [image] but [image].
§5.5.3 Specialization Strategies
Generalization strategies improve upon their successive conjectures by emitting indexes for larger and larger languages. Alternatively, a scientist can begin with an index for a language larger than the target language and then "cut down" her hypotheses to converge to an index for the target language. Such strategies are referred to as specialization strategies; they may be viewed as models for top-down or general-to-specific searches in artificial systems of empirical inquiry (see for example, Shapiro's MIS [171] and Quinlan's FOIL [157]).
Three specialization strategies can be defined as duals to the three generalization strategies. We consider only the dual of weak-monotonic scientists. Duals of strong-monotonic scientists and monotonic scientists are considered in the exercises.
5.59 Definition (Kapur [103])
(a) M is dual-weak-monotonic on L just in case, for each [image] with [image] and each [image] with [image], we have [image].
(b) M is dual-weak-monotonic on [image] just in case M is dual-weak-monotonic on each [image].
(c) M is dual-weak-monotonic just in case M is dual-weak-monotonic on each [image].
(d) [image].


Page 114
(e)
Clearly, [image]. The next result shows the surprising fact that every identifiable collection of languages can also be identified by a dual-weak-monotonic scientist.
5.60 Proposition [image] .
Proof (After Kinber and Stephan [109]): Fix M. We assume, without loss of generality (by Proposition 5.29), that M identifies T if and only if T contains a locking sequence for M on content(T). By the s-m-n theorem, there is a recursive f such that, for all e and s ,
.
We inductively define M' so that, for each s , there is a [image] such that [image]. Define [image]. Given s and x, define
.
Claim: M' identifies each language identified by M. To see this, first suppose M identifies T and suppose that T[n] is a locking sequence for M on T. Once M' outputs f(M(T[n']), T[n'] for some n' > n, it never changes its mind. Thus M' converges on T. Suppose M' converges to f(M(T[n"]), T[n"]Then T[n"] must be a locking sequence for M on content(T). It follows that M' identifies T. Thus the claim is shown.
Claim: M' is dual-weak-monotonic. To see this, first suppose [image] and [image] This implies that there is a g such that [image], [image], and [image] It follows that either [image]. In both cases, the dual-weak-monotonic property of M' is not violated, hence, the claim and the theorem follow.


Page 115
§5.6 Strategies for Function Identification
We now turn our attention to strategies for function identification. As in the case of languages, we consider both the global and class versions where they are meaningful. Notation: Recall from Chapter 4 that f[n] denotes both the partial function [image] and the initial segment of length n of the canonical text for f. Also recall from Definition 4.18 that [image].
§5.6.1 Consistency
The next definition formalizes consistency in the context of function identification.
5.61 Definition (Barzdins * [13], Blum and Blum [18])
(a) M is consistent on f just in case for all n, [image].
(b) M is consistent on [image] just in case M is consistent on each [image].
(c) M is consistent just in case M is consistent on [image].
(d) [image].
(e) [image].
Just as in the language paradigm, consistency has the ring of rationality. However, similarly to before, implementing the strategy can entail a loss of inductive power.
5.62 Proposition [image] .
Proof: Clearly, [image].
We first show that [image].
Consider the collection of self-describing functions [image]. It is easy to show that [image]. Suppose by way of contradiction that a scientist M that is consistent (on [image]) identifies [image]. Then, by Kleene's recursion theorem (Theorem 2.3), there exists an index e such that, for all x,
It is clear that [image]. Also, since M is consistent, for each x > 0, either [image] or [image]. Hence, for each x > 0, [image] It follows that [image], a contradiction.


Page 116
We next show that [image].
Define:
.
We leave it to the reader to verify that [image] We argue that [image]. Suppose by way of contradiction that a scientist M that is consistent on [image] identifies [image]. Then by Kleene's recursion theorem (Theorem 2.3), there exists an index e such that, for all x,
Suppose j e is total. Then [image], and for all x > 0, [image]. Hence, [image], a contradiction. Therefore, j e is not total. Suppose x is the least number such that j e(x) is not defined. Then [image] and [image] Let [image] be such that [image] Again, by Kleene's recursion theorem, there exists an index e1 such that, for all x,
.
It is easy to verify that [image] However, since [image] M is not consistent on [image]. This is a contradiction. It follows that no such M can exist.
§5.6.2 Popperian
As discussed in the context of languages, scientific practice usually demands the testability of hypotheses, a constraint that was labeled "accountability" in Section 5.2.3. We


Page 117
now formulate a similar requirement for the paradigm of function learning.
5.63 Definition (Case and Ngo-Manguelle [34])
(a) M is Popperian on f just in case for all n, [image].
(b) M is Popperian on [image] just in case M is Popperian on each [image].
(c) M is Popperian just in case M is Popperian on [image].
(d) [image].
(e) [image].
An index for a total computable function is a testable hypothesis, since it is possible to test its accuracy against the data provided by a finite sequence. Such testability motivates the terminology "Popperian," since Popper (e.g, [153]) insisted on this aspect of scientific practice. Requiring the testability of hypotheses appears to be a useful requirement. However, like many other seemingly rational constraints, both versions of Popperian scientists pay a price for their rationality, as implied by the next result.
5.64 Proposition [image] .
Proof: Clearly, [image].
We first show that [image].
Consider again the collection of self-describing computable functions [image] Clearly, [image]. Suppose by way of contradiction that M is Popperian (on [image]) and identifies [image]. Then, by Kleene's recursion theorem (Theorem 2.3), there exists an e such that, for all x,
.
Since M is Popperian, j e is total and thus [image]. Also, for all x > 0, [image] Thus [image], a contradiction. Hence, [image].
Let [image] be as defined in the proof of Proposition 5.62 on page 116. Clearly, [image]. By Exercise 5-22 [image].
We describe a nice characterization of [Ex]Popperian First, recall from Definition 5.10 that [image] is said to be r.e. indexable exactly when there is an [image] such that [image]. We define the class
.


Page 118
The characterization of [Ex]Popperian says that the collections of functions that Popperian scientists can identify are precisely the collections of functions that are subsets of r.e. indexable collections of functions.
5.65 Proposition (Barzdins * and Freivalds [15], Case and Smith [35]) [image] .
Proof: Suppose [image]. Fix a Popperian scientist M that identifies each function in [image]. Let [image]. It is easy to see that [image] and that [image] is r.e. indexable.
Suppose [image] is an r.e. indexable class of total functions. Choose a [image] such that [image]. Let M be a scientist that, for each [image],
.
It is easy to verify that M is Popperian and that [image].
§5.6.3 Reliability
Reliable scientists were first studied by Minicozzi [132]. Reliability in the context of languages guarantees that if a scientist converges on a text for a language, then the scientist converges to an index for that language. The following formalizes reliability in the context of functions.
5.66 Definition (Minicozzi [132])
(a) M is reliable on f just in case [image].
(b) M is reliable on [image] just in case M is reliable on each [image].
(c) M is recursive-reliable just in case M is reliable on [image].
(d) [image].
The next proposition shows that recursire-reliable scientists pay a price for this useful property.
5.67 Proposition [image] .
Proof: Clearly, [image]. Below we argue that [image] Our argument uses the following claim.


Page 119
5.68 Claim Suppose M is recursive-reliable. Then for all [image], there exists a [image] such that [image] and [image]. Moreover, there is a recursive function t such that, given s , [image] as above.
Proof (Claim 5.68): If such a [image] does not exist then M converges to M( s ) on all functions consistent with s . However, M( s ) can be an index for at most one function consistent with s . This contradicts the fact that M is recursive-reliable. The moreover clause is obvious.
Recall that [image]. Fix a recursive-reliable scientist M. We show that M fails to identify [image]. By Kleene's recursion theorem (Theorem 2.3), there exists an e such that j e may be defined as follows: let s 0 be such that [image], and [image]. Clearly, [image]. Also, [image]. Thus, [image].
§5.6.4 Decisiveness
In the course of identification a scientist may conjecture a hypothesis, abandon it after seeing more data, and revert to the abandoned hypothesis once again. A sensible strategy would be to consider only those scientists that never go back to an abandoned conjecture.
5.69 Definition
(a) M is decisive on f just in case, for all l, m, [image] with l < m < n and [image], we have [image].
(b) M is decisive on [image] just in case M is decisive on each [image].
(c) M is decisive just in case M is decisive on [image].
(d)
(e)
We shall now see that scientists can adopt a decisive strategy without loss of inductive competence.
5.70 Proposition (Schäfer-Richter [167]) [Ex]decisive = [Ex]class-decisive = Ex.
Proof: Clearly, [image]. We show that


Page 120
Suppose scientist M is given. We describe a scientist M' such that [image] and M' is decisive. Let [image] be a recursive function that satisfies the following equation.
For each M and each [image], define
Now let M' be a scientist such that, for all [image], M'( s ) = h(M( s [m]), s [m]), where m = convpoint(M, s ). We claim that [image] and M' is decisive.
Note that if [image], then M'(f) converges to h(i, f[m]), where i = M(f) and m is the convergence point for M on f. Moreover, j h(i,f[m]) = j i. Thus [image].
To see that M' is decisive, suppose f and l < m < n are given such that [image]. Let n' = convpoint(M,f[n]) and l' = convpoint(M,f[l]). Clearly, [image] and [image]. Now M'(f[n]) = h(M(f[n']), f[n']) and thus [image] (by construction of h). However, M'(f[l]) = h(M(f[l']), f[l']). Thus, [image], since, in the construction of h(M(f[l']), f[l']), either a mind change would be observed before input m or s M'(f[l']) is convergently different from f[m]. Therefore, M' is decisive.
§5.7 Bibliographic Notes
The question of consistency has been independently considered by Barzdins * [13] and by Blum and Blum [18] in the context of functions. The reader can find additional material on consistent strategies in Wiehagen and Liepe [202], Jantke and Beick [100], Zeugmann [206], and Fulk [70]. Consistency in the context of languages has been addressed by Angluin [6]. Wiehagen and Zeugmann [203] present an interesting perspective on the power of inconsistent strategies in the context of more practical domains.
The notion of set-driven scientists was introduced by Wexler and Culicover [194]. Schäfer-Richter [167], and later Fulk [69], independently established that set-drivenness is a restriction on computable scientists. The notion of rearrangement-independence was introduced as a weakening of set-drivenness by Schäfer-Richter [167] and by Fulk [69].


Page 121
The question of order-independence was first considered by Blum and Blum [18]. They showed that order-independence is not a restriction on TxtEx. The proof presented in this chapter is due to Fulk [69, 71]. In the proof he showed that not only can a scientist be converted into an order-independent scientist without any loss in learning ability, but the resulting order-independent scientist can also be made to satisfy several additional properties such as rearrangement-independence. The reader is referred to Lange and Zeugmann [121] for a treatment of order-independence and set-drivenness in the context of uniformly decidable families of recursive languages. A related result is also due to Jain [84].
The notion of prudence was introduced by Wexler and Culicover. Fulk [69, 71] showed that prudence is not a restriction on identification. The reader is referred to Kurtz and Royer [115] and to Jain and Sharma [91] for additional results on prudence.
The question of identification by reliable scientists was considered by Minicozzi [132]. The reader is directed to papers by Case, Jain, and Ngo-Manguelle [28] and by Kinber and Zeugmann [110, 111] for additional material on reliability.1
Angluin [6] began the investigation of conservative scientists. The study of monotonicity was initiated by Jantke [99] who also defined the notion of strong-monotonic strategies. Wiehagen [200] introduced monotonic strategies and Lange and Zeugmann [119] defined weak-monotonic strategies. The duals of these strategies were proposed by Kapur [103]. Lange, Kapur, and Zeugmann have obtained numerous results on the relative learning abilities of these strategies in the context of identifying uniformly decidable families of recursive languages, e.g., see [122], [209], and [120]. A survey of this work can be found in [208]. The study of monotonicity for r.e. languages is due to Jain and Sharma [88, 96], where the distinction between global and class versions of a strategy is formalized. Kinber and Stephan [109] also independently investigated monotonicity in the context of r.e. languages.
1In our discussion of strategies, we have required that the underlying realities a scientists investigates are to be modeled by recursively enumerable languages or computable functions. In the case of reliability, it is mathematically interesting to modify this requirement and consider the behavior of scientists on non-r.e. "languages" and non-recursive functions. For example, in the language case one can require, not unreasonably, that a reliable scientist should fail to converge on any text that has a non-r.e. set as its content. In the language case, this strengthened reliability requirement turns out to be equivalent to ordinary reliability. In the function case, matters are quite different and rather involved. For this reason, we have called the strategy discussed in Definition 5.66 as recursive-reliable to distinguish it from the notion of reliable scientists in the literature reserved for this stricter notion of reliability. Case, Jain, and Ngo-Manguelle [28] discuss these subtle issues. Fortunately, for other strategies discussed in this chapter, both for languages and functions, the analogous stricter version of global strategies do not place any additional constraint on identifiability.


Page 122
§5.8 Exercises
5-1 No natural language, it appears, includes a longest sentence. If this universal feature of natural language corresponds to an innate constraint on children's linguistic hypotheses, then children would be barred from conjecturing a grammar for a finite language. Such a constraint on potential conjectures amounts to a strategy. To formulate it, let us call M nontrivial on a language L just in case for all s such that [image], W j ( s )is infinite. M is nontrivial on [image] just in case M is nontrivial on each [image]. M is nontrivial just in case M is nontrivial on each [image]. Define:
Clearly, no nontrivial scientist can identify any finite language. In contrast, their behavior on collections of infinite languages is less evident. To explore the matter, show the following.
(a) There is [image] such that (i) every [image] is infinite, and (ii) [image].
(b)
(c)
5-2 Show that [image].
5-3 M is called nonexcessive just in case for all [image], [image]. [TxtEx]nonexcessive denotes [image]. Prove: For all [image], if [image], then [image] if and only if [image].
5-4 (J. Canny) M is said to be weakly nontrivial just in case for all infinite [image], WM(T[n]) is infinite for all [image] and all texts T for L. Nontriviality implies weak nontriviality. [TxtEx]weak-nontriv denotes [image] [image]. Show that for some collection [image] of infinite languages, [image].


Page 123
5-5 M is said to be conditionally consistent just in case for all [image], if [image], then [image]. [TxtEx]cond-consistent denotes [image] [image].
Refute the following variant of Proposition 5.6: If conditionally consistent M identifies [image], then [image].
5-6 Show that [image].
5-7 [image] is called total just in case for all [image] there is [image] such that [image] Note that a total language need not represent a function (since it need not be single valued). M is called total-minded just in case for all [image], if [image] then WM( s ) is total. [TxtEx]tot-minded denotes [image] [image]. Prove: There is [image] such that (a) every [image] is total, and (b) [image]. Hint: Use Rogers [158], Theorem 5-XVI: the single-valuedness theorem.
5-8 Prove that if [image] contains only infinite languages, then [image] TxtEx if and only if [image].
5-9 Give a proof of Lemma 5.33.
5-10 Show the following:
(a) [image].
(b) [image].
5-11 M is said to be gradualist just in case for all [image], [image] is finite. [TxtEx]gradualist denotes [image] [image]. Show that [TxtEx]gradualist = TxtEx.
5-12 M is called cautious just in case for all s , [image], [image] is not a proper subset of WM( s ). Note that cautious scientists behave as if they never overgeneralize. Compare this strategy with conservative scientists that do not over generalize on languages they identify, but may over generalize on languages they do not identify. [TxtEx]cautious denotes [image]. Show that [image].


Page 124
5-13 Show that [image].
5-14 A scientist that converges on every text may be termed ''confident." M is confident on L just in case for all texts T for L, [image]. M is confident on [image] just in case M is confident on each [image]. M is confident just in case M is confident on [image]. .
Show the following:
(a) Let a confident scientist M be given. Then for every [image], there is [image] such that (i) [image], and (ii) for all [image] such that [image], [image].
(b) [image].
5-15 Show the following:
(a)
(b)
5-16 (Kapur [103]) Define the dual of a strong-monotonic scientist as follows.
5.71 Definition(a) M is dual-strong-monotonic on L just in case, for all [image] with [image] and all s with [image], we have [image].
(b) M is dual-strong-monotonic on [image] just in case M is dual-strong-monotonic on each [image].
(c) M is dual-strong-monotonic just in case it is dual-strong-monotonic on each [image].
(d)
(e)
Show that [TxtEx]class-dual-strong-monotonic = [TxtEx]dual-strong-monotonic.
5-17 (Kapur [103]) Define the dual of a monotonic scientist as follows.


Page 125
5.72 Definition(a) M is dual-monotonic on L just in case, for each [image] with [image] and each s with [image] we have that [image].
(b) M is dual-monotonic on [image] just in case M is dual-monotonic on each [image].
(c) M is dual-monotonic just in case M is dual-monotonic on each [image].
(d)
(e)
What is the relationship between [TxtEx]dual-monotonic and [TxtEx]class-dual-monotonic? What is the relationship between [TxtEx]dual-monotonic and [TxtEx]dual-strong-monotonic?
5-18 Show that [TxtEx]class-dual-weak-monotonic = [TxtEx]dual-weak-monotonic.
5-19 In the discussion following Definition 5.50 we mentioned that the the global version of monotonicity is equivalent to strong monotonicity. This exercise establishes this fact.
(a) Define [TxtEx]global-monotonic, a global version on monotonicity.2
(b) Prove that [TxtEx]global-monotonic = [TxtEx]strong-monotonic by showing that every machine which is monotonic on N is also strong monotonic.
5-20
(a) Show that [image].
(b) Show that [image].
(c) Use Proposition 5.60 and parts (a) and (b) to deduce: .
5-21 Show that [image]. Thus conclude that the classes [TxtEx]class-weak-monotonic, [TxtEx]weak-monotonic, [TxtEx]conservative, and [TxtEx]class-conservative are all equal.
2Unlike for other criteria based on strategies, for monotonic identification we used [TxtEx]monotonic to denote class monotonicity instead of global monotonicity; hence this special notation for global monotonicity.


Page 126
5-22 Let [image] be as defined in the proof of Proposition 5.62 on page 116. Show that [image].
5-23 Show that [image].


Page 127
6
Criteria of Learning
In Chapter 5 we considered several conceptions of "scientist." In the present chapter we examine alternative criteria of scientific success.
The Ex and TxtEx paradigms require the learner's conjectures to converge to some one index for the function or language being learned. This models both the accuracy and stability of successful learning. However, not all theorists take such a requirement to be necessary for learning, although most accept its sufficiency. It is noted, for example, that physicists sometimes employ explanations that are predictively inaccurate for certain experiments. In particular, Newtonian mechanics was used for explanation long after it was recognized that the theory failed to accurately predict dispersion in the X-ray region. Similarly, in the developmental context it might be doubted that children stabilize to a grammar that exactly models the parents' language — or even stabilize to a single grammar at all. Accordingly, more liberal conceptions of accuracy and stability have been proposed for learning, enforcing weaker requirements in these respects. The present chapter reviews some elementary success criteria of this nature. More sophisticated criteria are discussed in Chapter 7. In each case we conceive of the new criterion as giving rise to a novel paradigm of inductive inference. In what follows, extensions of Ex are considered first, followed by extensions of TxtEx.
§6.1 Criteria for Function DIidentification
§6.1.1 Anomalous Ex-identification
Our initial focus will be on relaxing the strict accuracy required for success within the paradigm Ex. One means of weakening this requirement is to define a proximity measure between functions, and then allow learners to converge to indexes that are for functions "sufficiently close" to the target. A simple proximity measure involves counting the number of points on which two functions give different results. For finite n we thus consider two functions to be "n-close" if they are equal on all but at most n arguments. (They are considered unequal on an argument if only one of them is defined there.) Two functions are called "finitely" close if they are n-close for some n. These ideas are formalized in the following definition, which is recalled from Chapter 2.
6.1 Definition Let [image], [image], and [image].


Page 128
(a) We say that x =n f (read: x is an n-variant of f) just in case [image].
(b) We say that x =* f just in case [image] is finite; we refer to x as a finite variant of f.
In the definition it is helpful to think of an index i for x as a "possibly anomalous explanation" for f, that is, an explanation whose prediction may include a finite number of anomalies. In this case, i is called an n-error (or *-error) index for f. We distinguish two kinds of errors that i may embody in explaining f. If x (x) is undefined, then i commits an error of omission at x. If [image], then i commits an error of commission at x.
Definition 6.1 suggests the following criterion of learning, in which it suffices to converge to an index for a function that is proximate to the target. (The * case of the new paradigm was introduced by Blum and Blum [18], the other cases by Case and Smith [35].)
6.2 Definition (Blum and Blum [18], Case and Smith [35]) Let [image].
(a) M Exa-identifies f (written: ) just in case [image] and j M(f) =a f.
(b) M Exa-identifies [image] just in case [image].
(c)
Ex0, of course, is the same as Ex. Note that in Exa, for [image], the parameter 'a' is an upper bound on the number of errors allowed in the final hypothesis, not an exact number of required errors. Indeed, were a interpreted in the latter sense, Exa would collapse to the original paradigm Ex (see Exercise 6-2).
The success criterion for Ex* can be formulated this way: M Ex*-identifies [image] just in case for every [image] there is [image] such that M Exm-identifies f. Thus, M's errors must be bounded on each function in [image]. The bound itself, however, might grow without limit across different members of [image].
A simple modification of the proof of Proposition 4.15 yields:
6.3 Proposition For every collection [image] of functions, and any [image], [image] is Exa identifiable just in case some total scientist Exa-identifies [image].
It also follows that there is a recursively enumerable sequence of total computable scientists M0,M1, . . ., such that for all [image], there is an i such that [image].


Page 129
Analogous results hold for each of the paradigms treated in this chapter (see Exercise 6-1). As a consequence, to show the unlearnability of a certain collection of functions we shall often reason only about the behavior of total scientists, leaving this step of the argument implicit.
It is clear from Definition 6.2 that, for each [image], [image]. To show that the containment is proper, we introduce a variant of the "self-describing" functions [image] introduced in Definition 4.24.
6.4 Definition Let [image]. is the set of all [image] such that f(0) is an index for an a-variant of f, that is, j f(0) = a f.
The symbol [image] is read as "almost self-describing." It is clear that [image], and that [image] just in case f(0) is a *-error index for f. By Lemma 2.4, for all [image], [image]. The following result shows that [image] is an example of an Exm+1-identifiable collection of functions that no scientist can Exm-identify.
6.5 Proposition (Case and Smith [35]) For each [image], [image].
Proof: Fix m. Clearly, [image]. To show the proposition, it thus suffices to prove that [image].
Suppose by way of contradiction that scientist M Exm-identifies [image]. Without loss of generality we may assume that M is total (since an analog of Proposition 4.15 holds for Exm-identification). We now show the existence of a total computable function [image] such that M fails to Exm-identify f. The proof of this employs a technique that is frequently used in sequel, hence we discuss the idea behind the proof in some detail.
We use Kleene's recursion theorem (Theorem 2.3) to construct a program with index e such that the (partial) function j e is defined in stages. At the start of the construction, we initialize j e (0) = e. The construction is arranged so that if it ever reaches stage s, then at the beginning of that stage the domain of j e will be {0, . . ., x s - 1}, a finite initial segment of N. In stage s, the construction dovetails between the following two processes until, if ever, the search in b succeeds.
a. Hold back defining j e on the m + 1 many arguments x s, . . ., x s + m and, for x = x s + m + 1, x s + m + 2, . . . in turn, extend j e to take the value 0.
b. Search for a suitable extension of j e as defined thus far that forces the scientist M to change its mind.


Page 130
All of the extensions considered in b will be in [image]. If the search for a suitable extension succeeds in infinitely many stages, we then takef to be j e, which will turn out to belong to [image]. But M on such an f fails to converge. On the other hand, if at some stage, no suitable extension can be found, then M converges to the same program, p, for each of the extensions considered in b. But in this case we arrange that, among these extensions, there is one that differs from j p on each of the m + 1-many arguments x s, . . ., x s + m; hence M fails to converge to an m-error index for that particular extension.
Here is the formal construction.
Let j e(0) = e. Let x s denote the least x such that j e(x) has not been defined before stage s. Thus, x0 = 1. Go to stage 0.
Begin ( Stage s )
For each [image], define the function f y as follows.
Dovetail between a and b below until, if ever, the search in b succeeds.
a. For i = l to [image], set j e(x s + m + i) = 0.
b. Search for a [image] and an [image] such that [image].
If and when the search in b succeeds, let y and n be as discovered in the search and set j e(x) = f y(x) for each x < n for which j e, has yet to be defined. ( Hence, j e [n] = f y [n]. )
Go on to stage s + 1.
End ( Stage s )
Consider the following two cases.
Case 1: Infinitely many stages are executed. In this case, let f = j e. It is clear by construction that [image]. But scientist M makes infinitely many mind changes on this f, hence M fails to Exm-identify f.
Case 2: Some stage s starts but never terminates. For each [image], let f y be as defined in stage s and let p = M( j e[x s]). By construction, for each y, [image]. Also, since stage s never terminates, we have that, for each [image], [image]. But since [image], it follows that there is at least one


Page 131
such that f y' differs from j p on each of x s, . . ., x s + m. Take f = f y'. Then f is an element of [image] that M fails to Exm-identify.
From the above two cases it follows that [image].
The following corollary says that if the finite number of errors allowed in the final hypothesis is not bounded, then more collections of functions can be learned than otherwise.
6.6 Corollary (Case and Smith [35]) [image] .
Proof: It is clear that [image]. Suppose by way of contradiction that [image]. Then there exists an m such that [image], hence, any subset of [image] is also in Exm. But [image] is a subset of [image], which is not in Exm. This is a contradiction.
It is immediate from Proposition 6.5 that allowing more errors increases learning power. We note this fact in the form of an "anomaly hierarchy," one of many such hierarchies to be encountered in this and later chapters.
6.7 Corollary [image] .
§6.1.2 Behaviorally Correct Function Identification
Turning from accuracy to stability, we wish now to relax the Ex requirement that scientists converge to a single index for the target function. The simplest alternative is to require only that a scientist eventually ceases to produce incorrect indexes, leaving her the liberty of forever changing the particular index used to name the target function. This criterion was first introduced by Barzdins * [14] and later considered by Case and Smith [35] (see also Feldman[58]). It is formalized as follows.
6.8 Definition (Barzdins* [14], Case and Smith [35])
(a) M Bc-identifies f (written: ) just in case for all but finitely many n, j M(f[n]) = f.
(b) [image].
Bc is read as "behaviorally correct." Thus, scientist M Bc-identifies f just in case M, fed the graph of f, produces an infinite sequence of hypotheses, p0, p1, p2, . . ., such that for all but finitely many n, pn is an index for f. It follows immediately that [image]. We leave the proof of the following fact to Exercise 6-4.


Page 132
6.9 Proposition (J. Steel cited in Case and Smith [35]) [image] .
There remains the obvious question of whether Bc is strictly weaker than Ex*. The following proposition provides an affirmative answer.
6.10 Proposition (Case and Smith [35]) [image] .
Proof: Let [image]. Thus [image] is the collection of computable functions f such that, for all but finitely many n, f(n) is an index for f. By Lemma 2.4, [image] is nonempty.
Clearly, [image]. Fix an arbitrary scientist M. Below we exhibit a function [image]. It will thus follow that [image]. Without loss of generality, we assume that M is total.
By the operator recursion theorem (Theorem 2.6), there is a 1-1, recursive function p such that the behavior of programs with indexes p(0), p(1), p(2), . . . are as described in stages below. We arrange things so that one of the j (i)'s witnesses the failure of M to [image].
In the following construction [image] denotes the part of j p(n) defined before stage s. Let x s denote the least x such that j p(0) has not been defined before stage s. For each n, set [image]. If the construction reaches stage s, then the domain of [image] will be { 0, . . ., x s - 1 }, a finite initial segment of N, and [image] and [image] will be completely undefined. Go to stage 0.
Begin ( Stage s )
Let q s = M( j p(0)[x s]) and, for each x << x s, set j p(2s+1)(x) = j p(0)(x) and j p(2s+2)(x) = j p(0)(x). ( Hence, j p(0)[x s] = j p(2s+1)[x s] = j p(2s+2)[x s]. )
For y = x s to [image] do
Set j p(2s+1)(y) = p(2s + 1) and j p(2s+2)(y) = p(2s + 2).
Condition 1. .
Then, for each [image], set j p(0)(x) = j p(2s+1)(x) and henceforth make j p(2s+1) follow j p(0) so that p(2s + 1) is an index for j p(0). Go on to stage s + l.
Condition 2. Condition 1 fails, but [image].
Then, for each [image], set j p(0)(x) = j p(2s+2)(x) and, henceforth, make j p(2s+2) follow j p(0) so that p(2s + 2) is an index for j p(0). Go on to stage s + 1. ( Note that if neither condition succeeds, then the For loop continues. )


Page 133
Endfor
End ( Stage s )
Consider the following two cases.
Case 1: All stages terminate. In this case, let f = j p(0). Clearly, the range of f contains indexes only for f. Hence, [image]. However, M on f makes infinitely many mind changes; hence, [image].
Case 2: Some stage s starts but fails to terminate. In this case let fl = j p(2s+1) and f2 = j p(2s+2). Clearly, both fl and f2 are in [image] and, for infinitely many x, [image]. However, M(f1) = M(f2) = M( j p(0)[x s]). Thus M fails to Ex*-identify at least one of f1 and f2.
From the above cases it follows that [image].
6.11 Corollary [image] .
§6.1.3 Behaviorally Correct Function Identification with Anomalies
The previous two subsections investigated two ways of liberalizing the Ex criterion of successful learning. These two means are combined in the following definition.
6.12 Definition (Case and Smith [35]) Let [image].
(a) M Bca-identifies f (written: ) just in case for all but finitely many n, j M(f[n]) = a f.
(b) [image].
Thus, a scientist Bca-identifies function f just in case, being fed the graph of f, she produces an infinite sequence of hypotheses, p0, p1, p2, . . . such that for all but finitely many n, p n is an index for an a-variant of f. It is easy to see that [image]. The next proposition shows that these containments are strict.
6.13 Proposition (Case and Smith [35])
(a) For each [image],
(b)


Page 134
6.14 Corollary [image] .
Proof (of Proposition 6.13): Proof for part (a). Fix an [image]. Define
.
Clearly, [image]. We show that [image].
Fix an arbitrary scientist M. We argue that M fails to Bcm-identify some [image]. Without loss of generality, assume that M is a total scientist.
By implicit use of the operator recursion theorem (Theorem 2.6), we describe a repetition-free r.e. sequence of programs p(0), p(1), p(2), . . . such that, for some i, [image]. Here is an informal effective construction of the j p(i)'s.
For each [image], [image] denotes the part of j p(i) defined before stage s. Let x s denote the least x such that j p(0)(x s) has not been defined before stage s. If the construction reaches stage s, then the domain of [image] will be { 0, . . ., x s - 1 }, a finite initial segment of N, and [image] will be completely undefined. For each [image], set [image]. Go to stage 0.
Begin ( Stage s )
For each x << x s, set j p(s)(x) = j p(0)(x).
Dovetail between a and b until, if ever, the search in b succeeds.
a. For i = 0 to [image], set j p(s)(x s + i) = p(s).
b. Search for n, y0, y1, . . . ,ym such that [image] and, for each [image], [image], where [image].
If and when the search in b succeeds, let y0, y1, . . ., y m be the m+1 points on which M's conjecture on evidential state [image] converges.
( We now force j p(0) to differ from M's conjecture on these m + 1 points. )
Let x be the maximum element on which j p(s) has been thus far defined and let x' = max({ x, y m }).
For each [image], set j p(0)(y) = p(0), if [image], and set j p(0)(y) = p(s), otherwise.
For each [image], set j p(0)(y) = p(s).
For each [image], set j p(s)(y) = p(s).
( Note that at this point in the definitions of j p(0) and j p(s), these two functions are (m + 1)-variants. )


Page 135
Henceforth, make j p(s) behave exactly like j p(0) on arguments greater than x'.
( This ensures that p(s) is an (m + 1)-error index for j p(0). )
Go on to stage s + 1.
End ( Stage s )
Consider the following two cases.
Case 1: Infinitely many stages are executed. In this case, let f = j p(0). It is clear that [image] and everything in its range is either an index for f or an (m + 1)-error index for f. Hence, [image]. But, for each s, there is a s such that [image] and M's conjecture on s makes at least m + 1 mistakes in computing f. Hence, [image].
Case 2: Some stage s starts but never terminates. In this case, [image] and, for all but finitely many x, t p(s)(x) = p(s). Let f = t p(s). Clearly, [image]. Also, for each s such that [image], M's conjecture on s computes only a finite function because the search for y0, . . ., ym in step b fails. Hence, [image].
The proof of part (b) can be worked out on lines similar to the proof of Corollary 6.6.
Bc* is the weakest criterion of success considered so far in our discussion. Although further liberalization could be envisioned, the following proposition shows that no further weakening is necessary.
6.15 Proposition (L. Harrington cited in Case and Smith [35]) [image] .
Proof: Let MH be a scientist which, on input s , outputs a program with index e s , where, for each x,
Fix an arbitrary [image]. We show that MH Bc*-identifies f. Let p0 be the least index for f. Choose n0 so large that (a) [image] and (b) for each [image], [image]. Claim: For each [image], [image]. To see this, take [image] and consider an [image]. By our choices of n0, n, x n, and x it follows that, on input x, p0 is the p found in clause (i) of the definition of [image], and hence,
Therefore, the claim follows. Thus, MH Bc* identifies f.


Page 136
§6.1.4 Vacillatory Function Identification
The Bc criterion might appear overly liberal in allowing scientists to announce ever larger indexes for the target function. A more modest relaxation of Ex countenances endless shifts in hypotheses, but only within a fixed, finite set of alternatives. Thus, for scientist M to identify function f in this sense, there must be a finite set D f of indexes with two properties: first, all but finitely many of M's conjectures about f must be drawn from D f; second, every index in D f must be for f. It is easy to see that this new identification criterion is implied by Ex-identification (taking D f to be a singleton set) and implies Bc-identification. In order to facilitate comparison with earlier paradigms, we also incorporate anomalies into this success criterion. The formal definition is as follows.
6.16 Definition (Barzdins * and Podnieks [16], Case and Smith [35]) Let [image].
(a) M Fexa-identifies f (written: ) just in case there exists a nonempty finite set D f of a-error indexes for f such that for all but finitely many n, [image].
(b) [image].
So, for an M to Fexa-identify f, there must be some finite set D f of indexes to which M's conjectures must ultimately be limited — and D f must consist only of indexes for a-variants of f. Clearly, [image] for all [image]. Surprisingly, the inclusion is nowhere proper.
6.17 Proposition (Barzdins* and Podnieks [16], Case and Smith [35]) For each [image], Exa = Fexa.
Proof: Let [image]. We argue Exn = Fexn. The * case is discussed later.
As previously noted, [image], hence it suffices to show that [image]. We do this by showing how to effectively transform any scientist M into a corresponding scientist M' such that [image].
We employ an internal simulation argument that uses a cancellation technique. M' behaves as follows.
On input s , M' simulates M on s to find all the distinct indexes that M outputs on the initial sequences of s . Let these indexes be p0, pl, . . ., p k. M' then cancels any index p i, [image], from this list that are found to be convergently different from s at more than n arguments in less than or equal to [image] steps. More precisely, M' cancels any


Page 137
index p i for which [image]. (Recall that [image] is the finite function with graph content( s ).) Clearly, each of the uncanceled indexes makes only up to n errors of commission. For each uncanceled p i, let E pi denote the set of these [image] points for which it can be detected in [image] steps that p i makes an error of commission. More precisely, [image].
Now, for each uncanceled p i, let q i be an index of a program that behaves exactly like the program with index p i but is patched to agree with s on arguments in E pi. To be precise, q i is defined as follows:
Finally, let p be an index of a program formed from each of these q i's (derived from the uncanceled p i's) whose behavior is described as follows. The program with index p on any input y simulates each of the programs with indexes q i's on input y and outputs the same value as the (lexicographically least) q i, which converges first. M' on input s outputs p.
We now argue that [image]. Let [image]. Then any index q output infinitely often by M on f is such that s q =n f. Choose m0 to be so large that the following hold:
1. If program q is ever output by M on f, then q has been output at least once by M on f[m0], that is, [image].
2. If, for some [image], we have [image], then q is cancelled by M' after it has seen f[m0].
3. For each [image] that is never cancelled, we have that q's at most n convergent anomalies (if any) are discovered in [image] steps, and these anomalies are all less than m0.
Clearly, such an m0 exists. Also, after M' has seen f[m0], M' performs no new cancelations. Hence, in the limit M' on f outputs an index p that simulates a collection of indexes q i, none of which makes an error of commission and at least one of which makes no more than n errors of omission. Hence, j p =n f.
A proof of the a = * case can be worked out by modifying the above argument. The modification is based on the following observation. For the a = * case, the main problem arises in determining when a program has made enough convergent errors (so that it can be cancelled). For this, the machine M', upon seeing f[m], cancels a program, p, just in case it can be determined in [image] steps that p makes more convergent errors on inputs


Page 138
than the number of times p has been output by M on initial segments of f[m]. We leave the details of the proof to the reader.
§6.2 Criteria of Language Identification
Here we consider generalizations of the TxtEx criterion of language learning that parallel the generalizations of Ex in the previous section. We begin by allowing a finite number of errors into the scientist's final hypothesis.
§6.2.1 Anomalous TxtEx-identification
Terminology: Recall from Chapter 2 that L1 =n L2 means that [image] and such L1 and L2 arc called n-variants. Also recall that L1 =* L2 means that [image] is finite, and such L1 and L2 are called finite-variants. For each [image] and each L1 and L2 with L1 =a L2, we refer to an index i for L1 as an a-error index for L2. If [image], then we refer to x as an error of commission with respect to i and L. Similarly, [image] is an error of omission.
We now liberalize TxtEx to allow for a finite number of such errors.
6.18 Definition (Osherson and Weinstein [143], Case and Lynes [33]) Let
(a) M TxtExa-identifies L just in case for each text T for L, [image] and WM(T) = a L.
(b) M TxtExa-identifies [image] just in case M TxtExa-identifies each
(c) [image].
The definition implies that [image]. To show that the hierarchy is in fact strict we rely on a technique that will repeatedly appear in the sequel. It consists of translating results about function identification to the language setting. In the present case Proposition 6.5 and Corollary 6.6 are used to prove the following.
6.19 Proposition (Case and Lynes [33])
(a)
(b)


Page 139
Proof: For each [image], let L f denote the single-valued total language: . For each [image], let [image] denote the collection of single-valued total languages [image].
Let p1 be a recursive function that translates an index for a (partial) recursive function y into an index for the corresponding single-valued language L y . Formally, for all i, [image],
Similarly, let p2 be a recursive function that translates an index for a language L into an index for a partial recursive function represented by L. Formally, for all i, [image],
In the first condition of the above definition of j p2(i)(x), we assume that the z used is the first appropriate one produced by some uniform enumeration of W i.
Let [image] and let [image]. It is easy to verify that if i is an index for an a-variant of f such that i does not make any convergent errors (with respect to f), then pl (i) is an index for an a-variant of the single-valued total language L f. Similarly, if j is an index for an a-variant for the single-valued total language L, then p2(j) is an index for an a-variant of the recursive function represented by L.
Choose an [image]. (By Proposition 6.5, such an S exists.) We argue that [image].
Claim: . Proof: Let M be a scientist that searches a text for an element of the form [image] and keeps on emitting p1(z'), where z' is a program obtained by patching the convergent errors of z with respect to the function represented by the input language. Clearly, M TxtExm+1-identified [image]. Hence, the claim follows.
Claim: . Proof: Suppose by way of contradiction that a scientist M TxtExm-identifies [image]. Let [image] be such that t((x, y)) = <x, y> and t(#) = #. Extend t to [image] by taking t( s ) to be the result of applying t to each element of s . Now, let M' be a scientist such that, for each segment s , M'( s ) = p2(M(t( s ))). Since M TxtExm-identifies [image], it follows that M' must Exm-identify S, a contradiction. Hence, the claim and part (a) follows.
A similar proof works for part (b) using ASD* of Corollary 6.6.
6.20 Corollary [image] .


Page 140
§6.2.2 Behaviorally Correct Language Identification
The next definition liberalizes the stability requirement for TxtEx just as we did for Ex.
6.21 Definition (Osherson and Weinstein [143], Case and Lynes [33]) Let [image].
(a) M TxtBca-identifies L (written: ) just in case, for all texts T for L, for all but finitely many n, WM(T[n]) =a L.
(b) [image].
(c) TxtBc0 is abbreviated to TxtBc.
Thus a scientist M TxtBca-identifies language L just in case M, fed any text for L, produces an infinite sequence of hypotheses, all but finitely many of which are for a-variants of L. Successive conjectures need not be identical, nor even for the same language; and different texts may lead to different sequences.
The definition gives rise to a strict hierarchy, as described in the following corollary. Its proof follows a modification of the proof of Proposition 6.13 and is left for the reader. A different proof for this can be obtained using Proposition 6.24 below.
6.22 Corollary [image] .
In the case of functions, Propositions 6.9 and 6.10 reveal that Bc properly contains Ex*. Is the situation similar when we pass to TxtBc and TxtEx*? The following proposition shows that the latter paradigms are in fact incomparable.
6.23 Proposition(a) [image].
(b) [image].
Proof: Part (a) is an immediate consequence of Proposition 6.10. Part (b) is taken up in Exercise 6-9.
The above proposition shows that the instability allowed in TxtBc fails to compensate for the finite, but unbounded, number of errors allowed in TxtEx*. A subtler picture emerges when we consider bounded numbers of errors, as embodied in the criteria TxtExm.


Page 141
6.24 Proposition (Case and Lynes [33])
(a) [image].
(b) For each [image], [image].
Proof: We prove part (b). A proof of part (a) can be worked out by employing an analog of the locking sequence lemma (Theorem 3.22) for TxtBca-identification (see Exercise 6-9).
Suppose scientist [image]. We construct a scientist [image].
By the s-m-n theorem (Theorem 2.1), for each s , there is an index p s such that
,
where in the second part if [image] has fewer than m elements, we just take [image]. For each s , we take M'( s ) = p s .
Let T be a text for [image] and let p be the index to which M converges on T. Hence, W p =2m L. Let n0 be such that, for all [image],
(a) M(T[n] = p,
(b) [image] and [image], and
(c) [image].
Clearly, such an n0 exists. Note that, for each n > n0, M' patches all the errors of omission of M.
Now fix an [image]. Let M(T[n]) = p. Consider the following two cases:
Case 1: . That is, the number of mistakes of commission in [image]. Then, p[n] removes m of these mistakes of commission, [image] errors.
Case 2: card(W p - L) = m' and m' < m. That is, the number m' of mistakes of commission in p is < m. Then, p T[n] removes all these errors of commission, but potentially creates up to m - m' new errors of omission. However, this number, m - m', is still [image].
In both cases, [image] errors, hence M' TxtBcm-identifies [image].
§6.2.3 Vacillatory Language Identification
Recall the vacillatory criterion of success for functions introduced in Section 6.1.4. To be successful in the vacillatory sense, the learner's conjectures must eventually remain


Page 142
within some fixed, finite set of indexes — where each index is for a function sufficiently close to the target. We adapt this notion to the case of languages.
6.25 Definition (Case [25], Osherson and Weinstein [143]) Let [image] and [image].
(a) We say that M on T finitely converges to a finite set D just in case, for all but finitely many n, [image].
(b) [image] (written: ) just in case for all texts T for L there is a finite, nonempty set D of cardinality at most b such that M finitely converges to D and, for each [image], W i = a L.
(c) [image].
Thus, [image] just in case for every text T for L there is a nonempty, finite set D T of no more than b indexes for a-variants of L such that all but finitely many of M's conjectures are drawn from D T.
For the function case, Proposition 6.17 showed that there is nothing to be gained from allowing scientists to vacillate. The situation is different for languages. Indeed, we now prove that there are collections of languages for which 0-error indexes can be learned if the scientist may vacillate among n + 1 conjectures, but for which even *-error indexes cannot be learned if vacillation is limited to sets of size n.
6.26 Proposition (Case [25])
(a) For [image], [image].
(b) For [image], [image].
As an immediate corollary we obtain:
6.27 Corollary Let [image]. Then [image].
Proof (of Proposition 6.26): We prove only part (a). The argument for part (b) can be worked out using the proof of part (a) in a way similar to the proof of Corollary 6.6.
Notation: Define [image], where m is the least number [image] such that [image]. Intuitively, Lastn(M, s ) denotes the set of the last n distinct indexes output by M when it is fed evidential state


Page 143
s . If the number of distinct indexes output by M on s is less than n, then Lastn(M, s ) is the entire set of indexes output by M on s .
For each [image], define the collection of languages
.
It is easy to verify that [image]. It remains to show that [image].
Fix an arbitrary scientist M. By a padded version of the (n + 1)-ary recursion theorem (Theorem 2.5), there are distinct programs e0, el, · · ·, e n defining r.e. sets [image], [image], . . ., [image], respectively, which are constructed as follows. All of the [image] will be in [image] and one of the [image] will witness that M fails to [image]. It will thus follow that [image].
Let [image]. Go to stage 0.
Begin ( Stage s )
For each [image], enumerate <s, e0> into [image].
( This guarantees in Case 1 below that the [image] are all infinite. )
Set [image].
Dovetail between a and b below until, if ever, the search in b succeeds.
a.

enumerate <x, e j> into [image] for each [image].
Endfor
 b. Search for a [image] extending s such that
(i) [image] and
(ii) [image].
If and when the search in b succeeds, then:
Let [image].
For each [image], enumerate S into [image].
Choose s s+1 to be an extension of [image] such that content( s s+1) = S.
Go on to stage s + 1.
End ( Stage s )
We have the following two cases.


Page 144
Case 1: Each stage terminates. Then, [image]. Let [image]. Let [image]. Clearly, T is a text for L and [image], but M on T does not finitely converge to a set of cardinality at most n. Hence, M does not
Case 2: Some stage s starts but fails to terminate. For each [image], let [image]. Clearly, for each [image], [image] and [image]. Since the search in b fails in stage s, for every [image] extending [image] such that [image], we have [image]. Moreover, for each [image], L j D L j, is infinite. Thus, there is a [image] such that, for all [image], L j D W i is infinite. Thus, M fails to [image].
The above two cases imply the proposition.
In contrast to the above result, part (a) of the next proposition shows that there are collections of languages for which an (m+ 1)-error index can be identified in the limit, but for which m-error indexes cannot be learned even if the scientist is allowed to vacillate among a finite, but unbounded, number of conjectures.
6.28 Proposition
(a) For [image], [image].
(b)For all [image],
Proof: We prove only part (a). The proof of part (b) is left to the reader.
Recall that [image] and that, by Proposition 6.5, [image]. Let L f and [image] be as in the proof of Proposition 6.19. Consider the collection of single-valued total languages [image].
It is easy to see that [image]. We argue that [image]. Suppose by way of contradiction [image]. Then, in a way similar to the proof of Proposition 6.19 it can shown that there exists a scientist that Fexm-identifies [image]. But Fexm = Exm by Proposition 6.17. Hence, [image], a contradiction.
Exercises 6-12 and 6-13 below contain additional results comparing TxtFex with TxtBc.
§6.3 Bibliographic Notes
Errors in the final hypothesis for function identification were first considered by Blum and Blum [18] and later investigated extensively by Case and Smith [35]. The terminology


Page 145
''errors of omission" and "errors of commission" is due to Daley. Behaviorally correct function identification appears in the work of Barzdins * [14] (see also Feldman [58]). Case and Smith [35] investigated behaviorally correct identification in its full generality, including errors in the hypotheses. The result [image] is due to Harrington (cited in Case and Smith [35]). The result that vacillatory function identification is the same as identification of functions is due to Barzdins* and Podnieks [16]. Later, Case and Smith [35] showed that this result holds even if errors are allowed in the final program.
In the context of languages, errors in the final hypotheses were considered by Osherson and Weinstein [143] and by Case and Lynes [33]. These two papers also considered behaviorally correct language identification and its variants. Vacillatory language identification was first considered by Osherson and Weinstein [143] and later investigated extensively by Case [26].
§6.4 Exercises
6-1 Suppose [image]. Show that there exists a recursively enumerable sequence of total computable scientists M0, M1, . . . such that, for each [image] there is an i such that [image].
6-2 Consider the following criteria of function identification.
6.29 Definition Let [image].
(a) M Ex=m-identifies f (written: ) just in case [image] and [image].
(b) M Ex=m-identifies S just in case [image].
(c) [image].
Show that for all [image], Exm = Ex.
6-3 Prove each of the following.
(a) COFIN is TxtEx*-identifiable, where COFIN is the collection of cofinite languages.
(b) For each [image], [image].
(c) Let [image]. If scientist M TxtExa-identifies L, then there exists a [image] such that the following hold:


Page 146
1. ;
2. WM( s ) =a L;
3. .
The sequence s is referred to as TxtExa-locking sequence for M on L. (This is an analog of Definition 3.24 for the TxtExa paradigm.)
(d) For all [image], [image]. (Use the above locking sequence result.) Further conclude that [image].
6-4 (J. Steel cited in Case and Smith [35]) Show [image].
6-5 Consider the following definition.
6.30 Definition Let [image].
(a) M Exta-identifies f (written: ) just in case [image] [image].
(b) [image].
Show that Exta = Ext0 = Bc.
6-6 Consider the following criteria of success on functions.
6.31 Definition (Case and Smith [35]) Let [image].
(a) M Oexa-identifies f (written: ) just in case there exists a nonempty finite set D such that the following hold:
1. for some [image], j i =a f,
2. for all but finitely many n, [image], and
3. for each [image], there are infinitely many n such that M(f[n]) = i.
(b) [image].
Thus, M Oexa identifies a function f just in case M, fed the graph of f, vacillates among a nonempty finite set D of indexes such that there is at least one a-error index for f in the set D and each index in D is conjectured infinitely often by M. Show that for each [image] we have that Oexm = Exm, but that [image].


Page 147
6-7 Motivated by the definition of Oex above, consider the following variation in the definition of scientists.
6.32 Definition Suppose [image].
(a) A scientist is a mapping from SEG to finite sets of programs.
(b) A scientist M is said to FOexa-identify f (written: ) just in case there exists a nonempty finite set D such that the following hold:
1. for some [image], j i=a f, and
2. for all but finitely many n, M(f[n]) = D.
(c) [image].
Show that Oexa = FOexa.
6-8 Let [image] and [image]. Show that, for all n, [image]. (This generalizes the Nonunion Theorem (Theorem 4.25.))
6-9 Prove each of the following.
(a) Let [image]. If M TxtBca-identifies L, then there exists [image] such that the following hold:
1. ;
2. WM( s ) =a L;
3. .
Such a s is called a TxtBca-locking sequence for M on L. (This is an analog of the locking sequence lemma (Theorem 3.22) for TxtBca-identification.)
(b) For [image], [image].
(c) [image].
(d) [image].
6-10 Consider the following variation on TxtBca-identification.


Page 148
6.33 Definition Let [image].
(a) M TxtExta-identifies L (written: ) just in case [image].
(b) [image].
Intuitively, a scientist M TxtExta-identifies L just in case M, fed any text for L, semantically converges to indexes for some fixed a-variant of L. Clearly, TxtBc = TxtExt0.
(a) Show that [image].
(b) Show that [image].
(c) Is [image]?
6-11 Consider the following variation on [image] identification in which b is the exact number of indexes to which a scientist is required to converge.
6.34 Definition Let [image] and [image].
(a) [image] (written: ) just in case for each text T for L there exists a nonempty finite set D such that the following hold:
1. card(D) = b,
2. for each [image], W i =a L,
3. for all but finitely many n, [image], and
4. for each [image], there are infinitely many n such that M(T[n]) = i.
(b) [image].
Answer the following questions.
(a) Show that for [image] and [image], [image].
(b) Analogous to the above definition, define the criteria [image] in which the parameter a is now the exact number of errors made by each of the b indexes. Show that for [image] and [image], [image].
6-12 Show that [image]. Then, observe as a corollary that for [image], [image].


Page 149
6-13 Show the following refinements of the observation in Exercise 6-12.
(a)
(b)
6-14 (Advanced) Consider the following variation on
6.35 Definition (Osherson, Stob, and Weinstein [140] )Let [image] and [image].
(a) [image] (written: ) just in case for each text T for L there is a finite, nonempty set D of cardinality at most b such that (i) M finitely converges to D, (ii) for each [image], W i = a L, and (iii) for all i, [image], W i = W j
(b)
Show that for all [image],
Open Question: Is [image]?
6-15 Two approaches to relaxing the strict requirement of Ex-identification have been considered in this chapter, namely, allowing anomalies in the final program and weakening the notion of convergence. Here we consider a third approach. Instead requiring convergence to a program for the function, we allow a scientist to converge to a "trial and error" procedure for the function. We formalize what we mean by a "trial and error" procedure for a function through programs for limiting approximations. A two argument j -program i is referred to as Lim-program for h just in case for all x [image], where h (x) is undefined just in case the limit fails to exist. Intuitively, such a Lim-program, on a given input, is allowed finitely many mind changes about what output to produce. The next definition introduces a paradigm in which the scientist converges to a Lim-program for a finite variant of the function to be identified.
6.36 Definition (Case, Jain, and Sharma [29]) Let
(a) M LimEXa-identifies [image] (written: ) just in case [image] and M(f) is a Lim-program for an a-variant of f.
(b) [image].


Page 150
Show the following.
(a) For each [image], [image].
(b) [image]. Observe that this result together with part (a) implies [image].
(c)
(d) For each [image], [image].
(e) For each [image], [image].
A Lim-program for a function may be viewed as a higher-order program for the function. A three argument j -program i is called a Lim2-program for h ) just in case for all x [image]. This process can easily be iterated to define Limn programs. The reference [29] considers identification of such higher-order programs for functions.


Page 151
7
Inference of Approximations
§7.1 Approximations
Lakatos [117] claimed that most scientific theories are "born refuted." That is, the theories are put forth in the face of prima facie anomalies. To back this claim Lakatos sketched the history of a number of successful scientific theories that were nonetheless awash in an "ocean of anomalies." These theories, which are approximate explanations for the phenomenon in question, succeed in part because they were judged to be close enough approximations to be useful. Approximations arise in language learning also. To see this, have a conversation with a three-year-old child who, we will assume, speaks English. Now, the child's grammar almost certainly does not match ''standard" English grammar. For example, irregular verbs may be regularized, adjectives and adverbs may appear in peculiar places in sentences, and whole grammatical categories may be missing. Yet despite this, you can probably carry out a successful conversation. So there are quite reasonable informal criteria under which a learner of a language can be judged to have learned a sufficiently good approximation to the target language, even though this approximation may have vast differences from the target.
We previously considered inference of approximations in Chapter 6 where the Exa and TxtExa ( [image]) criteria were introduced and studied. It is questionable whether Lakatos' "oceans of anomalies" are properly reflected in, say, the setting of the Ex* criterion which demands that final explanations be correct on a co-finite set. In defense of Ex* one might argue that a clever coding of experiments could fence the anomalies into a finite set. (For instance, if a theory was known to be anomalous in the X-ray region of the EM-spectrum, then one could simply code all experiments on the X-ray region as a single "don't care" experiment.) But the cleverness seems only to mask Lakatos' insight. More is accomplished by attempting to frame success criteria that permit infinitely many anomalies in final explanations or grammars. Such is the topic of the present chapter.
Criteria permitting infinitely many anomalies in final explanations or grammars usually make some restriction on the allowed distribution of these anomalies. (Otherwise, the criteria are typically degenerate—see Exercise 7-1.) Most of this chapter concerns criteria that require that the "density" of anomalies be no more than a fixed amount, where the notion of "density" is formalized in various ways. We begin with a short


Page 152
excursion into elementary real analysis to introduce some tools that help in formalizing these density notions.
§7.2 Some Background
Real Numbers, Supremums, and Infimums
Here we review the small amount of real analysis required for this chapter. For more details on the following, see almost any book on real analysis, for example, Dudley [56] or Rudin [162].
Recall from Chapter 2 that R denotes the set of real numbers. In this chapter, let a, b, and c range over R. Recall that:
.
.
.
.

Also recall that, for natural numbers x and z:
.
.

Let X be a nonempty set of real numbers. We define inf(X) as follows. If there is a w such that, for all [image], [image], then inf(X) is the largest such w; otherwise, [image]. For example, [image], but note that [image]. For another example, [image] We define [image]. Equivalently, if there is a y such that, for all [image], [image] then sup(X) is the smallest such y; otherwise, [image]. Suppose that a0, a1, . . . is a sequence of real numbers. Define:
.
.
For example, for each n, let [image] and [image]. Then [image] is undefined, but lim [image] and lim [image]. We note that, for any sequence a0, al, . . . ,


Page 153
Density
We make use of the above real analysis to define a notion of the density of a set of natural numbers.
7.1 Definition
(a) Suppose B is finite and nonempty. We say that the density of A in B (written: den(A, B)) is the number
(b) The density of A (written: den(A)) is [image].
Clearly, the density of every subset of N is defined and in [image]. For instance, for each n we have, [image], [image] and thus it follows that [image] Here is a more involved example: Let
and A1 =N - A0. Then den(A0) = 0 because, for each n, [image] [image]; hence, lim [image]. By a similar argument, den(A1) = 0. But, since [image], [image]. In general, this notion of density is subadditive in the sense of part (a) of the following lemma.
7.2 Lemma
(a) If A and B are disjoint, then
(b) If [image], then [image] .
Part (b) of the lemma is an easy consequence of part (a). The proof of part (a) is left for Exercise 7-2. The next lemma states a key fact that we need about r.e. sets and density. Its proof is outlined in Exercise 7-3.
7.3 Lemma For each r.e. set A and each [image], there exists a recursive [image] such that [image] .
Lemma 7.3 is simply a density analog of the standard result in recursion theory that every infinite r.e. set has an infinite recursive subset. The existence of nonrecursive r.e. sets also has a density analog: there exists an r.e. set A such that each B, a recursive subset of A, has den(B) < den(A). See Exercise 7-4 for details.
Our primary use of this density notion is to obtain measures of how closely different sets and functions approximate each other.


Page 154
7.4 Definition Suppose [image] and a ,
(a) The asymptotic agreement between A and B (written: an(A, B)) is [image].
(b) The asymptotic agreement between a and b (written: aa( a , b ) is
(c) The asymptotic disagreement between A and B (written: ad(A, B)) is 1 - aa(A, B).
(d) The asymptotic disagreement between a and b (written: ad( a , b )) is 1 - aa( a , b ).
Note that [image]. So, ad( a , b ) is an asymptotic upper bound on the amount of disagreement of a and b on sufficiently large initial segments of N. The next proposition says that there is no finite function b , partial recursive a , and [image] such that the "a-radius ball around a ," i.e., [image] includes all recursive extensions of b .
7.5 Proposition For each a [image], finite function b , and partial recursive a , there is a recursive f such that [image] and ad( b , f) > a.
Proof: Fix a, b , and a . Let [image] If ad( a , f0 > a, we are done. Suppose [image]. We construct from f0 an f as required. Let [image]. Since [image], we have [image]. Choose some [image]. So, den(A) > b > 0. As A is r.e., we have, by Lemma 7.3, that there is a recursive [image] with [image]. Without loss of generality we assume [image]. Let [image]. By definitions of f and f0 and our assumption that [image], [image]. Since B is recursive and [image], [image] also. Observe that [image]. Therefore,
(by Lemma 7.2(b))
(by the choice of B)
< 1 a
(by the choice of b).

Therefore, by Definition 7.4(d), ad( a , f) > a, as desired.
§7.3 Approximate Explanatory Identification
We now make use of the density notions of the previous section to develop a series of identification criteria based on approximations. (We follow the pattern of Chapter 6 by


Page 155
first considering extensions of Ex followed by extensions of TxtEx.) The idea is that when a scientist M is presented with a function f, we would like the scientist to infer, in the limit, an explanation, p, such that the asymptotic disagreement between f and j p is no more that a prespecified amount. Here are the formal details.
7.6 Definition Suppose [image].
(a) M Aexa-identifies f (written: ) if and only if [image] and
(b) M Aexa-identifies S just in case [image].
(c)
Thus, for each [image], scientist M, fed f, converges to an explanation p = M(f) such that the asymptotic disagreement between f and j p is zero. At first glance, j p looks like an excellent approximation of f, but in reality the definition begs an important question. Suppose f is viewed as representing some physical phenomenon, say x represents a setting of a device and f(x) represents the device's reading for this setting. Then the representations of settings and readings each involve some coding into the natural numbers and, in the case of the settings, their coding can have a huge impact on density concerns. For instance, suppose f' is defined so that, for each x, f'(2x) = f(x) and f'(2x + 1) = 0. Then, f' can be considered to represent the same phenomenon as f, but [image], so it is very easy to obtain "good" approximations of f' that are not very informative. More dramatic examples of this problem are simple to arrange—see Exercise 7-6. Exercise 7-7 develops a "coding invariant," density-based identification criteria, but the notion appears artificial. As there does not seem to be any easy way out of the difficulty, we will simply live with the dependency of density on codings, and proceed to explore success criteria like Aex.
The next proposition States the basic hierarchy result for the Aex criteria. Its proof follows the proofs of Lemmas 7.8 and 7.9 below.
7.7 Proposition Suppose [image]. Then [image].
7.8 Lemma For each rational [image], [image] .
Proof: Fix a rational [image] and an M. We exhibit an [image]. Let [image] and consider the following stages s = 0, 1, 2,· · ·.


Page 156
Begin ( Stage s )
Search for the least [image] such that
(a) [image] and
(b)
If such a [image] is ever found, set s s+1 to [image].
End ( Stage s )
One of two things happen with this construction. Either (Case 1) it progresses through all the stages, or (Case 2) it progresses only up to some stage so because the search for [image] in that stage never terminates. The f we exhibit depends on which case holds.
Case 1: We have, for each s, that s s+1 is defined and, by clause (a) in the search, that [image] and [image]. Hence, [image] is a total recursive function which we call f. Since clause (b) in the search is satisfied for each s, we also have [image]. Hence, [image], as required.
Case 2: Let [image]. By Proposition 7.5 there is a recursiVe f such that f [image] and [image]. But, by this case M(f) = p0. Hence, [image] , as required.
7.9 Lemma Suppose q and r are rationals with [image] Then [image].
Proof: Let m and [image] be such that r = m/n. Let [image]. B is thus a recursive set with den(B) = r and [image]. Let [image] for each [image]. Clearly,
Suppose by way of contradiction that, for some M, [image]. For each [image], let [image]. Thus, for all [image], [image]; hence, [image]. Let M' be such that, for all f, M'(f) = M(f'). We show that [image], contradicting Lemma 7.8.
Fix an arbitrary recursive f and let p = M(f') (= M'(f)) and [image]. Since [image] we have [image]. Without loss of generality we assume that [image]. Claim: . (See Exercise 7-5 for the proof.) Since [image], we have that [image] [image]. Hence, [image]. Since f was arbitrary, we have that [image], a contradiction.
Proof (of Proposition 7.7): Fix reals a and b such that [image]. Since the rationals are dense in the reals (Dudley [56], Rudin [162]), there are rationals q and r


Page 157
such that a < q < r < b. Since [image], [image] and, by Lemma 7.9, [image], the proposition follows.
The next two propositions establish the relations between the Aex and the Bc hierarchies.
7.10 Proposition [image] .
For the proof, see Exercise 7-8.
7.11 Corollary [image] .
7.12 Proposition [image] .
Proof: Let [image]. The proof of Proposition 6.10 showed that [image]. Here we modify that proof to show that [image].
Choose arbitrary M and [image]. By the operator recursion theorem (Theorem 2.6) there is a one-one, recursive function p such that the behavior of programs with indexes p(0), p(1), p(2), . . . is described in stages below. We arrange things so that one j p(0), j p(1), j p(2), . . . witnesses the failure of M to Aexa-identify S.
The j p(i)'s are defined in stages s = 0, 1, 2, . . . . For each i and s, [image] denotes the finite segment of j p(i) defined before stage s. We take [image]. Let k be an integer such that k. (1 - a) > 1. For each s, let x s denote the least number not in the domain of [image], let q s = M( j p(0) [x s]), and let I s = [sk + 1, sk+ k].
Begin ( Stage s )
For each [image] and each x < x s, make [image].
For x = x s, x s + 1, x s + 2, . . . in turn, define [image] for each [image] until, if ever, an x is discovered such that [image] for some [image].
If such an x is discovered, then let i be the least element of I s such that [image]. Set [image] and from now on make j p(i) follow j p(0) so that p(i) is an index for j p(0)
End ( Stage s )
We consider the following two cases.
Case 1: All stages terminate. By the construction, the range of j p(0) contains only indexes for j p(0), hence [image]. However, M on j p(0) makes infinitely many mind changes.


Page 158
Case 2: Some stage s starts but fails to terminate. For each [image] we have by the construction that [image] and is total; hence [image]. Note that [image] for each [image]. We show that M fails to Aexa-identify at least one of these j p(i)For each [image], let [image]. Clearly, the A i's are disjoint. Hence, by Lemma 7.2(a), [image], which is [image]. Now, if it were the case that [image], then we would have [image] for each [image]; but then [image], a contradiction. Therefore, for at least one [image], [image].
From the above cases it follows that [image].
The Aex criteria is thus seen to be a hierarchy that sits above the Exa criteria and which is incomparable to the Bca hierarchy, except for the obvious degenerative case of Bc* = Aex1.
We conclude this section by brief consideration of the text analogs of the Aex criteria.
7.13 Definition Suppose [image]. We say that M TxtAexa-identifies L (written: ) if and only if, for each text T for L, [image] and [image]. Define "M TxtAexa-identifies S" and "TxtAexa" in the usual way.
The results for the Aex criteria all carry over to this new setting. For example, we have:
7.14 Proposition If [image], then [image].
In proving these results one cannot employ the trick of Section 6.2 used to convert Ex-based results to analogous TxtEx-based results. The difficulty is that the conversion [image] plays havoc with densities. On the other hand, Lemma 7.3—the foundation for the arguments of this section—works equally well in the text setting. Hence, one can fairly directly translate Aex arguments to TxtAex arguments. Exercise 7-9 illustrates this method by working through a proof of Proposition 7.14. Since these translations are all straightforward, we leave TxtAex versions of the other results of this section as exercises for the reader.
§7.4 Uniform Approximate Explanatory Identification
The Aex criterion allows infinite many errors provided that the density of these errors is suitably bounded. Notice, however, that Aex permits approximations that —although


Page 159
globally good — are locally terrible. As an example, let [image]. Clearly, den(C) = 1 and, if p and f are such that [image], then aa( j p, f) = 1. Thus the asymptotic agreement between j p and f is as good as possible, but [image] contains arbitrarily large gaps. The following definition addresses this defect in Aex by introducing a stricter notion of density.
7.15 Definition
(a) The uniform density of A in intervals of [image] (written: uden m (A)) is [image].
(b) The uniform density of A (written: uden(A)) is [image] ud m(A).1
(c) The asymptotic uniform agreement between A and B (written: aua(A, B)) is [image]. The asymptotic uniform agreement between a and b (written: aua( a , b )) is [image].
(d) The asymptotic uniform disagreement between A and B (written: aud(A, B)) is 1 -aua(A, B). The asymptotic uniform disagreement between a and b (written: aud( a , b )) is 1 - aua( a , b ).
So, if [image], then for each [image] there is an [image] such that for every interval I of length at least [image], [image]. In particular, if C is as above, then for each m, ud m(C) = 0; hence uden(C) = 0.
7.16 Definition Suppose a is a real in [image].
(a) An M Uexa-identifies f (written: ) if and only if [image] and [image].
(b) [image].
For example, if M Uex0-identifies f with p = M(f), then
,
thus p is a uniformly good approximation to f. The relationship of the Uex criteria to the Ex, Bc, and Aex criteria is easy to establish.
1Note that for each A and m, [image], and hence by elementary real analysis, the limit [image] ud m(A) always exists.


Page 160
7.17 Proposition Suppose a and b are reals in [image].
(a) [image].
(b) [image].
(c) [image].
(d) [image].
(e) [image].
(f) [image].
(g) [image].
Proof: For parts (a) through (d) adapt the proofs of the analogous results in the previous section.
For part (e), first let [image] and [image]. It is straightforward that [image] but that, for each [image], [image].
Part (f) follows from part (e).
To show part (g), first fix rationals q and r with [image] and let [image] be as in Lemma 7.9. Clearly, [image]. By the argument of Lemma 7.9, [image]. Therefore, [image], and thus part (g) follows by the density of the rationals in the reals.
Thus, as might have been expected, the Uex hierarchy turns out to be a stricter version of the Aex hierarchy. The formulation of the text version of the Uex criteria and the proof of the analog of Proposition 7.17 are both straightforward and left to the reader.
Uex is an improvement over Aex, but it fails to capture every aspect of uniform density. Consider the following example. For each [image], let
,
let g k be the characteristic function of [image], let z = l x.0, and, finally, let M be such that on every input, M produces some fixed index for z. Clearly, for each k, ud(C k) = 1 and aud(z, g k) = 0. Hence, M Uex0-identifies every element of [image]. But, for each k0, for all but finitely many k, the set [image] contains intervals of length k0 or greater. Thus M fails to give uniformly good approximations across the class [image]. The Huex (for homogeneous uniform approximate explanatory identification) criteria, developed in the next definition, address this problem.


Page 161
7.18 Definition Suppose [image] and [image].
(a) The asymptotic uniform agreement between a and b on intervals of [image] (written: aua m( a , b )) is [image].
(b) The asymptotic uniform disagreement between a and b on intervals of [image] (written: aud m( a , b )) is 1 - aua m ( a , b ).
(c) An M Huexa,m-identifies f (written: ) if and only if [image] and [image].
(d) [image].
(e) [image].
If [image], then [image] for all intervals I of length m or more. Note that there is no notion of an M Huexa-identifying a particular f. If [image], then for some m we have that for every interval I of length m or greater and for every [image], [image]. The basic properties of the Huex criteria are easy to establish.
7.19 Proposition(
a) For all a, [image] with a < b, [image].
(b) [image].
(c) [image].
(d) [image].
Proof: For parts (a), (b), (c), and (d), adapt the proofs of Proposition 7.7, Proposition 7.12, Corollary 7.11, and Proposition 7.10, respectively.
The most interesting property of the Huexa (for a < 1) criteria is that they fail to contain the Ex* criterion. That is,
7.20 Proposition [image] .
Proving the proposition requires taking a closer look at the Exn criteria. This is accomplished in the propositions that follow, from which Proposition 7.20 is obtained as an immediate corollary.
A basic problem with the Exn criterion for large n is that it permits a scientist to converge to an explanation that is correct on all but n points, but these n points many include all the experiments for which one would like correct predictions. Proposition 7.21


Page 162
provides a particular example of this. Chen[36] proved the analogous result for the Bcn criteria.
Terminology: We say that x is the point of convergence of M on f if and only if [image] and x is the least number such that, for all y > x, M(f[x]) = M(f[y]).
7.21 Proposition Suppose M is a scientist and [image].
(a) There is an [image] such that either [image] or else [image] and, if x is the point of convergence of M on f, then for each [image], [image].
(b) There are infinitely many [image] such that either [image] or else [image] and, if x is the point of convergence of M on f, then for each [image], [image] .
Part (a) of this proposition follows from the proof of Proposition 6.5. We leave it to the reader to check the details of this. Part (b) follows as an easy consequence of part (a). Using this proposition we can establish the relation of the Huex criteria to the Exn criteria and some final details of the relation of the Huex with the Uex and Aex criteria.
7.22 Proposition Suppose a, [image] and m, [image] .
(a) If [image], then [image].
(b) If n > a · (m + 1), then [image].
(c) If a < 1, then [image].
(d) If a< 1 and [image], then [image].
(e) If a < b, then [image] .
Proof: Observation: If [image], then [image] can have as many as [a · (m + 1)] members in any interval of length m, but no more than that.
We have from the Observation that, if [image] and if [image], then [image]; hence part (a) follows.
Part (b) follows from the Observation and Proposition 7.21(a).
Part (c) follows from Proposition 7.17(c) and Proposition 7.20.
By Definitions 7.16 and 7.18, if [image], then [image]. By part (c), this containment is strict; hence part (d) follows.
Suppose a < b and suppose q and r are rationals such that a < q < r < b. The S of the proof of Lemma 7.9 is clearly in Huex r, hence by the proof of Lemma 7.9,


Page 163
. Part (e) then follows by the density of the rationals in the reals.
Finally we note that Proposition 7.20 follows from Proposition 7.22(b). We thus see that by making our notion of density sufficiently uniform we obtain a hierarchy of criteria, each of which allows infinitely many anomalies but fails to include the Ex* criterion because Ex* is too liberal in the way it permits anomalies to be distributed.
We do not consider the relationships between the Huexa,m criteria here. We also leave to the reader the details of the formalization and proofs of the text variants of the above notions and results.
§7.5 Bibliographic Notes
Podnieks [152] and, in improving Podnieks' results, Chen [36, Theorem 5.9] employed what amounts to a learning theoretic density notion, but they did not use density notions to define identification criteria. The criteria considered above were introduced by Royer in [159]. This chapter is largely based on that paper. Independently, Smith defined something similar, but less general, to the Aex criteria. Smith and Velauthapillai study the Aex criteria and mind-change bounds in [179, 180]. The reader can find other applications of this chapter's density notions in Chapters 8 and 10 below.
Another approach to learning approximations, due to Fulk and Jain [73], is treated in Exercise 7-10.
§7.6 Exercises
7-1 We say that [image] if and only if [image] and [image] is infinite. Define [image] and [image] as usual. Show that [image]. Hint: Show there is a p0 such that, for every [image], [image] is infinite.
7-2 Here we develop a proof of Lemma 7.2(a).
(a) Fix a sequence a0, a1, . . . . Show: if and only if, for each [image], there exists n' such that for all [image], [image].
(b) Suppose [image] and [image]. Use part (a) to show that [image].
(c) Use part (b) to show Lemma 7.2(a).


Page 164
7-3 Here we work through the proof of Lemma 7.3. Fix an r.e. set A with index i and an [image]. We shall construct B, a recursive subset of A with [image].
Choose a rational number q and integer n such that [image]. Let x0 = 0; let x1 be the least number > 0 such that, for all [image], [image], and for each s > 0, let x s+1 = 2nx s. Let [image]; for each s > 0, let t s be the least number such that, for each [image], [image]; and let [image]. Finally, set [image].
(a) Show that there exists an x1 as claimed.
(b) Show that, for each s > 0, there exists a t s as claimed. Use this to show that B is a recursive subset of W i.
(c) Fix an s > 0. Show that [image] and thus, for each [image], [image].
(d) Fix an s > 0. Use part (c) and our choice of t s to show that, for all [image], [image].
(e) Use part (d) to conclude that [image].
7-4 (Advanced) Show the following.
(a) [image] is P 4-complete.
(b) [image] is a D 4 set. Conclude that not every density 1 r.e. set has a density 1 recursive subset.
7-5 We prove the claim in the proof of Lemma 7.9. Let r = m/n; let q be a rational
number in [image]; let [image]; and let [image] with [image].
(a) Show that, for all x, [image].
(b) Show that for each [image] there is an x0 such that, for all [image], [image].
(c) Show that [image].
7-6 Construct p , a recursive isomorphism (i.e., a recursive permutation of N) and a set
A such that den(A) = 1 and [image], but den( p (A)) = 0 and [image].
7-7 We say that a set A is scattered if and only if, for all recursive, one-one f, [image].


Page 165
(a) Show that infinite scattered sets exist and that each scattered set is either finite or immune.
(b) Show that there are hyperimmune sets which are not scattered and that there are infinite scattered sets which are not hyperimmune.
(c) Show that if S is a scattered set and p is a recursive isomorphism, then p (S) is also a scattered set.
(d) We say M Exscat-identifies f if and only if [image] and [image] is scattered. We also define Exscat(M) and Exscat in the usual way. Show that [image].
7-8 Here we show Proposition 7.10: . Let [image] and [image]. Clearly, [image]. Fix n. Show that if [image], then [image], a contradiction.
7-9 Here we develop a proof of Proposition 7.14.
(a) Show that for each [image], [image], and [image], there is a recursive set R such that [image] and ad(L, R) > a. Hint: Consider the two cases of ad(L, N) > a and [image].
(b) Show that for each rational [image], [image].
(c) Show that for rationals q and r with [image], [image].
(d) Prove Proposition 7.14.
7-10 C.S. Peirce [147] held that one should not expect science to converge on a final theory of a phenomenon X; instead, the expectation should be that science will produce a series of better and better approximations to X. Fulk and Jain [73] define the following identification criteria intended to model Peirce's theory of inference. M Ap-identifies f (written: ) if and only if there is a sequence [image] of subsets of N such that (i) for each n, [image]; (ii) [image]; (iii) [image]; and (iv) for infinitely many n, [image] is infinite. This turns out to be an extremely powerful criteria, as there is an M that Ap-identifies every element of [image] [73, Theorem 1]. We work through a proof of this below.
(a) For each [image], let p f denote the least p such that j p = f. Show that there is an M' that takes a function argument f and a numeric argument m and which is such that, for each f in [image] and each [image], [image] and j p' = f.


Page 166
(b) Consider an M such that for each s, M( s ) = p s where, for all x, [image].
Show that M Ap-identifies each member of [image].
7-11 Fulk and Jain [73] define the following density-restricted version of the Ap criterion (see Exercise 7-10). For each [image], we say that M Dapa-identifies f (written: ) if and only if there is a sequence [image] of subsets of N that satisfy (i) through (iv) as in Exercise 7-10 and (v) [image]. For each [image], define Dapa(M) and Dapa as usual.
(a) Show that for each [image], [image]. (Hint:: Use an operator recursion theorem argument.) Thus, while the Ap criterion is independent of encodings of experiments (unlike the Aex criteria), the Ap criterion has serious difficulties with density.
(b) Show that for each a and b with [image], [image].


Page 167
8
Environments
Recall the component concepts of a learning paradigm:
(a) a theoretically possible reality
(b) intelligible hypotheses
(c) the data available about any given reality, were it actual
(d) a scientist
(e) successful behavior by a scientist working in a given, possible reality
Recursively enumerable languages and total recursive functions are the theoretically possible realities proper to the paradigms discussed so far. For both languages and functions, computer programs have been conceived as intelligible hypotheses.
In Chapter 5 we examined alternative interpretations of item (d) by restricting the concept ''scientist" to subsets of the computable functions. Chapters 6 and 7 were devoted to a range of success criteria, in the sense of item (e). The present chapter concerns alternative construals of available data, item (c). Until now, the potential environments for a language or function have been equated with the class of all its texts. This equation embodies three assumptions about the character of the scientist's data, namely, that: (i) none are missing, (ii) those that reach the scientist are free of error, and (iii) they may arrive in any order. All three assumptions obviously misrepresent the circumstances of language acquisition. Thus, it is clear that children need not hear every sentence of their language in order to stabilize to an accurate grammar. They are also likely to face at least some ungrammatical intrusions (although perhaps not many; see [182]). There is also no doubt that children face a constrained order of sentences inasmuch as the speech addressed to them starts off simply. The same considerations apply to adult scientists conducting empirical inquiry. Their data are neither complete nor error-free, and the order of their arrival is constrained by such factors as cost. (Cheaper data arrive first!)
In what follows, erroneous data will be conceived as intrusions into the interface between a language and a scientist. Error thus expands the class of texts for a given language. Allowing data to be omitted has a similar effect whereas constraints on order shrink the class of texts a scientist might face. These ideas are defined precisely in Sections 8.1 and 8.2. We subsequently discuss how scientists can exploit multiple sources of data about the same reality.


Page 168
§8.1 Inaccurate Data
A text for a language L may suffer omissions from L, erroneous intrusions from [image], or both omissions and intrusions. Three kinds of inaccurate texts may thus be distinguished, to be called "incomplete," "noisy," and "imperfect" in what follows. We also distinguish different, finite numbers of the two defects (intrusion and omission). Infinite error is not considered here, but pointers to the relevant literature are provided later.
§8.1.1 Texts with Finite Number of Inaccuracies
Pursuant to our classification of inaccuracies, we define three kinds of inaccurate texts for languages.
8.1 Definition Let [image] and [image] be given. A text T is a-noisy for L just in case [image] and [image].
An a-noisy text for a language L can be viewed as a text for L into which any number of intrusions from a set of cardinality at most a have been inserted. Note that any single such intrusion may occur infinitely often in T.
8.2 Definition Let [image] and let [image] be given. A text T is a-incomplete for L just in case [image] and [image].
An a-incomplete text for L can be viewed as a text for L from which all occurrences of a given set of cardinality at most a have been removed.
8.3 Definition Let [image] and [image] be given. A text T is a-imperfect for L just in case [image].
Thus, an a-imperfect text for L omits some finite [image] and includes some finite [image]; moreover the cardinality of [image] is bounded by a.
Note that in the above three definitions, the case in which a = * implies that the number of inaccuracies is any finite number. The other cases model situations in which a scientist may be aware, a priori, of an upper bound on the number of inaccuracies infecting her environment. We now consider inaccurate texts for functions. Recall that we identify functions with their graphs and that SEG is the collection of all finite initial segments of (nonnoisy!) texts for functions. Thus, [image] SEG and we have no


Page 169
convenient way to denote the data available to scientists from noisy texts. The following definition remedies this.
8.4 Definition The set of all finite sequences over N2 is denoted SEGI. By a scientist for identifying functions using imperfect data is meant any computable function (partial or total) from SEGI to N.
For brevity in this chapter, we drop the qualifier "for identifying functions using imperfect data" when referring to scientists.
8.5 Definition Let [image] and [image] be given. Let G be a text.
(a) G is a-noisy for f just in case [image] and [image].
(b) G is a-incomplete for f just in case [image] and [image].
(c) G is a-imperfect for f just in case [image].
Note that two incorrect values for f(n) count as distinct, noisy points. To understand this idea, suppose that G is an inaccurate text for [image], that f(n) = x, that [image] and that x, y, z are all distinct. Then, provided there are no other intrusions, G is a 2-noisy text for f. Further, if we suppress the correct pair (n, x) from the foregoing text G, then it becomes a 3-imperfect text for f.
Our task is now to embed the foregoing conceptions of inaccurate data within an associated learning paradigm. One means of achieving this is to require scientists to converge to an accurate index for the target object (language or function), even on texts that harbor inaccuracies. The next definition formalizes this idea for the language case.
8.6 Definition Let a, [image] and scientist M be given.
(a.1) M NaTxtExb-identifies [image] (written: ) just in case for all a-noisy texts T for L, [image] and WM(T) =b L.
(a.2) [image].
(b.1) M InaTxtExb-identifies L (written: ) just in case for all a-incomplete texts T for L, [image] and WM(T) =b L.
(b.2) [image].
(c.1) M ImaTxtExb-identifies L (written: ) just in case
for all a-imperfect texts T for L, [image] and WM(T) =b L.


Page 170
(c.2) [image].
We illustrate the above definitions with a few examples. Let [image], where E denotes the set of even numbers and O denotes the set of odd numbers. Let e and o be indexes for E and O, respectively. Let scientist M, fed s , emit e if the majority of content( s ) are even; o otherwise. It is easy to see that M identifies [image] on *-noisy texts, *-incomplete texts, and *-imperfect texts. In contrast, there are two-clement classes of languages that are not identifiable on 1-noisy texts. For example, let [image], [image], where [image], and let T be some text for L'. Then T is also a 1-noisy text for both L and L'. Since [image], no scientist M converges on T to an index for both languages. It is also easy to verify that [image].
The above example demonstrates that inaccuracies in texts affect identifiability. The next proposition highlights the disruptive effects of 1-noisy texts. The reader is referred to the exercises for a discussion of identification from noisy texts without the computability restriction on scientists.
8.7 Proposition There is a collection of infinite, pairwise disjoint r.e. languages in TxtEx - N1TxtEx
Proof: For each m [image] define [image]. It is easy to verify that no scientist N 1TxtEx-identifies both L n,m and L n,m' for [image]. Now let h be any permutation of N, and define [image]. It is easy to see that for any permutation h, [image]. But if [image], and if M N 1TxtEx-identifies [image], then M falls to N1TxtEx-identifies [image]. Since there are only N0 many scientists and [image] many permutations of N, there must be a permutation h such that no scientist N 1TxtEx-identifies [image].
The next proposition parallels Proposition 8.7 and highlights the disruptive effects of identification from 1-incomplete texts. A proof analogous to the above suffices; details are left to the reader.
8.8 Proposition There is a collection, [image], of infinite, pairwise disjoint r.e. languages, such that [image].
Paradigms for function learning may be defined analogously to the language case.
8.9 Definition Let a, [image] and scientist M be given.


Page 171
(a.1) M NaExb-identifies f (written: just in case for all a-noisy texts G for f, [image] and j M(G) =b f.
(a.2) [image].
(b.1) M InaExb-identifies f (written: just in case for all a-incomplete texts G for f, [image] and j M(G) =b f.
(b.2) [image].
(c.1) M ImaExb-identifies f (written: ) just in case for all a-imperfect texts G for f, [image] and j M(G) =b f.
(c.2) [image].
As an example of a collection of functions whose identifiability is not affected by the presence of a finite number of inaccuracies in texts, consider the class [image] of constant functions, i.e., [image]. It is easy to construct a scientist that identifies [image] on *-noisy texts, *-incomplete texts, and *-imperfect texts. On the other hand, no scientist identifies [image], the collection of self-describing functions1, from 1-incomplete texts.
The basic idea of the foregoing Definitions 8.6 and 8.9 is easily extended to other criteria of learning introduced in Chapter 6. For example, consider the language learning criterion [image], according to which a scientist M is successful on a language L just in case, given any text for L, M converges to a finite set of indexes D such that [image] and each index in D is for some b-variant of L. An a-noisy-text version of [image] is defined by requiring the scientist to [image] a language on any a-noisy text. The resulting paradigm is named [image]. With this background, the reader may easily formulate the exact definitions of the following paradigms for language identification: , [image], [image], NaTxtBcb, InaTxtBcb, and ImaTxtBcb.
Several criteria of function identification studied in Chapter 6 may also be adapted to the present context. In particular, we shall focus on NaBcb, InaBcb, and ImaBcb in what follows.
§8.1.2 Hierarchy Results
The present section considers the tradeoff between inaccuracy in the available data versus leniency in the learning criterion. In particular, we investigate the effect of allowing
1Recall from Chapter 4 (Definition 4.24) that [image].


Page 172
additional errors in the output theory, in the sense discussed in Section 6.1.1. To what extent does such leniency compensate for additional noisy or missing points in the input data? The proposition stated below shows that the tradeoff is not straightforward. To see this, consider ImnExn. just in case there is some scientist M that behaves as follows. Given an n-imperfect text G for any [image], M converges on G to an index for a (partial) function h that differs from f on no more than n arguments. It might be thought that ImnExn defines the same family of collections as ImmExm for distinct n and m. However, this is not true. Indeed, Part (a) of the next proposition shows that allowing one additional error in the output theory, in some cases, more than compensates for additional imperfection in the input data. Specifically, there are classes of functions for which an (i + 1)-error program can be identified from texts with an arbitrarily large finite number of imperfections, but for which an i-error program cannot be synthesized, even from completely accurate texts. Part (c) of the proposition is a similar result about Bc-identification. It is also interesting to note that by part (e) there is a scientist that can Bc*-identify every computable function, even from texts with an unbounded, finite number of imperfections.
8.10 Proposition For all [image]:
(a) [image].
(b) [image].
(c) [image].
(d) [image].
(e) [image].
Proof: Part (a). Let [image]. It is easy to see that [image]. An easy extension of the proof of Proposition 6.5 shows that [image].
Parts (b), (c), and (d) can be shown by similar extensions of the proofs of Corollary 6.6 and Propositions 6.10 and 6.13 in Chapter 6. The proof of part (e) is left to the reader.
Proposition 8.10 yields a hierarchy of paradigms that may be summarized as follows.
8.11 Corollary Let [image]. Then:
(a) [image].


Page 173
(b) [image].
We leave it to the reader to work out counterparts of Proposition 8.10 and Corollary 8.11 for noisy and incomplete texts.
It is worth examining in more detail the impact on function identification of just a single noisy input. The next proposition shows that there are collections of functions for which programs can be identified from accurate texts, but for which programs for arbitrary finite variants cannot be identified from texts with at most one spurious datum.
8.12 Proposition [image] .
Proof: For each [image], define f' and f" as follows, for each j and [image]:
Consider the following collections of functions:

It is easy to verify that [image] and [image] (and hence [image]). However, according to Theorem 4.25, [image]. It is easy to see that for any [image], f(<0,0>) can be used to determine whether [image] or [image]. Thus, a scientist which Ex-identifies [image] can be constructed.
Suppose by way of contradiction that scientist M N 1Ex-identifies [image]. Then, using M, we show how to construct M' which Ex*-identifies [image], contradicting Theorem 4.25.
We first define two recursive functions twit and untwit. Let twit: be a recursive function such that, for all s and [image]:


Page 174
Let untwit be a recursive function such that, for any j -program i, for all x, j untwit(i)(x) = j i(<1, x>).
Now, let M'( s ) = untwit(M(twit( s ))). It is easy to see that if M N 1Ex*-identifies [image], then M' Ex*-identifies [image] But this yields a contradiction; hence [image].
Consider the following generalization of collection [image] defined in the proof of Proposition 8.12 above. For each [image] and [image] define [image] and [image] as follows.
Consider also the following collections of functions (where [image], [image] are defined in the proof of Proposition 8.12).
Using the proof of Proposition 8.12 as a model, it is easy to show that [image], but [image] is in neither N k+1Ex* nor Ink+1Ex* As a straightforward consequence (details are left for the reader), we have the following proposition.
8.13 Proposition For all [image]:
(a) [image].
(b) [image].
Proposition 8.13 yields several corollaries that clarify the relationship between the number of inaccuracies allowed in a text and the ability of scientists to learn on those texts. The following corollary, for example, provides information about Ex-identification from noisy texts.
8.14 Corollary [image] .
Let us now turn our attention to the identification of languages from inaccurate texts. The following Proposition is the language counterpart to Proposition 8.10 and can be shown using techniques similar to those used in Proposition 8.10. We leave the details as an exercise.


Page 175
8.15 Proposition For all [image]:
(a) [image].
(b) [image].
(c) [image].
(d) [image].
(e) [image].
(f) [image].
The foregoing result yields a collection of hierarchies that are the subject of Exercise 8-16. Some other hierarchies are implied by the following result:
8.16 Proposition For each [image],. .
Proof: For each finite [image] define:
It is easy to verify that [image]. Also, [image] [image]. But, [image] (see Exercise 6-9); thus [image].
§8.1.3 Comparison of Different Kinds of Inaccuracies
The last section revealed the extent to which inaccurate data can impede learning. However, no information was provided about the relative impact of different kinds of inaccuracies. For example, which is worse—noise or missing data? In the case of function learning we will see that missing data is strictly more disruptive than noise. To begin, the next proposition shows that there are collections of functions for which programs can be synthesized despite an arbitrary, finite number of noisy points, but for which even finite-variant programs cannot be synthesized if just one datum is missing. The language-identification counterpart of this result follows as an easy corollary.
8.17 Proposition [image] .


Page 176
Proof: For each [image] define:
Consider the collection of functions [image]. We first show that [image]. Suppose, by way of contradiction, that some scientist M InlEx*-identifies [image]. We describe a scientist M' which Ex*-identifies [image] —yielding a contradiction. For each f, let G f denote a text such that for all k, x, G f(<k, x>) = (1 + <k, x>, f(x)). Note that G f is a 1-incomplete text for f'. Also, note that G f[n] can be effectively computed from f[n]. Let g be a recursive function such that for all p, x, j g(p)(x) = j p(<1 + <0, x>>). Define M' such that M'(f[n])). Note that M' can easily be constructed from a description of M. Clearly, for each [image], if j p =* f', then j g(p) =* f. Since M In lEx*-identifies [image], it follows that M' Ex*-identifies [image]. However, [image] (Corollary 6.11); thus [image].
We now show that [image]. Let F be a mapping from SEGI to SEGI such that for each [image],
Also, for each text G, define the text G' such that for all n,
Now let G be a *-noisy text for [image]. It is easy to see that for all but finitely many n, G'[n] = F(G[n]). Also, for all i, x, and y, we have [image]. Moreover, from the finitely many candidates for f'(0) (at least one


Page 177
of which is correct), the actual value of f'(0) can be determined in the limit. This is possible because
Thus p 1(f'(0)) can be obtained from G' (and hence G) in the limit. Also, it is easy to determine f'(0), in the limit, from p 1(f'(0)) and from f'(0), a j -program for f' can easily be found.
8.18 Corollary [image] .
We leave it to the reader to modify the above proof to show the following result.
8.19 Proposition For each [image], [image].
8.20 Corollary For each [image], [image].
Propositions 8.17 and 8.19 may be paraphrased this way: there are collections of functions that can be learned from the most offensive noisy texts (*-noisy texts), but not from the least offensive incomplete texts (1-incomplete texts). It is natural to ask whether the reverse is true, i.e., whether there are collections of functions that can be learned from the most offensive incomplete texts (*-incomplete texts), but not from the least offensive noisy texts (1-noisy texts). Proposition 8.21 below answers this question negatively, thereby implying that—in the context of function identification—missing data are strictly more harmful than noisy data.
8.21 Proposition Let a, [image]. Then:
(a) [image].
(b) [image].
Proof: Let scientist M be given. We construct a scientist M' such that [image] and [image].
Let [image] be such that, for all s , all [image], and all x, [image],


Page 178
For each text G, let the text G' be such that, for all n, x, [image],
.
Now, if G is an a-noisy text for [image], then G' is an a-incomplete text for f. Moreover, for all but finitely many n, G'[n] = F(G[n]).
For each s , let M'( s ) = M(F( s )). It is easy to see that both [image] and [image].
The foregoing propositions show that missing data perturb function identification more than noisy data do. In the context of language identification, however, the matter is more subtle. The following proposition, for example, shows that there are collections of languages that can be identified despite one missing datum but cannot be identified in the presence of one noisy datum.
8.22 Proposition For each i > 0, [image].
Proof: Let [image] denote the collection of all such [image] for which there are at least two distinct [image] such that colx(L) is nonempty, finite, and [image].
We show below, in Lemma 8.23, that [image]. Using [image], for each [image] we define [image] to be the collection of languages [image] such that for some [image] the following hold for all j and x:
1. .
2. .
3. .
4. At least two of <0,0>, <0,1>, and <0,2> are in L.
5. If [image] and [image], then colx(L') is nonempty and finite and [image].
We leave it to the reader to show that, for each i, [image].
Let [image]. Clearly, for each [image], any text T for Noisyi(L) is also an i-noisy text for L. Lemma 8.23 thus implies that [image].
8.23 Lemma Let [image] be as deigned in the proof of Proposition 8.22. Then, [image].


Page 179
Proof: Suppose by way of contradiction that M TxtEx*-identifies [image]. Then by the operator recursion theorem, there exists a recursive, 1-1, increasing p such that W p(.) may be defined in stages as described below.
In the following construction, [image] denotes the part of W p(i) enumerated before stage s. (Note that there is no stage 0.) Let [image] and, for each i > 1, let [image]. Also let s 1 = (<0, p(0)>, <1, p(1)>). Go to stage 1.
Begin ( Stage s )
1. Enumerate [image] into each of W p(0), W p(1), W p(2s) and W p(2s + 1).
Enumerate <2, p(2s)> into both W p(0) and Wp(2s)..
Enumerate <2, p(2s + 1)> into both W p(1) and Wp(2s + 1).
Let [image] be an extension of s s such that [image].
Let [image] be an extension of s s such that
2. Dovetail between 2a and 2b until, if ever, step 2b succeeds. If and when step 2b succeeds, go to step 3.
2a.

2b. Search for [image], [image] such that
.
3. If and when 2b succeeds, let i and n be as found in 2b and set

Let s s+1 = an extension of [image]) such that content( s s+1) = S.
Enumerate S in both W p(0) and W p(1).
Go to stage s + 1.
End ( Stage s. )
Consider the following two cases.
Case 1: Infinitely many stages are executed. In this case, let [image]. But M on [image], a text for L, makes infinitely many mind changes—since the only


Page 180
way in which infinitely many stages can exist is by the success of step (2b) infinitely often.
Case 2: Some stage s is started but never left. In this case, let [image] and [image]. Note that L0 and L1 are infinitely different from each other. Let [image], and [image], where [image] and [image] are as defined in step 1 of stage s. Now, T0 is a text for L0 and T1 is a text for L1. However, M converges to the same grammar for both T0 and T1, thus M does not TxtEx*-identify [image].
The above cases imply that [image].
Having investigated noisy versus incomplete data, it is natural to consider next the relationship between incomplete and imperfect texts. How much more damage to learning results from adding noise to an environment already missing data? In this matter only approximate results arc known; the exact relationship is still open. We provide a list of some sample results. Proofs for some of them are developed in the exercises.
8.24 Proposition For all i > 0, [image].
8.25 Proposition For all i > 0 and [image], [image].
8.26 Proposition For all i, [image], [image].
§8.2 Texts with Additional Structure
The paradigms discussed until now suppose that an input text can be ordered arbitrary, and thus require scientists to succeed regardless of the manner in which their data are presented. This is, however, a questionable representation of many natural environments. It seems unlikely, for example, that children face an entirely arbitrary order of linguistic input, since simpler sentences usually arrive earlier than complex ones. The present section briefly discusses some paradigms that begin to respond to this consideration.
§8.2.1 Ascending Texts
It is often claimed that children encounter simple sentences first and difficult ones later. Complexity may be measured by the length of the sentence, degree of embedding, inflection etc. For our purposes we assume that a sentence whose code is smaller is simpler.


Page 181
Thus presenting simple sentences first and difficult ones later amounts to presenting the text in increasing order. We call such texts ''ascending." By convention, we order [image] thus: # < 0 < 1 < 2 < · · ·.
8.27 Definition A text T over natural numbers is ascending just in case T is nondecreasing as a function from N to [image]. A text G over pairs of natural numbers is ascending just in case p 1 ° G is nondecreasing where, for all x and y, p 1( (x, y) ) = x.
Consider the identification of functions on perfect text (i.e., containing no noise or omissions). It is important to see that presenting such texts in ascending order does not augment the family of identifiable collections of functions. This is because any perfect text for a function can be gradually and effectively converted into an ascending text for the same function (see Exercise 8-30 for details). The present section will therefore limit itself to language learning.
8.28 Definition Let [image].
(a) We say that M AscTxtExa-identifies L (written: ) just in case for all ascending texts T for L, [image] and WM(T) =a L.
(b) [image].
(c) AscTxtBca is defined similarly.
8.29 Proposition [image] .
Proof: Consider the following collection of languages:
.
We leave it to the reader to show that [image]. We argue that [image]. Let Gram be a recursive function such that for all finite sets D, WGram(D) = D. Let i N be an index for N. Now, for each s , define:
It is easy to verify that M AscTxtEx-identifies [image].


Page 182
§8.2.2 Informant Presentation
It is often assumed that children do not receive direct information about the non-sentences of their language (see the discussion in Chapters 1 and 3). Let us consider, however, what happens when texts contain both positive and negative information.
8.30 Definition We say that a text G for a 0-1 valued function is an informant for L just in case [image].
8.31 Definition Let [image].
(a) A scientist M InfTxtExa-identifies L (written: ) just in case on all informants G for L, [image] and WM(G) =a L.
(b) [image].
We can similarly define M InfTxtBca, etc. It is easy to see that [image] and [image]. We now prove the following Proposition which shows the distinction between the two.
8.32 Proposition [image] .
Proof: Let [image]. It is easy to see that [image], but not in AscTxtBc*.
§8.2.3 Recursive Texts and Nonrecursive Texts
A text, T, is said to be recursive just in case them exists a recursive function f such that for all n, f(n) = T(n).
If children s caretakers are machine simulable and are sheltered from random environmental influence, they might be limited to the production of recursive texts. Similarly, if natural phenomena are computable processes devoid of any random behavior, a scientist may be restricted to operating on recursive texts. Would such a limitation affect in principle the class of learnable languages? We first incorporate the notion of recursive texts into our learning paradigm.
8.33 Definition Let [image].
(a) M RecTxtExa-identifies L (written : ) just in case for all recursive texts T for L, [image] and WM(T) =a L


Page 183
(b) [image].
The following proposition shows that identification from recursive texts fails to yield any advantage over identification from arbitrary texts.
8.34 Proposition For all [image], TxtExa = RecTxtExa.
Proof: Follows from the stabilizing sequence construction given in Chapter 5.
However, the story is completely different if the scientists are not required to be computable. The following definition introduces the notion of identification from recursive texts by scientists that may not be computable. Convention: F in the following ranges over possibly noncomputable scientists.
8.35 Definition
(a) F RecLang-identifies L (written: ) just in case for all recursive texts T for L, [image] and WF(T) = L.
(b)
The next proposition says that there is a single noncomputable scientist that identifies each recursively enumerable language from recursive texts.
8.36 Proposition [image] .
Proof: Consider the following F:
Begin ( F on s )
Let i be the least number such that for all [image], j i(n) = s (n).
Output the least grammar for range ( j i) - { # }.
End ( F on s )
It is easy to see that
It should be noted that if caretakers and natural phenomena are assumed to be computer simulable, then there is no reason to consider, as in the above case, noncomputable scientists and children. But, since the computable nature of children and their environments is only a hypothesis, it is worth considering identification on nonrecursive texts by both computable and noncomputable scientists. We have yet to isolate the nonrecursive texts for separate study. The following definition fills this gap.


Page 184
8.37 Definition
(a) F NonrecLang-identifies L (written: ) just in case for any nonrecursive text T for L, [image] and WF(T) = L.
(b) [image].
8.38 Definition
(a) M NonrecTxtExa-identifies L (written : ) just in case for any nonrecursive text T for L, [image] and WM(T) =a L.
(b) [image].
It is natural to inquire whether the limitation to nonrecursive texts facilitates identification. The next proposition provides a negative answer to this question for both computable and noncomputable scientists. We omit the proof.
8.39 Proposition
(a) NonrecLang=Lang.
(b) (Wiehagen [195]) NonrecTxtEx = TxtEx.
§8.3 Multiple Texts
The paradigms discussed so far assume that scientists receive data about a given reality from a single source. The source is represented by the single text delivered to a scientist in the course of a single "run." Provided all data are accurate, this model embraces multiple sources of data as well, since a scientist can easily construct a single accurate text by consulting her different sources in some cyclical order. Matters become more complicated if one or more sources are faulty. Consider, for example, a scientist receiving data from multiple sources, some of which produce 1-imperfect text. It is not obvious that she can convert such data into a single 1-imperfect text.
This kind of consideration is important to modeling both language acquisition and scientific practice. In the former case it is clear that children are confronted with several sources of linguistic data (in the form of different caretakers, older children, etc.), none of which is 100% grammatically reliable. Similarly, it is common for scientists to base their theories on data collected by different teams working at different places using different instruments, with each team subject to particular forms of error.


Page 185
The present section begins to deal with these issues by extending our paradigms to model multiple sources of data, some of which are inaccurate. For this purpose scientists will be conceived as receiving a finite number of texts, announcing hypotheses after examining some initial segment of each of them. To keep the present discussion manageable, we confine ourselves to the identification of functions.
To begin, we need to enrich our definition of scientist.
8.40 Definition Let [image]. A scientist with k streams is a computable mapping from SEGIk into N.
8.41 Definition Let [image]. Fix a k stream scientist M, texts G1,G2, . . . ,G k, and [image]. We say M converges on G1,G2, . . . ,G k to i (written: ) just in case there exists an n such that M(G1[n1],G2[n2], . . . , G k[n k]) = i whenever n1, . . . , n k > n.
Next, we define the identification of functions from multiple texts, some of which could be inaccurate.
8.42 Definition Let j [image] with [image]. Let a, [image].
(a) M [image] f (written: ) just in case for any collection of k texts, G1, G2, . . . , G k, at least j of which are a-noisy for f, [image] and j M(G1,G2, . . . ,G k) =b f.
(b) [image].
(c) [image] and [image] are defined similarly to [image].
8.43 Definition When discussing identification criteria involving multiple data sources, those texts for which the number of inaccuracies is within the bound required by the criteria will be referred to as good texts.
The next three propositions describe situations in which learning from multiple inaccurate texts is no more difficult than learning from a single inaccurate text.
8.44 Proposition Let j and [image] be such that [image] and let [image]. Then:
(a) [image].
(b) [image].
(c) [image].


Page 186
(d) [image].
Proof: Given k texts G1, G2, . . . , G k, form a text G such that [image].It is easy to see that, if at least [image] of the k texts are *-noisy (*-incomplete, *-imperfect, accurate) for f, then so is G. The proposition follows.
8.45 Proposition Let j and [image] be such that [image] and let [image]. Then:
(a) [image].
(b) [image].
(c) [image].
Proof: We first introduce a technical notion. Let P be a finite set of programs. Define program Unify(P) as follows.
Begin ( j Unify(P) )
On input x:
Search for an [image] such that [image].
If and when such an i is found, output j i(x) for the first such i found.
End ( j Unify(P) )
Proof of Part (a). Let M NaEx-identify C. We show how to Ex-identify [image] from k texts, G1, G2, . . . , Gk, at least j of which are a-noisy for f.
So suppose [image], and G1, G2, . . . , G k are k texts such that at least j of them are a-noisy for f.
First we claim that there are distinct i1, i2, . . . , i j such that,
(A) for [image], [image] and
(B) for each l, [image], there is no x such that [image]. This is so, since if we choose i1, i2, . . . , i j to be such that [image], . . . , [image] are good, then (A) and (B) above are satisfied.
Note that, given texts G1, G2, . . . , G k, one can find, in the limit, distinct i1, i2, . . . , i j satisfying (A) and (B) above. So let M' be a scientist that, in the limit, finds such i1, i2, . . . , i j and outputs Unify(P), where [image].
Since [image] and [image], there is a [image] such that j p = f. This, along with (B) above, implies that Unify(P) is a program for f; hence part (a) follows.
Parts (b) and (c) can be proved similarly.


Page 187
By Exercise 8-25 we also have:
8.46 Proposition Let j and [image] be such that [image] and let [image]. Then:
(a) [image].
(b) [image].
(c)
The last three results inform us that if the number of inaccuracies is finite without any preassigned bound, or if the final program witnessing the identification is required to be either accurate or make a finite number of mistakes without any preassigned bound, then learning from multiple texts does no harm so long as a majority of the input texts are good.
The next two propositions follow from Propositions 8.45, 8.44, 8.13, and 8.10.
8.47 Proposition Let b, j, [image], [image] . Then:
(a) [image].
(b) [image].
8.48 Proposition Let b, j, [image] be such that [image]. Then,
Proposition 8.47(a), for example, says that there are collections of functions for which a program that makes up to (b + l) errors can be identified from multiple texts, a majority of which are *-imperfect, but for which a program that makes only up to b errors cannot be identified from a single accurate text. Propositions 8.47 and 8.48 yield a number of hierarchies. We note one of them in the next corollary, which implies that strictly larger classes of functions can be identified from multiple inaccurate texts, a majority of which are *-imperfect, by allowing extra anomalies in the final program.
8.49 Corollary Let j, [image] be such that [image]. Then, [image].
We now consider situations in which a scientist pays a price for learning from multiple inaccurate texts instead of learning from a single inaccurate text. We restrict ourselves to the case of noisy data delivered on three inaccurate texts, at least two of which are


Page 188
good. The reader is directed to the exercises and Baliga, Jain, and Sharma [12] for more results.
The following lemma gives information about the parameters a, b, c, and d, for which [image].
8.50 Lemma Let a, b, c, [image] be given. Suppose r, [image] are such that the following hold: , [image], and [image]. Then, [image].
Proof: Let [image]. Let C be the collection of functions [image] that satisfy the following three conditions.
1. .
2. For each [image], the set { [image]} is finite and [image].
3. For each [image] and x, y, [image], f(<i, < x, y>>) = f(<i, <x, z>>).
For any a-noisy text G for [image], since 2r > a, there exist an x < r and an [image] such that [image]. Thus, using clauses 2 and 3 in the definition of C, it is easy to see that [image]. The proof of [image] is fairly complex and we direct the reader to Baliga, Jain, and Sharma [12] for the proof.
Among other corollaries to this lemma we have the following.
8.51 Corollary Let a, b, [image] be such that [image] and [image]. Then, [image] .
Proof: Take r = c and a = b in the above lemma.
8.52 Corollary Let a, b, [image] be such that [image] and [image]. Then, [image].
Proof: Take r = a = c in the above lemma.
8.53 Corollary Let a, b, c [image] be such that [image] and [image]. Then, [image].
Proof: Take r = a = b in the above lemma.


Page 189
8.54 Corollary Let a, b, [image] be such that [image] and max [image]. Then, [image].
Proof: Take [image] in the above lemma.
The above results show that there are collections of functions for which a program that makes up to d errors can be identified from a single c-noisy text, but for which a program with up to d errors cannot be identified from three texts, at least two of which are c-noisy. Clearly, a price is being paid for distinguishing good texts from "bad" ones. An obvious question is whether this decrease in competence due to learning from multiple texts can be overcome by either decreasing the noise in good texts or by allowing the final inferred program to make extra errors. Some of these questions are treated in the exercises.
§8.4 Bibliographic Notes
The first study of inaccuracies is due to Schäfer-Richter [167]. This subject was also treated by Osherson, Stob, and Weinstein [140], Fulk and Jain [74], and Fulk, Jain, and Osherson [75]. The subject of infinite inaccuracies is treated by Jain [83]. An interesting approach to modeling noise in data is due to Stephan [186]. The study of learning from multiple sources of inaccuracies is due to Baliga, Jain, and Sharma [12].
The study of informants was first considered by Gold [80]. The subject of recursive and nonrecursive texts has been investigated by Wiehagen [195] and Freivalds [64].
§8.5 Exercises
8-1 For each [image], let f' be such that ( " i, x)[f'(<i, x>) = f(x)]. Suppose [image] is given. Show that [image].
8-2 Prove the following. Recall that [image].
(a) Let [image] be recursive. Then, [image].
(b)
8-3 Consider the notion of identification from *-noisy texts by scientists that need not be computable. Recall that F ranges over any kind of scientists, possibly noncomputable.


Page 190
F is said to N*Lang-identify [image] (written: ) just in case given any *-noisy text for L, F converges to an index for L. The class N*Lang is [image]. Prove the following generalization of Theorem 3.22 from Chapter 3.
(a) Let F N*Lang-identify [image]. Then, for every finite [image], there is [image] such that [image], WF( s ) = L, and for all [image], if [image], then
(b) Let F N*Lang-identify [image]. Show that for every [image] there is some [image] such that [image], [image] and for every [image], if [image], then [image].
8-4 Let [image]. Show that [image].
8-5 Prove the following.
(a) Let L, [image] be such that [image] and [image]. Then, both L - L' and L' - L are infinite.
(b) Let [image] be such that whenever L, [image] and [image], then both L - L' and L' - L are infinite. Then, [image].
8-6 Define In*Lang and Im*Lang analogously to the definition of N*Lang in Exercise 8-3. Prove the following generalizations of Theorem 3.22 from Chapter 3.
(a) Let F In*Lang-identify [image]. Then, for every finite [image] there is [image] such that [image], WF( s ) = L, and for all [image], if [image], then [image].
(b) Let F Im*Lang-identify [image]. Then, for every finite variant L' of L there is [image] such that [image], WF( s ) = L and for all [image], if [image], then [image].
8-7 Prove [image].
8-8 Define N*Func and In*Func analogously to N*Lang and In*Lang. Prove N*Func = In*Func.
8-9 Prove the following.


Page 191
(a)
(b) Let L be recursive. Then, [image]. Compare this result to Exercise 8-4.
8-10 Prove: N*Lang = Im*Lang.
8-11 Prove: .
8-12 Prove: .
Hint: Note that [image] from the proof of Proposition 8.12 can be used to show that [image]. A similar argument works here.
8-13 Prove, for all [image], that [image]. This is an extension of Proposition 8.13.
8-14 In the context of identification from inaccurate texts with a finite number of inaccuracies, this exercise compares situations in which a bound on the number of inaccuracies is available to situations in which there is no such bound. Show that [image] is nonempty. Hint: The positive part of this has to be non-constructive in i.
8-15 Prove Proposition 8.15.
8-16 Obtain the following hierarchies as corollaries to Proposition 8.15.
(a)
(b)
(c)
8-17 Prove Proposition 8.19.
8-18 Since [image], there is scope for further fine-tuning of Corollary 8.20. As an example of such a refinement, show that for each [image], [image].
Open Question: ?
8-19 Prove: .


Page 192
8-20 Prove Proposition 8.24
Hint: First consider the case i = 1. For a function f, define [image]. Let
.
Show that [image]. For i > 1, modify the definition of Sf appropriately.
8-21 Prove Proposition 8.25
8-22 Prove Proposition 8.26
Hint: First consider the case j = 0. Suppose a rearrangement-independent scientist M is given. For [image], consider any text G that is 2i imperfect for f. For each x, y, z such that [image], assume without loss of generality that [image]. Note that this implies there are at most i noisy elements in G. First show that if for some D of cardinality i and for some n1 and n2 with n1 < n2 we have
for each [image] with cardinality i, there is a [image] with [image] such that [image] is a locking sequence for M on content(G) - D - D';
then, either
(i) there exists a noisy element in content(G[n2]) - content(G[n1]), or
(ii) for some [image] with cardinality i, [image], where [image] is as above, is a program for f.
Next, use the above facts to obtain, in the limit, a finite set of programs, one of which is a program for f.
8-23 Prove: .
8-24 Prove: .
8-25 Prove Proposition 8.46.


Page 193
8-26 Prove: .
Hint: First show how to obtain a 2c-noisy text from 3 texts, at least 2 of which are c-noisy.
8-27 Prove: .
8-28 Prove: .
Hint: Consider the case in which 3 texts, at least 2 of which are c-noisy, do not suffice to give a 2c - 1 noisy text for f. Then use the fact that [image].
8-29 Prove: .
8-30 Prove: .
8-31 Let b, [image]. Prove the following:
(a) [image],
(b) [image],
(c) [image],
8-32 Prove the following, which is an analog of Lemma 8.50 for incomplete texts.
.
8-33 Prove: .
8-34 Let [image]. Prove the following:
(a) [image],
(b) [image],
(c) [image],
(d) [image],
(e) [image].
8-35 Let [image]. Prove the following:
(a) [image].


Page 194
(b) [image],
(c) [image],
(d) [image],
(e) [image].
8-36 Using the definition of AscTxtEx as a model, define AscEx. Show that Ex = AscEx. Thus, in the context of function learning, requiring data to be presented in ascending order does not yield any extra learning power.


Page 195
PART III
PART III: ADDITIONAL TOPICS


Page 197
9
Team and Probabilistic Learning
§9.1 Introduction
The paradigms presented so far have modeled empirical inquiry by a single, deterministic, computable scientist. In the present chapter, we consider paradigms that permit more liberal conceptions.
Empirical inquiry in the scientific domain is seldom an individual enterprise. Many scientific breakthroughs result from the efforts of several scientists investigating a problem; scientific success is achieved if one or more of the scientists are successful. This observation about the practice of science can be partially incorporated into our model of empirical inquiry by a ''team" of computable scientists. The team is said to be successful just in case one or more members in the team are successful.
Another variation on the notion of "scientist" is obtained by considering those machines which, in addition to their algorithmic nature, have the added ability to base their actions on the outcomes of random events. Such scientists can be modeled using probabilistic Turing machines (in the sense of Gill [78]).
The present chapter considers identification of functions and languages by teams of computable scientists and by probabilistic scientists.
§9.2 Motivation for Identification by Teams
The next two propositions are commonly referred to as "nonunion theorems." They respectively establish that the classes Ex and TxtEx are not closed under union. That is, the union of two identifiable collections of functions (respectively, languages) is not necessarily identifiable. (Proposition 9.1 is a restatement of Theorem 4.25 due to L. Blum and M. Blum, and Proposition 9.2 restates a fact established in Chapter 4.)
9.1 Proposition Let [image] and [image]. Then, both [image] and [image] are in Ex, but [image].
9.2 Proposition Let [image] and [image]. Then, both [image] and [image] are in TxtEx, but [image].


Page 198
These results may be viewed as a fundamental limitation on our ability to build general purpose devices for empirical inquiry and motivate the use of heuristic methods in Artificial Intelligence. However, they also suggest a weaker criterion of identification in which a team of scientists is employed and success of the team is equated with the success of any member in the team. Let us illustrate this idea in the context of functions.
Consider the collections of functions [image] and [image] in Proposition 9.1. Let M1 Ex-identify [image] and M2 Ex-identify [image]. Now, if we employed the team of M1 and M2 to identify [image] and weakened the criterion of success to the requirement that success is achieved just in case at least one member in the team is successful, then under this changed criterion, the collection [image] is identifiable by the team of M1 and M2. This idea can be extended to teams of n scientists, at least m of which are required to be successful.
We now formalize function and language identification by teams. Anomalies in the hypothesized programs are also incorporated in the definitions.
9.3 Definition (Smith [178]) Let m, [image] and [image].
(a) A team of n scientists M1, M2, . . ., Mn is said to [image] (written: ) just in case f is Exa-identified by at least m of the Mi's.
(b) [image] is the collection of [image] such that some team of n scientists [image] each function in [image].
9.4 Definition (Osherson, Stob, and Weinstein [140]) Let m, [image] and [image].
(a) A team of n scientists M1, M2, . . ., Mn, is said to [image] (written: ) just in case L is TxtExa-identified by at least m of the Mi's.
(b) [image] is the collection of [image] such that some team of n scientists [image] each language in [image].
For both [image] and [image] the fraction [image] is referred to as the success ratio of the paradigm. As has been the practice, the cases a = 0 are simply referred to as [image] and [image]. Most of the results presented in the present chapter are for the case a = 0; other cases are considered in the exercises. Let us note that Definitions 9.3 and 9.4 fail to formalize one aspect of scientific practice that is central to


Page 199
the informal idea of teamwork. When different scientists work separately on the same problem it is often the case that individual progress is recognizable by all concerned. The hypotheses of the individual scientists thus influence each other in a way that is not captured by the paradigms discussed in the present chapter.
§9.3 Team Identification of Functions
We first consider team identification of functions when the success of the team requires any one member in the team to be successful.
The following result says that there are collections of functions for which a correct program can be synthesized by a team of (n + 1) scientists, at least one of which is successful, but for which even a finite variant program cannot be synthesized by a team of n scientists with the requirement that at least one of them be successful.
9.5 Proposition (Smith [178]) For each [image], [image].
Proof: For each [image], let
.
It is easy to verify that [image]. We argue, using a diagonalization argument, that [image]. This argument can easily be generalized to show that [image].
Suppose, by way of contradiction, there exists a team of two scientists, M0 and M1, that witnesses [image]. Then, by the implicit use of the operator recursion theorem, there exists a 1-1, monotonically increasing, recursive function p such that j p(·) (and, hence, W p(·)) is as described in stages below.
We initialize j p(3)(0) = p(0), j p(3)(1) = p(1), and j p(3)(2) = p(2). Enumerate p(3) into W p(0). Set avail = 3. Intuitively, avail denotes the least number such that, for all i > avail, p(i) has not yet been used in the diagonalization. Let x s denote the least x such that j p(3)(x) has not been defined before stage s. Go to stage 0.
Begin ( Stage s )
1. Set avail = avail + 1.
Set cur = avail.
Enumerate p(cur) into W p(1).
For each x < x s, set j p(cur) (x) = j p(3) (x).


Page 200
Set r = s mod 2.
2. Dovetail steps 3 and 4 until, if ever, step 3 succeeds. If and when step 3 succeeds go to step 5.
( Intuitively, if step 3 succeeds in each stage, then [image] and neither M0 nor M1 Ex*-identifies j p(3). )
3. Search for an extension [image] of j p(3)[x s] such that [image].
4. Let x s, s', denote the least x such that j p(cur)(x) has not been defined before substage s' of stage s.
Go to substage 0.
Begin ( Substage s' )
 4.1. Set avail = avail + 1.
Enumerate p(avail) into W p(2).
For each x < x s, s', set j p(avail) (x) = j p(cur) (x).
4.2. Dovetail steps 4.3 and 4.4 until, if ever, step 4.3 succeeds. If and when step 4.3 succeeds, go to step 4.5.
4.3. Search for an extension [image] of j p(cur) [x s, s'] such that [image].
4.4. For x = x s, s' to [image] do set j p(avail) (x) = 0.
4.5 Let [image] be as found in step 4.3.
For each [image], set j p(cur) (x) = y if j p(cur) (x) is not already defined.
Set [image]. (Note the diagonalization.)
 Go to substage s' + 1.
End ( Substage s' )
5. Let s be as found in step 3.
For each [image], set j p(3)(x) = y if j p(3)(x) is not already defined.
Set [image]. (Note the diagonalization.)
Go to stage s + 1.
End ( Stage s )
Now, consider the following cases.
Case 1: Each stage terminates. Let f = j p(3). Clearly, f> is computable and a member of C2 (since f(0) = p(0) and W p(0) = { p(3) }). Also, because of the success of step 3 and the diagonalization at step 5 in each even (respectively, odd) stage, we have that either M0 (respectively, M1) diverges on f or else the last program output by M0 (respectively, M1) on f commits infinitely many convergent errors.


Page 201
Case 2: Some stage s starts but does not terminate. Let r and cur be as defined in step 1 of stage s. Since step 3 does not succeed, M r does not Ex*-identify any extension of j p(3), and thus M r does not Ex*-identify any extension of j p(cur). We have two subcases.
Subcase 2.1: Each substage in stage s terminates. Let f = j p(cur). Clearly, f is computable and a member of C2, since f (1) = p(1) and max(Wp(1)) = p(cur). Also, by the success of step 4.3 and the diagonalization in step 4.5 in each substage, M1-r either diverges on f, or the last program output by M1-r on f commits infinitely many convergent errors.
Subcase 2.2: Some substage s' in stage s starts but does not terminate. In this case, let avail be as of the end of step 4.1 in substage s' of stage s. Let f = j p(avail). Clearly, f is recursive and an extension of j p(cur). Also, f is a member of C2, since f(2) = p(2) and max(W p(2)) = p(avail). However, since step 4.3 does not succeed, M1-r, does not Ex*-identify any extension of j p(cur) and thus does not Ex*-identify f.
From the above eases it follows that [image].
We leave it to the reader to show that the above proposition implies the following corollary which says that increasing the size of team results in identifiability of larger collections of functions.
9.6 Corollary Let
The study of the general case, [image], to which we will return in Section 9.5, is aided by results on identification of functions by probabilistic scientists—our next topic.
§9.4 Identification by Probabilistic Scientists
Computable scientists have played a central role in the paradigms studied thus far. In this section we consider probabilistic scientists that behave like computable scientists except that every now and then they have the ability to base their actions on the outcome of a random event such as the flip of a fair coin.
More formally, a probabilistic scientist P may be construed as an algorithmic machine that is equipped with a fair t-sided coin (or die), where t is an integer greater than 1. P's response to an evidential state s depends, in general, not only on s but also on the outcomes of the coin flips that P performed up to that point. We formalize coin flips and coin flip sequences in the following definition.


Page 202
9.7 Definition Suppose t > 1.
(a) N t denotes {0, 1, 2, . . ., t - 1}, the set of possible outcomes of a flip of a t-sided coin.
(b) For each [image], [image] denotes the collection of all length k sequences of possible flips of a t-sided coin. denotes [image], the collection of all finite t-ary sequences. (A typical variable for elements of [image] is r ).
(c) [image] denotes the collection of infinite sequences of flips of a t-sided coin. Elements of [image] are called oracles for a t-sided coin or t-ary oracles. O will range over oracles.
We treat a t-ary oracle somewhat like a text for the finite language N t and carry over notation for texts to oracles as follows.
9.8 Definition Let t > 1.
(a) Let [image]. The length of r is denoted by [image] For [image], the n th member of r is denoted by r (n), and the initial sequence of length n in r is denoted by r [n].
(b) Let O be a t-ary oracle. Then, the n th member of O is denoted O(n). The initial finite sequence of O of length n is denoted O[n].
Let P be a probabilistic scientist equipped with a t-sided coin, [image], and let [image] be given. Then P r ( s ) denotes the output (if any) of P on s after [image] or fewer coin flips are read from r . That is, the outcome of P's first coin flip (if it occurs) is r (0), the outcome of the second flip is r (1), and so on. If P tries to perform more coin flips than [image] in responding to the evidential state s , then P r ( s ) is undefined. Let O be an oracle. Then PO( s ) denotes PO[n]( s ), where n is the least number, if any, such that PO[n]( s ) is defined; if no such n exists, then PO( s ) is undefined. Finally, PO(f) is the limit of P O(f[m]) (as [image]) as usual. If [image] to an index for f, we say that P O Ex-identifies f. Intuitively, the probability of P Ex-identifying f will be the same as the probability of { [image] Ex-identifies f}. We formalize this notion in Section 9.4.2 after reviewing some basic probability theory in the next subsection.
Convention: For the rest of this chapter we shall assume that probabilistic scientists are total in the sense that, for each P, O, and s , there is an n such that PO[n]( s ) is defined. It can be easily verified that this assumption does not affect the generality of the results discussed below.
The subject of identification by probabilistic scientists was first studied by Freivalds [63] and by Pitt [149, 150]. Our presentation closely follows that of Pitt.


Page 203
§9.4.1 Background Probability Theory
A probability space consists of
• W , a set of possible outcomes of experiments;
• ß, a collection of subsets of W (satisfying conditions of Definition 9.9 below), called events or measurable sets; and
• pr, a function from ß to the real interval [image] (satisfying the conditions of Definition 9.10 below), called a probability measure.
Before discussing the conditions on ß and pt, we consider the familiar example of the uniform probability measure on a finite, nonempty set W . In this case ß = the collection of all subsets of W and pr(E) = card(E)/card( W ) for [image]. So if W = N2, then the probability of 0 (heads) = pr({0}) = 1/2 = pr({1}) = the probability of 1 (tails) and pr( W ) = 1. If [image], then the probability of an even number of 0's in three flips = pt(E) (where [image]. If W is a finite or countable set, then one can usually take every subset of W to be an event. If W is uncountable (such as [image]), then set-theoretic difficulties typically force one to take ß to be a proper subset of the powerset of W that satisfies the properties given in the following definition.
9.9 Definition [image] is a Borel field (or s -algebra) if and only if
(a) [image],
(b) [image], and
(c) ß is closed under countable unions, i.e., if [image] is countable, then [image].
The smallest Borel field that contains a particular collection, A, of subsets of W is called the Borel field generated by A.
As [image], Borel fields are also closed under countable intersections.
9.10 Definition A probability measure on a Borel field ß of subsets of W is a real-valued function pt: such that
(a) pr( W ) = 1, and
(b) pr is countably additive, i.e., if [image] is a countable collection of pairwise disjoint sets, then [image].


Page 204
For each [image] and t > 1, let [image] and, for each [image] define [image]. So ( [image], [image], [image]) is just the uniform probability space on [image]. Easy exercise: Show that, for each k and t, [image] and [image] satisfy the conditions for a Borel field and probability measure, respectively.
Now let us consider the problem of constructing for [image] an appropriate probability space ( [image], [image], [image]) where, as usual, t is an integer greater that 1. Somehow, this space should be the "limit" of the ( [image], [image], [image])'s. Moreover, we want the probability that an infinite sequence of coin flips starts with a 0 (respectively, 1, . . ., t - 1) to be 1/t, and, in general, we want the probability that an infinite sequence of coin flips has r (a particular finite t-ary sequence) as an initial subsequence to be [image]. So, defining, for each [image],
we know that all of the [image] should be in [image] with [image]. Thus, we take [image] to be the Borel field generated by [image], and, less obviously, for each [image], define
It can be shown (see Dudley [56]) that this [image] is a probability measure for [image]. This probability space on [image] will suffice for our purposes. Henceforth, we will say that an [image] is measurable if and only if [image]. Many natural sets turn out to be measurable, as shown by the next lemma. First, we introduce a bit of terminology. For [image] and [image], we say a relation [image] is arithmetic if and only if P can be expressed in the language of first-order arithmetic augmented by a 1-ary function variable O. So for example, the relation "there are infinitely many n such that O(n) = 0" is expressible by: . (Rogers discusses and characterizes such arithmetic relations in Section 15.2 of [158].)
9.11 Lemma Suppose [image], [image], and [image] is arithmetic. Then, for each x1, . . ., xk, the set [image] is measurable.
Proof: Without loss of generality, suppose that for all O, x1, . . . xk,


Page 205
where [image], each Q i is either the quantifier $ or " , and R can be expressed without quantifiers. We proceed by induction on n. Suppose n = 0. Then, there is a number m such that in the quantifier free statement that expresses P, all references to elements of O involve elements [image] m. Hence it follows that [image] can be expressed as a finite union of particular [image] with [image]. Thus the base case follows. Suppose n > 0 and the lemma holds for n - 1. Then for each y1, the collection,
is measurable. Moreover, if Q1 = $ , then [image] and if Q1 = " , then [image]. In either case it follows that [image] is measurable. Hence, the induction step follows.
Fix a probabilistic scientist P and [image] and let i f be an index for f. Then we have that [PO Ex-identifies f] is equivalent to
which, by standard tricks (see Section 14.8 of Rogers [158]), is seen to be arithmetical. Hence, as desired, we have
9.12 Lemma (Pitt [149, 150]) For each probabilistic scientist P and [image], { [image] Ex-identifies f} is measurable.
§9.4.2 Probability of Function Identification
The work of the last subsection justifies the following definition.
9.13 Definition (Pitt [149, 150]) Let P be a probabilistic scientist equipped with a t-sided coin ( [image]) and [image]. Then, [image].
The next lemma says that the notion of probabilistic Ex-idetifiability does not depend on the value of t.
9.14 Lemma (Pitt [149, 150]) Let t > 2. Let P be a probabilistic scientist with a t-sided coin. Then, there exists a probabilistic scientist P' with a two-sided coin such that for each [image], [image].


Page 206
The proof of this lemma involves more technical probability theory than we want to discuss here. We refer the reader to Pitt [150] for its proof. The lemma frees us from specifying the number of sides of the coin, thereby allowing us to talk about probability function [image] without specifying t. For this reason, we will refer to [image] as simply pr in the sequel. Also, we are at liberty to use whatever number of sides of a coin that is convenient for the presentation at hand.
9.15 Definition (Pitt [149, 150]) Let [image].
(a) We say that P Prob pEx-identifies f (written: ) just in case
(b)
The next proposition establishes a link between team and probabilistic inference. It says that any class of functions team-identifiable by a team of scientists of size n can also be identified by a single probabilistic scientist with probability [image] 1/n.
9.16 Proposition (Pitt [149, 150]) Let, [image] Then [image].
Proof: Let [image], as witnessed by the team of scientists M1, M2, . . ., Mn. Let P be a probabilistic scientist, equipped with an n-sided coin, that behaves as follows. P on [image] first flips its coin once and obtains a number [image] and henceforth simulates scientist Mi+1 on f. Clearly, for each [image], [image].
Pitt [149, 150] also established the converse of the above result: for each [image], [image] and thus showed that probabilistic identification and team identification are successful on essentially the same collections on functions. This result will be an immediate corollary of Proposition 9.24 below. In order to prove this result, Pitt used a technique of calculating probabilities on "infinite computation trees" described in the next subsection. To facilitate the description, it is helpful to standardize the way probabilistic machines make use of their coin flips—see the next definition. The lemma following this definition shows that we may, without loss of generality, assume all probabilistic scientists are so standardized.
9.17 Definition (Pitt [149, 150]) Suppose P is a probabilistic scientist. P is nice just in case P is equipped with a two-sided coin and the behavior of P on a function f is an infinite sequence of rounds each of which consists of the following three phases carried out in the order indicated.


Page 207
Phase a: Receive an element of the graph of f.
Phase b: Issue an hypothesis.
Phase c: Flip the coin.
9.18 Lemma (Pitt [149, 150]) Let P be a probabilistic scientist. Then there exists a nice P' such that, for each [image], [image].
§9.4.3 Infinite Computation Trees
Let P be a nice probabilistic scientist and let [image] be given. The infinite computation tree for P on f, denoted [image], is a record of P's behavior on all possible 2-ary oracles when P is fed the graph of f in canonical order. We describe [image] and its relation to probabilistic Ex-identification in this subsection.
Convention: Throughout this subsection we will keep P and f fixed. All terminology and notation will be understood to be relative to the choice of particular P and f. When we use these terms and notation in later sections, the particular P and f we have in mind will always be understood.
is an infinite complete binary tree. Each node of [image] is labeled with an element of [image]. The root of [image] is labeled with [image] (the empty sequence) and, if a. node of [image] is labeled with r , then the node's left child is labeled [image] and its right child is labeled [image]. A node with label r represents the state of P just after phase b of round [image] when P is fed the graph of f in canonical order and receives r as the result of its first [image] coin flips; guess( r ) denotes the hypothesis issued by P in phase b of this round. We identify nodes with their labels so that when we speak of node r we mean the node in [image] with label r . The depth of node r is simply [image]. Hence, the depth of the root is 0.
A path [image] in [image] is an infinite sequence of nodes [image], [image], [image], . . . , such that, for each i, [image] and [image] extends [image]. (That is, [image] is the root and [image] occurs at depth i in the tree and is the parent of node [image].) [image] will range over paths in [image]. There is an obvious one-to-one correspondence between paths and 2-ary oracles. By convention, when we speak of the measure of a set of paths, we will mean the measure of the corresponding set of oracles. The next definition introduces the path analog of the [image].
9.19 Definition For each node r of [image], [image] denotes
It is obvious that [image] corresponds to [image], and, hence, [image] The measurable sets [image] will be used in computing probabilities of more interesting collections of


Page 208
paths. To help talk about these more interesting collections, the next definition describes what it means for a path in [image] to converge and introduces some terminology about convergence of paths.
9.20 Definition
(a) We say that [image] converges to j just in case, for all but finitely many i, [image].
(b) We say that [image] converges at node r just in case, for [image], [image] and k is the least number such that for all [image], [image].
(c) For each r , C r denotes [image].
(d) We say that a path [image] k-agrees with C r just in case:
(i) [image] and [image],
(ii) [image], . . . , k, [image], and
(iii) [image] or [image].
(e) For each r and each [image], C r ,k denotes [image].
(f) For each [image], C(A) denotes [image].
It follows from Lemma 9.11 that all of the C r 's, C r k's, and C(A)'s are measurable. We shall be interested in computing pr(C(A)) for particular sets A, and the C r 's and C r k,'s will be our avenue for doing this. The next lemma summarizes the relationship between the C(A)'s and C r 's and states some elementary properties of the C r 's and C r ,k,'s. We leave its proof to the reader.
9.21 Lemma (Pitt [149, 150]) Fix r and k with [image]. Then:
(a) For each [image], [image].
(b) For each r and [image] [image] and [image] .
(c) For each r [image] C r ,k and [image].
(d) For distinct r and r ', [image].
Fix an A and let [image]. It follows from the above lemma that C(A) is the disjoint union of the members of C, and hence [image]. The probability of C r , in turn, is the monotone decreasing limit of [image] The next lemma shows how to compute the probabilities of the C r k's.


Page 209
9.22 Lemma (Pitt [149, 150]) Suppose [image] and N p,k denotes [image]. Then,
(a) [image], and
(b) pr(C r k) can be computed by looking at only the first k + 1 levels of [image].
Proof: We first argue
Claim: C r k is the disjoint union of members of [image].
Proof of the Claim: For distinct r 0 and r 1 in N r ,k, [image] and [image] are disjoint because both nodes r 0 and r 1 are at depth k and, since they are distinct, no path can pass through both.
Suppose [image]. Then, [image] passes through some [image], and hence [image].
Suppose [image]. Since the definition of N r k does not depend on nodes deeper than level k + 1, all paths passing through [image] must be in C r ,k. Hence, [image].
The claim thus follows.
Therefore, by the claim and the countable additivity of pr we have
and so, part (a) follows.
It is easy to see that N r ,k can be effectively determined by observing only the first k + 1 levels of [image]. Thus, part (b) follows from part (a).
We now present a lemma that is crucial to the proof of the main result of this section.
9.23 Lemma (Pitt [149, 150])Suppose [image] and [image]. Then, there is a finite collection of nodes { r 0, . . ., r k} such that [image], for each [image], and [image].
Proof: Let [image]. By Lemma 9.21 we have, for all [image],
Now, if the sum of infinitely many nonnegative quantities is > p, then there is a finite subcollection of these that sum up to some number > p. Therefore, there is a finite [image] such that { r 0, . . ., r k} are as required.


Page 210
§9.4.4 The Key Correspondence
We are now in a position to prove
9.24 Proposition (Pitt [149, 150]) For each [image] and [image], [image].
This proposition immediately follows from the next proposition and the fact that FOex = Ex (see Exercise 6-7 in Chapter 6).
9.25 Proposition (Pitt [149, 150])Let p > 1/(n + 1) and [image]. Then, there are M1, M2, . . ., Mn such that [image].
Proof: Let P be a probabilistic scientist such that [image].
We construct from P a team of n deterministic scientists M1, M2, . . ., Mn as follows. (Note: We use the usual ordering on [image] below.)
Begin ( Mi( s ), with [image] )
Construct [image], the first k + 1 levels of [image], by simulating P with input s and all 2-ary sequences of length k.
For each node r in [image], compute pr(C r ,k).
Let r k be the least node in [image], if any, such that [image].
If r k is found,
then output the canonical index of { [image]}
else output 0
End (M i( s ))
Notation: Let goodf denote the collection of all j -indices for f, i.e., [image]. Then, C(goodf) is the collection of all paths (oracles) that result in successful Ex-identification of f by P. Hence, pr(P Ex-identifies f) = pr(C(goodf)).
Now, [image] implies that [image]. Recall that C(N) is the collection of all converging paths in [image]. Hence, [image] and [image]. Since [image], there exists an [image] such that [image].
We argue that the scientist Mm FOex-identifies f. Let us focus on the behavior of Mm on f[k]. Mm correctly assumes that the probability of converging paths in [image] is greater than m/(n + 1) and attempts to find, in the limit, a finite collection


Page 211
of nodes where most paths converge. To this end, Mm first finds the smallest r k such that [image] and then outputs the canonical index for the finite set [image].
Now, by Lemma 9.23, there exists a collection of nodes { r 0, . . . , r v} in [image] such that [image]. This implies that there exists a smallest numbered node r * such that [image], for all k > depth(j). (Choosing any [image] satisfies the inequality.)
The result follows from the following claim.
9.26 Claim
(a) For all but finitely many k, r k = r *.
(b) [image] contains a j -index for f.
We can deduce the proposition from the claim as follows. Since Mm, fed f[k], outputs the canonical index for the finite set [image], (a) implies that Mm converges to the canonical index for [image]. Moreover, according to (b), [image] contains a j -index for f, thereby implying that Mm FOex-identifies f. We now prove the claim.
Part (a). It is easy to verify that part (a) follows from the choice of r *.
Part (b). Since goodf is the set of all j -indexes for f, (N- goodf) is the collection of all such j -indexes that are not for f. Now, observe that since C(goodf) and C(N - goodf) are disjoint, pr(C(N)) = pr(C(goodf)) + pr(C(N - goodf)). We also know by the hypothesis of the proposition and the choice of m that [image] and pr(C(goodf)) > 1/(n + 1). Thus, pr(C(N - goodf)) < m/(n + 1).
Let I denote the set [image]. Observe that [image]. Therefore, at least one element in I must be a correct j -index for f, because otherwise [image], [image], and [image], a contradiction. Hence, I contains a j -index for f.
This completes the proof of the proposition.
As an immediate corollary to Propositions 9.16 and 9.24, we have the following:
9.27 Corollary (Pitt [149, 150]) For each [image], [image].
The above corollary, together with Corollary 9.6 implies the following:
9.28 Corollary (Pitt [149, 150]) For each [image], [image].


Page 212
Thus, the team hierarchy is contained in the probabilistic hierarchy. However, it turns out that the probabilistic hierarchy is no finer than the team hierarchy. To see this, let [image] . Clearly, [image]. Now, by Theorem 9.24, [image]. But, Corollary 9.27 implies that [image]. Thus, [image]. We have essentially shown the following corollary, which says that the probabilistic hierarchy is exactly the same as the team hierarchy.
9.29 Corollary (Pitt [149, 150]) For each [image] and each [image], [image].
§9.5
Corollary 9.29 can be used to characterize generalized team identification paradigms in which more than one member of the team is required to be successful. To make this clear we rely on the following definition.
9.30 Definition For each [image], let [image], where [image] is such that [image].
It is easy to verify that for [image], [image]. The next result is simply a restatement of Corollary 9.29 using this notion.
9.31 Corollary (Pitt and Smith [151]) For each [image], we have [image].
The following result says that all collections of functions that can be identified by a team of n scientists with the requirement that at least m out of n are successful can also be identified by a single probabilistic scientist with probability [image].
9.32 Proposition (Pitt and Smith [151]) Suppose [image] and [image]. Then, [image].
Proof: Let [image]. Let M1, M2, . . . , Mn be (deterministic) scientists witnessing [image]. Let P be a probabilistic scientist equipped with an n-sided coin. The behavior of P can be described thus: P, before receiving any input, flips its n-sided coin and obtains a number [image], P then simulates the deterministic scientist Mi+l. Clearly, for each [image], [image]. Hence, [image].


Page 213
The next result completely characterizes [image] in terms of probabilistic identification.
9.33 Proposition (Pitt and Smith [151]) Suppose [image].
Then,
Proof: We first show that [image]. The definition of IN implies that for all [image], IN(IN(p)) = IN(p). Now, by Corollary 9.31, we have [image].
We now show that [image]. Since [image], Proposition 9.32 implies that [image]. Observe that [image]. Thus, by Corollary 9.29, we have [image]. Hence, [image]. We need now only show that [image]. Observe that for any [image], [image]. Thus, [image]. Since [image], we have [image]. Therefore, [image].
§9.6 Team and Probabilistic Identification of Languages
Team identification of languages was introduced in Definition 9.4. We now adapt the machinery of probabilistic scientists introduced in Section 9.4 to language identification.
Let P be a probabilistic scientist equipped with a t-sided coin and let T be a text for some language [image]. Then, the probability of P TxtEx-identifying T is taken to be [image]. It follows from Lemma 9.11 that {O | PO TxtEx-identifies T} is measurable.
The following definition, motivated by the above discussion, introduces the probability of identification of a text.
9.34 Definition (Pitt [149])Let T be a text and P be a probabilistic scientist equipped with a t-sided coin ( [image]). Then, [image] denotes [image].
The next definition describes language identification by probabilistic scientists. As in the case of function identification, there is no loss of generality in assuming a two-sided coin, since the analog of Lemma 9.14 can easily be shown to hold in this new context.


Page 214
We are thus freed from specifying the number of sides of the coin, and can write the probability function without its subscript t. In the sequel, we shall in fact refer to [image] by pr.
9.35 Definition (Pitt [149]) Let [image].
(a) P ProbpTxtEx-identifies L (written: ) just in case for each text T for L [image].
(b)
We now discuss some results about team and probabilistic identification of languages. In the context of functions, it is a simple consequence of the equivalence of team and probabilistic identification that if the success ratio of a team is greater than [image], then the team can be simulated by a single scientist without any loss in learning power. Such a cut-off ratio is referred to as the aggregation ratio of the team learning paradigm. It is also clear that in the context of functions the only success ratios of interest are of the form [image] with k > 1.
The story is different for language identification. First, the aggregation ratio for language identification turns out to be [image]. Second, the notions of team and probabilistic identification fail to coincide in the language case. Probabilistic identification turns out to be strictly more powerful than team identification. Finally, the results for languages arc more difficult to obtain and only a partial picture is known. In what follows, we first present results for team identification of languages with success ratios [image]. This is followed by the presentation of some results for success ratios of the form [image] with k > 2.
Team language identification with success ratio
We first consider when a team of scientists can be simulated by a single scientist without loss of learning ability. The next proposition below says that the collections of languages that can be identified by teams with success ratio greater than [image] (that is, more than two-thirds of the members in the team are required to be successful) are the same as those collections of languages that can be identified by a single scientist.
9.36 Proposition Suppose j and k are such that [image]. Then [image].
To facilitate the proof of the above proposition and other results in this chapter, we define the following technical notion.


Page 215
9.37 Definition Let Â be a nonempty finite multiset of grammars. Then the grammar majority(Â) is defined to be a grammar such that [image].
Clearly, majority(Â) can be defined using the s-m-n theorem (Theorem 2.1). Intuitively, majority(Â) is a grammar for a language that consists of all such elements that are enumerated by a majority of grammars in Â. Below, whenever we use a set as an argument to majority we assume the argument to be a multiset.
Proof (of Proposition 9.36): Let j and k be as given in the hypothesis of the proposition. Let [image] by a team consisting of scientists M1, M2, . . . , Mk. We then describe a scientist M that [image].
For a finite sequence s and a scientist M', define
Intuitively, conv(M', s ) is the length of the longest subsequence of a where M' conjectures a hypothesis distinct from the one it conjectures on s .
Let [image], [image], . . ., [image] be a permutation of l, 2, . . . , k, such that, for [image],
Note: ''<" here refers to ordering on pairs: (k0, l0) < (k1, l1) just in case either k0 < k1 or else k0 = kl and l0 < l1.
For each s , define [image].
To complete the proof it must be shown that if the team consisting of scientists M1, M2, . . . , Mk [image], then M TxtEx-identifies L. This is the subject of Exercise 9-8.
Proposition 9.38 below says that the collections of languages that can be identified by a team with success ratio [image] (that is, at least two-thirds of the members in the team are required to be successful) are the same as those collections of languages that can be identified by a team of 3 scientists, at least 2 of which are required to be successful.
9.38 Proposition For each j > 0, [image].
Proof: Let j be as given in the hypothesis of the proposition. Suppose a team consisting of scientists M1, . . . , M3j [image]. We then describe scientists [image], [image], and [image] such that the team consisting of [image], [image], and [image] witnesses [image].


Page 216
Let conv be as defined in Equation 9.1. Let [image], [image], . . . , [image] be a permutation of 1, 2, . . . , 3j, such that, for each r = 1, . . . , 3j- 1,
Define scientists [image], [image], and [image] so that for each s :
Now suppose T is a text for [image]. Consider the following two cases.
Case 1: At least 2j + 1 of the scientists in the team consisting of scientists M1, M2, . . . ,M3j converge on T. In this case, it is easy to verify that [image]. Moreover, [image] (respectively, [image]) TxtEx-identifies T if [image] (respectively, does not TxtEx-identify T).
Case 2: Not case 1. In this case, [image] and [image].
We leave it to the reader to modify the above proof to show the following result, which says that probabilistic identification of languages with probability of success at least [image] is the same as team identification of languages with success ratio [image].
9.39 Proposition [image] .
Proposition 9.40 below establishes that [image] is indeed the cut-off point at which team identification of languages becomes more powerful than identification by a single scientist.
9.40 Proposition [image] .
Proof: Let [image] be as in the proof of Proposition 8.22. By Lemma 8.23, [image]. So we need only show that [image]. Consider a team consisting of three scientists M0, M1, and M2. For each [image], scientist Mi behaves as follows: On T[n], Mi outputs the maximum y, if any, such that [image]. It is easy to verify that if T is a text for some language in [image], then at least two of the scientists will converge in the limit to a grammar for content(T). Thus, [image].


Page 217
Team Language Identification for Success Ratios
We first discuss results for success ratio [image]. In the context of functions, the following result immediately follows from Proposition 9.33.
9.41 Corollary (Pitt [149], Pitt and Smith [151]) For all j > 0, [image].
This result says that the collections of functions that can be identified by a team with success ratio 1/2 are the same as those collections of functions that can be identified by a team employing two scientists and requiring at least one to be successful. Consequently, [image]. In other words, there is nothing to be gained by introducing redundancy into a team learning functions.
Surprisingly, in the context of language identification, Proposition 9.42 below implies that for success ratio [image] there is something to be gained by introducing redundancy. As a consequence of this result, a direct analog of Pitt's connection for function inference does not lift to language learning.
A proof of this result can be obtained by a somewhat complex version of the proof of Proposition 9.40. We direct the reader to Jain and Sharma [92] for the details.
9.42 Theorem [image] .
Even more surprising is the next proposition, which implies that the collections of languages that can be identified by teams employing six scientists and requiring at least three to be successful are exactly the same as those collections of languages that can be identified by teams employing two scientists and requiring at least one to be successful!
9.43 Proposition For all j, [image].
Proof: Let j be as given in the hypothesis of the proposition. Suppose a team consisting of scientists M1, M2, . . . , M4j+2 [image]. We describe two scientists, [image] and [image], that [image].
Let cony be as defined in the proof of Proposition 9.36. Let [image], [image], . . ., [image] be a permutation of 1, 2, . . . , 4j + 2 such that, for each r = 1, . . . , 4j + 1,
For each r and s , define


Page 218
Let [image] be the (lexicographical least) set of cardinality j such that, for [image], [image] with [image] and [image], we have [image].
For each s , let [image] and [image] be such that:
Claim: The team consisting of [image] and [image] witnesses that [image].
Proof: Let T be a text. If j + 1 of the first 2j + 1 converging scientists on T converge to a correct grammar, then clearly [image] converges to a correct grammar. Otherwise, [image] in its selection of S s , removes j + 1 incorrect scientists from the first 2j + 1 converging scientists, ensuring that at least j + 1 of the scientists captured in S s and the next j + 1 converging scientists (that is, scientists converging in order 2j + 2, . . . , 3j + 2) converge to a correct grammar. This will guarantee that [image] converges to a correct grammar. Thus, the claim and the proposition follow.
The picture for team success ratio [image] is completed by Proposition 9.44 below. The proof is complicated; the reader is directed to Jain and Sharma [92] for the details. We leave it to the reader to verify the corollary following the proposition.
9.44 Proposition For all m and [image] such that 2n does not divide m, we have that [image].
9.45 Corollary For all m and [image] , [image] divides n or m is odd.
Proposition 9.44 can also be used to show the next result that shows that probabilistic identification of languages with probability of success at least [image] is strictly more powerful than team identification of languages with success ratio [image] (see Jain and Sharma [92]).
9.46 Proposition [image] .
The next proposition notes a similar fact about the power of probability over teams. Again, we direct the reader to Jain and Sharma [92] for the details.
9.47 Proposition For all [image] , [image].


Page 219
§9.7 Bibliographic Notes
Team identification of functions ( [image]) was first defined by Case, motivated by the nonunion theorem of Blum and Blum [18]. It was studied extensively by Smith [178]. The general case of team identification (m out of n) is due to Osherson, Stob, and Weinstein [139]. Probabilistic scientists in the context of learning were first considered by Freivalds [60]. Pitt [149] was the first to notice the connection between team identification and probabilistic identification of functions.
Jain and Sharma [92] investigated team identification of languages. Proposition 9.36 also appears in Osherson, Stob, and Weinstein [139], and may also be shown using an argument from Pitt [149] about probabilistic language learning.
Recently there has been lively interest in the interaction between probability, teams, and the number of allowable mind changes (see Wiehagen, Freivalds, and Kinber [201] and Daley and Kalyanasundaram [48]). Considerable work has been devoted to the special case of 0 mind changes (i.e., finite identification). We direct the reader to Freivalds [63], Jain, Sharma, and Velauthapillai [97], Daley, Pitt, Velauthapillai, and Will [53], Daley, Kalyanasundaram, and Velauthapillai [50]. The problem of teams for Popperian finite identification of functions is addressed by Daley, Kalyanasundaram, and Velauthapillai [51] and Daley and Kalyanasundaram [49].
Allowing teams of finite learners to make up to a finite number of errors in the conjectured hypothesis has been addressed by Daley, Kalyanasundaram, and Velauthapillai[52]. Behaviorally correct function identification by teams has been studied by Daley [46, 47]. In the context of language identification, work has hardly begun on other criteria. We direct the reader to Jain and Sharma [90] for results on finite, vacillatory, and behaviorally correct identification of languages by teams. Meyer [130] has investigated probabilistic identification of indexed families of computable languages (see Meyer [131] for interaction between monotonicity constraints and probabilistic identification of indexed families of computable languages).
An attempt at investigating some general properties of teams has been made by Ambainis [2]. The notion of asymmetric teams has been introduced and studied by Apsitis *, Freivalds, and Smith [7].
§9.8 Exercises
9-1 This exercise investigates whether, in the context of functions, anomalies in the final program can be traded for extra team members. Show: For all i, [image] and [image], [image],where [image].


Page 220
9-2 This exercise establishes that the tradeoff established in Exercise 9-1 is optimal. For each r, [image], define
Show the following:
(a) for all k, [image], where [image].
(b) [image]. Hint: Use a priority construction.
9-3 Show that [image] if and only if (i) [image] and (ii) b = * or [image].
9-4 Show that: .
9-5 (Pitt [149, 150]) Adapt the definition of ProbpEx to incorporate anomalies in the final program. Then establish the following analog of Corollary 9.29: For all [image], [image], and [image], [image].
9-6 (Pitt and Smith [151]) Establish the following analog of Proposition 9.33: For all [image] and all m, [image] with [image], [image].
9-7 Prove: For all j, [image] with [image] and [image], [image]. Observe that this result implies that, for all j, [image] with [image], [image].
9-8 Complete the proof of Proposition 9.36.
9-9 Prove: For all j > 0 and [image], [image]. Observe that this result implies that, for all j > 0, [image].
9-10 Prove: For all i, [image] , [image]. Observe that this result implies that, for j, [image].


Page 221
10
Learning with Additional Information
§10.1 Introduction
Scientific inquiry almost never starts from scratch. Previous inquiry, common sense, or mere intuition cut back the range of potential realities that scientists are willing or able to consider. In the favorable case, reducing the search space leaves reality among the possibilities still under consideration. (Otherwise, the door is wide open for frustration.) In the case of linguistic development, there is broad agreement that successful language acquisition depends upon limitations in the class of potential languages that the child is willing to impute to her caretakers. Indeed, if all r.e. sets were genuine candidates for natural languages, the child might get stuck conjecturing the finite set of sentences heard to date!
It is clear that our models of inquiry (either scientific or developmental) should represent such a priori restrictions on the class of possible hypotheses. To the present point in our discussion, however, such restrictions have been handled in the crudest possible way. We have simply declared a particular collection of functions or languages to be relevant to scientific success, and allowed the scientist to fail with impunity on the others. For example, to say that [image] is identifiable means that if the class of possible realities is limited to [image], then some scientist can reliably determine which member of these potentialities is actual. The curtailment of possible reality to [image] is modeled by including no more than [image] in the criterion of successful inquiry. In this way it is possible to ask whether success can be guaranteed if reality is pinned down a priori to [image]. For [image] the answer is Yes; the answer is negative for many other collections of functions and languages — which is what makes the subject interesting. Nevertheless, much is missing from our account of the scientist's starting point. Not every collection of functions or languages need constitute a feasible or meaningful restriction on hypotheses, yet our theory provides no natural means for enforcing such a distinction.
The issue of scientific starting points is so fundamental and complex that we cannot hope to provide much insight at the present stage of theory construction. (Perhaps the reader will consent to visit us again when the book is in its fourth or fifth edition?) We would nonetheless like to discuss one aspect of the topic for which some results have been obtained. The class of plausible hypotheses that come to the mind of a scientist might interact with the character of the true hypothesis. In other words, since the scientist is


Page 222
part of (or at least connected to) the reality she. is trying to discover, she might have a certain set of ideas if the world is one way, and a, different set if the world is another. To take the starkest example, if DNA had different chemical properties than it does then geneticists (whose minds are partly determined by their own stock of DNA) might have started off with a different set of potential hypotheses about enzyme production and cell regulation. This kind of interaction suggests a richer representation of scientists, to be pursued in the present chapter. Specifically, scientists will be fitted out with a numerical parameter that communicates partial information about the reality inscribed in the text they are examining. In this way, the correct hypothesis impacts the class of potential realities for which the scientist is suited. We shall consider two such parameterization schemes, as follows.
Upper bounds on hypotheses. First, we shall assume that scientists have prior information about the size of a correct explanation for the phenomenon under investigation. Specifically, they are given an upper bound on the minimum size program for the function they are facing. Section 10.2 considers the extent to which this kind of information facilitates inquiry.
Approximate hypotheses. Second, we assume that scientists have approximately true theories about the language or function with which Nature confronts them. The utility of different kinds of approximations will be examined in Section 10.3.
§10.2 Upper Bound on the Size of Hypothesis
We begin by considering the impact on function identification of advance information about the size of the smallest, explanatory hypothesis for the incoming data. Then we consider the analogous issue for language learning.
§10.2.1 Function Identification with Program Size Upper Bound
Recall from the discussion on page 23 that our standard program size measure is [image] That is, the size of program index p is simply p itself. This measure, while not completely natural, is mathematically convenient and, as discussed in Chapter 2, recursion theoretically equivalent to any other program size measure (Definition 2.8). Thus, in the following, "an upper bound on the size of the minimal sized hypothesis for [image] " shall mean "an upper bound on the minimal index for f." Such additional information can


Page 223
be incorporated into the identification paradigm by viewing a scientist as computing a mapping from N × SEG into N, where the first argument is the size bound. We let M, with or without decorations, range over such scientists; it will be clear from context if we mean a scientist with or without additional information. Thus, M(x, s ) denotes the hypothesis conjectured by scientist M on evidential state s and additional information x. The following definition formalizes the notion of convergence of a scientist on a function in the presence of additional information.
10.1 Definition [image] (read: M on f with additional information x converges) just in case there exists an i such that for all but finitely many n, M(x, f[n]) = i. If [image], then M(x, f) is defined = the unique i such that for all but finitely many n, M(x, f[n]) = i; otherwise, M(x, f) is said to be undefined.
The next definition extends the Ex paradigm to model situations where a scientist, in addition to being fed a graph of the function, is also presented with an upper bound on the minimal program index for the function. The definition below also models cases in which an upper bound may only be available for the minimal program index for a finite variant of the function being identified. To this end, for [image]), we let MinProg c(f) denote the minimal program index in the j -programming system that computes f with at most c errors, i.e., [image].
10.2 Definition Let a, [image].
(a) M Bexa,c-identifies f (written: ) just in case, for all [image], [image] and j M(x,f) =a f.
(b) [image].
Thus a scientist M Bexa,c-identifies f just in case M, fed the graph of f and an upper bound on MinProg c(f), converges to an index for a program that computes f with at most a errors. The notion of Bex0,0-identification was first studied by Freivalds and Wiehagen [67]. In the Bexa,c paradigm, a is the bound on the number of errors allowed in the converged program and c is the bound on the number of errors allowed in the additional information. The reader should note that in this paradigm a scientist may converge to different indexes for different upper bounds. However, if we further require that the final converged index be the same for any upper bound, we get a new identification paradigm defined below.


Page 224
10.3 Definition Let a, [image].
(a) M UniBexa,c-identifies f (written: ) just in case, for some i with j i =a f, we have that for every [image], [image].
(b) [image].
The UniBex0,0-identification criterion was first introduced by Freivalds and Wiehagen [67]. The following proposition is immediate.
10.4 Proposition Let [image] such that [image]. Let [image] such that such that [image]. Then,
(a) [image].
(b) [image].
(c) [image].
(d) [image].
Proposition 10.4 suggests that the highest quality additional information is an upper bound on the minimal O-error program and the worst quality is an upper bound on the minimal *-error program. The natural question is: upon replacing the [image] in the hypothesis of the above proposition with <'s, do the containments become strict? Another immediate observation is that for [image], [image]. Again, we would like to know whether this containment is strict. The results below, together with the exercises, answer these questions.
The next proposition shows that even the best quality UniBex type of additional information does not always compensate for allowing an extra error in the final program. That is, there are collections of functions for which an (a + 1)-error program can be identified, but for which an a-error program cannot be UniBex-identified even if the scientist has knowledge of an upper bound on the minimal O-error program index of the function.
10.5 Proposition For all [image], [image].
Proof: Let [image], which clearly is in Exa+1. Fix an arbitrary scientist M. We shall exhibit a function [image] that M fails to UniBexa,0-identify. The f in question will be computed by one of a repetition-free, r.e. sequence of programs, p(0), p(1), p(2), . . . constructed through implicit use of the operator recursion theorem (Theorem 2.6).


Page 225
We give an informal effective construction of the j p(i)'s in successive stages s = 1, 2, 3, . . . . At the beginning of stage s > 0, j p(s) will be completely undefined and j p(0) will be defined only on the initial segment {0, . . . , n s - 1}, where n s denotes the least number not yet in domain ( j p(0)). We initialize j p(0)(0) to p(0) and go to stage 1.
Begin ( Stage s )
Set j p(0)(n s) =1, and for each [image], set j p(s)(x) = j p(0)(x).
Let j = M(p(0), j p(0)[n s + 1]).
If M(p(s), j p(s)[n s + 1]) = j, then go to step 1, else go to step 2.
Step 1.
Let [image] be the least x not yet in domain ( j p(0)).
For l = 0, . . ., a, set [image].
Set [image].
Repeat
Set j p(s)(y) = j p(0)(y) = 0 and reset y = y + 1.
until, if ever, at least one of the following two conditions holds.
Condition 1A: M(p(s), [image].
Condition 1B: .
Step 1a. If Condition 1A holds then go to step 2.
Step 1b. If Condition 1B, but not 1A, holds then:
Let l be the least convergence point discovered in Condition 1B.
Set [image].
For each [image], set [image] if [image].
Go to stage s + 1.
Step 2.
Let [image] be the least x not yet in domain( j p(s)).
For each [image] not yet in domain ( j p(0)), set j p(0)(x) = j p(s)(x).
Repeat
Set [image] and rest
until, if ever, at least one of the following two conditions holds.
Condition 2A: .
Condition 2B: .
Step 2a. If Condition 2A holds then go to stage s + 1.
Step 2b. If Condition 2B, but not 2A, holds then go to Step 1.
End ( Stage s )


Page 226
Now consider the following two cases.
Case 1: All stages halt. In this case, let p(0) be the additional information and f = j p(0). Clearly, j p(0) is total and is in S. We then have two subcases.
Subcase 1a: M(p(0), f) diverges. In this case, M fails to UniBexa,0-identify f.
Subcase 1b: M(p(0), f) converges to j at stage s. In this case, the only way in which all stages halt is by the execution of step 1b infinitely often. But, j M(p(0),f) is then infinitely different from f.
Case 2: Some stage s begins but does not halt. We then have three subcases.
Subcase 2a: Steps 1 and 2 are both executed infinitely often. In this case, let f = j p(0) = j p(s), which is clearly in S. Now, the only way that steps 1 and 2 can be executed infinitely often without leaving stage s is by the repeated execution of steps 1a and 2b. Thus, M with additional information p(s) infinitely often outputs j without converging to j. Therefore, M on f with additional information p(s) fails to converge.
Subcase 2b: In stage s, the algorithm eventually enters and never leaves step 1. In this case, let f = j p(s). Since j p(0) =a+1 j p(s), we have [image]. Observe that M on f with additional information p(s) converges to j because, otherwise, Condition 1A would succeed. Also observe that j j does not converge on at least a + 1 values because, otherwise, Condition 1B would succeed. Thus, M fails to UniBexa,0-identify f.
Subcase 2c: In stage s, the algorithm eventually enters and never leaves step 2. In this case, let f = j p(0) = j p(s), which is clearly in S. Observe that M on f with additional information p(s) does not converge to j because, otherwise, Condition 2B would succeed. Also observe that M on f with additional information p(0) converges to j because, otherwise, Condition 2A would succeed. Thus, M fails to UniBexa,0-identify f.
As the above cases and subcases are exhaustive, we have that M fails to UniBexa,0-identify S.
10.6 Corollary Suppose [image] . Then, [image].
The corollary implies that if one keeps fixed the bound on the number of errors allowed in the additional information, then larger collections of functions can be UniBex-identified by allowing extra errors in the final inferred program. The proof of the corollary is left to the reader.


Page 227
A natural question to ask at this point is whether a similar hierarchy also holds for Bex-identification. The next proposition shows that only a weak analog of Proposition 10.5 for Bex-identification is possible.
10.7 Proposition For all [image], [image].
Proof: Fix n. We construct a scientist M that Bexn,n-identifies all of [image]. Recall from Chapter 2 that, for each i, s, and x, we define j i,s(x) = j i(x), if both x < s and F i < s; and j i, s(x) is undefined otherwise. For each j, s , and x, define:
Intuitively, S s ,x is a set of programs that appear correct for the given additional information x and the finite initial segment s . For each j and s , let patch( s , j) be a program that computes
Thus, if j is a program that computes f with at most n errors, then, for sufficiently large s, program patch(f[s], j) will not make any convergent errors. For each finite set A, let Unify(A) be a program that computes
Clearly, we can take errors, patch, and Unify to be recursive. Finally, for each s and x, we define
Fix an [image] and an [image]. Then for sufficiently large s, the only errors program [image] makes are divergent errors whose total count is bounded by n. Therefore, M Bexn,n-identifies f as required.
Let us contrast the result above with the following proposition which shows that the n = * analog of Proposition 10.7 fails.
10.8 Proposition [image] .


Page 228
Proof: Consider the following collections of functions:
.
.
.
We argue that [image]. Suppose by way of contradiction that a scientist M Bex*,*-identifies S. Let i0 be a program for [image], the everywhere 0 function. Let M' be a scientist (which uses no additional information) such that, for each s ,
For any [image], max(f(0), i0) is clearly an upper bound on the minimal program for a finite variant of f, hence M' Ex*-identifies every [image]. This is a contradiction, since it was shown in Theorem 4.25 that [image]. Therefore, [image].
Proposition 10.7 limits us to the following weak analog of Proposition 10.5 for Bex-identification.
10.9 Proposition Suppose [image]. Then, [image].
Proof: Let [image], which is clearly in Exa+1. Suppose by way of contradiction that there is a scientist M theft Bexa,a+1-identifies S. Let M' be a scientist (without any additional information) such that, for all s ,
Since for any [image], f(0) is an upper bound on MinProg a+1(f), it follows that for each [image], Thus, M' Exa-identifies S. This is a contradiction, since it was shown in Proposition 6.5 that [image].
Propositions 10.9, 10.7, and 10.8 yield the following two corollaries.
10.10 Corollary For each [image], [image].
10.11 Corollary [image] .


Page 229
The first corollary says that if we fix the number of errors allowed in the additional information, then larger collections of functions can be Bex-identified by allowing extra errors in the final inferred program. This gain is achieved, however, only so far as the bound on the number of errors in the final inferred program does not exceed the bound on the number of errors allowed in the additional information. When these two bounds become equal, there is nothing to be gained by allowing extra errors in the final program. The second corollary says that, on the other hand, if a finite but unbounded number of errors is allowed in the additional information, allowing extra errors in the final program always yields a gain.
Thus far we have concentrated on showing the advantage of allowing extra errors in the final inferred program. We now consider the effects of allowing extra errors in the additional information. The next result shows that there are collections of functions for which an accurate program can be UniBex-identified in the presence of an upper bound on the minimal size c-error program, but for which even a *-error program cannot be UniBex-identified in the presence of an upper bound on the minimal size (c + 1)-error program.
10.12 Proposition For each [image], [image].
Proof: Consider the following collections of functions:
.
.
.
We exhibit a scientist M0 that UniBex0,c-identifies S. First we define an auxiliary function F such that, for any finite set D,
Now, for each x and s , define


Page 230
Fix an [image] and an [image]. Clearly, condition (i) in definition of M0 will succeed for sufficiently large initial segments of f. Thus, [image], which by definition of [image], is a program for f.
Fix an [image] and an [image]. Then, for any initial segment of f and this x, condition (i) will fail. Thus, for any sufficiently large n, M0(x, f[n]) will stabilize to [image], a program for f.
Therefore, [image].
The proof of [image] is a diagonalization employing the operator recursion theorem (Theorem 2.6). We refer the reader to Jain and Sharma [86] for the proof.
The next proposition illustrates the power of even a small amount of additional information. The proposition says that there are collections of functions that can be UniBex-identified in the presence of an upper bound on the minimal size *-error program, but which cannot be Bc-identified even if the scientist is allowed to output programs that commit no more than a predetermined number of errors.
10.13 Proposition For each [image], [image].
The proof of this result is the subject of Exercise 10-3. Propositions 10.12 and 10.13 have the following corollary on UniBex-identification.
10.14 Corollary Suppose [image]. Then:
(a) [image].
(b) [image].
Part (a) of the corollary says that even the worst quality of additional information (an upper bound on a minimal *-error program) yields extra learning power over Exa-identification. Part (b) says that if the bound on the number of errors allowed in the final inferred program is fixed in advance, then decreasing the quality of the additional information results in a reduction in learning power with respect to UniBex-identification. The proof of the above corollary is left to the reader. A related result about Bex-identification is the subject of Exercise 10-4.
We end this section by presenting a result that implies the advantages of Bex-identification over UniBex-identification.
10.15 Proposition Suppose [image]. Then, [image].


Page 231
10.16 Corollary For all [image] and all [image], [image].
Thus, if the bound on the number of errors allowed in both the additional information and the final program are fixed, then requiring a scientist to converge to the same program for any upper bound is restrictive.
Proof (of Proposition 10.15): Let [image].
Fix an [image] and an [image]. Since [image], given f and x, one can infer in the limit a program p such that j p =c f. For each y, let w y be the unique number such that [image]. (The uniqueness of w y follows from the definition of [image] and the fact that j p =c f.) Let modify(p) be a program obtained from p such that, for all y and z, [image], where w y is as defined above. It follows immediately that modify(p) is a program for f.
It thus follows that [image].
Suppose [image]. Then it is easy to modify M to [image]. But as [image] (see the remark in Exercise 10-7), this is a contradiction. Hence, [image].
It is open at present whether Proposition 10.15 can be extended to show [image]. Similar notions of additional information for the Bc paradigm are treated in the exercises.
§10.2.2 Language Identification with an Upper Bound on Grammar Size
Additional information for a language-learning scientist can be modeled as an upper bound on the minimal index grammar for the language to be learned. We view scientists that learn languages in the presence of such additional information as computing a mapping [image]. Our treatment of languages is thus analogous to that of functions. For this reason we highlight only basic definitions and results that turn out differently from the functional context.
For each [image] and language L, MinGram c(L) denotes the minimal grammar in the j -system that accepts L with at most c errors. That is, [image].
10.17 Definition [image] (read: M on text T with additional information x converges) just in case there is an i such that for all but finitely many n, M(x, T[n]) = i, in


Page 232
which case M(x, T) is defined to be this i. If no such i exists, then M(x, T) is said to be undefined.
The following two definitions state the text analogs of the Bex and UniBex paradigms.
10.18 Definition Let a, [image].
(a) M TxtBexa,c-identifies L (written: ) just in case, for all [image], there is an i with W i =a L such that, for each text T for L, we have [image].
(b) [image].
10.19 Definition Let a, [image].
(a) M TxtUniBexa,c-identifies L (written: ) just in case there is an i with W i =a L such that, for each [image] and each text T for L, we have [image].
(b) [image].
Thus, M TxtBexa,c-identifies L just in case M, fed a text for L and an upper bound on MinGram c(L), converges to a grammar that accepts L with at most a errors. As in the case of functions, the reader should note that in the TxtBexa,c paradigms, the scientist may converge to different grammars for different upper bounds.
Using the technique demonstrated in Chapter 6 (see, for example, the proof of Proposition 6.19), it is easy to see that the diagonalization results about Bex-identification and UniBex-identification yield analogous results for TxtBex-identification and TxtUniBex-identification. For example, the following result immediately follows from Proposition 10.5.
10.20 Proposition For each [image], [image].
10.21 Corollary For each [image], [image] [image].
The corollary says that by keeping the number of errors in the additional information fixed, larger collections of languages can be TxtUniBex-identified by increasing


Page 233
the bound on the number of errors in the final inferred grammar. (We note that Corollary 10.21 may be directly argued from Corollary 10.6.)
One might attempt to use Corollary 10.10 in a similar fashion in order to obtain an analogous hierarchy result about TxtBex-identification. However, this strategy yields only the partial hierarchy:
for all [image], [image].
Corollary 10.10 provides no information about whether TxtBexc,c = TxtBexc+1,c or [image]. This is because only diagonalization results can be translated from functions to languages. To obtain the full hierarchy we establish the following proposition which says that there is a collection of languages such that, for each member language L, an (a + 1)-error grammar can be identified, but an a-error grammar cannot always be TxtBex-identified even if the scientist is given the best possible additional information—an upper bound on MinGram0(L).
10.22 Proposition Suppose [image]. Then, [image].
Proof: Let [image], which is clearly in TxtExa+1. Suppose by way of contradiction that some scientist [image]. Then, by Kleene's recursion theorem (Theorem 2.3), there exists a grammar e informally described in stages below.
Let i N be a grammar for N. Let [image] denote the finite subset of W e enumerated before stage s. Let [image] and w = max ({ e, i N }). Go to stage 0.
Begin ( Stage s )
Step 1.
Search for a s extending s s until at least one of
Condition 1A. .
Condition 1B. A set [image] of cardinality a + 1 is found.
holds.
If Condition 1A held, go to Step 2, otherwise go to Step 3.
Step 2. (The mind change case.)
 Set m = max(content( s )) + 1.
Enumerate all of { 0, . . . , m} into W e.
Let s s + 1 be an extension of s with content( s s + 1) = { 0, . . . , m }..
Go to stage s + 1.
Step 3. (A suitable D was found in Condition 1B.)


Page 234
Set [image].
Enumerate all of ({0, . . . , m} - D) into W e.
Let s ' be an extension of s s such that content( s ') = ({ 0, . . . , m } - D).
Repeat
 Set m = m + 1.
Enumerate m into W e.
Set [image].
until [image].
Enumerate all of D into W e.
Let s s + 1 be an extension of s ' with content( s s + 1) = [W e enumerated until now].
Go to stage s + 1.
End ( Stage s )
Now consider the following cases:
Case 1: Infinitely many stages halt. In this case, let [image]. But, M on text [image] for L with additional information w = max({ e, i N }) fails to converge.
Case 2: Some stage, s, begins but does not halt.
Subcase 2a: The construction never leaves Step 1 in stage s. In this case, let [image]. Note that M on all extensions of s s converges to M(w, s s), and [image] is finite. Thus, M fails to TxtBexa,0-identify N.
Subcase 2b: The construction enters, but never leaves Step 3 in stage s. In this case, let [image]. M on a text for L converges to M(w, s s). But, [image]. Thus, [image] is not an a-variant of L.
From the above cases, it follows that M fails to [image].
The above result has the following corollary that summarizes the advantages of allowing extra errors in the final converged grammar for TxtBex-identification.
10.23 Corollary For each [image], we have [image] [image].
The advantage of a better quality of additional information, for both TxtBex-identification and TxtUniBex-identification, is summarized in Corollaries 10.25 and 10.26. These corollaries follow from the next proposition, whose proof is left to Exercise 10-9.
10.24 Proposition For each [image], [image].


Page 235
10.25 Corollary For all [image],
10.26 Corollary For all [image], [image].
We have the next corollary as an immediate consequence of Proposition 10.15.
10.27 Corollary For each [image], [image].
This last corollary yields Corollary 10.28, which is the language counterpart of Corollary 10.16. Corollary 10.28 says that if the bound on the number of errors allowed in both the additional information and the converged grammar are fixed, then requiring a scientist to converge to the same grammar for any upper bound is restrictive.
10.28 Corollary For each [image] and all [image],
It is tempting to be somewhat metaphoric about the above result and read into it an observation about human language learning—we yield to the temptation. Children tend to learn a language effortlessly, compared to adults in a class room setting. A possible explanation may be that the learning criteria used by. children allows them to converge to any grammar for the language, whereas adults are constrained to learn some unique grammar prescribed by the teacher!
As in the case of functions, it is still open whether the above result holds for c = *. Similar notions of additional information for other language learning paradigms (TxtFex and TxtBc) are treated in the exercises.
§10.3 Approximate Hypotheses as Additional Information
Pursuant to our introductory discussion, we now explore a second conception of a priori information about the environment, and again allow this information to depend on which potential environment is ''actual." This time we provide the scientist with an approximately true theory about the language or function with which they are confronted. To model the approximate character of the information provided, we rely on the "density of agreement" concepts defined in Chapter 7.


Page 236
Convention: For the remainder of the present chapter, d, d0, d1, d2 . . . range over real numbers in the unit interval.
§10.3.1 Function Identification in the Presence of Approximations
In the following an approximation to a function f will be taken as a partial recursive function h that agrees with f to some extent. The following definition introduces two different formalizations of "extent of agreement."
10.29 Definition Let [image], [image], and [image].
(a) We say that h is d-conforming with f just in case:
(1) [image], i.e., h does not contradict f; and
(2) [image].
(b) We say that h is uniformly d-conforming with f just in case:
(1) [image], i.e., h does not contradict f; and
(2) [image].
Let us recall from Chapter 7 the motivation for uniform d-conformity. It is this: even if h is 1-conforming with f, h may be a bad approximation locally for many large intervals; uniform conformity renders the approximation more homogeneous.
In the paradigms defined below, a scientist learning f is fitted out with a program for an approximation h to f, along with access to the graph of f. The approximation h will be either d-conforming or uniformly d-conforming. Thus, our scientists again compute mappings from N × SEG to N, and M(p, s ) denotes the conjecture of M on prior information p plus evidential state s A definition similar to Definition 10.1 can be stated to describe the convergence of a scientist on information p and graph f.
The next definition makes things official. It extends the Ex paradigm to situations in which the scientist has access to a program for a partial function that is d- conforming with the function to be learned.
10.30 Definition Let [image] and [image].
(a) A scientist M ApdExa-identifies f (written: ) just in case, for all p such that j p is d-conforming with f, [image] and j M(p,f) = a f.
(b) [image].


Page 237
Replacing d-conformity by uniform d-conformity in Definition 10.30 produces the following paradigm.
10.31 Definition Let [image] and [image].
(a) A scientist M UapdExa-identifies f (written: ) just in case, for all p such that j p is uniformly d-conforming with f, [image] and j M(p,f) =a f.
(b) [image].
Ap and Uap are abbreviations for 'Approximate partial additional information' and 'Uniform approximate partial additional information,' respectively. The Uap-type additional information is intuitively better than the Ap type, and indeed the results to follow will confirm this. Since any Uapd-type additional information is also an Apd-type additional information, we have the following.
10.32 Proposition For all [image] and all [image] , [image].
We next establish that there are collections of functions that can be identified with some Uap-type additional information of nonzero density, but cannot be identified in the presence of the best possible Ap-type additional information even if the the scientist is allowed to converge to a finite variant program.
10.33 Proposition Suppose [image]. Then [image].
Proof: Let n0 = 0 and, for each [image], let n2i + i + 1 and n2i+2 = n2i+1 · 2i.
For each j, define
Also, define
Finally, let
We show that [image] in the next two claims and thus establish the proposition.


Page 238
10.34 Claim [image] .
Proof: Suppose by way of contradiction that some scientist M ApaEx*-identifies [image]. We show that the existence of such an M implies that [image] is Ex*-identifiable, contradicting Corollary 6.11. First, let p* be a program such that
Clearly, for each [image], we have that [image] and [image]. Hence, j p* is 1-conforming with each member of [image]. Next, for each f, define
So, if [image], then [image]. Also let r be a recursive function such that, for all i and j, j r(i)(j) = j i(min(S j)). So if j i = f', for some [image], then j r(i) = f. Finally, let M' be a scientist such that, for each f,
As the reader may check, it follows from our assumption on M and the above definitions that M' must [image]. Thus we have the desired contradiction.
10.35 Claim Suppose [image]. Then [image].
Proof: Let p be a recursive function such that, for each s and x,
Also, let M be a scientist such that, for all s and s , M(s, s ) = p(s).
Fix some [image] and suppose that s is such that j s is uniformly d-conforming to f. Then it easily follows that, for each j, [image], and hence, j p(s) = f. Therefore, M UapdEx-identifies f.
Let us contrast the preceding result with the following proposition, showing that Uap-type additional information cannot, in general, compensate for a higher density Ap-type additional information. The proof of this proposition is left to Exercise 10-18.


Page 239
10.36 Proposition Suppose [image]. Then [image].
We next show that allowing an extra error in the final inferred program cannot, in general, be compensated by the best Uap-type additional information.
10.37 Proposition
(a) For all [image], [image].
(b) [image].
Proof: For each [image], define
Also, for each [image], define [image]. Observe that for all [image],
We leave it as exercise to show that the proposition follows from the above observation together with results from Section 6.1.1.
The previous three results imply the following corollary, which reveals the complete relationship between UapdExa and ApdExa for various values of a and d. The proof of the corollary is left to the reader.
10.38 Corollary Let a, [image] and d1, [image].
(a) [image].
(b) [image].
(c) For all [image], [image].
In the paradigms considered above, partial explanations do not contradict the function being learned. There is no reason to believe, however, that the state-of-the-art explanation available to a scientist is necessarily free of errors of commission. A natural, and currently open, line of further investigation is to consider approximations that are correct on a set of certain density and either undefined or incorrect off that set.


Page 240
§10.3.2 Language Identification With Approximations
In the following an approximation to a language L will be taken to be another language L' such that [image] and L' "conforms" to L. We will consider two different formalizations of conformity. We first introduce the notions of relative density of L' in L and of uniform relative density of L' in L. These notions are then used in Definition 10.40 to present the two formalizations of conformity.
10.39 Definition Let L = { x0 < x1 < x2 < . . .} and L' be members of e .
(a) The relative density of L' in L (written: rd(L', L)) is defined as:
(b) The uniform relative density of L' in L (written: urd(L', L)) is defined as:
.
10.40 Definition Let [image]. Let L and [image].
(a) We say that L' is language d-conforming with L just in case we have
(1) [image]; and
(2) [image].
(b) We say L' is language uniformly d-conforming with L just in case we have
(1)
(2)
The paradigms now to be discussed are analogous to the function paradigms introduced in Definitions 10.30 and 10.31. A scientist attempting to learn a language L is provided with a grammar for a language [image], in addition to access to a text for L. In the first paradigm, L' is a language that d-conforms with L; in the second paradigm, L' uniformly d-conforms with L. Thus (just as before), we conceive our scientists as computing mappings from. N × SEQ to N. Once again, a definition similar to Definition 10.17 can be formulated to describe convergence on advance information x and text T. Officially, we proceed as follows.


Page 241
10.41 Definition Let [image] and
(a) A scientist M TxtAcpdExa-identifies L (written: ) just in case, for all texts T for L and all p such that W<p is language d-conforming with L, we have [image] and W<SB >M(p,T) =a L.
(b)
Replacing d-conformity in the above definition by uniform d-conformity yields the paradigm TxtUapdExa.
Before presenting results about TxtApdExa and TxtUapdExa, let us take another step in the elaboration of paradigms. In both of the foregoing models, the advance information about the incoming language L is "positive" in the sense that it describes a subset of L rather than its complement. It can also be imagined that the child receives advance, negative information in the form of an index for a subset of N - L. (This possibility does not bear on the debate about the existence of negative information in texts; textual information is provided by caretakers whereas advance information is lodged in the child's mind through the genome.) We rely on the following definition to formulate the possibility of advance, negative information.
10.42 Definition Let [image] and [image].
(a) A scientist M TxtAcpdExa-identifies L (written: ) just in case, for all texts T for L and all p such that W p is language d-conforming with (N - L), we have [image] and WM(p,T) =a L.
(b)
Acp is an abbreviation for "Approximate complement partial additional information." Replacing d-conformity in the above definition by uniform d-conformity yields the paradigm TxtUacpdExa.
Finally, we introduce paradigms in which the learner receives advance information about both L and N - L, where L is the language being presented. Within these paradigms, scientists compute mappings from N × N × SEQ to N. The first argument provides advance information about a subset of L and the second about a subset of N - L. Thus, M(x, y, s ) denotes the conjecture of scientist M on a grammar x for a language L, plus a grammar y for an (r.e.) subset of N - L, plus an initial segment s of a text for L. Setting things down in an official way yields the following definitions.


Page 242
10.43 Definition [image] (read: M on text T with positive additional information x and negative additional information y converges) just in case there is an i such that for all but finitely many n, M(x, y, T[n]) = i, in which case M(x, y, T) is defined to be this i. If M(x, y, T) fails to converge, then M(x, y, T) is undefined.
10.44 Definition Let [image]) and d1, [image].
(a) We say that a scientist M [image] a language L (written: ) just in case, for all texts T for L, all p1 with is W p1 is d1-language conforming with L, and all p2 with W p 2 is d2-language conforming with (N - L), we have [image] and [image].
(b)
In [image], the positive additional information is of type Ap and negative additional information is of type Acp. The reader can similarly provide definitions for the following paradigms that arise by taking all combinations of the Ap and Uap types of positive additional information and the Acp and Uacp types of negative additional information:
(a)
(b)
(c)
Having defined these paradigms, we now are in a position to present some representative results. The reader may easily check that all of the results in Section 10.3.1 about the paradigms ApdExa and UapdExa have corresponding counterparts for the TxtApdExa and TxtUapdExa paradigms.
We first prove that extra errors in the final inferred grammar cannot be compensated for by any amount of additional information. More precisely, we prove that there are collections of languages that can be identified by allowing up to k + 1 errors in the final grammar, but which cannot be identified by allowing up to k errors in the final grammar, even if the scientist is given the best possible additional positive information (Uap-type density 1) and the best possible additional negative information (Uacp-type density 1).
10.45 Proposition
Proof: Fix some m > 1. Let n0 = 0. For each [image], let n3i+l = n3i + m i, n3i+2 = n3i + m i and n3i+3 = n3i+2+1. Let [image], [image],


Page 243
and [image]. Finally, let
Clearly, [image]. Also, since grammars for L1 and L2 are valid additional information of types Uap1 and Uacp1 respectively, we have that [image]. Suppose by way of contradiction that M TxtEx k-identifies [image]. It is, then, easy to convert M to M' such that M' TxtExk-identifies [image]. But this is not true as implied by Exercise 6-3. Thus, no such M can exist.
We leave the proof of the following as an exercise.
10.46 Proposition
The next proposition illustrates the power of Uacp-type negative additional information over Acp-type negative additional information. More precisely, there are collections of languages that can be identified in the presence of some Uacp-type additional information of nonzero density, but cannot be identified in the presence of the best possible Acp-type negative additional information, even if the scientist is also given the best possible positive additional information (Uap-type density 1) and is only required to converge to a grammar for a finite variant of the language. The proof of the proposition is treated in Exercise 10-19.
10.47 Proposition For all d > 0,
A similar result below illustrates the power of Uap-type positive additional information over Ap-type positive additional information. That is, there are collections of languages that can be identified in the presence of some Uap-type additional information of nonzero density, but cannot be identified in the presence of the best possible Ap-type positive additional information, even if the scientist is also given the best possible negative additional information (Uacp-type density 1) and is only required to converge to a grammar for a finite variant of the language. See Jain and Sharma [85] for the proof.
10.48 Proposition For all d > 0,
The next result illustrates the power of Ap-type positive additional information over lower density Uap-type positive additional information. More precisely, if d2 > d1, then there are collections of languages that can be identified in the presence of Ap-type positive additional information of density d2, but that cannot be identified in the


Page 244
presence of Uap-type positive additional information of density d1, even if the scientist is also given the best possible negative additional information (Uacp-type density 1) and is only required to output a grammar for a finite variant of the language.
10.49 Proposition Suppose [image]. Then,
The proof of the proposition can be found in Jain and Sharma [85].
We next present a negative additional information counterpart of the previous proposition, and illustrate the power of Acp-type negative additional information over lower density Uacp-type negative additional information. Again, the reader is referred to Jain and Sharma [85] for a proof.
10.50 Proposition Suppose [image]. Then, [image].
The following corollary summarizes the complete relationship between all the paradigms introduced in this subsection. It follows from the results presented above, as the reader may check.
10.51 Corollary Let a [image] and d, d1, d2, d3, [image], [image].
(a)
(b)
(c)
(d)
(e)
(f)
§10.4 Bibliographic Notes
The subject of upper bound on program size as additional information for function identification was first considered by Freivalds and Wiehagen [67] and generalized by Jain and Sharma [86]. The latter paper also investigated analogs of these paradigms for Bc, TxtEx, TxtFex, and TxtBc paradigms.


Page 245
The subject of Ap and Uap types of additional information for Bc, TxtFex, and TxtBc is covered in Jain and Sharma [85].
Other approaches to additional information have been considered by Fulk [68], by Case, Kaufmann, Kinber, and Kummer [32], by Baliga and Case[1l], and by Kaufmann and Stephan [104].
§10.5 Exercises
10-1 Consider a variant of Bexa,c-identification in which the additional information about a function f is provided as a sequence whose limiting value is an upper bound on MinProg c(f). More formally, let X range over infinite sequences of natural numbers x0, x1, x2,. . . and let [image] denote the limit of the sequence, if the sequence converges.
10.52 Definition Let a, [image].
(a) M BEXa,c-identifies f (written: just in case, for all X such that [image]), we have [image] and, for [image], [image].
(b)
Show that for each a, [image], Bexa,c = BEXa,c. Does a similar result hold for other paradigms in Section 10.2?
10-2 Complete the proof of Proposition 10.12.
10-3 Give a proof for Proposition 10.13.
Hint: Consider:
It is easy to verify that [image]. Use Kleene's recursion theorem (Theorem 2.3) to show that [image].


Page 246
10-4 The aim of this exercise is to establish a hierarchy for Bex-identification which shows that decreasing the quality of additional information results in a reduction in learning power. Towards this goal, first prove that, for all [image], [image]. Then, verify that this result implies that for all [image],
10-5 Show that, for each [image], [image].
Hint: Use the union of the following classes of functions:
10-6 Show that [image].
Hint: Consider S, the class of functions [image] each of which satisfies:
1.
2.
3.
10-7 Show that [image]. Observe that this result implies that [image]. This latter observation says that there is no scientist that can UniBex-identify every recursive function, even if the scientist is given the best quality additional information and is only required to output a finite variant program.
Hint: Use the class of functions [image].
10-8 Use an argument similar to the one for Exercise 10-7 to argue [image]. Note: It is currently open whether this result or the one in Exercise 10-7 can be extended to [image].
10-9 Give a proof of Proposition 10.24.
Hint: For each [image], consider the class of languages


Page 247
It is easy to check that [image]. Using the n-ary recursion theorem (Theorem 2.5), show that [image]. Then generalize this argument to show that [image].
10-10 The purpose of this exercise is to extend Aex and Uaex paradigms from Chapter 7 to incorporate both Ap and Uap types of additional information. We illustrate this extension by defining [image] paradigm below. First recall from Chapter 7 that the asymptotic agreement between two partial functions h and q (denoted: aa( h , q )) is [image] and the asymptotic disagreement between h and q (denoted: ad( h , q )) is 1 - aa( h , q ).
10.53 Definition Let dl, [image].
(a) A scientist [image] just in case, for each p with j p that is d1-conforming with f, we have that [image] and [image].
(b)
Similarly to the above, define [image], [image], and [image] paradigms. Give simple arguments for the following.
(a) For all [image], [image].
(b) For all [image], [image].
10-11 Show that, for all d1 > 0 and all d2, d3 with d2 + d3 < 1, [image].
Hint: Without loss of generality, assume that dl = 2/m, d2 = l/m, d3 = (m - l - 1)/m for integers [image] and [image]. Let n0 = 0. For each [image], let n2i+1 = m i+1 + n2i, and n2i+2 = n2i+1 + (i + 1). · m. Let [image]. Then, use C, the class of functions [image], each of which satisfy:
1. For all [image], f(x) = 0.
2. For all j and all [image], f(x) = f(j).
10-12 Suppose d1, d2, and d3 are real numbers such that [image] and d2+d3 < 1. Use a technique similar to the one of Exercise 10-11 to show that [image]. Also, verify that this result implies [image].


Page 248
10-13 Use a technique similar to the one for Exercise 10-11 to show that, for all d1 and d2 with d1 + d2 < 1, [image]. Also, verify that this result implies that, for all d < 1, [image].
10-14 Show that, for all d1 > 0 and all d2 < 1, [image].
Hint: Without loss of generality, assume that d1 = 2/m and d2 = (m - 2)/m for an integer [image]. Let no n0 = 0, n2i+1 = m i+1 + n2i, and n2i+2 = n2i+1 + (i + 1) · m. Let [image] and, for each j, [image]. Then, use C, the class of functions [image], each of which satisfies:
1. For all [image],f(x) = 0.
2. For all j and all [image], f(x) = f(j).
10-15 Suppose d1, d2, and d3 are such that d2 < dl and d3 < 1. Show
Hint: Without loss of generality, assume that d2 = l/m, d1 = (l + 2)/m, and d3 = (m - 2)/m for integers [image] and [image]. Let n0 = 0, n2i+1 = m i+1 + n2i, and n2i+2 = n2i+1 + (i + 1) · m. Let [image] and, for each j, let [image]. Then, use C, the class of functions [image] each of which satisfies:
1. For each [image], f(x) = 0
2. For all j and all [image], f(x = f(j)..
10-16 Use a technique similar to the one in the hint for Exercise 10-15 to show that, for all dl and d2 with d1 > d2, [image].
10-17 Use a technique similar to the one in the hint for Exercise 10-15 to show that, for all d1, d2, and d3 with d2 > d1 and d1 + d3 < 1, [image].
10-18 Give a proof of Proposition 10.36.
Hint: Without loss of generality, assume that d2 = (k + 3)/m and d1 = k/m for integers k and m with [image]. Let n0 = -1 and ni = mi. Let Sj denote the set [image]. Let [image]. Consider the class C of functions [image], each of which satisfies:
1.
2. For each j, [image].


Page 249
Now show that [image] and [image].
10-19 Give a proof of Proposition 10.47.
Hint: Fix some integer m > 1. Let n0 = 0, and for each i and each j < i, let
For each j, let [image]. Consider [image], the class of languages [image], each of which satisfies:
1.
2.
3.
4.
5. is finite or co-finite.
Show that [image] (first, use the additional information to construct a text for the complement of the input language; then use the identification method used to identify finite (respectively, co-finite) languages on characteristic function input). Also, observe that [image], and [image]. Use this observation to argue that [image].


Page 251
11
Learning with Oracles
§11.1 Introduction
In Chapters 3 and 4 we observed that unidentifiability can arise for two distinct reasons:
1. there may be some information theoretic limitation inherent in the collection of underlying realities being identified; or
2. the collection of underlying realities is in some way too complex for a computable scientist to identify.
In this chapter we explore the second of these barriers. We do this by considering scientists that are allowed access to knowledge not obtainable through any computable process. We illustrate the key issues in the context of both functions and languages.
In the case of function identification, we know that [image], the collection of computable functions, is identifiable by a noncomputable scientist (Proposition 3.43), but cannot be identified by any computable scientist (Theorem 4.28). This suggests that if some additional information of noncomputable nature were available to computable scientists, the collection [image] might become identifiable. In this chapter such information is modeled as membership oracles for noncomputable sets, and through this we are able to classify the hardness of the problem of identifying [image].
In the context of languages we have seen that any collection of r.e. languages that contains all the finite languages and an infinite language cannot be identified by any scientist, computable or noncomputable (Corollary 3.28). So a scientist will not be able to overcome such a barrier simply by having access to information about noncomputable processes. However, it is still interesting to investigate whether larger collections of languages become identifiable if a scientist is provided information about processes that are increasingly noncomputable.
The results on these topics are primarily of technical interest, and this chapter provides only a brief survey, with proofs of some sample findings.
§11.2 Oracle Scientists
Consider a machine that, in addition to performing algorithmic computation, is allowed to ask membership queries about some [image] that may not be recursive. Such machines


Page 252
are referred to as oracle machines. In this section we consider identification by scientists that have access to such a membership oracle. A membership oracle for [image] may be thought of as an infinite sequence of 0's and l's whose bits appear in the sequence
c A(0), c A(1), c A(2), . . . ,
where X A denotes the characteristic function of A. We use A to denote both the set and its membership oracle.
An oracle scientist may be construed as a computable scientist with the added ability to consult an oracle for membership queries. More concretely, an oracle scientist may be viewed as a Turing machine with an extra read-only tape, called the oracle tape, upon which the membership oracle for some set A is written. This oracle Turing machine behaves like a usual Turing machine except that its actions may also depend on the content of the oracle tape. In this chapter we let M, with or without decorations, range over oracle, as well as ordinary, scientists. It will always be clear from context whether M is intended as an ordinary or oracle scientist. We denote a scientist n equipped with an oracle A as MA, and MA( s ) denotes the conjecture of M with access to a membership oracle for A on evidential state s .
The next section concerns function identification by oracle scientists. Section 11.4 discusses language identification in this context.
§11.3 Function Identification by Oracle Scientists
Suppose M is an oracle scientist and [image]. If the sequence of hypotheses issued by M A on [image] corresponds to an Ex-identification of f, then M A is said to O AEx-identify f, or alternatively, as defined below, M is said to O AEx-identify f (Gasarch and Pleszkoch [76]). We formalize this paradigm in the following definition, and leave it to the reader to check that the notion of convergence of a computable scientist on a function can be easily adapted for convergence of an oracle scientist on a function.
11.1 Definition (Gasarch and Pleszkoch [76]) Let [image].
(a) M, O AEx-identifies f (written [image]) just in case. and [image].
(b) [image].


Page 253
§11.3.1 Omniscient Oracles
Recall that [image] (Theorem 4.28). A natural question is: How much additional information (in the form of an oracle) need one supply to a scientist in order for [image] to be identifiable? Let us call A omniscient if and only if [image]. The next proposition shows that K (the halting set) is omniscient.
11.2 Proposition (Adleman and Blum [1]) [image] .
Proof: Let g be a relativized recursive function such that, for all x,
Recall that, for each [image], [image] is the finite function whose graph is content( s ). For each X and s , define
Clearly, M K Ex-identifies [image].
Adleman and Blum [1] completely characterize the omniscient sets as follows. Let A' denote the halting problem relative to oracle A. We say that A is high if and only if [image]. (See Soare [183] for a detailed discussion of high sets.)
11.3 Proposition (Adleman and Blum [1]) For all A, [image] if and only if A is high.
The if direction of this result is left for Exercise 11-1. The only if direction is quite involved and is omitted here.
§11.3.2 Trivial Oracles
Let us call A trivial if and only if O AEx = Ex. Clearly, every recursive A is trivial. There turn out to be nonrecursive trivial sets, and the class of all trivial sets has an attractive characterization which we give below. Before stating this characterization we first need to explain 1-generic sets.
Let [image]. We let g , with or without decorations, range over STR. We write [image] just in case g 0 is a prefix of g 1, and we write


Page 254
just in case g is a prefix of c A. Clearly, [image] is a partial order on STR. We identify the elements of STR with those of N.1
11.4 Definition (Jockusch [101]) A is 1-generic just in case, for every r.e. set L, there is an n such that either (a) [image], or (b) for all [image], [image].
Jockusch [101] shows that 1-generic sets exist and are, in a reasonable sense, plentiful. Here then is the promised characterization of trivial sets.
11.5 Proposition For all A, O AEx = Ex if and only if [image] and A is Turing reducible to a 1-generic set.
The if direction of the proposition is due to Fortnow, Gasarch, Jain, Kinber, Kummer, Kurtz, Pleszkoch, Slaman, Solovay, and Stephan [59], and the only if direction is due to Slaman and Solovay [177]. Slaman and Solovay's [177] proof of the only if direction is quite difficult. Kummer and Stephan [114] have an easier proof of this direction. Here we show Proposition 11.6 below, a weak version of the if direction. The full argument of the if direction is left to Exercise 11-4.
11.6 Proposition Suppose A is a 1-generic set that is [image] K. Then O AEx = Ex. The following two lemmas imply the proposition.
11.7 Lemma Suppose A is 1-generic and [image]. Then there is an M such that, for each [image], M A Ex-identifies f, making only finitely many queries to A.
11.8 Lemma Suppose [image] and [image] and M are such that, for each [image] , M A Ex-identifies f, making only finitely many queries to A. Then [image].
We prove Lemma 11.7 below. The proof of Lemma 11.8 is left to Exercise 11-3. Before proving Lemma 11.7, we introduce one more bit of notation. For each oracle scientist M, [image], and [image], we define
1Via the isomorphism [image] Exercise: Show that this really is an isomorphism.


Page 255
Proof (of Lemma 11.7): Let M0 be an oracle scientist such that [image] Ex-identifies [image]. For each oracle X and each [image], define useX( s ) to be the smallest prefix of X, if any, such that [image] Clearly, usex is partial recursive in X. We also define, for each oracle X and [image],
11.9 Claim
(a) G A is recursive in A, monotone nondecreasing, and for each s , [image], and one can compute G A( s ) using only [image] much of A.
(b) For each [image], there is an n f such that [image] and [image].
Proof: Part (a) follows directly from the definition of G. For part (b), fix an [image]. It is clear from the definition of G that, if [image], to say n f, then [image]. Moreover, since G A is monotone increasing, if [image] is bounded, then [image]. So, for part (b) it suffices to simply show that [image] is bounded. For each n, let [image]. If [image], then we are done by the definition of G. So, suppose [image] Since [image]. Ex A-identifies f, there are i0 and no such that, for all [image]. Let
Clearly, L is r.e. By our choice of n0 we have that, for each m, [image] . Therefore, by the 1-genericity of A, there must be an m0 such that, for all [image]. Let n1 be the least number such that [image] (and, hence, [image]). It thus follows from our choice of m0 and the definition of G that, for all n,
For each X and s , define [image]. It follows from Claim 11.9 that M is as required.


Page 256
§11.3.3 Bounded Queries
An oracle scientist M in the process of O AEx-identifying a function f may ask infinitely many questions of the oracle A. A natural refinement on the O AEx paradigm is to bound the number of questions a scientist is allowed to ask. This refinement is the subject of the next definition. First, we formalize the concept of ''set of questions asked of an oracle by a scientist examining the graph of a function."
Let Queries(M, A, s ) denote the set { [image] asks a question of the form [image] of A in conjecturing a hypothesis on c }. Then the set of queries to A by M on a function f, denoted Queries(M, A, f), is [image] Queries(M,A,f[n]).
11.10 Definition (Gasarch and Pleszkoch [76]) Suppose [image] and M is an oracle scientist.
(a) M OA,bEx-identifies f (written: ) just in case [image] and [image].
(b) [image].
Intuitively, an oracle scientist M is said to OA,bEx-identify a function f if and only if M O AEx-identifies f by asking only up to b distinct queries of A. As an immediate corollary of Lemma 11.8 we have
11.11 Corollary If [image], then O A,*Ex = Ex.
Fortnow, Gasarch, Jain, et al. [59] show the converse to this.
A natural question is whether there is anything to gain from allowing oracle scientists to ask additional queries. The next proposition shows that this is indeed the case—provided the oracle involved is powerful enough.
11.12 Proposition (Fortnow, Gasarch, Jain, et al. [59]) For all A, the following are equivalent.
(a)
(b) For all n,


Page 257
§11.4 Language Identification by Oracle Scientists
We now consider the identification of languages by oracle scientists. The next definition extends the TxtEx paradigm to identification by oracle scientists. We again let the reader verify that notation about computable scientists converging on a text carries over to oracle scientists.
11.13 Definition Let [image].
(a) An oracle scientist M O ATxtEx-identifies L (written: ) just in case, for each text T for L, we have [image] and [image].
(b)
As was the case with functions, the first natural question is whether there are omniscient oracles, that is, whether there is an A such that [image]. In contrast to the function case, in this setting we obtain a negative answer to this question.
11.14 Proposition For all A, [image].
Proof: As the reader can check, Proposition 3.22 extends to oracle scientists. Hence, Corollary 3.28 implies the present proposition.
Since no oracle suffices to make e identifiable, an interesting question is whether employing a more powerful oracle in the arithmetic hierarchy yields extra learning power. The following result provides a sufficient condition for an oracle B allowing the identification of at least one collection of languages that cannot be identified using oracle C. Recall that [image].
11.15 Proposition Suppose A0, A1, A2, . . . is a sequence of subsets of N such that [image]. Let [image] and let C be any set such that [image]. Then, there is an [image].
For an example of a sequence of sets A0, A1, A2, . . . satisfying the proposition's hypothesis, take [image] for each [image]. Our proof of the above result relies on the following lemma, which is a relativization of the locking sequence lemma (Theorem 3.22). The proof of the lemma is left to the reader.
11.16 Lemma Suppose M O ATxtEx-identifies L. Then there is a s such that:
(a)


Page 258
(b) [image], and
(c) for all [image] with [image] and [image], we have that [image].
We refer to s as an O ATxtEx-locking sequence for M on L.
Proof (of Proposition 11.15): Define
, and
.
11.17 Claim [image] .
Proof: We first note that by the s-m-n theorem (Theorem 2.1) there are recursive functions g0 and g1 such that for all i and j:
Consider the following oracle scientist (with oracle X).
Program for M X on s
If [image] for some [image] and some nonempty [image],
then output 0 and halt.
Otherwise:
Let i and D be such that
If
then output g0(i)
else output g1(i, j), where j is the canonical index of D.
End Program
We leave it as an exercise to show that M B TxtEx-identifies [image].
11.18 Claim [image] .
Proof: Suppose by way of contradiction that there is an M that OCTxtEx-identifies. We show that
Suppose i is such that A i is finite. Then by our definition of [image], [image] Thus, by Lemma 11.16 there is an OCTxtEx-locking sequence for M on [image].


Page 259
Suppose i is such that A i is infinite. Then, for every s with [image] there are infinitely many [image] such that [image].
Therefore, we have that
A i is finite
So, [image], a contradiction.
§11.5 Bibliographic Notes
The study of function identification in the presence of membership oracles was initiated by Gasarch and Pleszkoch [76]. An earlier work in this direction is due to Adleman and Blum [1]. The reader is referred to a comprehensive paper by Fortnow, Gasarch, Jain, Kinber, Kummer, Kurtz, Pleszkoch, Slaman, Solovay, and Stephan [59] for numerous results on this topic.
The investigation of language identification in the presence of membership oracles was first considered by Jain and Sharma [87], and extended by Kummer and Stephan [114]. Ott and Stephan [146] demonstrate the use of oracles in the context of a model for learning infinite recursive branches of recursive trees due to Kummer and Ott [113].
A related model studied by Gasarch and Smith [77] allows a scientist to ask a teacher questions, phrased in a prespecified first-order language, about the function being identified.
§11.6 Exercises
11-1 (Adleman and Blum [1]) Suppose A is high (see page 253). Show that [image].
11-2 (Gasarch and Pleszkoch [76]) A set A is said to be low if [image]. Show that [image].


Page 260
11-3 Let [image] be limiting recursive. Suppose that [image]. Further suppose that for each [image], M on input f, makes at most finitely many queries to A, that is, [image]. Show that [image].
11-4 (Fortnow, Gasarch, Jain, et al. [59]) Suppose A is Turing reducible to both K and some 1-generic set. Show that O AEx = Ex.
11-5 Extend Definition 11.13 in the obvious way to allow oracle scientists to converge to finite variant grammars for the language being identified. That is, for [image] and [image], define paradigms O ATxtEx a. Then establish the following stronger version of Proposition 11.15:
Let A0, A1, A2, . . . be a sequence of sets such that [image] and let [image]. Choose C so that [image]. Then there is an [image].
Hint: Consider a cylindrification of the class used in the proof of Proposition 11.15.


Page 261
12
Complexity Issues in Identification
§12.1 Introduction
Our study has thus far concentrated on the question of what is learnable in principle when there are no constraints on either
(a) the computational resources required by the scientist, or
(b) the complexity of final hypotheses.
The present chapter discusses the prospects for learnability when resources are bounded,
or when final hypotheses are required to be simple.
The complexity of the Identification Process.
Unlike the case for complexity of computable functions, there are no standard notions of "feasible" identification or even agreement about how to measure the computation costs of identification. Worse yet, the study of the computational complexity of functionals and operators is still in its infancy, with knotty questions surrounding even the most basic definitions — see Cook [44], Kapron and Cook [102], Seth [169, 170], and Royer [160].
In the light of the above difficulties, only partial attempts have been made to model the complexity of the identification process. Some of these are:
1. bounding the number of mind changes made by a scientist before convergence (discussed in Section 12.2);
2. bounding the number of examples required before the onset of convergence (discussed in Section 12.3);
3. measuring the amount of computation done by the scientist before the onset of convergence (discussed in Exercise 12-6).
Additionally, in Section 12.4 we discuss an axiomatic treatment of the complexity of convergence.
The complexity of the Final Hypothesis.
It is easy to motivate the desire for succinct final hypotheses. Numerous formulations of succinctness have been advanced for both functions and languages. Sections 12.5 and 12.6 examine a number of such proposals for languages. The analogous cases for functions can be found in the exercises.


Page 262
§12.2 Mind Change Complexity
We refer to the abandonment of a scientific conjecture as a mind change. The definition of identification places no restriction on the number of mind changes that precede convergence. In the present section we examine the impact on identifiability of bounding this number. To proceed, it will be convenient to slight modify the definition of scientist.
We pick a nonnumerical entity "?" and append it to the range of scientists. Thus, in the functional context, scientists become mappings from SEG to [image] Moreover, we restrict the term "scientist" to mappings M of this kind that meet the following, additional constraint: For all [image], and x, [image], if [image] then [image]. In other words, scientists (in our new sense) can issue ? only on some initial segment of the incoming graph; once they respond numerically (or are undefined), they do not issue ? again. Intuitively, "M(f[n]) = ?" represents a situation in which M has not seen enough data to issue any sensible hypothesis and so instead issues a ''?", which means 'no hypothesis yet.' For scientist M on function f, we say that M on f has a mind change at m if and only if we have: m > 0, [image] and [image]. Thus the case in which M(f[m - 1]) = ? and [image] does not count as a mind change.
We are now in a position to formalize identification with a bounded number of mind changes. The following definition also handles errors in final hypothesis. Recall that " [image] " means that x is finite.
12.1 Definition (Barzdins * and Freivalds [15], Case and Smith [35]) Let a and b be elements of ( [image]).
(a)
1.
2. .
(b) [image].
So, [image] is simply the Exa paradigm defined in Chapter 6. The special case of [image] is variously referred to in the literature as: the Fin paradigm, finite identification, and one shot learning. The Fin paradigm, in which a scientist's first conjecture has to be correct, first appears in the work of Gold [80] and Trakhtenbrot and Barzdins* [188].
The following proposition says that there is a collection of functions S such that: there is some scientist that infers, with no mind changes, an (n + 1)-error program for


Page 263
each element of S, but there is no scientist that infers an n-error program for each element of S—even if we allow the scientist to make an arbitrary number of mind changes. The proof of this proposition follows from the argument given for Proposition 6.5.
12.2 Proposition (Case and Smith [35]) For each [image], [image].
Similarly, as an immediate consequence Corollary 6.6, we have the following.
12.3 Corollary (Case and Smith [35]) [image] .
The next result shows the advantages of allowing an extra number of mind changes. The first part says that there is a collection of functions S for which there is a scientist that for each function in S infers a program via only n + 1 mind changes, but for which even a *-error program cannot be identified if only n mind changes are allowed
12.4 Proposition (Case and Smith [35)] (a) [image].
(b) [image].
Proof: We argue only the special case of part (a): . Part (b) and the general case of part (a) are handled in Exercise 12-1.
Let [image], which is clearly in Exn+1. Suppose by way of contradiction that there is an [image]. Let [image], which is obviously in C n. Hence, by our assumption on M, there is an
.
For i = 1, . . ., n + 1, we inductively define f i and m i as follows.
It follows from a simple induction argument that each f i is a member of C n, and thus that each m i is well defined. It also follows that M on f n+1 has a mind change at each of the n + 1 many points m1, . . ., m n+1, a contradiction.


Page 264
As an immediate corollary to the above, we have the following, which summarizes the advantages of allowing extra mind changes.
12.5 Corollary Let [image]. Then, [image].
§12.3 Number of Examples Required
Another freedom available to a scientist in the identification paradigm is that she can see as much data as she wishes before settling on a final conjecture. Practical systems for empirical inquiry seldom have such luxury. It is thus worth considering modifications on the identification paradigm in which a scientist is limited by the number of examples she can see before settling on a final conjecture. Here we discuss a proposal due to Wiehagen.
A simplistic approach to bounding the number of data elements would be to define a paradigm under which a scientist can see no more than a predetermined number of examples before converging. This approach is not satisfactory, however, since it does not allow the bound to vary among different functions in the collection to be identified (after all, the graphs of distinct functions might coincide on arbitrary long initial segments of N). In order to describe a paradigm in which the bound depends on the underlying reality being identified, we need a mechanism for naming these possible realities. One way to achieve this is to include in the paradigm's definition a parameter y , which is the programming system (numbering) in which a scientist's conjectures are interpreted. (N.B. In this section we allow the possibility that [image] is a strict subset of [image].) Until now such a parameterization was implicit and a scientist's hypotheses were interpreted in some fixed acceptable programming system for the partial recursive functions. The parameterized version of the Ex paradigm is as follows.
12.6 Definition Let y be a programming system.
(a) M Ex-identifies S with respect to y (written: ) just in case for each [image] and y M(f) = f.
(b) [image].
It is easy to check that for any two acceptable programming systems, y and y ', Ex y = Ex y '. Thus, if attention is restricted to acceptable programming systems, then choosing one over the other does not yield any extra learning ability. Most of the paradigms discussed in this book can straightforwardly be redefined with the underlying pro-


Page 265
gramming system as a parameter; we will denote the resulting classes simply by including the programming system in the subscript. For example, Exn, y denotes the collections of functions that can be identified with no more than n mind changes with respect to the acceptable programming system y .
Before formalizing paradigms with a bounded number of examples, we introduce a couple of technical tools. For each M and [image], define
.
Roughly, conv (M, s ) is the last mind change in the sequence [image] Given a scientist M and [image], we also define
.
Thus, cony(M, f) denotes the earliest convergence point, if any, for M on f.
We now introduce identification from a bounded number of examples in a given programming system. N.B. The paradigm described below is dependent on the order in which the function is fed to the scientist. For convenience of investigation, we assume that the function is presented to the scientist in canonical order. Such a requirement is a weakness of this model.
12.7 Definition (Wiehagen [199]) Let h be a partial recursive function and y a programming system.
(a) S is said to be h-Bounded-Ex-identifiable with respect to y (written: ) just in case there exists a scientist M that Ex-identifies S with respect to y and, for all i with [image], we have [image].
(b) [image].
(c) [image].
(d) [image].
Surprisingly, Bounded-Ex is no less inclusive than Ex. Indeed:
12.8 Proposition (Wiehagen [199]) Bounded-Ex = Ex.
Proof: Fix an arbitrary M. We construct a programming system y and a scientist M' such that [image], where [image]. This will establish the


Page 266
proposition. Recall that our standard pairing function [image] is one-one, onto, and monotone nondecreasing in both arguments.
For each i, n, and x, define
Since [image] is recursive, we have that [image] is partial recursive. Observe that [image] is total if and only if j i is total and [image]. Moreover, if [image] is total, then [image]. For each [image], define
.
It follows that, for each [image], [image], y M'(g) = g and conv(M', g) = conv(M, g). Finally, since for all i and n, [image], it follows that for each [image], M' id-BoundedEx y -identifies g.
Note that the h witnessing the above is extremely simple. In contrast, we have the following which says that there exists a programming system y for which there are collections of functions that can be identified with no more than one mind change with respect to y , but that are not in h-Bounded-Ex y for any recursive function h.
12.9 Proposition (Wiehagen [199]) There exists a programming system y for which there are collections of functions S such that [image]).
Proof: Let X be any nonrecursive r.e. set and let f be a 1-1 recursive function such that range(f) = X. Without loss of generality, let [image]. Let [image] and, for each [image], let
.
For each i, define
.
Clearly, [image] is partial recursive.
It is clear that [image]. Suppose by way of contradiction that, for some recursive h, M h-BoundedEx-identifies each y i. Let k = h(0). Then it follows that [image] if and only if [image]. But this contradicts the nonrecursiveness of X.


Page 267
§12.4 An Axiomatic Approach to Complexity of Convergence
In this section we briefly discuss axiomatizations of various complexity measures for convergence. This discussion is based on work of Daley and Smith [54], which in turn was inspired by Blum's [19] axiomatic treatment of complexity measures for computable functions. As before, we assume in what follows that texts for functions are arranged in canonical order.
12.10 Definition Let M denote the class of all computable scientists. Suppose C is a partial function from [image]. We say that C is a complexity measure for convergence if and only if the following two axioms are satisfied.
(A1) [image].
(A2) The relation [C(M, f) = n] is limiting-recursively decidable in M, f, and n.1
These two axioms parallel Blum's axioms for the complexity of programs (see page 24). Note that the definition concerns complexity of convergence, not identification. In other words, there is no requirement that the final hypothesis be correct.
The following proposition shows that the mind change complexity measure described in Section 12.2 satisfies the above axioms. See Exercises 12-5 and 12-6 for other examples of measures.
12.11 Proposition (Daley and Smith [54]) Let d (M, f) denote the number of mind changes made by M on f. Then d satisfies the axioms given in Definition 12.10
Proof: Clearly, d (M, f) is defined if and only if [image]. So, d satisfies axiom (A1). For each M and [image], define
.
Clearly, [image] is recursive. Note that, for each M and f,
It is thus straightforward to show that d satisfies axiom (A2).
Daley and Smith [54] have a number of further results on complexity measures based on this axiomatic approach.
1 That is, there is a recursive functional Q such that, for all M, [image], and [image], we have that [image] and this limit is 1 if C(M, f) = n and 0 otherwise.


Page 268
§12.5 Strictly Minimal Identification of Languages
Identification places no constraint on the size of the final hypothesis, so long as it corresponds to the incoming function or language. More realism in this regard is easy to justify since conciseness is widely touted as a virtue of good theory. Similarly, there is reason to study small, final hypotheses in the acquisition of language by children. To the extent that developmental psycholinguists seek to characterize the form of the grammar in the child's mind, models of learning should recognize that final hypotheses cannot be arbitrarily large (assuming that the child cannot implement a Turing Machine whose states exceed the number n of synapses in the brain — or 2n if we crudely attempt to model all possible brain configurations).
In this and the next section we consider two approaches to restricting the size of final hypotheses. We consider results only for language learning, leaving functions to the exercises. One of our main concerns is to study the dependence of size restrictions on the underlying programming system in which a scientist's conjectures are interpreted.
A natural restriction on hypothesis size is that it be minimal. Recall from Chapter 2 that the index of a program satisfies the requirements of a Blum program size measure. The next definition introduces a paradigm in which scientists are required to converge to minimal-size hypotheses in a given programming system
12.12 Definition
(a) M TxtMin y -identifies L (written: ) just in case, for all texts T for L, [image].
(b) [image].
12.13 Proposition There is an acceptable programming system y such that TxtMin y contains an infinite collection of infinite r.e. languages.
Proof: For each y, let [image] and let [image]. Recall that j is our standard acceptable programming system. We define a programming system y as follows. (The y 2i+1 case in this definition guarantees that y is acceptable.) For all i, define:
.


Page 269
For each s , define
We leave it as a straightforward exercise to check that M TxtMin y -identifies [image].
The TxtMin y paradigm can be related in a striking fashion to TxtEx. For this purpose, we introduce the following definition which is based on a related notion of Freivalds [61] (see Exercise 12-8).
12.14 Definition (Case and Chi [27])
(a) Suppose g and v are recursive functions. We say that [image] is limiting standardizable via g with recursive estimate v (written: ) if and only if, for each [image], there is an i L with [image] such that, for every i with W i = L we have:
1. , and
2. .
(b) We say that [image] is text limiting standardizable with recursive estimate (written: ) if and only if, for some recursive g and v we have [image].
Intuitively, the role of g in the definition of TxtLsr is to provide indirectly a limiting recursive solution to a special case of the grammar equivalence problem ( [image]) where the grammars generate languages in [image]; the v places some extra constraints on how g reaches its limit.2 The notion of TxtLsr defined above is implicitly parameterized by the choice of acceptable programming system. Explicit parameterization is not called for, because it is easy to check that the class TxtLsr is independent of the choice of acceptable programming system. Here is the promised characterization of TxtMin y .
12.15 Proposition For all [image], the following are equivalent.
(a) For some acceptable programming system y , [image].
(b) [image].
2This interpretation is due to John Case.


Page 270
Proof: Let [image] be given.
. Suppose that y is an acceptable programming system and that [image]. Clearly, [image] It suffices to construct recursive functions g and v such that [image] Since y and j are acceptable, there are recursive functions, r1 and r2, such that, for all i,
.
For each i, let T i be the text such that, for each x and t,
Thus, T i is a text for W i. For each i and n, define v(i) = r 2(i) + 1 and
It is immediate from the definition of g that, for each i, [image]. Now suppose that [image] and W i = L. Then [image]. Hence, [image], which is a j -grammar for L. Therefore, [image]) as required.
. Let g and v be recursive functions such that [image] For each [image], let i L be as in Definition 12.14(a). The following simple observation is crucial in our construction of y . The proof is obvious.
12.16 Claim Suppose i is such that there are infinitely many n with g(i, n) = i. Then either [image] of [image] and [image].
Let [image] and [image]. For each [image], define
We note that r provides a recursive one-to-one correspondence between A and N. For each (i0, j0) and (i1, jl) [image] we write (i0, j0) <l> (i1, j1) if and only if r(i0, j0) <l> r(i1, j1). Since r is a one-to-one correspondence between A and N, this is a total order on A. Moreover, by the definition of r we have


Page 271
We define a partial recursive [image] by the equation:
So if [image], then h (i, j + 1) is the (j + 1)-st distinct grammar in the list g(i, 0), g(i, 1), g(i, 2), . . .; and if [image], then this list contains fewer than (j + 1) distinct
grammars. For each [image] and [image], define
Since r is a recursive one-to-one correspondence between A and N, it follows that
is well defined. It follows by clause (i) in the definition of y that y is acceptable. Recall that, for all i and s, [image].
12.17 Claim Suppose [image]. Then:
(a) If j= 0, then
(b) If j > 0 and [image], then [image].
(c) If j > 0, [image], and [image], then
(d) If j > 0, [image], and [image], then
The above claim follows directly from the definition of y . We also have:
12.18 Claim Suppose [image] and (i, j) is the least element of A such that h (i, j) = i L. Then:
(a) W r(i, j) = L (hence, [image]).
(b) j > 0.
(c) If L is infinite, then MinGram Y = r(i, j).
Proof: Part (a). If j = 0, then h (i, 0) = i L implies, by the definition of h , that i = i L, and, by Claim 12.17(a), [image]. If j > 0, then by the definitions of y and h and the fact that [image], we also have that [image].


Page 272
Part (b). Suppose i* = MinGram j (L). Then, by our choice of i* and Claim 12.17(a), we have that, for all (i, 0) < (i*,0), [image]. Since [image], we have that [image] and, hence, for some [image], we must have [image]. Thus, it follows that j > 0, although we may well have (i, j) < (i*, j*).
Part (c). Suppose L is infinite. Suppose by way of contradiction that for some [image] we have r(i', j') = MinGram y (L). By part (a) and the ordering on A, it follows that (i', j') < (i, j). By the argument for part (b) it must be the case that j' > 0. Since L = W r(i', j') is infinite, it follows from Claim 12.17(b) that [image]. Let p = h (i', j'). By Claim 12.17(c) we have that, for infinitely many n, g(p, n) = p. Hence, by Claim 12.17(d), W p = W h (i', j') = W r(i', j'), which by hypothesis is [image]. So, by Claim 12.16, we must have h (i', j') p = i L. But since (i', j') < (i, j), this contradicts our choice of (i, j) as the least element of A with h (i, j) = i L. Hence, part (c) follows.
It is convenient to introduce a y -analog of W i, s. Towards this end fix p h , some j -program for h . Then, for each [image] and [image], define
By Claim 12.17 we have that, for all [image], [image], and, for all s, [image]. Moreover, deciding whether [image] is recursive in i, j, s, and x.
Now let M be a scientist that TxtEx-identifies [image]. We define a scientist M' as follows.
Program for M' on s .
Let k = M( s ), [image], and p = g(k, n).
Find the least [image], if any, such that [image] and [image].
If no such (i, j) is found, then output 0 and halt.
If such an (i, j) is found, then:
Find the least [image], if any, such that [image] and [image].
If no such an (i', j') was found, output r(i, j).
If such an (i, j) was found, output r(i', j').
End Program.


Page 273
We claim that [image]. To see this, suppose T is a text for an [image]. Then [image] and Wk = L. So, for all sufficiently large n, we have that [image] and g(k, n) = i L. Therefore, in the program for M', for all sufficiently large n, the search for (i, j) finds the least (i, j) such that h (i, j) = i L. We consider two cases.
Case 1: L is finite. In this case it follows from Claim 12.18(a) and our definition of M' that [image].
Case 2: L is infinite. Suppose [image] is such that [image] and, for infinitely many n, [image]. Then it follows that Wr(i, j) = L. But by Claim 12.18, the only way that can happen is if (i', j') = (i, j). Hence, by the program for M', for all but finitely many n, M'(T[n]) = r(i, j) = MinGram y (L).
It thus follows that [image].
§12.6 Nearly Minimal Identification
We next consider paradigms in which scientists converge to hypotheses that are of minimal size, modulo a recursive fudge factor. (We say that the hypotheses are of ''nearly minimal" size.) The next two definitions introduce this idea.
12.19 Definition Suppose y is a programming system and [image]. We say that i is an h-minimal y -grammar for L just in case [image] and [image].
12.20 Definition (Case and Chi [27])Suppose [image].
(a) M h-TxtMex y -identifies [image] (written: ) just in case, for each [image] and each text T for L, we have that [image] and M(T) is an h-minimal y -grammar for L.
(b) [image].
(c) [image].
The following proposition is immediate.
12.21 Proposition For all acceptable programming systems y and y ', TxtMex y = TxtMex Y '.
So, if the fudge factor is allowed to be any computable function, the notion of nearly minimal identification is independent of the underlying acceptable programming system.


Page 274
We thus sometimes refer to TxtMex y (for acceptable programming system y ) as simply TxtMex. If the fudge factor is required to be some fixed computable function, then drastic things can occur, as the next proposition demonstrates.
12.22 Proposition For each computable h, there is an acceptable programming system such that no infinite collection of infinite languages can be h-TxtMex ½ -identified.
As an immediate corollary of Proposition 12.22 and Proposition 12.13 we have:
12.23 Corollary There are acceptable programming systems, y and y , for which we have [image].
Thus, TxtMin y -identification is dependent on the choice of acceptable programming system y . If we take as a given that the notions of our theory must be recursively invariant, this corollary precludes the study of TxtMin y -identification as an interesting criterion of language learning. On the other hand, it may be the case that the dependence of size-restricted paradigms on the underlying acceptable programming system is a fundamental fact about learnability rather than a mere mathematical inconvenience.
Proof (of Proposition 12.22): Fix an [image] which we assume without loss of generality is strictly increasing. Let [image] denote a finite sequence uniformly formed from j and s such that: (i) [image] and (ii) [image]. Let M0, M1, M2, . . . be a recursive enumeration of total computable scientists along the lines of Corollary 4.16. We define
Clearly, g is strictly increasing and recursive. For each i, define [image], where for each s and x,


Page 275
12.24 Claim For all i:
(a) If i = g(j) for some j, then [image].
(b) If g(j) < i < g(j) + j + 3 for some j and [image] is infinite, then [image].
(c) If [image] for some j, then [image].
The above claim follows immediately from the definition of y . We also have:
12.25 Claim Suppose L is an infinite r.e. set with MinGram y (L) > 0. Let j + 1 = MinGram y (L) and let A be the set of h-minimal y -grammars for L. Then:
(a) [image].
(b) For each i e A and each i < j, we have that [image].
Proof: Let S = { g(j) + 1, . . ., g(j) + j + 2}. Suppose [image] and there is no i < j such that [image]. Then it follows from the definition of [image] that as s goes to infinity, so does the s' of clause (ii). Hence, [image]. Since there are only j + 1 many [image] and j + 2 many [image], there is at least one y -grammar for L in S. Let i* be the least y -grammar for L in S. Since L is infinite, it follows from our choice of j + 1 and Claim 12.24 that i* = MinGram y (L). Since h is strictly increasing, we have that [image]. Hence, by Claim 12.24(c), all the h-minimal y -grammars must be [image]. Part (a) of the claim thus follows. Part (b) follows using part (a) and the construction of [image].
We leave the rest of the proof to the reader.
Jain and Sharma [89] discuss other properties of the h-TxtMex paradigm.
§12.7 Bibliographic Notes
The subject of bounding the number of mind changes was first considered by Barzdins * and Freivalds [15].
Case and Smith [35] were the first to study the interaction of mind changes and anomalies in the final program. For other results relating to mind changes, see Case, Jain, and Ngo-Manguelle [28]. Case, Jain, and Sharma [31] investigate mind changes in the context of vacillatory identification of functions. Mind change complexity of indexed families of computable languages has been investigated by Mukouchi [135] and by Lange and Zeugmann [118]. Recently, Freivalds and Smith [66] proposed a generalized notion


Page 276
of mind changes based on the use of constructive ordinals to bound the number of mind changes. See Jain and Sharma [94] and Ambainis, Jain, and Sharma [4] for applications of this notion to the analysis of the complexity of learning natural classes of languages. More generalized notions of mind change complexity can be found in Ambainis, Freivalds, and Smith [3] and Sharma, Stephan, and Ventsov [174].
The approach of bounding the number of examples before a scientist converges as a measure of complexity is due to Wiehagen [199, 198, 197]. These references also present a number of variants on this theme.
The idea of total work performed by a scientist before the onset of convergence as a model of complexity is due to Daley and Smith [54]. Freivalds has [62] an alternative proposal in which the number of distinct hypotheses conjectured by a scientist is considered a measure for the complexity of identification.
Freivalds [62] made the first attempt at an axiomatization of the complexity of identification for functions. The approach presented in this chapter is due to Daley and Smith [54]. Schäfer-Richter [167] has an alternative axiomatization.
Restrictions on program size in the context of functions were first studied by Freivalds [61]. He also introduced the notions of nearly minimal identification and limiting standardizable with a recursive estimate. Chen [37] considered variants of nearly minimal identification for functions in the presence of anomalies in the final program. Kinber [107, 108] has a number of additional results on program-size restrictions for function identification.
Case and Chi [27] adapted Freivalds' definition of nearly minimal function identification to languages. Jain and Sharma [89] considered strictly minimal identification, nearly minimal identification, and analogs of some of Kinber's notions for languages. Case, Jain, and Sharma [30] investigated nearly minimal identification in the context of vacillatory identification of languages.
The subject of learning "fastest" hypotheses has not been as well investigated as that of learning succinct hypotheses. The interested reader is referred to Zeugmann [207].
Recently, the idea of reduction from recursion theory has been employed to compare the difficulty of learning classes of concepts. This notion, referred to as intrinsic complexity, was first investigated by Freivalds, Kinber, and Smith [65] in the context of functions. Jain and Sharma [93] studied the intrinsic complexity of languages. See Jain and Sharma [95] for the structure of these reductions and Jain and Sharma [94] for connections between intrinsic complexity and mind change bounds measured by constructive ordinals.


Page 277
§12.8 Exercises
12-1 For each [image], let [image]. Intuitively, cyl(f) denotes the cylindrification of f.
(a) Show that [image].
(b) Show that [image].
12-2 Show [image].
12-3 Recall the convention that: 0 < 1 < 2 < . . . < *. Also recall that, for each [image], Exa can be written as [image], that is, there is no bound on the number of mind changes. Suppose [image]. Show that [image].
12-4 (Sharma [173]) Adapt the notion of mind changes to the paradigm InfTxtEx (Definition 8.31) to define the paradigm InfTxtExn. Show that [image]. This somewhat surprising result says that the collections of languages that can be one shot learned from both positive and negative data can also be identified in the limit from only positive data. Additionally, show that [image].
12-5 Show that the function Conv defined in Equation (12.1) on page 265 satisfies the axioms given in Definition 12.10.
12-6 The following definition (due to Daley and Smith [54]) is intended to capture the total amount of work done by a scientist on a function before the onset of convergence.
12.26 Definition Let F M(f[n]) denote the time (or any other suitable Blum complexity measure [19]) used by M on the evidential state f[n]. For each M and f, define
The above is based on the integral [image] F(x) dx defining work in classical mechanics; auc stands for 'area under the curve.' Note that, as was the case with identification from a bounded number of examples, the above notion also assumes that the graph of the


Page 278
function is fed to the scientist in canonical order. Also observe that the auc measure is defined for a scientist on a function if the scientist converges on the function; it does not matter to what the scientist converges.
Show that auc satisfies the axioms given in in Definition 12.10.
This measure is developed in greater detail in Daley and Smith [54].
12-7 (Freivolds [61], Kinber [106]) The following provides the function analog of the TxtMin paradigm.
12.27 Definition
(a) We say that M Min y -identifies f (written: ) just in case [image].
(b) [image].
Show that there is an acceptable programming system y for which Min y has an infinite r.e. class of functions as an element.
12-8 (Freivolds [61]) Freivolds introduced the notion of limit standardizability with a recursive estimate (abbreviated: Lsr) defined below:
12.28 Definition We say that S is limiting standardizable via g with recursive estimate v (written: ) if and only if, for each [image], there is an if with j if = f such that, for every i with j i = f we have:
(a) [image], and
(b) [image].
We say that S is limiting standardizable with a recursive estimate (written: ) if and only if, for some recursive g and v, [image].
(a) Prove that the notion of Lsr is independent of the choice of an acceptable programming system.
(b) Establish the following characterization of Min y -identification. The following are equivalent for allS.
(i) For some acceptable y , [image].
(ii) [image].


Page 279
12-9 (Freivalds [61], Chen [37]) The following formalizes the notion of nearly minimal identification for functions.
12.29 Definition Let a be a member of ( [image]) and let h be a recursive function.
(a) M [image] (written: ) if and only if, for each [image], we have that [image], y M(f) = a f, and [image].
(b) [image].
(c) [image].
Thus, a scientist M [image] S just in case for each [image], M Exa-identifies f in the acceptable programming system y , and the final stabilized output of M on f is no bigger than h(MinProg y (f)).
(a) Suppose that [image]) and that y and y ' are acceptable programming systems. Show that [image]. (Thus, it makes sense to refer to [image] as just Mexa)
(b) Suppose that h is a recursive function such that, for all x, [image]. Show that there exists an acceptable y such that for all S, [image] is finite.
(c) Use part (b) and Exercise 12-7 to show that there are two acceptable programming systems y and y ' such that [image].
12-10 (Chen [37]) Show the following:
(a) [image].
(b) For each [image], [image].
(c) [image].
12-11 Using an argument similar to that for Proposition 12.15, prove:
12-12 For each [image], define TxtMexa to the obvious variation on TxtMex that permits a-many anomalies in the final grammar. Show the following:
(a) [image].
(b) For each [image], [image].
(c) [image].


Page 281
13
Beyond Identification by Enumeration
§13.1 Gold's and Barzdins' * Conjectures
This chapter concerns the strategy of identification by enumeration. Under this strategy a scientist has a fixed list of possible hypotheses and, at any point in time, the current conjecture is always the first hypothesis on the list that is consistent with the current data. We consider only identification of functions. A similar study can be carried out for identification of languages from informants.1 We formalize identification by enumeration as follows.
13.1 Definition
(a) A scientist M is an enumerator just in case there exists a recursive f such that [image] and, for all [image], M( s ) = f(i), where i is the least number such that [image].
(b) [image] is identifiable by enumeration just in case there exists an enumerator M such that [image].
Many collections of functions are identifiable by enumeration, as shown by the following, easy proposition.
13.2 Proposition (Gold [80]) Each r.e. indexable class of computable functions (see Definition 5.10) is identifiable by enumeration.
Since identification by enumeration can be viewed as a search for the correct hypothesis in a suitably generated space of hypotheses, this strategy captures an essential property of most practical systems of empirical inquiry. The naturalness of this strategy led Gold [80] to conjecture that:
Identification by enumeration is the only method of identification in the sense that each identifiable collection of functions is also identifiable by enumeration.
1 For identification of languages from texts, it can be shown that identification by enumeration is not a very powerful strategy, as even the class [image] is not identifiable by enumeration.


Page 282
This conjecture is appealing but false. The collection of self-describing functions, [image], is identifiable, but it is easily shown that [image] cannot be identified by any scientist that is an enumerator.
In defense of Gold's intuitions, refutation of his conjecture via [image] seems like a trick. After all, to identify [image] requires no more than fetching some coded value from the input function. In the 1970's, Barzdins * formulated a more sophisticated version of Gold's conjecture designed to transcend such counterexamples. He reasoned that if a class [image] of functions is identifiable only by way of a self-referential property, then there would be a total recursive operator [image] that would transform the class into an unidentifiable one. The idea is that if a scientist is able to find the embedded self-referential information in the elements of a class, so can a total recursive operator which can then weed out this information. To see this in the context of [image], consider the operator [image] such that, if [image], then g(x) = f(x + 1), for all [image]. essentially "shifts the function f to the left." It is easy to see that [image], and we know from prior work that [image]. Thus, [image] transforms the identifiable class [image] into an unidentifiable class [image] by removing the self-referential information from [image] that made it identifiable.
Informally stated, Barzdins'* conjecture is:
If the projection of a class of functions under all total recursive operators is identifiable, then the class is identifiable by enumeration.
More formally, we have:
13.3 Definition (Fulk [72]) [image] is said to be robustly Ex-identifiable just in case for all total recursive operators [image], [image].
13.4 Conjecture (Barzdins * as formalized by Fulk [72]) Every subclass of [image] that is robustly Ex-identifiable is contained in some r.e. indexable subclass of [image] .
This conjecture is also appealing, and also false. The next section presents a cunning refutation due to Fulk [72]. Beyond simply showing the conjecture to be false, the refutation demonstrates an identification strategy that is strictly more general than enumeration but in the same spirit.
§13.2 Fulk's Refutation of Barzdins'* Conjecture
Here is Fulk's result.


Page 283
13.5 Proposition (Fulk [72]) There exists a class [image] of recursive functions such that:
(a) For all total recursive operators [image], [image].
(b) [image] is not contained in an r.e. indexable class of computable functions.
Proof: The argument is organized as a series of claims. We first introduce some definitions and notation.
For this proof, we let s and T (with or without decorations) range over INIT. Also, in this proof we shall identify each s with [image], the finite function with graph content ( s ). It will always be clear from context whether s is taken as a partial function or a member of INIT.
Let h 0 and h 1 be partial functions. If there is an x such that [image], we say that h 0 and h 1 are inconsistent (written: ); otherwise, we say that h 0 and h 1 are consistent (written: h 0 ~ h 1). So, h 0 and h 1 are consistent if and only if [image] is a (single-valued) partial function.
Let Q be an effective indexing of the class of recursive operators. That is, [image] is exactly the class of recursive operators and l i, [image] is itself a recursive operator (of type [image]). See Section 9.8 of Rogers [158] for an example of such an indexing. Recall from Chapter 2 that each recursive operator [image] has the following topological property.
Continuity: For all a , [image].
We shall make strong use of this property in the following.
Our first claim introduces some technical machinery to help in the definition of [image]. The proof of this claim is left to Exercise 13-1.
13.6 Claim There are sequences of initial segments, [image] and [image], that satisfy properties (A), (B), and (C) below.
(A) [image] and [image] are limiting-recursive functions.
(B) For all i, and all j > i, [image] and [image] .
(C) For each k and each [image], either (C.1) or (C.2) is true.
(C.1)
(C.2)


Page 284
Fix [image] and [image] that witness Claim 13.6. Let con(., .) denote the predicate such that, for all i and k,
13.7 Claim
(a) Suppose that [image], Q k is total recursive, and con (i, k) holds. Then, for all [image], con (i, k) also holds.
(b) For each fixed k, trip predicate con(i, k) is limiting-recursively (in i) decidable.
Proof: Part (a) follows from Claim 13.6(C). Part (b) is an easy exercise.
Let f be a limiting-recursive function such that, for all i and x,
Intuitively, f(i) is a program for a function that extends s i by diagonalizing against the i-th possible r.e. indexable class of computable functions. Note that since l i. s i is limiting recursive, such a limiting-recursive f can be constructed using the s-m-n theorem (Theorem 2.1). Finally, we define
13.8 Claim S is not contained in any r.e. indexable class of computable functions.
Proof: Suppose by way of contradiction that there is a recursive function p such that [image]. Choose i0 such that [image] Since [image] is total and its range consists of programs for total functions, it follows that [image]. Since [image], there is a j such that [image]. Thus we have
a contradiction.
Fix an arbitrary k such that Q k is total recursive. Our next goal is to show that [image]. Since our choice of k is arbitrary, this will establish the proposition. To


Page 285
help show [image], we use the s-m-n theorem (Theorem 2.1) to define two limiting-recursive functions g and h as follows. For each i and x define:
Since l i.Ti is limiting recursive, it follows that one can construct a limiting-recursive g as above. For each [image], define
and, for each i > k, define
Since l i.con(i, k), f, and g are limiting-recursive, it follows that one can construct a limiting-recursive h as above. (Note: One cannot, in general, limiting-recursively decide whether Q k( j f(i)) is total. But this is not a difficulty since (13.1) affects only finitely many values of h.)
13.9 Claim
(a) For each i, if con(i, k), then s g(i) is consistent with Q k( j f(i)).
(b) For each [image], [image]. Thus, [image].
(c) For each j > i, [image].
Proof: By Claim 13.6(C) for [image], we have that con(i, k) implies
Since [image], part (a) follows from the definition of g.
Part (b) follows from part (a) and definition of h.
For part (c), first note that, for [image], we have by (13.1) that j h(i) is total, and hence, for such [image], part (c) clearly holds. So assume i > k and suppose j h(i) ~ j h(j). By


Page 286
(13.2), this implies that Q k( j f(i)) is consistent with Q k( j f(j)). By the definition of j f(j) and Claim 13.6(B) we have [image]. Hence, it follows that con(i, k) and
So this case follows also.
We now proceed to prove that Q k(S) belongs to Ex. From Claim 13.9(b) we have [image]. Also as a corollary to Claim 13.9(c) we have:
13.10 Claim For all j with [image] and all i < j, either j h(i) = j h(j) or [image] .
We now construct a machine M Ex-identifying the class [image]. Let H(i, t) be a recursive function such that [image]. For each [image], define
, where i is the least number [image] such that [image].
Using Claim 13.10, it follows immediately that M Ex-identifies [image]. Thus the proposition follows.
We note that M in the above proof can be seen as performing a more general sort of identification by enumeration. M's search space is described by a limiting recursive function h, and not every j h(i), [image] is total. This may be contrasted with the original notion of identification by enumeration in which the search space of an enumerator is described by a recursive function whose range consists exclusively of programs for total functions.
§13.3 Exercises
13-1 Show that [image] and [image] as defined below are as required in Claim 13.6. For convenience, let [image]. Now for each [image], inductively define s i and [image] to be the lexicographically least pair from INIT that satisfies


Page 287
(a)
(b) [image], and
(c)
13-2 Before Fulk's work [72], Kurtz and Smith [116] gave the following, weaker for-malization of Barzdins's * conjecture, which they refuted.
Conjecture: is r.e. indexable if and only if [image].
Proposition 13.5 implies that this conjecture is false, but we can give a direct refutation as follows.
13.11 Definition [image] is said to be stable if and only if, for all recursive operators Q such that [image], [image].
(a) Suppose f is a limiting-recursive function and [image]. Show that [image] is stable.
(b) Construct a limiting recursive-function f such that [image] is not r.e. indexable.
(c) Conclude that the above conjecture is false.


Page 289
BIBLIOGRAPHY
[1] L. Adleman and M. Blum, Inductive inference and unsolvability, Journal of Symbolic Logic 56 (1991), 891-900.
[2] A. Ambainis, Probabilistic and team PFIN-type learning: General properties, Proceedings of the Ninth Annual Conference on Computational Learning Theory, ACM Press, 1996, pp. 157-168.
[3] A. Ambainis, R. Freivalds, and C. Smith, General inductive inference types based on linearly-ordered sets, Proceedings of Symposium on Theoretical Aspects of Computer Science, Lecture Notes in Computer Science, vol. 1046, Springer-Verlag, 1996, pp. 243-253.
[4] A. Ambainis, S. Jain, and A. Sharma, Ordinal mind change complexity of language identification, Third European Conference on Computational Learning Theory (S. Ben-David, ed.), Lecture Notes in Artificial Intelligence, vol. 1208, Springer-Verlag, 1997, pp. 301-315.
[5] D. Angluin, Finding patterns common to a set of strings, Journal of Computer and System Sciences 21 (1980), 46-62.
[6] ———, Inductive inference of formal languages from positive data, Information and Control 45 (1980), 117-135.
[7] K. Apsitis *, Asymmetric team learning, Proceedings of the Tenth Annual Conference on Computational Learning Theory, ACM Press, 1997, pp. 90-95.
[8] S. Arikawa, S. Miyano, A. Shinohara, T. Shinohara, and A. Yamamoto, Algorithmic learning theory with elementary formal systems, IEICE Trans. Inf. and Syst. E75-D No. 4 (1992), 405-414.
[9] S. Arikawa, T. Shinohara, and A. Yamamoto, Learning elementary formal systems, Theoretical Computer Science 95 (1992), 97-113.
[10] H. Arimura and T. Shinohara, Inductive inference of Prolog programs with linear data dependency from positive data, Proc. Information Modelling and Knowledge Bases V, IOS Press, 1994, pp. 365-375.
[11] G. Baliga and J. Case, Learning with higher order additional information, Algorithmic learning theory: Fourth International Workshop on Analogical and Inductive Inference (AII '94) and Fifth International Workshop on Algorithmic Learning Theory (ALT '94) (S. Arikawa and K. Jantke, eds.), Lecture Notes in Artificial Intelligence, vol. 872, Springer-Verlag, 1994, pp. 64-75.
[12] G. Baliga, S. Jain, and A. Sharma, Learning from multiple sources of inaccurate data, SIAM Journal of Computing 26 (1997), 961-990.


Page 290
[13] J. Barzdins *, Inductive inference of automata, functions and programs, Int. Math. Congress, Vancouver, 1974, pp. 771-776.
[14] ———, Two theorems on the limiting synthesis of functions, Theory of Algorithms and Programs, vol. 1, Latvian State University, 1974, In Russian, pp. 82-88.
[15] J. Barzdins* and R. Freivalds, On the prediction of general recursive functions, Soviet Mathematics Doklady 13 (1972), 1224-1228.
[16] J. Barzdins* and K. Podnieks, The theory of inductive inference, Mathematical Foundations of Computer Science, Math. Inst. of the Slovak Academy of Sciences, 1973, pp. 9-15.
[17] D. Bickerton, The roots of language, Karoma, 1981.
[18] L. Blum and M. Blum, Toward a mathematical theory of inductive inference, Information and Control 28 (1975), 125-155.
[19] M. Blum, A machine-independent theory of the complexity of recursive functions, Journal of the ACM 14 (1967), 322-336.
[20] ———, On the size of machines, Information and Control 11 (1967), 257-265.
[21] G. Boolos and R. Jeffrey, Computability and logic, Cambridge University Press, 1980.
[22] R. Brown and C. Hanlon, Derivational complexity and the order of acquisition in child speech, Cognition and the Development of Language (J. R. Hayes, ed.), Wiley, 1970.
[23] J. Carbonell, Machine learning: Paradigms and methods, MIT Press, 1990.
[24] J. Case, Periodicity in generations of automata, Mathematical Systems Theory 8 (1974), 15-32.
[25] ———, The power of vacillation, Proceedings of the Workshop on Computational Learning Theory (D. Haussler and L. Pitt, eds.), Morgan Kaufmann, 1988, pp. 133-142.
[26] J. Case, The power of vacillation in language learning, SIAM Journal on Computing (1997), to appear.
[27] J. Case and H. Chi, Machine learning of nearly minimal size grammars, unpublished manuscript, 1986.
[28] J. Case, S. Jain, and S. Ngo Manguelle, Refinements of inductive inference by Popperian and reliable machines, Kybernetika 30 (1994), 23-52.
[29] J. Case, S. Jain, and A. Sharma, On learning limiting programs, International Journal of Foundations of Computer Science 3 (1992), no. 1, 93-115.
[30] ———, Vacillatory learning of nearly minimal size grammers, Journal of Computer and System Sciences 49 (1994), 189-207.
[31] ———, Complexity issues for vacillatory function identification, Information and Computation 116 (1995), 174-192.


Page 291
[32] J. Case, S. Kaufmann, E. Kinber, and M. Kummer, Learning recursive functions from approximations, Second European Conference on Computational Learning Theory (Paul Vitányi, ed.), Lecture Notes in Artificial Intelligence, vol. 904, Springer-Verlag, 1995, pp. 140-153.
[33] J. Case and C. Lynes, Machine inductive inference and language identification, Proceedings of the 9th International Colloquium on Automata, Languages and Programming (M. Nielsen and E. M. Schmidt, eds.), Lecture Notes in Computer Science, vol. 140, Springer-Verlag, 1982, pp. 107-115.
[34] J. Case and S. Ngo Manguelle, Refinements of inductive inference by Popperian machines, Tech. Report 152, SUNY/Buffalo, 1979.
[35] J. Case and C. Smith, Comparison of identification criteria for machine inductive inference, Theoretical Computer Science 25 (1983), 193-220.
[36] K. J. Chen, Tradeoffs in machine inductive inference, Ph.D. thesis, SUNY/Buffalo, 1981.
[37] ———, Tradeoffs in inductive inference of nearly minimal sized programs, Information and Control 52 (1982), 68-86.
[38] N. Chomsky, Syntactic structures, Mouton & Co., 1957.
[39] ———, Aspects of the theory of syntax, MIT Press, 1965.
[40] ———, Reflections on language, Pantheon, 1975.
[41] ———, Initial states and steady states, Language and Learning (M. Piatelli-Palmarini, ed.), Harvard University Press, 1980.
[42] ———, Rules and representations, Columbia University Press, 1980.
[43] ———, Knowledge of language, Praeger, 1986.
[44] S. Cook, Computability and complexity of higher type functions, Logic from Computer Science (Y.N. Moschovakis, ed.), Springer-Verlag, 1991, pp. 51-72.
[45] N. Cutland, Computability: An introduction to recursive function theory, Cambridge University Press, 1980.
[46] R. Daley, On the error correcting power of pluralism in BC-type inductive inference, Theoretical Computer Science 24 (1983), 95-104.
[47] ———, Transformation of probabilistic learning strategies into deterministic learning strategies, Proceedings of the Workshop on Computational Learning Theory (D. Haussler and L. Pitt, eds.), Morgan Kaufmann, 1988, pp. 157-163.
[48] R. Daley and B. Kalyanasundaram, Capabilities of probabilistic learners with bounded mind changes, Proceedings of the Sixth Annual Conference on Computational Learning Theory, ACM Press, 1993, pp. 182-191.


Page 292
[49]. ———, Use of reduction arguments in determining Popperian FIN-type learning capabilities, Algorithmic Learning Theory: Fourth International Workshop (ALT '93) (K. Jantke, S. Kobayashi, E. Tomita, and T. Yokomori, eds.), Lecture Notes in Artificial Intelligence, vol. 744, Springer-Verlag, 1993, pp. 173-186.
[50] R. Daley, B. Kalyanasundaram, and M. Velauthapillai, Breaking the probability 1/2 barrier in FIN-type learning, Proceedings of the Fifth Annual Workshop on Computational Learning Theory, ACM Press, 1992, pp. 203-217.
[51] ———, The power of probabilism in Popperian finite learning, Analogical and Inductive Inference, Proceedings of the Third International Workshop, Lecture Notes in Artificial Intelligence, vol. 642, Springer-Verlag, 1992, pp. 151-169.
[52] ———, Capabilities o f fallible finite learning, Proceedings of the Sixth Annual Conference on Computational Learning Theory, ACM Press, 1993, pp. 199-208.
[53] R. Daley, L. Pitt, M. Velauthapillai, and T. Will, Relations between probabilistic and team one-shot learners, Proceedings of the Fourth Annual Workshop on Computational Learning Theory (L. Valiant and M. Warmuth, eds.), Morgan Kaufmann, 1991, pp. 228-239.
[54] R. Daley and C. Smith, On the complexity of inductive inference, Information and Control 69 (1986), 12-40.
[55] M. Demetras, K. Post, and C. Snow, Feedback to first language learners: The role of repetitions and clarification questions, Journal of Child Language 13 (1986), 275-292.
[56] R. Dudley, Real analysis, Wadsworth & Brooks/Cole, 1989.
[57] H. Feldman, S. Goldin-Meadow, and L. Gleitman, Beyond Herotodus: The creation of language by linguistically deprived deaf children, Action, Symbol and Gesture: The Emergence of Language (A. Lock, ed.), Academic Press, 1978.
[58] J. Feldman, Some decidability results on grammatical inference and complexity, Information and Control 20 (1972), 244-262.
[59] L. Fortnow, W. Gasarch, S. Jain, E. Kinber, M. Kummer, S. Kurtz, M. Pleszkoch, T. Slaman, R. Solovay, and F. Stephan, Extremes in the degrees of inferability, Annals of Pure and Applied Logic 66 (1994), 231-276.
[60] R. Freivalds, Functions computable in the limit by probabilistic machines, Mathematical Foundations of Computer Science, Lecture Notes in Computer Science, vol. 28, Springer-Verlag, 1974, pp. 77-87.
[61] ———, Minimal Gödel numbers and their identification in the limit, Mathematical Foundations of Computer Science, Lecture Notes in Computer Science, vol. 32, Springer-Verlag, 1975, pp. 219-225.


Page 293
[62] ———, On the complexity and optimality of computation in the limit, Theory of Algorithms and Programs, vol. 2, Latvian State University, 1975, pp. 155-173.
[63] ———, Finite identification of general recursive functions by probabilistic strategies, Proceedings of the Conference on Fundamentals of Computation Theory, Akademie-Verlag, Berlin, 1979, pp. 138-145.
[64] ———, Recursiveness of the enumerating functions increases the inferrability of recursively enumerable sets, Bulletin of the European Association for Theoretical Computer Science 27 (1985), 35-40.
[65] R. Freivalds, E. Kinber, and C. Smith, On the intrinsic complexity of learning, Second European Conference on Computational Learning Theory (Paul Vitányi, ed.), Lecture Notes in Artificial Intelligence, vol. 904, Springer-Verlag, 1995, pp. 154-169.
[66] R Freivalds and C. Smith, On the role of procrastination in machine learning, Information and Computation (1993), 237-271.
[67] R. Freivalds and R. Wiehagen, Inductive inference with additional information, Electronische Informationverarbeitung und Kybernetik 15 (1979), 179-195.
[68] M. Fulk, Inductive inference with additional information, Journal of Computer and System Sciences, to appear.
[69] ———, A study of inductive inference machines, Ph.D. thesis, SUNY/Buffalo, 1985.
[70] ———, Saving the phenomenon: Requirements that inductive machines not contradict known data, Information and Computation 79 (1988), 193-209.
[71] ———, Prudence and other conditions on formal language learning, Information and Computation 85 (1990), 1-11.
[72] ———, Robust separations in inductive inference, 31st Annual IEEE Symposium on Foundations of Computer Science (1990), 405-410.
[73] M. Fulk and S. Jain, Approximate inference and scientific method, Information and Computation 114 (1994), 179-191.
[74] ———, Learning in the presence of inaccurate information, Theoretical Computer Science A 161 (1996), 235-261.
[75] M. Fulk, S. Jain, and D. Osherson, Open problems in systems that learn, Journal of Computer and System Sciences 49 (1994), no. 3, 589-604.
[76] W. Gasarch and M. Pleszkoch, Learning via queries to an oracle, Proceedings of the Second Annual Workshop on Computational Learning Theory (R. Rivest, D. Haussler, and M. Warmuth, eds.), Morgan Kaufmann, 1989, pp. 214-229.
[77] W. Gasarch and C. Smith, Learning via queries, Journal of the ACM (1992), 649-674.


Page 294
[78] J. Gill, Computational complexity of probabilistic Turing machines, SIAM Journal of Computing (1977), 675-695.
[79] L. Gleitman and E. Newport, The invention of language by children: Environmental and biological influences on the acquisition of language, Invitation to Cognitive Science: Language, 2nd Edition (L. Gleitman and M. Liberman, eds.), MIT Press, 1995.
[80] E. M. Gold, Language identification in the limit, Information and Control 10 (1967), 447-474.
[81] K. Hirsh-Pasek, R. Treiman, and M. Schneiderman, Brown and Hanlon revisited: Mothers' sensitivity to ungrammatical forms, Journal of Child Language 11 (1984), 81-88.
[82] J. Hopcroft and J. Ullman, Introduction to automata theory, languages, and computation, Addison-Wesley, 1979.
[83] S. Jain, Program synthesis in the presence of infinite number of inaccuracies, Journal of Computer and System Sciences 53 (1996), no. 1, 583-591.
[84] ———, Strong monotonic and set driven inductive inference, Journal of Experimental and Theoretical Artificial Intelligence 9 (1997), 137-143.
[85] S. Jain and A. Sharma, Learning in the presence of partial explanations, Information and Computation 95 (1991), 162-191.
[86] ———, Learning with the knowledge of an upper bound on program size, Information and Computation 102 (1993), 118-166.
[87] ———, On the non-existence of maximal inference degrees for language identification, Information Processing Letters 47 (1993), 81-88.
[88] ———, On monotonic strategies for learning r.e. languages, Algorithmic learning theory: Fourth International Workshop on Analogical and Inductive Inference (AII '94) and Fifth International Workshop on Algorithmic Learning Theory (ALT '94) (S. Arikawa and K. Jantke, eds.), Lecture Notes in Artificial Intelligence, vol. 872, Springer-Verlag, 1994, pp. 349-364.
[89] ———, Program size restrictions in computational learning, Theoretical Computer Science 127 (1994), 351-386.
[90] ———, On aggregating teams of learning machines, Theoretical Computer Science 137 (1995), 85-108.
[91] ———, Prudence in vacillatory language identification, Mathematical Systems Theory 28 (1995), 267-279.
[92] ———, Computational limits on team identification of languages, Information and Computation 130 (1996), 19-60.


Page 295
[93] ———, The intrinsic complexity of language identification, Journal of Computer and System Sciences 52 (1996), 393-402.
[94] ———, Elementary formal systems, intrinsic complexity, and procrastination, Information and Computation 132 (1997), 65-84.
[95] ———, The structure of intrinsic complexity of learning, Journal of Symbolic Logic 62 (1997), 1187-1201.
[96] ———, Generalization and specialization strategies for learning r.e. languages, Annals of Mathematics and Artificial Intelligence (1998), to appear.
[97] S. Jain, A. Sharma, and M. Velauthapillai, Finite identification of function by teams with success ratio 1/2 and above, Information and Computation 121 (1995), 201-213.
[98] K. Jantke, Natural properties of strategies identifying recursive functions, Electronische Informationverarbeitung und Kybernetik 15 (1979), 487-496.
[99] ———, Monotonic and non-monotonic inductive inference, New Generation Computing 8 (1991), 349-360.
[100] K. Jantke and H. Beick, Combining postulates of naturalness in inductive inference, Electronische Informationverarbeitung und Kybernetik 17 (1981), 465-484.
[101] C. Jockusch, Degrees of generic sets, Recursion Theory: Its generalizations and applications (F. Drake and S. Wainer, eds.), Cambridge University Press, 1980, pp. 110-139.
[102] B. Kapron and S. Cook, A new characterization of type 2 feasibility, SIAM Journal of Computing 25 (1996), 117-132.
[103] S. Kapur, Monotonic language learning, Algorithmic Learning Theory: Third International Workshop (ALT '92) (S. Doshita, K. Furukawa, K. Jantke, and T. Nishida, eds.), Lecture Notes in Artificial Intelligence, vol. 743, Springer-Verlag, 1992, pp. 147-158.
[104] S. Kaufmann and F. Stephan, Robust learning with infinite additional information, Third European Conference on Computational Learning Theory (S. Ben-David, ed.), Lecture Notes in Artificial Intelligence, vol. 1208, Springer-Verlag, 1997, pp. 316-330.
[105] M. Kearns and U. Vazirani, An Introduction to Computational Learning Theory, MIT Press, 1994.
[106] E. Kinber, On a theory of inductive inference, Proceedings of the 1977 International Fundamentals of Computation Theory, Lecture Notes in Computer Science, vol. 56, Springer-Verlag, 1977, pp. 435-440.
[107] ———, On limit identification of minimal Gödel numbers for functions from enumerable classes, Theory of Algorithms and Programs, vol. 3, Latvian State University, 1977, pp. 35-56.


Page 296
[108] ———, A note on limit identification of c-minimal indices, Electronische Informationverarbeitung und Kybernetik 19 (1983), 459-463.
[109] E. Kinber and F. Stephan, Language learning from texts: Mind changes, limited memory and monotonicity, Information and Computation 123 (1995), 224-241.
[110] E. Kinber and T. Zeugmann, Inductive inference of almost everywhere correct programs by reliably working strategies, Electronische Informationverarbeitung und Kybernetik 21 (1985), 91-100.
[111] ———, One-sided error probabilistic inductive inference and reliable frequency identification, Information and Computation 92 (1991), 253-284.
[112] M. Krishna Rao, A class of Prolog programs inferable from positive data, Algorithmic Learning Theory: Seventh International Workshop (ALT '96) (A. Arikawa and A. Sharma, eds.), Lecture Notes in Artificial Intelligence, vol. 1160, Springer-Verlag, 1996, pp. 272-284.
[113] M. Kummer and M. Ott, Learning branches and learning to win closed games, Proceedings of the Ninth Annual Conference on Computational Learning Theory, ACM Press, 1996, pp. 280-291.
[114] M. Kummer and F. Stephan, On the structure of degrees of inferability, Journal of Computer and System Sciences 52 (1996), no. 2, 214-238.
[115] S. Kurtz and J. Royer, Prudence in language learning, Proceedings of the Workshop on Computational Learning Theory (D. Haussler and L. Pitt, eds.), Morgan Kaufmann, 1988, pp. 143-156.
[116] S. Kurtz and C. Smith, On the role of search for learning, Proceedings of the Second Annual Workshop on Computational Learning Theory (R. Rivest, D. Haussler, and M. Warmuth, eds.), Morgan Kaufmann, 1989, pp. 303-311.
[117] I. Lakatos, Falsification and the methodology of scientific research programmes, The methodology of scientific research programmes, Philosophic Papers Volume 1 (J. Worrall and G. Currie, eds.), Cambridge University Press, 1978, pp. 8-101.
[118] S. Lange and T. Zeugmann, Learning recursive languages with a bounded number of mind changes, International Journal of Foundations of Computer Science 4 (1993), no. 2, 157-178.
[119] ———, Monotonic versus non-monotonic language learning, Proceedings of the Second International Workshop on Nonmonotonic and Inductive Logic, Lecture Notes in Artificial Intelligence, vol. 659, Springer-Verlag, 1993, pp. 254-269.
[120] ———, Characterization of language learning from informant under various monotonicity constraints, Journal of Experimental and Theoretical Artificial Intelligence 6 (1994), 73-94.


Page 297
[121] ———, Set-driven and rearrangement-independent learning of recursive languages, Mathematical Systems Theory 29 (1996), 599-634.
[122] S. Lange, T. Zeugmann, and S. Kapur, Monotonic and dual monotonic language learning, Theoretical Computer Science A 155 (1996), 365-410.
[123] P. Langley, H. Simon, G. Bradshaw, and Z. Zytkow, Scientific discovery, MIT Press, 1987.
[124] H. Lasnik, The forms of sentences, Invitation to Cognitive Science: Language, 2nd Edition (L. Gleitman and M. Liberman, eds.), MIT Press, 1995.
[125] E. Lenneberg, Biological foundations of language, Wiley, 1967.
[126] H. Lewis and C. Papadimitriou, Elements of the theory of computation, Prentice-Hall, 1981.
[127] E. Martin and D. Osherson, Scientific discovery based on belief revision, Journal of Symbolic Logic 62 (1997), 1352-1370.
[128] E. Martin and D. Osherson, Elements of scientific inquiry, M.I.T. Press, Cambridge MA, 1998.
[129] R. Matthews and W Demopoulos, Learnability and linguistic theory, Kluwer, 1989.
[130] L. Meyer, Probabilistic language learning under monotonicity constraints, Algorithmic Learning Theory: Sixth International Workshop (ALT '95), Lecture Notes in Artificial Intelligence, vol. 997, Springer-Verlag, 1995, pp. 169-184.
[131] ———, Monotonic and dual-monotonic probabilistic language learning, Third European Conference on Computational Learning Theory (S. Ben-David, ed.), Lecture Notes in Artificial Intelligence, vol. 1208, Springer-Verlag, 1997, pp. 66-78.
[132] E. Minicozzi, Some natural properties of strong identification in inductive inference, Theoretical Computer Science (1976), 345-360.
[133] T. Motoki, T. Shinohara, and K. Wright, The correct definition of finite elasticity: Corrigendum to identification of unions, Proceedings of the Fourth Annual Workshop on Computational Learning Theory (L. Valiant and M. Warmuth, eds.), Morgan Kaufmann, 1991, p. 375.
[134] S. Muggleton and C. Feng, Efficient induction of logic programs, Proceedings of the First Workshop on Algorithmic Learning Theory, Ohmsa Publishers, 1990, Reprinted by Ohmsa Springer-Verlag, pp. 368-381.
[135] Y. Mukouchi, Inductive inference with bounded mind changes, Algorithmic Learning Theory: Third International Workshop (ALT '92) (S. Doshita, K. Furukawa, K. Jantke, and T. Nishida, eds.), Lecture Notes in Artificial Intelligence, vol. 743, Springer-Verlag, 1992, pp. 125-134.


Page 298
[136] E. Newport, L. Gleitman, and H. Gleitman, Mother I'd rather do it myself: Some effects and noneffects of maternal speech style, Talking to children: Language input and acquisition (C. Snow and C. Ferguson, eds.), Cambridge University Press, 1977.
[137] D. Osherson, Computer output, Cognition 20 (1985), 261-264.
[138] D. Osherson, M. Stob, and S. Weinstein, Learning theory and natural language, Cognition 17 (1984), 1-28.
[139] ———, Aggregating inductive expertise, Information and Control 70 (1986), 69-95.
[140] ———, Systems that learn: A n introduction to learning theory for cognitive and computer scientists, MIT Press, 1986.
[141] ———, Synthesising inductive expertise, Information and Computation 77 (1988), 138-161.
[142] D. Osherson and T. Wasow, Species specificity and task specificity in the study of language: a methodological note, Cognition 4 (1976), no. 2, 203-214.
[143] D. Osherson and S. Weinstein, Criteria of language learning, Information and Control 52 (1982), 123-138.
[144] ———, On the study of first language acquisition, Journal of Mathematical Psychology 39 (1995), 129-145.
[145] D. Osherson, S. Weinstein, D. de Jongh, and E. Martin, A first-order framework for learning, Handbook of Logic and Language (J. van Bentham and A. ter Meulen, eds.), Elsevier Science Publishers, 1996.
[146] M. Ott and F. Stephan, Structural measures for games and process control in the branch learning model, Third European Conference on Computational Learning Theory (S. Ben-David, ed.), Lecture Notes in Artificial Intelligence, vol. 1208, Springer-Verlag, 1997, pp. 94-108.
[147] C. S. Peirce, Collected papers, Harvard University Press, Cambridge, Mass., 1958.
[148] S. Pinker, Language acquisition, Invitation to Cognitive Science: Language, 2nd Edition (L. Gleitman and M. Liberman, eds.), MIT Press, 1995.
[149] L. Pitt, A characterization of probabilistic inference, Ph.D. thesis, Yale University, 1984.
[150] ———, Probabilistic inductive inference, Journal of the ACM 36 (1989), 383-433.
[151] L. Pitt and C. Smith, Probability and plurality for aggregations of learning machines, Information and Computation 77 (1988), 77-92.
[152] K. Podnieks, Probabilistic synthesis of enumerated classes of functions, Soviet Mathematics Doklady 16 (1975), 1042-1045.
[153] K. Popper, Objective knowledge: An evolutionary approach, Clarendon Press, 1979.


Page 299
[154] G. Pullum, Learnability, hyperlearning, and the poverty of the stimulus, Proceedings of the 22nd Annual Meeting of the Berkeley Linguistics Society (J. Johnson, M. Juge, and J. Moxley, eds.), Berkeley Linguistics Society, 1996.
[155] H. Putnam, Probability and confirmation, Mathematics, Matter, and Method, Cambridge University Press, 1975.
[156] ———, What is innate and why: Comments on the debate, Language and Learning (M. Piatelli-Palmarini, ed.), Harvard University Press, 1980.
[157] J. Quinlan, Learning logical definitions from relations, Machine Learning 5 (1990), 239-266.
[158] H. Rogers, Theory of recursive functions and effective computability, McGraw-Hill, 1967, Reprinted, MIT Press 1987.
[159] J. Royer, Inductive inference of approximations, Information and Control 70 (1986), 156-178.
[160] J. Royer, Semantics versus syntax versus computations: Machine models for type-2 polynomial-time bounded functionals, Journal of Computer and System Sciences 54 (1997), 424-436.
[161] J. Royer and J. Case, Subrecursive programming systems: Complexity & succinctness, Birkhäuser, 1994.
[162] W. Rudin, Principles of mathematical analysis, 3rd edition, McGraw-Hill, 1976.
[163] B. Russell, A history of western philosophy, Simon and Schuster, 1945.
[164] ———, Human knowledge: Its scope and limits, Simon and Schuster, 1948.
[165] Y. Sakakibara, Grammatical inference: An old and new paradigm, Algorithmic Learning Theory: Sixth International Workshop (ALT '95), Lecture Notes in Artificial Intelligence, vol. 997, Springer-Verlag, 1995, pp. 1-24.
[166] G. Sankoff and P. Brown, The origins of syntax in discourse: A case study of Tok Pisin relatives, Language 52 (1976), 631-666.
[167] G. Schäfer-Richter, Uber eingabeabhangigkeit und komplexitat yon inferenzstrategien., Ph.D. thesis, RWTH Aachen, 1984.
[168] B. Schieffelin and A. Eisenberg, Cultural variation in children's conversations, Early language: Acquisition and intervention (R. Schiefelbusch and D. Bricker, eds.), University Park Press, 1981.
[169] A. Seth, There is no recursive axiomatization for feasible functionals of type 2, Seventh Annual IEEE Symposium on Logic in Computer Science, IEEE Computer Society Press, 1992, pp. 286-295.


Page 300
[170] ———, Some desirable conditions for feasible functions of type 2, Eighth Annual IEEE Symposium on Logic in Computer Science, IEEE Computer Society Press, 1993, pp. 320-331.
[171] E. Shapiro, Inductive inference of theories from facts, Tech. Report 192, Computer Science Department, Yale University, 1981.
[172] ———, Algorithmic program debugging, MIT Press, 1983.
[173] A. Sharma, A note on batch and incremental learnability, Journal of Computer and System Sciences (1998), to appear.
[174] A. Sharma, F. Stephan, and Y. Ventsov, Generalized notions of mind change complexity, Proceedings of the Tenth Annual Conference on Computational Learning Theory, ACM Press, 1997, pp. 96-108.
[175] T. Shinohara, Rich classes inferable from positive data: Length-bounded elementary formal systems, Information and Computation 108 (1994), 175-186.
[176] J. Shoenfield, Mathematical logic, Addison-Wesley, 1967.
[177] T. Slaman and R. Solovay, When oracles do not help, Proceedings of the Fourth Annual Workshop on Computational Learning Theory, Morgan Kaufmann, 1991, pp. 379-383.
[178] C. Smith, The power of pluralism for automatic program synthesis, Journal of the ACM 29 (1982), 1144-1165.
[179] C. Smith and M. Velauthapillai, On the inference of programs approximately computing the desired function, Analogical and Inductive Inference, Proceedings of the International Workshop (K. Jantke, ed.), Lecture Notes in Computer Science, vol. 265, Springer-Verlag, 1986, pp. 164-176.
[180] ———, On the inference of approximate programs, Theoretical Computer Science 77 (1990), 249-266.
[181] R. Smullyan, Theory of formal systems, annals of mathematical studies, no. 47, Princeton, N J, 1961.
[182] C. E. Snow and C. A. Ferguson (eds.), Talking to children: Language input and acquisition, Cambridge University Press, Cambridge, 1977.
[183] R. Soare, Recursively enumerable sets and degrees, Springer-Verlag, 1987.
[184] R. J. Solomonoff, A formal theory of inductive inference, Part I, Information and Control 7 (1964), 1-22.
[185] ———, A formal theory of inductive inference, Part II, Information and Control 7 (1964), 224-254.


Page 301
[186] F. Stephan, Noisy inference and oracles, Algorithmic Learning Theory: Sixth International Workshop (ALT '95), Lecture Notes in Artificial Intelligence, vol. 997, Springer-Verlag, 1995, pp. 185-200.
[187] P. Suppes, Philosophy and the sciences, Acting and reflecting (W. Sieg, ed.), Kluwer, 1990.
[188] B. Trakhtenbrot and J. Barzdins *, Konetschnyje awtomaty (powedenie i sintez), Nauka, Moskwa, 1970, in Russian. English Translation: Finite Automata-Behavior and Synthesis, Fundamental Studies in Computer Science 1, North Holland, Amsterdam, 1975.
[189] H. van Riemskijk and E. Williams, Introduction to the theory of grammar, MIT Press, 1986.
[190] T. Wasow, Grammatical theory, Foundations of Cognitive Science (Michael Posner, ed.), MIT Press, 1989.
[191] J. Webb, Mechanism, mentalism, and metamathematics, D. Reidel, 1980.
[192] K. Weihrauch, Computability, Springer-Verlag, 1987.
[193] J. Werker, Exploring developmental changes in cross-language speech perception, Invitation to Cognitive Science: Language, 2nd Edition (L. Gleitman and M. Liberman, eds.), MIT Press, 1995.
[194] K. Wexler and P. Culicover, Formal principles of language acquisition, MIT Press, 1980.
[195] R. Wiehagen, Identification of formal languages, Mathematical Foundations of Computer Science, Lecture Notes in Computer Science, vol. 53, Springer-Verlag, 1977, pp. 571-579.
[196] ———, Characterization problems in the theory of inductive inference, Proceedings of the 5th International Colloquium on Automata, Languages and Programming, Lecture Notes in Computer Science, vol. 62, Springer-Verlag, 1978, pp. 494-508.
[197] ———, How fast is program synthesis from examples, Mathematical Methods of Specification and Synthesis of Software Systems (W. Bibel and K. Jantke, eds.), Lecture Notes in Computer Science, vol. 215, Springer-Verlag, 1985, pp. 231-239.
[198] ———, On the complexity of effective program synthesis, Analogical and Inductive Inference, Proceedings of the International Workshop (K. Jantke, ed.), Lecture Notes in Computer Science, vol. 265, Springer-Verlag, 1986, pp. 209-219.
[199] ———, On the complexity of program synthesis from examples, Electronische Informationverarbeitung und Kybernetik 22 (1986), 305-323.
[200] ———, A thesis in inductive inference, Nonmonotonic and Inductive Logic, 1st International Workshop (J. Dix, K. Jantke, and P. Schmitt, eds.), Lecture Notes in Artificial Intelligence, vol. 543, Springer-Verlag, 1990, pp. 184-207.
[201] R. Wiehagen, R. Freivalds, and E. Kinber, On the power of probabilistic strategies in inductive inference, Theoretical Computer Science 28 (1984), 111-133.


Page 302
[202] R. Wiehagen and W. Liepe, Charakteristische eigenschaften yon erkennbaren klassen rekursiver funktionen, Electronische Informationverarbeitung und Kybernetik 12 (1976), 421-438.
[203] R. Wiehagen and T. Zeugmann, Ignoring data may be the only way to learn efficiently, Journal of Experimental and Theoretical Artificial Intelligence 6 (1994), 131-144.
[204] K. Wright, Identification of unions of languages drawn from an identifiable class, Proceedings of the Second Annual Workshop on Computational Learning Theory (R. Rivest, D. Haussler, and M. Warmuth, eds.), Morgan Kaufmann, 1989, pp. 328-333.
[205] T. Yokomori, On polynomial-time learning in the limit of strictly deterministic automata, Machine Learning 19 (1996), 153-182.
[206] T. Zeugmann, A-posteriori characterizations in inductive inference of recursive functions, Electronische Informationverarbeitung und Kybernetik 19 (1983), 559-594.
[207] ———, On the synthesis of fastest programs in inductive inference, Electronische Informationverarbeitung und Kybernetik 19 (1983), 625-642.
[208] T. Zeugmann and S. Lange, A guided tour across the boundaries of learning recursive languages, Algorithmic Learning for Knowledge-Based Systems (K. Jantke and S. Lange, eds.), Lecture Notes in Artificial Intelligence, vol. 961, Springer-Verlag, 1995, pp. 190-258.
[209] T. Zeugmann, S. Lange, and S. Kapur, Characterizations of monotonic and dual monotonic language learning, Information and Computation 120 (1995), 155-173.


Page 303
NOTATION INDEX
N, 15
N+, 15
#, 15
*, 15
, 15
, 15
, 15
, 15
, 15
, 15
, 15
card(A), 15
, 15
min(A), 15
max(A), 15
A[n], 16
D , 16
, 16
[x, y], 16
[x, y), 16
(x, y], 16
(x, y), 16
, 16
16
16
((x, y)), 16
'' , 16
$ , 16
, 16
, 16
$ !, 16
, 16
, 16
, 16
, 16
, 16
, 17
, 17
, 17
, 17
, 17
, 17
domain( h ), 17
range( h ), 17
f o g, 17
h [n], 17
h (A), 17
X A, 17
m x1. Q(x 1, . . ., x n), 17
, 17
, 18
p , 18
, 18
, 18
, 18
, 18
rowx(A), 18
colx(A), 18


Page 304
n p, 19
, 20
j , 20
, 20
pad(()·, ·), 21
MinProg n ( a ), 24
MinGram n (L), 24
, 24
, 24
j i, s, 25
W i, s, 25
K, 25
content(T), 31
T(n), 32
T[n], 32
SEQ, 32
for [image], 32
s (n) for [image] 32
s [n] for [image], 32
, 35
, 35
, 37
for [image], 41
for [image], 41
, for [image], 41
, for [image], 41
, 41
, 41
s - for [image], 45
s last for [image], 45
content(G), 50
SEG, 50
for [image], 50
content( s ) for [image], 50
s (n) for [image], 50
s [n] for [image], 50
for s [image], 51
, 51
, 51
, 51
, 51
s -n, 57
s last n, 57
Lang, 62
Func, 62
TxtEx, 63
, 64
Ex, 69
INIT, 69
FA( s ), 70
, 71
, 71
DL(i), 76
[·], 76
[·]f, 76
, 79
, 80
, 84
, 84
[TxtEx]all-def, 93
[TxtEx]class-all-def, 93
[TxtEx]consistent, 93
[TxtEx]class-consistent, 95
[TxtEx]account, 96


Page 305
[TxtEx]class-account, 96
, 97
[TxtEx]prudent, 98
[TxtEx]set-driven, 99
[TxtEx]rearrangement-independent, 100
[TxtEx]order-indenpent, 101
[TxtEx]class-order-independent, 101
visible( s ), 102
[TxtEx]reliable, 106
[TxtEx]conservative, 108
[TxtEx]class-conservative, 108
[TxtEx]strong-conservative, 109
[TxtEx]class-strong-monotonic, 109
[TxtEx]monotonic, 110
[TxtEx]weak-monotonic, 110
[TxtEx]class-weak-monotonic, 110
[TxtEx]dual-weak-monotonic, 113
[TxtEx]class-dual-weak-monotonic, 114
[Ex]consistent, 115
[Ex]class-consistent, 115
[Ex]Popperian, 117
[Ex]class-Popperian, 117
Enum, 117
[Ex]rec-reliable, 118
[Ex]decisive, 119
[Ex]class-decisive, 119
[TxtEx]class-nontrivial, 122
[TxtEx]class-nontrivial, 122
[TxtEx]nonexcessive, 122
[TxtEx]weak-nontriv, 122
[TxtEx]cond-consistent, 123
[TxtEx]tot-minded, 123
[TxtEx]gradualist, 123
[TxtEx]cautious, 123
[TxtEx]confident, 124
[TxtEx]dual-strong-monotonic, 124
[TxtEx]class-dual-strong-monotonic, 124
[TxtEx]dual-monotonic, 125
[TxtEx]class-dual-monotonic, 125
Exa, 128
, 129
Bc, 131
Bca, 133
Fexa, 136
TxtExa, 138
TxtBca, 140
TxtBca, 140
, 142
Ex=m, 145
, 145
Exta, 146
Oexa, 146
FOexa, 147
TxtExta, 148
, 148
, 149
, 149
LimExa, 149
inf, 152
sup, 152
lim inf, 152
lira sup, 152
den(A, B), 153
den(A), 153


Page 306
aa(A, B), 154
ad(A, B), 154
Aexa, 155
TxtAexa, 158
uden m(A), 159
uden(A), 159
aua(A, B), 159
aud(A, B), 159
Uexa, 159
Huexa, 160
aua m( a , b ), 161
aud m( a , b ), 161
Huexa,m, 161
Huexa, 161
, 163
Dapa, 166
SEGI, 169
NaTxtExb, 169
InaTxtExb, 169
ImaTxtExb, 169
NaExb, 171
InaExb, 171
ImaExb, 171
AscTxtExa, 181
AscTxtBca, 181
InfTxtExa, 182
InfTxtBca, 182
RecTxtExa, 182
RecLang, 183
NonrecLang, 184
NonrecTxtEx, 184
, 185
, 185
, 185
N*Lang, 190
In*Lang, 190
Im*Lang, 190
In*Func, 190
Im*Func, 190
AscEx, 194
, 198
, 198
N t, 202
, 202
, 202
, 202
, 202
O(n), 202
O[n], 202
PO( s ), 202
PO(f), 202
pr(A), 203
, 204
, 204
, 204
, 204
ProbpEx, 206
, 207
, 207
C r, 208
C r,k, 208
C(A), 208
IN(p), 212
ProbpTxtEx, 214


Page 307
TeamTxtEx, 214
conv(M, s ), 215
M(x, s ), 223
M(x, f), 223
MinProg c(f), 223
Bexa,c, 223
UniBex, 224
MinGram c(L), 231
M(x, T), 231
TxtBex, 232
TxtUniBex, 232
ApdExa, 236
UapdExa, 237
urd(L', L), 240
TxtApdExa, 241
TxtApdExa, 241
M(x, y, T), 241
TxtApd1Acpd2Exa, 242
TxtApd1Uacpd2Exa, 242
TxtUapd1Acpd2Exa, 242
TxtUapd1Uacpd2Exa, 242
BEXa,c, 245
Apd1Aexd2, 247
OAEx, 252
STR, 253
Queries(M, A, s ), 256
OA,bEx, 256
OA,bTxtEx, 257
? 262
, 262
, 262
Ex Y , 264
conv(M, sigma), 265
conv(M, f), 265
h-Bounded-Ex Y , 265
Bounded-Ex Y , 265
Bounded-Ex, 265
, 267
s (M, f), 267
TxtMin, 268
TxtLsr, 269
TxtLsr(g, v), 269
h-TxtMex, 273
TxtMex, 273
TxtMex, 274
auc(M, f), 277
TxtMin, 278
Min Y , 278
Lsr(g, v), 278
Mex, 279
, 279
, 279


Page 309
AUTHOR AND SUBJECT INDEX
A
acceptable programming system, 20
accountable identification, 96
accuracy of learning, 13
Adleman, L., 253, 259
Aexa identification, 155
Ambainis, A., 219, 276
Angluin, D., 42, 85, 93, 107, 108, 120, 121
Ap identification, 165
identification, 247
ApdExa identification, 236
approximate explanatory identification, 155
Apsitis *, K., 219
Arikawa, A., 85
Arimura, H., 85
AscTxtBca identification, 181
ascending text, 58, 180, 181, 194
AscEx identification, 194
AscTxtExa identification, 181
asymptotic agreement, 154
asymptotic disagreement, 154
asymptotic uniform agreement, 159, 161
asymptotic uniform disagreement, 159, 161
B
Baliga, G., 188, 189, 245
Barzdins*, J., 95, 115, 118, 120, 131, 136, 145, 262, 275, 282
Barzdins'* Conjecture, 282
Bc identification, 131, 133
Bca identification, 133
behaviorally correct identification, 131, 140
Beick, H., 120
BEXa,c identification, 245
Bexa,c identification, 223
Bickerton, D., 82
Blum, L., 4, 27, 41, 42, 71, 101, 102, 115, 120, 121, 128, 144, 197, 219
Blum, M., 4, 23, 24, 27, 41, 42, 71, 101, 102, 115, 120, 121, 128, 144, 197, 219, 253, 259, 267, 268, 277
Boolos, G., 9
Borel field, 203
Bradshaw, G., 4, 61
Brown, P., 82
Brown, R., 32
C
candidate stabilizing sequence, 103
Canny, J., 122
canonical index, 16
canonical order, 69
canonical text, 69, 70
Carbonell, J., 61
Case, J., 18, 23, 63, 117, 118, 121, 128, 129, 131-133, 135, 136, 138, 140-142, 144-146, 149, 219, 245, 262, 263, 269, 273, 275, 276
cautious identification, 123
characteristic function, 17
Chen, K. J., 162, 163, 276, 279
Chi, H., 269, 273, 276
Chomsky, N., 3, 4, 29, 37
Church, A., 15
compactness of a functional, 19
comparative grammar, 29, 30, 44, 47, 66, 82
computation tree, 207
path, 207
computational complexity measure, 24
axioms for, 24, 267
computer simulability, 61
conditionally consistent identification, 122
confident identification, 59, 84, 124
conservative identification, 107


Page 310
consistent identification, 93, 115
constant scientists, 37
continuity of an operator, 19
convergence
finitely, 142
of a path in a computation tree, 208
of a scientist, 35
on multiple texts, 185
Cook, S., 261
cover of e , 66
Culicover, P., 30, 45, 49, 99, 120, 121
Cutland, N., 15
D
d-conforming, 236
language, 240
language uniformly, 240
uniformly, 236
Daley, R., 145, 219, 267, 276-278
Dap identification, 166
data
inaccurate, 168
de Jongh, D., 30
decisive identification, 119
Demetras, M., 32
Demopoulos, W., 40
density of a set, 153
density of one set relative to another, 153
descriptor
for functions, 75
for languages, 75
noise in, 76
divergence of a scientist, 35
dual-monotonic identification, 125
dual-strong-monotonic identification, 124
dual-weak-monotonic identification, 113
Dudley, R., 152, 156, 204
E
easily distinguishable, 56
effective continuous functional, 19
efficiency of learning, 13, 261
Eisenberg, A., 32
elasticity
finite, 85
infinite, 85
empirical inquiry, 4
central concepts, 5, 13, 27, 167
data, 5, 8-10, 31-32, 49-50
intelligible hypotheses, 5, 10, 31-32, 49-50
possible realities, 5, 8-10, 28-30, 48-49
scientists, 5, 10-11, 32-35, 50-51, 197
success criteria, 5, 11-13, 35-38, 51-52, 127
empty sequence, 32
enumeration of computable scientists, 69, 71
enumerator, 59, 281
error of commission, 128, 138
error of omission, 128, 138
evidential state, 33
Ex identification, 69
Ex identification with respect to Y , 264
Ex=m identification, 145
Exa identification, 128
identification, 262
exact identification, 81
in the weak sense, 87
identification, 163
Exscat identification, 165
Exta identification, 146
extensionality, 61
F
fat text, 47
Feldman, H., 82
Feldman, J., 131, 145
Feng, C., 108
Fexa identification, 136
finite identification, 262


Page 311
finite thickness, 85
finite variants of functions, 17
finite variants of sets, 16
finitety convergent scientist, 142
FOexa identification, 147
FOIL, 113
Fortnow, L., 254, 256, 259, 260
Freivalds, R., 39, 118, 202, 219, 223, 224, 244, 262, 269, 275, 276, 278, 279
Fulk, M., 98, 100-102, 120, 121, 163, 165, 166, 189, 245, 282, 283
Func, 62
function conjectured by a scientist, 51
functional, 19
G
Gasarch, W., 252, 254, 256, 259, 260
generic set, 254
Gill, J., 197
Gleitman, H., 32
Gleitman, L., 32, 82
Gold, E. M., 4, 12, 27, 39, 43, 59, 63, 69, 72, 189, 262, 281, 282
Gold, E.M., 36, 51
Goldin-Meadow, S., 82
Golem, 108
gradualist identification, 123
grammar, 29
equivalence, 269
h-minimal, 273
H
h-Bounded Ex identification, 265
halting problem, 15, 25
Hanlon, C., 32
Harrington, L., 135, 145
high set, 253
Hirsh-Pasek, K., 32
Hopcroft, J., 15, 29
Huexa,m identification, 161
human language, 29, 30, 40, 47, 48, 235
I
identification
accountable, 96
Aexa, 155
Ap, 165
247
ApdExa, 236
approximate explanatory, 155
AscTxtBca, 181
AscEx, 194
AscTxtExa, 181
Bc, 131, 133
Bca, 133
behaviorally correct, 131, 140
BEXa,c, 245
Bexa,c, 223
cautious, 123
conditionally consistent, 122
confident, 59, 84, 124
conservative, 107
consistent, 93, 115
Dap, 166
decisive, 119
dual-monotonic, 125
dual-strong-monotonic, 124
dual-weak-monotonic, 113
Ex, 69
Ex with respect to Y , 264
Ex=m, 145
Exa, 128
, 262
exact, 81
exact in the weak sense, 87
, 163
Exscat, 165
Exta, 146
Fexa, 136
FOexa, 147
gradualist, 123
h-Bounded Ex, 265


Page 312
identification (continued)
Huexa,m, 161
Im*Func, 190
Im*Lang, 190
ImaExb, 171
ImaTxtExb, 169
in the limit, 39
In*Func, 190
In*Lang, 190
InaExb, 171
InaTxtExb, 169
InfTxtBca, 182
InfTxtExa, 182
LimExa, 149
, 279
Min Y , 278
monotonic, 109
, 185
, 185
, 185
N*Lang, 190
NaExb, 170
NaTxtExb, 169
nonexcessive, 122
NonrecLang, 184
NonrecTxtEx, 184
nontrivial, 122
Oexa, 146
of a collection of functions, 51
of a collection of languages, 36
of a function, 51
of a language, 36
of a text, 35
OA,bEx, 256
OAEx, 252
OATxtEx, 257
order independence, 101
Popperian, 117
ProbpEx, 206
ProbpTxtEx, 214
prudent, 98
rearrangement independence, 100
RecLang, 183
RecTxtExa, 182
recursive reliable, 118
reliable, 106, 118
set driven, 99
strong-monotonic, 108
, 198
, 198
total minded, 123
TxtAcpdExa, 241
TxtAexa, 158
, 242
TxtApdExa, 241
, 242
TxtBca, 140
TxtBexa,c, 232
TxtEx, 63, 138
TxtExa, 138
TxtExExact, 81
[TxtEx]global-monotonic, 125
TxtExta, 148
TxtExWeakExact, 87
, 148
, 142
, 149
TxtMex, 274
TxtMex Y , 273
TxtMin Y , 268
, 242
, 242
TxtUniBexa,c, 232
UapdExa, 237
Uexa, 159
UniBexa,c, 224
vacillatory function, 136
vacillatory language, 141


Page 313
identification (continued)
via enumeration, 281
weak-monotonic, 110
weakly nontrivial, 122
identification*, 38
Im*Func identification, 190
Im*Lang identification, 190
ImaExb identification, 171
ImaTxtExb identification, 169
imperfect text, 168, 169
In*Func identification, 190
In*Lang identification, 190
inaccurate data, 168
InaExb identification, 171
InaTxtExb identification, 169
incomplete text, 168, 169
index of a function, 20
indexed family of languages, 85
induction by enumeration, 59
informant for a language, 182
information theoretic limits, 34
InfTxtBca identification, 182
InfTxtExa identification, 182
intensionality, 61
internal simulation argument, 69, 70
J
Jain, S., 121, 149, 163, 165, 166, 188, 189, 217-219, 230, 243-245, 254, 256, 259, 260, 275, 276
Jantke, K., 48, 75, 80, 81, 108, 120, 121
Jeffery, R., 9
Jockusch, C., 254
K
Kalyanasundaram, B., 219
Kapron, B., 261
Kapur, S., 113, 121, 124
Kaufmann, S., 245
Kearns, M., 13
Kinber, E., 114, 121, 219, 245, 254, 256, 259, 260, 276, 278
Kleene, S., 20
Krishna Rao, M., 85
Kummer, M., 245, 254, 256, 259, 260
Kurtz, S., 121, 254, 256, 259, 260, 287
L
Lakatos, I., 151
Lang, 62
Lange, S., 110, 112, 121, 275
Langley, P., 4, 61
language, 18
language acquisition, 3
language conjectured by a scientist, 33
language d-conforming, 240
Lasnik, H., 29
lean text, 58
learning strategy, 91
class, 92
global, 92
length of a sequence, 32, 50
Lenneberg, E., 32
Lewis, H., 15
Liepe, W., 120
LimExa identification, 149
limiting partial recursive, 25
limiting recursive functional, 25
limiting recursive functions, 25
limiting recursive set, 25
limiting standardizable, 269, 278
locking sequence, 42, 56
TxtBca, 147
TxtExa-locking sequence, 146
locking text, 56
low set, 259
Lynes, C., 63, 138, 140, 141, 145
M
Martin, E., 9, 30
Matthews, R., 40
memory-limited scientist, 47
the function identification case, 52


Page 314
memory-limited scientist (continued)
the language identification case, 45
identification, 279
Meyer, L., 219
mind change, 35, 262
Minicozzi, E., 58, 106, 118, 121
minimal identification, 268
Min Y identification, 278
MIS, 113
Miyano, S., 85
monotonic identification, 109
monotonicity of a functional, 19
Motoki, T., 85
Muggleton, S., 108
Mukouchi, Y., 275
identification, 185
identification, 185
identification, 185
multiple texts, 184, 185
N
N*Lang identification, 190
n-memory limited, 57
n-mute, 39
n-variants of functions, 17
n-variants of sets, 16
NaExb identification, 170
natural number, 15
NaTxtExb identification, 169
nearly minimal identification, 273
negative information, 31, 32
Newport, E., 32, 82
Ngo-Manguelle, S., 117, 121, 275
noisy text, 168, 169
noncomputable scientists, 33, 34, 51, 65
nonexcessive identification, 122
NonrecLang identification, 184
NonrecTxtEx identification, 184
nonrecursive text, 182
nontrivial identification, 122
nonunion theorem, 71, 197
O
Oexa identification, 146
omniscient oracle, 253
operator, 19
oracle, 25
oracle scientist, 252
OA,bEx identification, 256
OAEx identification, 252
OATxtEx identification, 257
order independence identification, 101
Osherson, D., 4, 9, 30, 34, 75, 79, 138, 140, 142, 145, 149, 189, 198, 219
Ott, M., 259
P
padding lemma, 21
pairing function, 18
Papadimitriou, C., 15
paradigms, 5
parameterized scientist, 76
partial recursive function, 15
path in a computation tree, 207
Peirce, C. S., 165
percent identification, 56
performability, 77
Pinker, S., 3, 4, 30, 32
Pitt, L., 202, 205-214, 217, 219, 220
Pleszkoch, M., 252, 254, 256, 259, 260
Podnieks, K., 136, 145, 163
point of convergence, 162
Popper, K., 117
Popperian identification, 117
positive integers, 15
Post, K., 32
probabilistic scientist, 201
nice, 206
probability measure, 203
ProbpEx identification, 206
ProbpTxtEx identification, 214


Page 315
program size complexity, 23
program synthesis, 48
programming system, 19, 264
projection functions, 18
prudent identification, 98
Pullum, G., 38
Putnam, H., 4, 38
Q
Quinlan, J., 113
R
r.e. extendible, 99
r.e. index set, 94
r.e. indexable, 94, 117
r.e. sets, 18
rationality, 11, 37
rearrangement independence identification, 100
RecLang identification, 183
RecTxtExa identification, 182
recursion theorems
k-ary recursion theorem, 22
Kleene's recursion theorem, 21
operator recursion theorem, 23
recursive function, 15
recursive functional, 19
recurssive language, 18
recursive operator, 19
recursive reliable identification, 118
recursive text, 182
recursively enumerable languages, 18
recursively enumerable set, 15
relative density, 240
reliable identification, 58, 106, 118
robust identification, 282
Rogers, H., 15, 16, 87, 94, 101, 123, 204, 205
Royer, J., 18, 121, 163, 261
Rudin, W., 152, 156
Russell, B., 3, 4
S
s-m-n theorem, 20
Sakakibara, Y., 85
Sankoff, G., 82
scattered set, 164
Schäfer-Richter, G., 100, 102, 119, 120, 189, 276
Schieffelin, B., 32
Schneiderman, M., 32
scientist
oracle, 252
parameterized, 76
totality, 68-69, 92
with k streams, 185
with additional information, 232, 241
within the function identification paradigm, 51
within the language identification paradigm, 33
scientists
with additional information, 223
self-monitoring, 39
set driven identification, 99
Seth, A., 261
Shapiro, E., 48, 113
Sharma, A., 121, 149, 188, 189, 217-219, 230, 243-245, 259, 275-277
Shinohara, A., 85
Shinohara, T., 85
Shoenfield, J., 87
s -algebra, 203
Simon, H., 4, 61
single-valued language, 18
single-valued total language, 18
Slaman, T., 254, 256, 259, 260
Smith, C., 118, 128, 129, 131-133, 135, 136, 144-146, 163, 198, 199, 212, 213, 217, 219, 220, 259, 262, 263, 267, 275-278, 287
Smullyan, R., 22


Page 316
Snow, C., 32
Soare, R., 253
Solomonoff, R., 4
Solovay, R., 254, 256, 259, 260
stabilizing sequence, 102
stable set, 287
Steel, J., 132, 146
Stephan, F., 114, 121, 189, 245, 254, 256, 259, 260, 276
Stob, M., 30, 75, 79, 149, 189, 198, 219
strategy
learning, 91
strictly ascending text, 58
strong-monotonic identification, 108
Suppes, P., 34
T
identification, 198
identification, 198
tell-tale of a language, 85
text, 31
ascending, 181, 194
for a function, 49
for a language, 31
imperfect, 168, 169
incomplete, 168, 169
noisy, 168, 169
nonrecursive, 182
recursive, 182
strictly ascending, 58
total minded identification, 123
total recursive functional, 19
total recursive operator, 19
Trakhtenbrot, B., 262
translator between programming systems, 20
Treiman, R., 32
trivial oracle, 253
Turing, A., 15
TxtAcpdExa identification, 241
TxtAexa identification, 158
identification, 242
TxtApdExa identification, 241
identification, 242
TxtBca identification, 140
TxtBca-locking sequence, 147
TxtBexa,c identification, 232
TxtEx identification, 63, 138
TxtExa identification, 138
TxtExa-locking sequence, 146
TxtExExact identification, 81
[TxtEx]global-monotonic identification, 125
TxtExta identification, 148
TxtExWeakExact identification, 87
identification, 148
identification, 142
identification, 149
TxtMex identification, 274
TxtMex Y identification, 273
TxtMin Y identification, 268
identification, 242
identification, 242
TxtUniBexa,c identification, 232
U
UapdExa identification, 237
Uexa identification, 159
Ullman, J., 15, 29
UniBexa,c identification, 224
unidentifiability
computational, 251
information-theoretic, 251
uniform relative density, 240
uniformly d-conforming, 236
V
vacillatory function identification, 136
vacillatory language identification, 141
van Riemskijk, H., 30
Vazirani, U., 13


Page 317
Ventsov, Y., 276
W
Wasow, T., 4, 29
weak-monotonic identification, 110
weakly memory limited, 57
weakly nontrivial identification, 122
Webb, J., 34
Weihrauch, K., 9
Weinstein, S., 30, 75, 79, 138, 140, 142, 145, 149, 189, 198, 219
Werker, J., 30
Wexler, K., 30, 45, 49, 99, 120, 121
Wiehagen, R., 26, 39, 66, 109, 120, 121, 184, 189, 219, 223, 224, 244, 264-266, 276
Will, T., 219
Williams, E., 30
Wright, K., 85
Y
Yamamoto, A., 85
Yokomori, T., 85
Z


Page i
Systems That Learn


Page ii
Learning, Development, and Conceptual Change
Lila Cleitman, Susan Carey, Elissa Newport, and Elizabeth Spelke, editors
Names for Things: A Study in Human Learning, John Macnamara, 1982
Conceptual Change in Childhood, Susan Carey, 1985
"Gavagai!" or the Future History of the Animal Language Controversy, David Premack, 1986
Systems That Learn: An Introduction to Learning Theory for Cognitive and Computer Scientists, Daniel N. Osherson, Michael Stob, and Scott Weinstein, 1986
From Simple Input to Complex Grammar, James L. Morgan, 1986
Concepts, Kinds, and Cognitive Development, Frank C. Keil, 1989
Learnability and Cognition: The Acquisition of Argument Structure, Steven Pinker, 1989
Mind Bugs: The Origins of Procedural Misconception, Kurt VanLehn, 1990
Categorization and Naming in Children: Problems of Induction, Ellen M. Markman, 1990
The Child's Theory of Mind, Henry W. Wellman, 1990
The Organization of Learning, Charles R. Gallistel, 1990
Understanding the Representational Mind, Josef Perner, 1991
An Odyssey in Learning and Perception, Eleanor J. Gibson, 1991
Beyond Modularity: A Developmental Perspective on Cognitive Science, Annette Karmiloff-Smith, 1992
Mindblindness: An Essay on Autism and "Theory of Mind," Simon Baron-Cohen, 1995
Speech: A Special Code, Alvin M. Liberman, 1995
Theory and Evidence: The Development of Scientific Reasoning, Barbara Koslowski, 1995
Race in the Making: Cognition, Culture, and the Child's Construction of Human Kinds, Lawrence A. Hirschfeld, 1996
Words, Thoughts, and Theories, Alison Gopnik and Andrew N. Meltzoff, 1996
The Cradle of Knowledge: Development of Perception in Infancy, Philip J. Kellman and Martha E. Arterberry, 1998
Language Creation and Change: Creolization, Diachrony, and Development, edited by Michel DeGraff, 1998
Systems That Learn: An Introduction to Learning Theory, Second Edition, Sanjay Jain, Daniel M. Osherson, James S. Royer, and Arun Sharma, 1999


Page iii
Systems That Learn
An Introduction to Learning Theory
Second Edition
Sanjay Jain
Daniel Osherson
James S. Royer
Arun Sharma
A Bradford Book
The MIT Press
Cambridge, Massachusetts
London, England


Page iv
© 1999 Massachusetts Institute of Technology
All rights reserved. No part of this book may be reproduced in any form by any electronic
or mechanical means (including photocopying, recording, or information storage and
retrieval) without permission in writing from the publisher.
This book was set in Computer Modern by the authors and was printed and bound in
the United States of America.
Libary of Congress Cataloging-in-Publication Data
Systems that learn: an introduction to learning theory / Sanjay Jain
. . . [et al.] — 2nd ed.
p. cm. — (Learning, development, and conceptual change)
"A Bradford book."
Includes bibliographical references and index.
ISBN 0-262-10077-0 (hardcover: alk. paper)
1. Learning—Mathematical aspects. 2. Learning. Psychology of.
3. Human information processing—Mathematical models. I. Jain,
Sanjay, 1965 Feb. 22- II. Series.
BF318.083 1999
153.1'5'015113—dc 2198-34861
CIP


Page ix
SERIES FOREWORD
This series in learning, development, and conceptual change includes state-of-the-art reference works, seminal book-length monographs, and texts on the development of concepts and mental structures. It spans learning in all domains of knowledge, from syntax to geometry to the social world, and is concerned with all phases of development, from infancy through adulthood.
This series intends to engage such fundamental questions as:
The nature and limits of learning and maturation: the influence of the environment, of initial structures, and of maturational changes in the nervous system on human development; learnability theory; the problem of induction; domain-specific constraints on development.
The nature of conceptual change: conceptual organization and conceptual change in child development, in the acquisition of expertise, and in the history of science.
LILA GLEITMAN
SUSAN CAREY
ELISSA NEWPORT
ELIZABETH SPELKE


Page v
CONTENTS
Series Foreword
ix
Preface
xi
I
Fundamentals of Learning Theory
1
1
Introduction
3
1.1 Empirical inquiry
3
1.2 Paradigms
5
1.3 Some simple paradigms
5
1.4 Discussion of the paradigms
8
2
Formalities
15
3
Identification
27
3.1 Languages as theoretically possible realities
27
3.2 Language identification: Hypotheses, data
31
3.3 Language identification: Scientists
32
3.4 Language identification: Scientific success
35
3.5 Identification as a limiting process
38
3.6 Characterization of identifiable
40
3.7 Some alternative paradigms
44
3.8 Memory-limited scientists
45
3.9 Second paradigm: Identification of functions
48
3.10 Characterization of identifiable
51
3.11 Summary
54
3.12 Exercises
55
4
Identification by Computable Scientists
61
4.1 Preliminaries
61
4.2 Language identification by computable scientist
63
4.3 Function identification by computable scientist
69
4.4 Parameterized scientists
75
4.5 Exact identification
81
4.6 Summary
83
4.7 Exercises
84
II
Fundamental Paradigms Generalized
89
5 Strategies for Learning
91
5.1 Strategies for language identification: Introduction
91
5.2 Constraints on potential conjectures
92


Page vi
5.3 Constraints on the use of information
99
5.4 Constraint on convergence
100
5.5 Constraints on the relation between conjectures
107
5.6 Strategies for function identification
115
5.7 Bibliographic notes
120
5.8 Exercises
122
6
Criteria of Learning
127
6.1 Criteria for function identification
127
6.2 Criteria of language identification
138
6.3 Bibliographic notes
144
6.4 Exercises
145
7
Inference of Approximations
151
7.1 Approximations
151
7.2 Some background
152
7.3 Approximate explanatory identification
154
7.4 Uniform approximate explanatory identification
158
7.5 Bibliographic notes
163
7.6 Exercises
163
8
Environments
167
8.1 Inaccurate data
168
8.2 Texts with additional structure
180
8.3 Multiple texts
184
8.4 Bibliographic notes
189
8.5 Exercises
189
III
Part III: Additional Topics
195
9
Team and Probabilistic Learning
197
9.1 Introduction
197
9.2 Motivation for identification by teams
197
9.3 Team identification of functions
199
9.4 Identification by probabilistic scientists
201
9.5
212
9.6 Team and probabilistic identification of languages
213
9.7 Bibliographic notes
219
9.8 Exercises
219
10
Learning with Additional Information
221
10.1 Introduction
221
10.2 Upper bound on the size of hypothesis
222
10.3 Approximate hypotheses as additional information
235
10.4 Bibliographic notes
244
10.5 Exercises
245


Page vii
11
Learning with Oracles
251
11.1 Introduction
251
11.2 Oracle scientists
251
11.3 Function identification by oracle scientists
252
11.4 Language identification by oracle scientists
257
11.5 Bibliographic notes
259
11.6 Exercises
259
12
Complexity Issues in Identification
261
12.1 Introduction
261
12.2 Mind change complexity
262
12.3 Number of examples required
264
12.4 An axiomatic approach to complexity of convergence
267
12.5 Strictly minimal identification of languages
268
12.6 Nearly minimal identification
273
12.7 Bibliographic notes
275
12.8 Exercises
277
13
Beyond Identification by Enumeration
281
13.1 Gold's and Barzdins' * conjectures
281
13.2 Fulk's refutation of Barzdins'* conjecture
282
13.3 Exercises
286
Bibliography
289
Notation Index
303
Author and Subject Index
309


Page xi
PREFACE
The book in your hands offers an introduction to Formal Learning Theory and a review of its principal results. The theory is one of several mathematical approaches to the issues centering on intelligent adaptation to the environment. Other perspectives (not discussed here) include Bayesian probability theory, PAC ("probably, approximately correct") learning, and artificial life. The analysis developed in the present book conceives learners number theoretically and deploys the tools of recursive-function theory to understand how they can stabilize to an accurate view of reality. This line of inquiry was initiated in the 1960s by Hilary Putnam, R. J. Solomonoff, and E. Mark Gold. Since then it has developed prodigiously, to the point that a single work cannot encompass its many theorems.
The book is self-contained, inasmuch as necessary material from the theory of computation is explained in Chapter 2. In addition, exercises throughout the text provide experience in using computational arguments to prove facts about learning.
The present edition is built upon the first, but has aimed for wider coverage of the field. We are grateful to Scott Weinstein and Michael Stob for permission to rework and integrate the original text. The magnitude of our intellectual debt to them will be obvious to anyone who compares the two editions.
We would like to express our gratitude to John Case and Mark Fulk. John introduced three of us to formal learning theory and helped shape our early understanding of the field. Mark was an invaluable friend. In his brief career he produced some beautiful results that have enriched the present work. Other profound intellectual debts are to the works of E. Mark Gold and Noam Chomsky. Gold [80] established the formal framework within which learning theory has developed. Chomsky's writings have revealed the intimate connection between the projection problem and human intelligence. In addition, we have been greatly influenced by the research of Blum and Blum [18], Angluin [6], Case and Smith [35], and Wexler and Cullicover [194].
It is also our pleasure to thank Andris Ambainis, Robert Daley, Rusins Freivalds, William Gasarch, Klaus Jantke, Bala Kalyanasundaram, Shyam Kapur, Efim Kinber, Stuart Kurtz, Martin Kummer, Steffen Lange, Eric Martin, Franco Montagna, Matthias Ott, Carl Smith, Frank Stephan, Mahe Velauthapillai, Roll Wiehagen, and Thomas Zeugmann for countless discussions about learning. Many of their discoveries have been recounted in the pages to follow. For what is missing or mistold we alone are responsible.


Page xii
We thank the following institutions for support in preparing the second edition of this book.
• The Australian Research Council (contract numbers A49530274 and A49600456 to A. Sharma)
• The Department of Electrical Engineering and Computer Science, Syracuse University
• The Department of Information Systems and Computer Science, National University of Singapore
• The Istituto San Raffaele (Milan, Italy)
• The National Science Foundation (grants CCR-89011154 and CCR-9522987 to J. Royer)
• The Office of Naval Research (contract number N00014-89-J-1725 to D. Osherson and S. Weinstein)
• The Psychology Department, Rice University
• The School of Computer Science and Engineering, The University of New South Wales
We would also like to acknowledge the support of Prof. S. N. Maheshwari of the Department of Computer Science and Engineering at IIT Delhi for making the facilities of his department available to one of us during the early stages of this project.
Finally, special thanks to Elaine Weinman for her careful reading of the manuscript and to Nell Jones for the timely loan of some LATEX macros.
We would be pleased to hear from our readership, for better or for worse. To contact us, try: sanjay@iscs.nus.edu.sg, osherson@rice.edu, royer@top.cis.syr.edu, or arun@cse.unsw.edu.au. An errata list for the book will be maintained at the address http://www.cis.syr.edu/~royer/stl2e/.